Meltdown Update Kernel doesnt boot

Bug #1742323 reported by Achim Behrens on 2018-01-10
172
This bug affects 36 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Joseph Salisbury
Xenial
Critical
Joseph Salisbury

Bug Description

Using a Dell Poweredge T20 and Ubuntu 16.04 with the 4.4 Kernel.

Just got the Meltdown update to kernel linux-image-4.4.0-108-generic but this doesnt boot at all. It just hangs after grub. There is no logs from syslog or such. SysReq Keys dont work neither.
The last kernel linux-image-4.4.0-104-generic still boots fine.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-4.4.0-104-generic 4.4.0-104.127
ProcVersionSignature: Ubuntu 4.4.0-104.127-generic 4.4.98
Uname: Linux 4.4.0-104-generic x86_64
NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
AlsaVersion: Advanced Linux Sound Architecture Driver Version k4.4.0-104-generic.
AplayDevices: Error: [Errno 2] No such file or directory: 'aplay'
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord'
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', '/dev/snd/hwC0D0', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/controlC0', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
Card0.Amixer.info: Error: [Errno 2] No such file or directory: 'amixer'
Card0.Amixer.values: Error: [Errno 2] No such file or directory: 'amixer'
Date: Wed Jan 10 01:36:01 2018
HibernationDevice: RESUME=UUID=9b654b0f-96ef-49f0-bfd8-ad7907cb7b99
InstallationDate: Installed on 2017-05-17 (237 days ago)
InstallationMedia: Ubuntu-Server 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.3)
IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig'
MachineType: Dell Inc. PowerEdge T20
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-104-generic.efi.signed root=UUID=9edb2ffb-791e-4988-b3a9-7ce73227802c ro
RelatedPackageVersions:
 linux-restricted-modules-4.4.0-104-generic N/A
 linux-backports-modules-4.4.0-104-generic N/A
 linux-firmware 1.157.14
RfKill: Error: [Errno 2] No such file or directory: 'rfkill'
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/11/2017
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A12
dmi.board.name: 0VD5HY
dmi.board.vendor: Dell Inc.
dmi.board.version: A07
dmi.chassis.type: 6
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA12:bd05/11/2017:svnDellInc.:pnPowerEdgeT20:pvr00:rvnDellInc.:rn0VD5HY:rvrA07:cvnDellInc.:ct6:cvr:
dmi.product.name: PowerEdge T20
dmi.product.version: 00
dmi.sys.vendor: Dell Inc.

Achim Behrens (k1l) wrote :
summary: - Meltdown Update doesnt boot
+ Meltdown Update Kernel doesnt boot

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Can you see if this bug happens with the following kernel:

http://kernel.ubuntu.com/~jsalisbury/lp1741934/

Also, can you post a digital image or screen shot of the panic?

Changed in linux (Ubuntu):
importance: Undecided → Critical
tags: added: kernel-key
Changed in linux (Ubuntu Xenial):
importance: Undecided → Critical
status: New → Confirmed
Changed in linux (Ubuntu):
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu Xenial):
assignee: nobody → Joseph Salisbury (jsalisbury)
Alexis Wilke (alexis-m2osw) wrote :

Achim Behrens,

Is the kernel that fails really 104? Or is that your backup that you just booted into to report the problem?

The one that fails for me is the new one, 108. It just "panics" nearly instantaneously.

owise1 (o-wise-1) wrote :

Hi - just did update and also had issue where boot failed to progress - bit hard to tell what was happening as the HDMI video had not come up at that point. had to revert to 4.4.0-104. Running on Intel NUC Celeron(R) CPU 847.

Dave

Punit Patpatia (punit-patpatia) wrote :

Hi, Just did an update this morning to 4.4.0-108-generic and the boot failed to process. I restarted the system and entered the Grub screen where I received advance options to login. I am though able to login with 4.4.0-104-generic. I am not proficient in Ubuntu commands. If you want I can run the commands and share the screenshots.

Rik Stigter (rikstigter) wrote :

Same here on a HP Microserevr Gen8, Celeron CPU G1610T. There seem to be problems in other distro's as well, a collegue informed me. F.I. 4.14.12 Debian (package naam 4.14.0-3) can't compile Nvideo modules etc., etc.
Back to the drawing board!

Marc (marc-preuss) wrote :

I had the same issue as described above. Ubuntu 16.04.3 LTS updated from 4.4.0.104 to 4.4.0.108, boot fails. No video display. Reboot again with 4.4.0.104 works.

Processor: 4x Intel(R) Core(TM) i5-4460 CPU @ 3.20GHz

Cima (andrea-cimatoribus) wrote :

I'm having the same problem, no boot with 108, works fine with 104, on a machine with Intel(R) Core(TM) i7-5820K CPU @ 3.30GHz and NVDIA proprietary drivers. The boot process stops almost immediately.

I took a picture of the kernel error message (attached), apologies for the poor quality, but it is the best I could manage.

Ville Mattila (vmattila) wrote :

I can verify 4.4.0-108.131 panics on a Dell Poweredge R630 (Xeon E5-2630) and a Fujitsy Primergy TS140S2 (Xeon E3-1220) and my home server (Core i5-4670), exactly as described on comment #4 by Alexis.

On the Fujitsu Primergy server linux-image-4.4.0-108-generic_4.4.0-108.131~lp1741934_amd64.deb (ref comment #3) runs fine, i.e. it does not panic.

Fedik (fedikw) wrote :

I got boot problem also, but only a black screen no any message.

Ubuntu 16.04.3 LTS x86_64
Intel(R) Core(TM) i5-2400 CPU @ 3.10GHz

Virtualization: VT-x
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm epb tpr_shadow vnmi flexpriority ept vpid xsaveopt dtherm ida arat pln pts

Semenov Pasha (sempasha) wrote :

Same issue, CPU is Intel(R) Pentium(R) CPU G630 @ 2.70GHz

winnie (winnie-) wrote :

Same here with i5-2400 CPU @ 3.10GHz.

We have a lab with 40 machines, where we just turned off auto-updates. Would be nice to know what the issue is ;)

Thanks in advance.

Robbert Korving (robkorv) wrote :

I have the same problem in Ubuntu 14.04

Achim Behrens (k1l) wrote :

@3 i will try your kernel builds right now. I cant take a screenshot since there is just a blank screen.

@4 i did run ubuntu-bug on the booting kernel, which is the older one.

I just saw Dell offering a Bios/Uefi update. I will flash that after trying the test-kernel from @3

Achim Behrens (k1l) wrote :

ok, the kernel from #3 didnt work. still the same issue, just doesnt do anything after grub.

will try the new bios from dell now.

Mossroy (mossroy) wrote :

This seems to affect many users : https://ubuntuforums.org/showthread.php?t=2382157

I have a Intel(R) Core(TM) i5-3450S CPU and kernel 4.4.0-108 doesn't boot
Booting with 4.4.0-104 works

flags of my CPU : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm epb tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms xsaveopt dtherm ida arat pln pts

I have no video display when it crashes. If I boot in recovery mode, it only displays (translated in English) :
Loading Linux 4.4.0-108-generic...
Loading initial ramdisk...

And nothing else happens.

NB : my root partition is encrypted with LUKS

I have the same issue in Ubuntu 14.04

ianrumford (p-ian-s) wrote :

Same here.

Sandy Bridge 2500k

Achim Behrens (k1l) wrote :

ok, updated the BIOS, did not change.

if i boot the linux-image-4.4.0-108-generic_4.4.0-108.131~lp1741934_amd64.deb from #3 it hangs after:
Loading Linux 4.4.0-108-generic...
Loading initial ramdisk...

when running the recovery mode, when booting the regular mode it doesnt show anything.

Jakub Dzik (abukaj) wrote :

Same here (Xenial): 2 x Intel Xeon CPU E5-2609 v2, motherboard X9DAi (Supermicro)

However another computer with 2x Dual-Core AMD Opteron 2212, motherboard S2927 (TYAN) boots fine.

Achim Behrens (k1l) wrote :

While trying to get the BIOS update to a USB-Pendrive i found out on my Thinkpad x230 running 17.10 the latest kernel update make the USB not working properly :/
It show all usb pendrives as write-protected, while with the older kernel they do work. i will open another bug for this, when i can reboot to that kernel again.

Jean Vieille (jviille) wrote :

Same problem, "Kernel panic" after 4.4.0-108.131 update.
No way to reboot, even from a network boot.
I can log in rescue, which runs a different kernel in my case (OVH) 4.14.12-mod-std-ipv6-64-rescue

hovis (hovis) wrote :

Same here with an Intel R1304BTL Server (S1200BTL mainboard) with Xeon CPU E3-1220.

16.04.3 LTS - Panic here with 108. 104 works fine.

hovis (hovis) wrote :

Just saw 109 has been pushed to the repositories. Updating to that now works fine where 108 crashed.

Ville Mattila (vmattila) wrote :

4.4.0-109, which is now available as security update from regular Ubuntu repositories, works on all three servers of mine which panic'ed with 4.4.0-108. Thank you Ubuntu kernel team!

Achim Behrens (k1l) wrote :

4.4.0-109 fixed it for me. so this bug is resolved, thanks

Florin Cristudor (crflorin) wrote :

109 Is fixing my problems on Intel CPUs. Not seen the issue on AMD CPU. Thanks!

Charles Burrows (charlbur) wrote :

How can I find 4.4.0-109? I have tried to update with Ubuntu Software and 'about this computer' from the settings icon in the taskbar. Both methods tell me that my system is up to date and I can't find 109 on any of the Xenial repos. Thanks

Rik Stigter (rikstigter) wrote :

Many thanks for this speedy fix!

Carter Braxton (cbraxton) wrote :

I'm still having problems even with 4.4.0-109. This is running Ubuntu Mate 16.04 on an Intel Core i5-3570K with onboard graphics and luks disk encryption. Although the system gets a little farther than it did with 4.4.0-108, the password screen comes up in low resolution mode and does not respond to keyboard input, apparently crashed. So for now I'm back to running 4.4.0-104.

Joseph Salisbury (jsalisbury) wrote :

@Carter Braxton, Can you open a new bug for the issue you are seeing? Also, please add the tag 'pti' to the bug.

Thanks in advance!

Many thanks to the Kernel Team for this speedy fix!

4.4.0-109 fixed the problem

Carter Braxton (cbraxton) wrote :

@Joseph Salisbury,

It's working now. Previously I had uninstalled, but not purged, the 4.4.0-108 kernel. I purged the remains and reinstalled 4.4.0-109, everything appears to be OK now running the new kernel.

Aditya Suseno (aditya-suseno) wrote :

@Carter Braxton

Having the same problem with you. But now it's working. Thanks for the tips. For those of you having the same problem with me and Carter Braxton (low resolution in 4.4.0-109 kernel). You need to PURGE all 4.4.0-108 kernel image and the remaining HEADERS. Use command: sudo apt autoremove

To post a comment you must log in.