ath10k_pci: firmware crashed!

Bug #1730331 reported by Paolo Pisati on 2017-11-06
80
This bug affects 15 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Artful by Paolo Pisati
linux-firmware (Fedora)
Fix Released
High
linux-firmware (Ubuntu)
Undecided
Unassigned
Nominated for Artful by Paolo Pisati

Bug Description

...
Nov 4 18:35:50 akane kernel: [ 10.216896] ath10k_pci 0000:04:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043222ff sub 0000:0000
Nov 4 18:35:50 akane kernel: [ 10.216908] ath10k_pci 0000:04:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
Nov 4 18:35:50 akane kernel: [ 10.217641] ath10k_pci 0000:04:00.0: firmware ver 10.2.4.70.63-2 api 5 features no-p2p,raw-mode,mfp,allows-mesh-bcast crc32 4ff9e14d
Nov 4 18:35:50 akane kernel: [ 10.228600] kvm: Nested Virtualization enabled
Nov 4 18:35:50 akane kernel: [ 10.228611] kvm: Nested Paging enabled
Nov 4 18:35:50 akane kernel: [ 10.258913] ath10k_pci 0000:04:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
Nov 4 18:35:50 akane kernel: [ 10.263535] MCE: In-kernel MCE decoding enabled.
Nov 4 18:35:50 akane kernel: [ 10.271401] EDAC amd64: Node 0: DRAM ECC enabled.
Nov 4 18:35:50 akane kernel: [ 10.271416] EDAC amd64: F16h_M30h detected (node 0).
Nov 4 18:35:50 akane kernel: [ 10.271491] EDAC MC: DCT0 chip selects:
Nov 4 18:35:50 akane kernel: [ 10.271494] EDAC amd64: MC: 0: 4096MB 1: 0MB
Nov 4 18:35:50 akane kernel: [ 10.271523] EDAC amd64: MC: 2: 0MB 3: 0MB
Nov 4 18:35:50 akane kernel: [ 10.271526] EDAC amd64: MC: 4: 0MB 5: 0MB
Nov 4 18:35:50 akane kernel: [ 10.271528] EDAC amd64: MC: 6: 0MB 7: 0MB
Nov 4 18:35:50 akane kernel: [ 10.271530] EDAC MC: DCT1 chip selects:
Nov 4 18:35:50 akane kernel: [ 10.271532] EDAC amd64: MC: 0: 0MB 1: 0MB
Nov 4 18:35:50 akane kernel: [ 10.271534] EDAC amd64: MC: 2: 0MB 3: 0MB
Nov 4 18:35:50 akane kernel: [ 10.271537] EDAC amd64: MC: 4: 0MB 5: 0MB
Nov 4 18:35:50 akane kernel: [ 10.271539] EDAC amd64: MC: 6: 0MB 7: 0MB
Nov 4 18:35:50 akane kernel: [ 10.271541] EDAC amd64: using x4 syndromes.
Nov 4 18:35:50 akane kernel: [ 10.271542] EDAC amd64: MCT channel count: 1
Nov 4 18:35:50 akane kernel: [ 10.271829] EDAC MC0: Giving out device to module amd64_edac controller F16h_M30h: DEV 0000:00:18.3 (INTERRUPT)
Nov 4 18:35:50 akane kernel: [ 10.271892] EDAC PCI0: Giving out device to module amd64_edac controller EDAC PCI controller: DEV 0000:00:18.2 (POLLED)
Nov 4 18:35:50 akane kernel: [ 10.271894] AMD64 EDAC driver v3.5.0
Nov 4 18:35:50 akane kernel: [ 10.532131] EXT4-fs (sdc1): mounted filesystem with ordered data mode. Opts: errors=remount-ro
Nov 4 18:35:50 akane kernel: [ 10.575859] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: errors=remount-ro
Nov 4 18:35:50 akane kernel: [ 11.397803] ath10k_pci 0000:04:00.0: firmware crashed! (uuid f75dd562-d1bb-40a7-8454-fdc5f86cb8aa)
Nov 4 18:35:50 akane kernel: [ 11.407389] ath10k_pci 0000:04:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043222ff sub 0000:0000
Nov 4 18:35:50 akane kernel: [ 11.407395] ath10k_pci 0000:04:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
Nov 4 18:35:50 akane kernel: [ 11.408085] ath10k_pci 0000:04:00.0: firmware ver 10.2.4.70.63-2 api 5 features no-p2p,raw-mode,mfp,allows-mesh-bcast crc32 4ff9e14d
Nov 4 18:35:50 akane kernel: [ 11.408148] ath10k_pci 0000:04:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
Nov 4 18:35:50 akane kernel: [ 11.408156] ath10k_pci 0000:04:00.0: htt-ver 0.0 wmi-op 5 htt-op 2 cal otp max-sta 128 raw 0 hwcrypto 1
Nov 4 18:35:50 akane kernel: [ 11.410197] ath10k_pci 0000:04:00.0: firmware register dump:
Nov 4 18:35:50 akane kernel: [ 11.416213] ath10k_pci 0000:04:00.0: [00]: 0x4100016C 0x000015B3 0x009BFF84 0x00955B31
Nov 4 18:35:50 akane kernel: [ 11.424559] ath10k_pci 0000:04:00.0: [04]: 0x009BFF84 0x00060130 0x00000013 0x00000000
Nov 4 18:35:50 akane kernel: [ 11.432767] ath10k_pci 0000:04:00.0: [08]: 0x009C8EA4 0x00007170 0x00000001 0x00435300
Nov 4 18:35:50 akane kernel: [ 11.441059] ath10k_pci 0000:04:00.0: [12]: 0x00000009 0x00000000 0x00958360 0x0095836B
Nov 4 18:35:50 akane kernel: [ 11.449397] ath10k_pci 0000:04:00.0: [16]: 0x00958080 0x0094078E 0x00000000 0x00000000
Nov 4 18:35:50 akane kernel: [ 11.457686] ath10k_pci 0000:04:00.0: [20]: 0x409BFF84 0x0040AB44 0x004101E0 0x0000000C
Nov 4 18:35:50 akane kernel: [ 11.466132] ath10k_pci 0000:04:00.0: [24]: 0x809BFE1C 0x0040ABA4 0x00000006 0xC09BFF84
Nov 4 18:35:50 akane kernel: [ 11.474583] ath10k_pci 0000:04:00.0: [28]: 0x8098E907 0x0040ABD4 0x009C8E7C 0x0000016B
Nov 4 18:35:50 akane kernel: [ 11.482902] ath10k_pci 0000:04:00.0: [32]: 0x8098FD3B 0x0040ABF4 0x004209EC 0x00420B0C
Nov 4 18:35:50 akane kernel: [ 11.491150] ath10k_pci 0000:04:00.0: [36]: 0x8098A7DA 0x0040AC34 0x00420AA0 0x004062DC
Nov 4 18:35:50 akane kernel: [ 11.499362] ath10k_pci 0000:04:00.0: [40]: 0x80988785 0x0040AC94 0x00410760 0x00400000
Nov 4 18:35:50 akane kernel: [ 11.507630] ath10k_pci 0000:04:00.0: [44]: 0x8098AEC8 0x0040AD44 0x00410760 0x00000001
Nov 4 18:35:50 akane kernel: [ 11.516006] ath10k_pci 0000:04:00.0: [48]: 0x809B67C4 0x0040AD84 0x00410760 0x00411344
Nov 4 18:35:50 akane kernel: [ 11.524305] ath10k_pci 0000:04:00.0: [52]: 0x809B293C 0x0040ADA4 0x00400000 0x00416FA4
Nov 4 18:35:50 akane kernel: [ 11.532748] ath10k_pci 0000:04:00.0: [56]: 0x809C0C3D 0x0040ADE4 0x0040AE08 0x00412118
Nov 4 18:35:50 akane kernel: [ 11.541095] ath10k_pci 0000:04:00.0: Copy Engine register dump:
Nov 4 18:35:50 akane kernel: [ 11.547452] ath10k_pci 0000:04:00.0: [00]: 0x00057400 0 0 3 3
Nov 4 18:35:50 akane kernel: [ 11.554384] ath10k_pci 0000:04:00.0: [01]: 0x00057800 3 3 8 9
Nov 4 18:35:50 akane kernel: [ 11.561196] ath10k_pci 0000:04:00.0: [02]: 0x00057c00 1 1 0 1
Nov 4 18:35:50 akane kernel: [ 11.567903] ath10k_pci 0000:04:00.0: [03]: 0x00058000 1 1 2 1
Nov 4 18:35:50 akane kernel: [ 11.574837] ath10k_pci 0000:04:00.0: [04]: 0x00058400 0 0 40 0
Nov 4 18:35:50 akane kernel: [ 11.581753] ath10k_pci 0000:04:00.0: [05]: 0x00058800 0 0 0 0
Nov 4 18:35:50 akane kernel: [ 11.588573] ath10k_pci 0000:04:00.0: [06]: 0x00058c00 0 0 0 0
Nov 4 18:35:50 akane kernel: [ 11.595230] ath10k_pci 0000:04:00.0: [07]: 0x00059000 0 0 0 0
Nov 4 18:35:50 akane kernel: [ 11.771390] audit: type=1400 audit(1509816949.536:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/tcpdump" pid=666 comm="apparmor_parser"
Nov 4 18:35:50 akane kernel: [ 12.102917] audit: type=1400 audit(1509816949.868:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/sbin/dhclient" pid=667 comm="apparmor_parser"
Nov 4 18:35:50 akane kernel: [ 12.105017] audit: type=1400 audit(1509816949.870:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=667 comm="apparmor_parser"
Nov 4 18:35:50 akane kernel: [ 12.106804] audit: type=1400 audit(1509816949.872:5): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-helper" pid=667 comm="apparmor_parser"
Nov 4 18:35:50 akane kernel: [ 12.108462] audit: type=1400 audit(1509816949.873:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=667 comm="apparmor_parser"
Nov 4 18:35:50 akane kernel: [ 12.635016] ip_tables: (C) 2000-2006 Netfilter Core Team
Nov 4 18:35:50 akane kernel: [ 12.668168] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
Nov 4 18:35:50 akane kernel: [ 13.002272] IPv6: ADDRCONF(NETDEV_UP): enp3s0: link is not ready
Nov 4 18:35:53 akane kernel: [ 15.928771] igb 0000:03:00.0 enp3s0: igb: enp3s0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
Nov 4 18:35:53 akane kernel: [ 16.036516] IPv6: ADDRCONF(NETDEV_CHANGE): enp3s0: link becomes ready
Nov 4 18:35:54 akane kernel: [ 16.604191] ath10k_pci 0000:04:00.0: wmi unified ready event not received
Nov 4 18:35:54 akane kernel: [ 16.694629] ath10k_pci 0000:04:00.0: could not init core (-110)
Nov 4 18:35:54 akane kernel: [ 16.700905] ath10k_pci 0000:04:00.0: could not probe fw (-110)
Nov 4 18:35:54 akane kernel: [ 16.720168] ath10k_pci 0000:04:00.0: cannot restart a device that hasn't been started
Nov 4 18:36:04 akane kernel: [ 25.934360] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
...

flag@akane:~$ dpkg -l | grep linux-image-4.13
ii linux-image-4.13.0-16-generic 4.13.0-16.19 amd64 Linux kernel image for version 4.13.0 on 64 bit x86 SMP
flag@akane:~$ dpkg -l | grep linux-firm
ii linux-firmware 1.169 all Firmware for Linux kernel drivers

the interesting part is that, at the moment, i'm back to a 4.4. kernel (4.4.0-98-generic #121) and linux-firmware 1.169 works fine with it.

Paolo Pisati (p-pisati) wrote :
Paolo Pisati (p-pisati) wrote :

Since LP wrapped up the kernel messages above, here is the full kernel.log.

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: artful
Paolo Pisati (p-pisati) wrote :

Here is another confirmation of this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1490172

and downgrading to a previous version of linux-firmware (as suggested above, and to xenial-updates in my case), made the problem disappear:

$ dpkg -l | grep linux-firmware
ii linux-firmware 1.157.13 all Firmware for Linux kernel drivers

The updated firmware used in the bionic branch of the linux-firmware packages git repo seems to fix this problem entirely for me.

To be clear, I did this:

FWIW, I did the following:

$ git clone git://kernel.ubuntu.com/ubuntu/linux-firmware.git
...
$ cd linux-firmware
$ git checkout bionic
...
$ sudo cp ath10k/QCA6147/hw3.0/* /lib/firmware/ath10k/QCA6147/hw3.0/

Then I rebooted.

The new firmware seems to drop my connections much less frequently. Perhaps upgrading the firmware in the linux-firmware package is the right solution here.

Changed in linux-firmware (Ubuntu):
status: New → Confirmed

Before pulling in the new firmware, I tried the upstream kernel per the wiki instructions I found in the Ubuntu wiki. The same problem existed there. Now, I am running the artful kernel with the bionic firmware files that I manually copied over as indicated above.

Scott Jacobi (plotor) wrote :

I tried what Wren tried, but this did not fix the problem for me. I replaced the entire QCA6147 directory, not just hw3.0. Still no luck.

Created attachment 1413693
dmesg output, lspci -vv, modinfo ath10k_pci

Description of problem:
After a certain time running (probably every several hours), the ath10k_pci driver crashes and the wireless device stops working. Setting wlan to off and on again will make it work again. This bug was first seen since the last kernel upgrade (from 4.15.9 to 4.15.10). Maybe related to bug 1490172.

Version-Release number of selected component (if applicable):
- Linux HOSTNAME 4.15.10-300.fc27.x86_64 #1 SMP Thu Mar 15 17:13:04 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
- linux-firmware.noarch 20171215-82.git2451bb22.fc27
- Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
- Dell XPS 13 9370 laptop

How reproducible:

Steps to Reproduce:
1. Upgrade kernel to 4.15.10
2. Use the ath10k_pci driver with the jQualcomm Atheros network card
3. Wait and see

Actual results:

[106670.143021] ath10k_pci 0000:02:00.0: firmware crashed! (guid db1989b3-95dd-4829-a0ef-6902b448f555)
[106670.143052] ath10k_pci 0000:02:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 1a56:143a
[106670.143060] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 0 testmode 0
[106670.144732] ath10k_pci 0000:02:00.0: firmware ver WLAN.RM.4.4.1-00051-QCARMSWP-1 api 6 features wowlan,ignore-otp crc32 c3fd4411
[106670.145862] ath10k_pci 0000:02:00.0: board_file api 2 bmi_id N/A crc32 0e26ef70
[106670.145872] ath10k_pci 0000:02:00.0: htt-ver 3.44 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[106670.158902] ath10k_pci 0000:02:00.0: failed to get memcpy hi address for firmware address 4: -16
[106670.158913] ath10k_pci 0000:02:00.0: failed to read firmware dump area: -16
[106670.158923] ath10k_pci 0000:02:00.0: Copy Engine register dump:
[106670.158941] ath10k_pci 0000:02:00.0: [00]: 0x00034400 2 2 3 3
[106670.158958] ath10k_pci 0000:02:00.0: [01]: 0x00034800 7 7 404 405
[106670.158975] ath10k_pci 0000:02:00.0: [02]: 0x00034c00 4 4 66 67
[106670.158992] ath10k_pci 0000:02:00.0: [03]: 0x00035000 0 0 2 0
[106670.159008] ath10k_pci 0000:02:00.0: [04]: 0x00035400 5585 5523 10 202
[106670.159025] ath10k_pci 0000:02:00.0: [05]: 0x00035800 0 0 64 0
[106670.159041] ath10k_pci 0000:02:00.0: [06]: 0x00035c00 16 15 6 4
[106670.159058] ath10k_pci 0000:02:00.0: [07]: 0x00036000 0 0 0 1
[106670.165254] ath10k_pci 0000:02:00.0: failed to read hi_board_data address: -28
[106670.223625] ieee80211 phy0: Hardware restart was requested
[106670.912546] ath10k_pci 0000:02:00.0: Unknown eventid: 118809
[106670.915332] ath10k_pci 0000:02:00.0: Unknown eventid: 90118
[106671.023012] ath10k_pci 0000:02:00.0: device successfully recovered
[106748.553078] wlp2s0: deauthenticating from c0:c1:c0:d2:1c:5f by local choice (Reason: 3=DEAUTH_LEAVING)
[106753.714651] ath10k_pci 0000:02:00.0: Unknown eventid: 118809
[106753.717648] ath10k_pci 0000:02:00.0: Unknown eventid: 90118
[106753.760424] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready

Expected results:
Obviously not crashing

Additional info:
See attachments.

V-Mark (vertesmark) wrote :

I face very similar problem, but I have v2.1 hardware of QCA6174 (I assume you do not have QCA6147 neither).
I installed Kubuntu Bionic Beaver (18.04) from fresh.

I still face the firmware crash IF (and only if) I switch off / hibernate my laptop with active WIFI connection.
If I switch off wifi before hibernate, everything is perfect.
Relevant syslog:
May 16 23:48:53 HU-NB058 kernel: [159310.466589] wlp2s0: deauthenticating from 84:16:f9:7b:a6:88 by local choice (Reason: 3=DEAUTH_LEAVING)
May 16 23:48:53 HU-NB058 systemd[1]: Starting Load/Save RF Kill Switch Status...
May 16 23:48:53 HU-NB058 systemd[1]: Started Load/Save RF Kill Switch Status.
May 16 23:48:56 HU-NB058 wpa_supplicant[734]: wlp2s0: CTRL-EVENT-DISCONNECTED bssid=84:16:f9:7b:a6:88 reason=3 locally_generated=1
May 16 23:48:56 HU-NB058 kernel: [159313.534608] ath10k_pci 0000:02:00.0: failed to install key for vdev 0 peer 84:16:f9:7b:a6:88: -110
May 16 23:48:56 HU-NB058 kernel: [159313.534616] wlp2s0: failed to remove key (0, 84:16:f9:7b:a6:88) from hardware (-110)
May 16 23:48:56 HU-NB058 kernel: [159313.540951] ath10k_pci 0000:02:00.0: firmware crashed! (guid b84d150d-4ef6-4369-bcf1-e5f53f30e725)
May 16 23:48:56 HU-NB058 kernel: [159313.540968] ath10k_pci 0000:02:00.0: qca6174 hw2.1 target 0x05010000 chip_id 0x003405ff sub 11ad:0804
May 16 23:48:56 HU-NB058 kernel: [159313.540974] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
May 16 23:48:56 HU-NB058 kernel: [159313.542103] ath10k_pci 0000:02:00.0: firmware ver SW_RM.1.1.1-00157-QCARMSWPZ-1 api 5 features ignore-otp,no-4addr-pad crc32 10bf8e08
May 16 23:48:56 HU-NB058 kernel: [159313.542739] ath10k_pci 0000:02:00.0: board_file api 2 bmi_id N/A crc32 ae2e275a
May 16 23:48:56 HU-NB058 kernel: [159313.542746] ath10k_pci 0000:02:00.0: htt-ver 3.1 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
May 16 23:48:56 HU-NB058 kernel: [159313.547609] ath10k_pci 0000:02:00.0: firmware register dump:
May 16 23:48:56 HU-NB058 kernel: [159313.547612] ath10k_pci 0000:02:00.0: [00]: 0x05010000 0x00000000 0x0092E4DC 0x4E0C99B6
May 16 23:48:56 HU-NB058 kernel: [159313.547614] ath10k_pci 0000:02:00.0: [04]: 0x0092E4DC 0x00060130 0x00000018 0x0041A760

Issue is present on Fedora 28 too.

Hardware is a Dell Inspiron 5570:
[root@localhost ~]# lspci
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (rev 07)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 08)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #1 (rev f1)
00:1c.4 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #6 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Intel(R) 100 Series Chipset Family LPC Controller/eSPI Controller - 9D4E (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445] (rev c1)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 07)
03:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)
[root@localhost ~]#

Kai-Heng Feng (kaihengfeng) wrote :

If you still have the issue with latest linux kernel and lates linux firmware, please raise the issue to <email address hidden>.

Download full text (15.3 KiB)

Same issue here:

$ lspci -vv
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 02)
 Subsystem: Lenovo Device 505b
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
 Latency: 0
 Capabilities: <access denied>

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02) (prog-if 00 [VGA controller])
 Subsystem: Lenovo Device 505c
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 123
 Region 0: Memory at f2000000 (64-bit, non-prefetchable) [size=16M]
 Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]
 Region 4: I/O ports at e000 [size=64]
 [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
 Capabilities: <access denied>
 Kernel driver in use: i915
 Kernel modules: i915

00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21) (prog-if 30 [XHCI])
 Subsystem: Lenovo Device 505b
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 121
 Region 0: Memory at f4400000 (64-bit, non-prefetchable) [size=64K]
 Capabilities: <access denied>
 Kernel driver in use: xhci_hcd

00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
 Subsystem: Lenovo Device 505b
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin C routed to IRQ 18
 Region 0: Memory at f442a000 (64-bit, non-prefetchable) [size=4K]
 Capabilities: <access denied>
 Kernel driver in use: intel_pch_thermal
 Kernel modules: intel_pch_thermal

00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
 Subsystem: Lenovo Device 505b
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 125
 Region 0: Memory at f442b000 (64-bit, non-prefetchable) [size=4K]
 Capabilities: <access denied>
 Kernel driver in use: mei_me
 Kernel modules: mei_me

00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21) (prog-if 01 [AHCI 1.0])
 Subsystem: Lenovo Device 505b
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 120
 Region 0: Memory at f4428000 (32-bit, non-pre...

Aydin K. (akocas) wrote :

I'm having still (06/2018, Ubuntu 18.04, latest linux-firmware) the issue with the crashing ath10k_pci firmware, mostly after the laptop goes to suspend mode.

My workaround currently is restarting it via:

    sudo rmmod ath10k_pci
    sudo modprobe ath10k_pci
    sudo ifup -a

Steph Gosling (n-steph) wrote :

Seen on a Dell XPS 9370 with Bionic

root@xps:~# uname -a
Linux xps 4.15.0-23-generic #25-Ubuntu SMP Wed May 23 18:02:16 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

root@xps:~# dpkg -l | grep linux-firmware
ii linux-firmware 1.173.1 all Firmware for Linux kernel drivers

Jul 19 11:21:29 xps kernel: [125708.177380] ath10k_pci 0000:02:00.0: firmware crashed! (guid 8295f701-6db1-4210-9b74-5735191ef649)
Jul 19 11:21:29 xps kernel: [125708.177441] ath10k_pci 0000:02:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 1a56:143a
Jul 19 11:21:29 xps kernel: [125708.177454] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
Jul 19 11:21:29 xps kernel: [125708.179368] ath10k_pci 0000:02:00.0: firmware ver WLAN.RM.4.4.1-00079-QCARMSWPZ-1 api 6 features wowlan,ignore-otp crc32 fd869beb
Jul 19 11:21:29 xps kernel: [125708.180804] ath10k_pci 0000:02:00.0: board_file api 2 bmi_id N/A crc32 20d869c3
Jul 19 11:21:29 xps kernel: [125708.180825] ath10k_pci 0000:02:00.0: htt-ver 3.47 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
Jul 19 11:21:29 xps kernel: [125708.193759] ath10k_pci 0000:02:00.0: failed to get memcpy hi address for firmware address 4: -16
Jul 19 11:21:29 xps kernel: [125708.193798] ath10k_pci 0000:02:00.0: failed to read firmware dump area: -16
Jul 19 11:21:29 xps kernel: [125708.193821] ath10k_pci 0000:02:00.0: Copy Engine register dump:
Jul 19 11:21:29 xps kernel: [125708.193847] ath10k_pci 0000:02:00.0: [00]: 0x00034400 14 14 3 3
Jul 19 11:21:29 xps kernel: [125708.193886] ath10k_pci 0000:02:00.0: [01]: 0x00034800 23 23 451 452
Jul 19 11:21:29 xps kernel: [125708.193928] ath10k_pci 0000:02:00.0: [02]: 0x00034c00 55 55 117 118
Jul 19 11:21:29 xps kernel: [125708.193955] ath10k_pci 0000:02:00.0: [03]: 0x00035000 1 1 3 1
Jul 19 11:21:29 xps kernel: [125708.193983] ath10k_pci 0000:02:00.0: [04]: 0x00035400 6419 6349 167 103
Jul 19 11:21:29 xps kernel: [125708.194005] ath10k_pci 0000:02:00.0: [05]: 0x00035800 0 0 64 0
Jul 19 11:21:29 xps kernel: [125708.194044] ath10k_pci 0000:02:00.0: [06]: 0x00035c00 24 23 18 16
Jul 19 11:21:29 xps kernel: [125708.194071] ath10k_pci 0000:02:00.0: [07]: 0x00036000 0 0 0 1
Jul 19 11:21:29 xps kernel: [125708.223465] ath10k_pci 0000:02:00.0: failed to read hi_board_data address: -28
Jul 19 11:21:29 xps kernel: [125708.307465] ieee80211 phy0: Hardware restart was requested
Jul 19 11:21:30 xps kernel: [125709.032695] ath10k_pci 0000:02:00.0: Unknown eventid: 118809
Jul 19 11:21:30 xps kernel: [125709.035603] ath10k_pci 0000:02:00.0: Unknown eventid: 90118
Jul 19 11:21:30 xps kernel: [125709.138884] ath10k_pci 0000:02:00.0: device successfully recovered
Jul 19 11:21:33 xps wpa_supplicant[1079]: TDLS: Invalid frame - payloadtype=1 category=240 action=10

DooMMasteR (winrootkit-w) wrote :

For me the firmware also crashes on a
> 02:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)

And it is always the same log.

I changed nothing on my wifi, so the issue must have been introduced by some change in ubuntu.

Steph Gosling (n-steph) wrote :

I'd made precisely one change to the config on the XPS9370; which was to add deep sleep to the kernel boot parameters for grub, vis.

```
GRUB_CMDLINE_LINUX_DEFAULT="splash mem_sleep_default=deep"
```

as otherwise this device didn't always sleep on lid close. I'm going to revert that (and pay attention to the hot laptop) and see if it happens, though I appreciate it won't be a huge step forward in narrowing this down.

DooMMasteR (winrootkit-w) wrote :

I have never had problems wit heat or sleep, so I would see this issue completely unrelated.

Also it did work for me, fine, for months in the past and I changed nothing to the system.

royden (ryts) wrote :

For those on Bionic and who recently met the trouble, try down-grading linux-firmware to 1.73 from 1.73.1. Test.

I have a different wifi chipset and met problems wifi with the update solved by the downgrading.
 Of course, YMMV. If this helps, then a new bug report must be filed for each chipset and v1.73.1.

royden (ryts) wrote :

PS: kernel 4.15.0-33 will not work with the downgraded linux-firmware, but 4.15.0-32 and earlier will.

Steph Gosling (n-steph) wrote :

The deep sleep kernel command-line parameter had no discernible effect.

The laptop ran for me for 3 days on mains without the firmware crashing and now just has after the first sleep. This was running 1.173.1 firmware so I will now downgrade and test.

Steph Gosling (n-steph) wrote :

running firmware 1.173 the problem persists.

Download full text (3.4 KiB)

I'm experiencing the same thing on Dell XPS 15 9560 with:
kernel-4.18.8-200.fc28.x86_64
linux-firmware-20180815-86.gitf1b95fe5.fc28.noarch

The errors in the logs look like:
Sep 21 21:32:08 toronto kernel: ath10k_warn: 151 callbacks suppressed
Sep 21 21:32:08 toronto kernel: ath10k_pci 0000:02:00.0: failed to wake target for read32 at 0x0003a028: -110
Sep 21 21:32:08 toronto kernel: ath10k_pci 0000:02:00.0: failed to wake target for read32 at 0x0003a028: -110
Sep 21 21:32:08 toronto kernel: ath10k_pci 0000:02:00.0: failed to wake target for read32 at 0x0003a028: -110
Sep 21 21:32:08 toronto kernel: ath10k_pci 0000:02:00.0: failed to wake target for read32 at 0x0003a028: -110
Sep 21 21:32:08 toronto kernel: ath10k_pci 0000:02:00.0: failed to wake target for read32 at 0x0003a028: -110
Sep 21 21:32:08 toronto kernel: ath10k_pci 0000:02:00.0: failed to wake target for read32 at 0x0003a028: -110
Sep 21 21:32:08 toronto kernel: ath10k_pci 0000:02:00.0: failed to wake target for read32 at 0x0003a028: -110
Sep 21 21:32:08 toronto kernel: ath10k_pci 0000:02:00.0: failed to wake target for read32 at 0x0003a028: -110
Sep 21 21:32:08 toronto kernel: ath10k_pci 0000:02:00.0: failed to wake target for read32 at 0x0003a028: -110
Sep 21 21:32:08 toronto kernel: ath10k_pci 0000:02:00.0: failed to wake target for read32 at 0x0003a028: -110
Sep 21 21:32:10 toronto kernel: ath10k_pci 0000:02:00.0: failed to read device register, device is gone
Sep 21 21:32:10 toronto kernel: ath10k_pci 0000:02:00.0: firmware crashed! (guid ff612ca1-711b-4011-8ec2-9a4e23859951)
Sep 21 21:32:10 toronto kernel: ath10k_pci 0000:02:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 1a56:1535
Sep 21 21:32:10 toronto kernel: ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 0 testmode 0
Sep 21 21:32:10 toronto kernel: ath10k_pci 0000:02:00.0: firmware ver WLAN.RM.4.4.1-00079-QCARMSWPZ-1 api 6 features wowlan,ignore-otp crc32 fd869beb
Sep 21 21:32:10 toronto kernel: ath10k_pci 0000:02:00.0: board_file api 2 bmi_id N/A crc32 20d869c3
Sep 21 21:32:10 toronto kernel: ath10k_pci 0000:02:00.0: htt-ver 3.47 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
Sep 21 21:32:10 toronto kernel: ath10k_pci 0000:02:00.0: failed to read firmware dump area: -28
Sep 21 21:32:10 toronto kernel: ath10k_pci 0000:02:00.0: Copy Engine register dump:
Sep 21 21:32:11 toronto kernel: ath10k_pci 0000:02:00.0: [00]: 0x00034400 4294967295 4294967295 4294967295 4294967295
Sep 21 21:32:11 toronto kernel: ath10k_pci 0000:02:00.0: [01]: 0x00034800 4294967295 4294967295 4294967295 4294967295
Sep 21 21:32:11 toronto kernel: ath10k_pci 0000:02:00.0: [02]: 0x00034c00 4294967295 4294967295 4294967295 4294967295
Sep 21 21:32:11 toronto kernel: ath10k_pci 0000:02:00.0: [03]: 0x00035000 4294967295 4294967295 4294967295 4294967295
Sep 21 21:32:11 toronto kernel: ath10k_pci 0000:02:00.0: [04]: 0x00035400 4294967295 4294967295 4294967295 4294967295
Sep 21 21:32:11 toronto kernel: ath10k_pci 0000:02:00.0: [05]: 0x00035800 4294967295 4294967295 4294967295 4294967295
Sep 21 21:32:11 toronto kernel: ath10k_pci 0000:02:00.0: [06]: 0x00035c00 4294967295 4294967295 4294967295 4294967295
Sep 21 21:32:11 toron...

Read more...

Comment from original bug reporter:

For me this is resolved and was probably caused by myself: After 'dnf upgrade' (from command line), when firmware updates were installed, I did not restart immediately every time. Since I'm doing this, I've never had this issue again...

Thanks for all your good work,

Lukas

I am having the same issue on a Dell XPS 9560.

$ uname -a
Linux localhost.localdomain 4.18.10-100.fc27.x86_64 #1 SMP Wed Sep 26 11:06:22 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

I have restarted the computer since updating and that does not resolve the problem.

Wifi usually crashes after a few hours of use.

scadza (dineshdharme) wrote :

I am also facing the same issue. I see the firmware crashed logs and the computer hangs around that time. I see this while working on the laptop i.e I don't do suspend or resume.

same here: dell xps 9575

$uname -a
Linux narcissus 4.19.2-301.fc29.x86_64 #1 SMP Sat Nov 17 17:58:01 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Chris Klosowski (cklosowski) wrote :

I'm also seeing this occur on 18.10. These are some logs in my `/var/log/syslog` around the time of the crash:

Chris Klosowski (cklosowski) wrote :

Just wanted to add a note here. I had noticed this only happened on my home network, and nowhere else.

I had tried hard-setting the channels and bands but nothing affected it on my Linksys WRT1200AC even with moving it around the house and using extenders. At my co-working space I rarely had the issue on a Netgear Nighthawk.

I replaced the router and added extender with a Nighthawk X10 and Nighthawk X6S mesh extender and things seem to have stopped the drops entirely for me.

I know replacing the router isn't a solution, but thought it might give some ideas as to possibly being in the way the routers and the signals are read by the firmware.

There's updated ath10k firmwares in linux-firmware-20181219-89.git0f22c852.fc28

Download full text (6.7 KiB)

Same here on Dell XPS 13 9370 running Fedora 29. The solution from the Arch Linux Forums[1] seems to help, i.e. running:

echo 1 | sudo tee /sys/bus/pci/rescan

Debug data below.

[1] https://bbs.archlinux.org/viewtopic.php?id=231896

Kernel:

Linux arnieworld 4.19.10-300.fc29.x86_64 #1 SMP Mon Dec 17 15:34:44 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Device:

02:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
 Subsystem: Bigfoot Networks, Inc. Killer 1435 Wireless-AC
 Flags: bus master, fast devsel, latency 0, IRQ 136
 Memory at dc000000 (64-bit, non-prefetchable) [size=2M]
 Capabilities: [40] Power Management version 3
 Capabilities: [50] MSI: Enable+ Count=1/8 Maskable+ 64bit-
 Capabilities: [70] Express Endpoint, MSI 00
 Capabilities: [100] Advanced Error Reporting
 Capabilities: [148] Virtual Channel
 Capabilities: [168] Device Serial Number 00-00-00-00-00-00-00-00
 Capabilities: [178] Latency Tolerance Reporting
 Capabilities: [180] L1 PM Substates
 Kernel driver in use: ath10k_pci
 Kernel modules: ath10k_pci

Firmware package:

Installed Packages
Name : linux-firmware
Version : 20181219
Release : 89.git0f22c852.fc29
Arch : noarch
Size : 328 M
Source : linux-firmware-20181219-89.git0f22c852.fc29.src.rpm
Repo : @System
From repo : updates
Summary : Firmware files used by the Linux kernel
URL : http://www.kernel.org/
License : GPL+ and GPLv2+ and MIT and Redistributable, no modification permitted
Description : This package includes firmware files required for some devices to
             : operate.

Dmesg (was woken from suspend):

[378842.718993] PM: suspend entry (s2idle)
[378842.718994] PM: Syncing filesystems ... done.
[378842.735193] Freezing user space processes ... (elapsed 0.225 seconds) done.
[378842.960661] OOM killer disabled.
[378842.960662] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[378842.962540] Suspending console(s) (use no_console_suspend to debug)
[378843.287087] PM: suspend devices took 0.324 seconds
[380686.688006] ath10k_pci 0000:02:00.0: Unknown eventid: 118809
[380686.775577] WARNING: CPU: 6 PID: 29126 at drivers/net/wireless/ath/ath10k/mac.c:5625 ath10k_bss_info_changed+0xd2e/0xe70 [ath10k_core]
[380686.775578] Modules linked in: cmac thunderbolt ccm fuse rfcomm tun bridge stp llc devlink libcrc32c ip_set nfnetlink arc4 bnep sunrpc vfat fat hid_multitouch snd_hda_codec_hdmi snd_soc_skl ath10k_pci snd_soc_skl_ipc ath10k_core snd_soc_sst_ipc snd_soc_sst_dsp snd_hda_codec_realtek snd_hda_ext_core snd_soc_acpi_intel_match snd_soc_acpi snd_hda_codec_generic snd_soc_core snd_compress mac80211 ac97_bus snd_pcm_dmaengine dell_laptop iTCO_wdt mei_wdt snd_hda_intel iTCO_vendor_support dell_wmi uvcvideo dell_smbios intel_rapl wmi_bmof x86_pkg_temp_thermal intel_powerclamp snd_hda_codec intel_wmi_thunderbolt videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 coretemp snd_hda_core videobuf2_common snd_hwdep dell_wmi_descriptor dcdbas snd_seq kvm_intel videodev btusb snd_seq_device btrtl btbcm snd_pcm intel_cstate
[380686.775612] ath btintel bluetooth cfg80211 media intel_uncore intel_ra...

Read more...

Download full text (9.8 KiB)

Same, XPS 15 9575 running Fedora 29
linux-firmware-20181219-89.git0f22c852.fc28.src.rpm

For me it goes out a few times a day, started fairly recently. `rmmod ath10k_pci` seems to lock everything up completely (tried to reload it at first). Restarting each time "works" but requires a hard reset (shutdown hangs on firewalld).

Haven't tried the rescan trick yet.

Kernel: Linux mobile1-local 4.19.10-300.fc29.x86_64 #1 SMP Mon Dec 17 15:34:44 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

  *-network
       description: Wireless interface
       product: QCA6174 802.11ac Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 32
       serial: [REMOVED]
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath10k_pci driverversion=4.19.10-300.fc29.x86_64 firmware=RM.4.4.1.c2-00057-QCARMSWP-1 ip=[REMOVED] latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:149 memory:ec000000-ec1fffff

[19047.239214] ath10k_pci 0000:02:00.0: firmware crashed! (guid 23d2bcab-6c75-4c99-a742-65320c6f23ab)
[19047.239250] ath10k_pci 0000:02:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 1a56:143a
[19047.239263] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 0 testmode 0
[19047.240966] ath10k_pci 0000:02:00.0: firmware ver RM.4.4.1.c2-00057-QCARMSWP-1 api 6 features wowlan,ignore-otp,no-4addr-pad,raw-mode crc32 e061250a
[19047.242147] ath10k_pci 0000:02:00.0: board_file api 2 bmi_id N/A crc32 20d869c3
[19047.242158] ath10k_pci 0000:02:00.0: htt-ver 3.56 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[19047.255212] ath10k_pci 0000:02:00.0: failed to get memcpy hi address for firmware address 4: -16
[19047.255225] ath10k_pci 0000:02:00.0: failed to read firmware dump area: -16
[19047.255232] ath10k_pci 0000:02:00.0: Copy Engine register dump:
[19047.255250] ath10k_pci 0000:02:00.0: [00]: 0x00034400 0 0 3 3
[19047.255269] ath10k_pci 0000:02:00.0: [01]: 0x00034800 22 22 35 36
[19047.255285] ath10k_pci 0000:02:00.0: [02]: 0x00034c00 42 41 39 40
[19047.255301] ath10k_pci 0000:02:00.0: [03]: 0x00035000 12 12 14 12
[19047.255317] ath10k_pci 0000:02:00.0: [04]: 0x00035400 2307 2283 182 118
[19047.255333] ath10k_pci 0000:02:00.0: [05]: 0x00035800 0 0 64 0
[19047.255348] ath10k_pci 0000:02:00.0: [06]: 0x00035c00 24 21 15 11
[19047.255364] ath10k_pci 0000:02:00.0: [07]: 0x00036000 0 0 0 1
[19047.268201] ath10k_pci 0000:02:00.0: failed to read hi_board_data address: -28
[19047.326400] ieee80211 phy0: Hardware restart was requested
[19050.052580] ath10k_pci 0000:02:00.0: firmware crashed! (guid e78f1069-d791-4a25-bc91-7fc1a06f653c)
[19050.052607] ath10k_pci 0000:02:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 1a56:143a
[19050.052622] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 0 testmode 0
[19050.054022] ath10k_pci 0000:02:00.0: firmware ver RM.4.4.1.c2-00057-QCARMSWP-1 api 6 features wowlan,ignore-otp,no-4addr-pad...

Read more...

Hi all, it's worth to mention that for me the problem is gone after a colleague, which had the same laptopt model as they are bought in batches by the company I work at, quit the job and before he returns the laptop I asked if we could switch the wifi card.

After changing wifi cards (same model, same card) the problem is gone completely (3 months). I'm not directly saying that this is a hardware issue, but I'm stating that changing the wifi card for another one which is the same model, the problem is gone.

Download full text (6.8 KiB)

I will update this. Problem is back. After a while of not having any issues, they're back now with the wifi card from the other lenovo laptop:

Jan 26 17:52:18 leyla kernel: ath10k_pci 0000:05:00.0: failed to wake target for read32 at 0x00080008: -110
Jan 26 17:52:18 leyla kernel: ath10k_pci 0000:05:00.0: failed to wake target for write32 of 0xffffffff at 0x00080008: -110
Jan 26 17:52:18 leyla kernel: ath10k_pci 0000:05:00.0: failed to wake target for write32 of 0xfffffffe at 0x00080008: -110
Jan 26 17:52:18 leyla kernel: ath10k_pci 0000:05:00.0: failed to wake target for read32 at 0x0003a028: -110
Jan 26 17:52:18 leyla kernel: ath10k_pci 0000:05:00.0: failed to wake target for read32 at 0x0003a028: -110
Jan 26 17:52:18 leyla kernel: ath10k_pci 0000:05:00.0: failed to wake target for read32 at 0x0003a028: -110
Jan 26 17:52:18 leyla kernel: ath10k_pci 0000:05:00.0: failed to wake target for read32 at 0x0003a028: -110
Jan 26 17:52:18 leyla kernel: ath10k_pci 0000:05:00.0: failed to wake target for read32 at 0x0003a028: -110
Jan 26 17:52:18 leyla kernel: ath10k_pci 0000:05:00.0: failed to wake target for read32 at 0x0003a028: -110
Jan 26 17:52:18 leyla kernel: ath10k_pci 0000:05:00.0: failed to wake target for read32 at 0x0003a028: -110
Jan 26 17:52:21 leyla kernel: ath10k_pci 0000:05:00.0: failed to read device register, device is gone
Jan 26 17:52:22 leyla kernel: ath10k_pci 0000:05:00.0: firmware crashed! (guid bdf279f7-7edf-44ab-b1e8-aa68c97a1a25)
Jan 26 17:52:22 leyla kernel: ath10k_pci 0000:05:00.0: qca9377 hw1.1 target 0x05020001 chip_id 0x003821ff sub 17aa:0901
Jan 26 17:52:22 leyla kernel: ath10k_pci 0000:05:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 0 testmode 0
Jan 26 17:52:22 leyla kernel: ath10k_pci 0000:05:00.0: firmware ver WLAN.TF.2.1-00021-QCARMSWP-1 api 6 features wowlan,ignore-otp crc32 42e41877
Jan 26 17:52:22 leyla kernel: ath10k_pci 0000:05:00.0: board_file api 2 bmi_id N/A crc32 8aedfa4a
Jan 26 17:52:22 leyla kernel: ath10k_pci 0000:05:00.0: htt-ver 3.56 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
Jan 26 17:52:22 leyla kernel: ath10k_pci 0000:05:00.0: failed to read firmware dump area: -28
Jan 26 17:52:22 leyla kernel: ath10k_pci 0000:05:00.0: Copy Engine register dump:
Jan 26 17:52:22 leyla kernel: ath10k_pci 0000:05:00.0: [00]: 0x00034400 4294967295 4294967295 4294967295 4294967295
Jan 26 17:52:22 leyla kernel: ath10k_pci 0000:05:00.0: [01]: 0x00034800 4294967295 4294967295 4294967295 4294967295
Jan 26 17:52:22 leyla kernel: ath10k_pci 0000:05:00.0: [02]: 0x00034c00 4294967295 4294967295 4294967295 4294967295
Jan 26 17:52:22 leyla kernel: ath10k_pci 0000:05:00.0: [03]: 0x00035000 4294967295 4294967295 4294967295 4294967295
Jan 26 17:52:22 leyla kernel: ath10k_pci 0000:05:00.0: [04]: 0x00035400 4294967295 4294967295 4294967295 4294967295
Jan 26 17:52:22 leyla kernel: ath10k_pci 0000:05:00.0: [05]: 0x00035800 4294967295 4294967295 4294967295 4294967295
Jan 26 17:52:22 leyla kernel: ath10k_pci 0000:05:00.0: [06]: 0x00035c00 4294967295 4294967295 4294967295 4294967295
Jan 26 17:52:23 leyla kernel: ath10k_pci 0000:05:00.0: [07]: 0x00036000 4294967295 4294967295 4294967295 4294967295
Jan 26 17:52:23 leyla kernel:...

Read more...

> For the record, anyone knows how to recover the wifi driver without rebooting? I've tried reinserting the module without luck. Can you advice?

I have the same problem o Debian with firmware ver RM.4.4.1.c2-00057-QCARMSWP-1 api 6, but I finally managed to reset the device without reboot:

    # remove faulty module:
    sudo modprobe -r ath10k_pci
    # lspci shows card being in the slot 03:00.0
    # tried resetting first, didn't help. Probably irrelevant:
    echo 1 | sudo tee /sys/bus/pci/devices/0000\:03\:00.0/reset
    # remove device:
    echo 1 | sudo tee /sys/bus/pci/devices/0000\:03\:00.0/remove
    # rescan PCI:
    echo 1 | sudo tee /sys/bus/pci/rescan
    # probably irrelevant:
    echo 1 | sudo tee /sys/bus/pci/drivers_autoprobe
    # load module back:
    sudo modprobe ath10k_pci

The inux-firmware-20190213-93.git710963fe has a new firmware for QCA6174 so please test

linux-firmware-20190213-93.git710963fe.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-42cbff0fd6

linux-firmware-20190213-93.git710963fe.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-f27089e66c

linux-firmware-20190213-93.git710963fe.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-f27089e66c

linux-firmware-20190213-93.git710963fe.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-42cbff0fd6

linux-firmware-20190213-93.git710963fe.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

linux-firmware-20190213-93.git710963fe.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Download full text (12.9 KiB)

Well, Fedora 29 here:

Hardware name: Dell Inc. XPS 13 9360/0PF86Y, BIOS 2.10.0 09/27/2018

[158303.517518] usb 1-3: device not accepting address 3, error -71
[158303.828861] ath10k_pci 0000:3a:00.0: failed to read device register, device is gone
[158303.920145] ath10k_pci 0000:3a:00.0: firmware crashed! (guid 272e6d4f-fef9-4c4a-a6b9-f7190b14076b)
[158303.920147] ath10k_pci 0000:3a:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 1a56:1535
[158303.920149] ath10k_pci 0000:3a:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 0 testmode 0
[158303.920510] ath10k_pci 0000:3a:00.0: firmware ver RM.4.4.1.c2-00057-QCARMSWP-1 api 6 features wowlan,ignore-otp,no-4addr-pad,raw-mode crc32 e061250a
[158303.920786] ath10k_pci 0000:3a:00.0: board_file api 2 bmi_id N/A crc32 4ed3569e
[158303.920788] ath10k_pci 0000:3a:00.0: htt-ver 3.56 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[158305.566298] ath10k_warn: 155 callbacks suppressed
[158305.566300] ath10k_pci 0000:3a:00.0: failed to wake target for read32 at 0x00036044: -110
[158305.596775] ath10k_pci 0000:3a:00.0: failed to wake target for read32 at 0x00036044: -110
[158305.627248] ath10k_pci 0000:3a:00.0: failed to wake target for read32 at 0x00036044: -110
[158305.657728] ath10k_pci 0000:3a:00.0: failed to wake target for read32 at 0x00036044: -110
[158305.688206] ath10k_pci 0000:3a:00.0: failed to wake target for read32 at 0x00036044: -110
[158305.718676] ath10k_pci 0000:3a:00.0: failed to wake target for read32 at 0x00036044: -110
[158305.749150] ath10k_pci 0000:3a:00.0: failed to wake target for read32 at 0x00036044: -110
[158305.779624] ath10k_pci 0000:3a:00.0: failed to wake target for read32 at 0x00036044: -110
[158305.810098] ath10k_pci 0000:3a:00.0: failed to wake target for read32 at 0x00036044: -110
[158305.840570] ath10k_pci 0000:3a:00.0: failed to wake target for read32 at 0x00036044: -110
[158310.137722] ath10k_pci 0000:3a:00.0: failed to read firmware dump area: -16
[158310.137723] ath10k_pci 0000:3a:00.0: Copy Engine register dump:
[158310.259437] ath10k_pci 0000:3a:00.0: [00]: 0x00034400 4294967295 4294967295 4294967295 4294967295
[158310.381133] ath10k_pci 0000:3a:00.0: [01]: 0x00034800 4294967295 4294967295 4294967295 4294967295
[158310.502843] ath10k_pci 0000:3a:00.0: [02]: 0x00034c00 4294967295 4294967295 4294967295 4294967295
[158310.594126] ath10k_warn: 156 callbacks suppressed
[158310.594127] ath10k_pci 0000:3a:00.0: failed to wake target for read32 at 0x00035040: -110
[158310.624558] ath10k_pci 0000:3a:00.0: failed to wake target for read32 at 0x00035048: -110
[158310.624559] ath10k_pci 0000:3a:00.0: [03]: 0x00035000 4294967295 4294967295 4294967295 4294967295
[158310.654990] ath10k_pci 0000:3a:00.0: failed to wake target for read32 at 0x0003543c: -110
[158310.685415] ath10k_pci 0000:3a:00.0: failed to wake target for read32 at 0x00035444: -110
[158310.715847] ath10k_pci 0000:3a:00.0: failed to wake target for read32 at 0x00035440: -110
[158310.746267] ath10k_pci 0000:3a:00.0: failed to wake target for read32 at 0x00035448: -110
[158310.746268] ath10k_pci 0000:3a:00.0: [04]: 0x00035400 4294967295 4294967295 4294967295 4294967295
[158310.776698] ath10k_pci 0000:3a:...

Forgot to add that this is with the latest firmware from this thread: linux-firmware-20190213-93.git710963fe.fc29.noarch.

Download full text (3.3 KiB)

I am seeing this occur on 16.04 and that too only on my home network. I am using a D-Link DIR-150M router. Hope this helps in solving this bug.

$ dmesg | grep 'ath10k\|wlp5s0'

[43748.066244] IPv6: ADDRCONF(NETDEV_CHANGE): wlp5s0: link becomes ready
[43798.366800] wlp5s0: AP 18:0f:76:8d:56:b4 changed bandwidth, new config is 2412 MHz, width 2 (2422/0 MHz)
[43798.405413] ath10k_pci 0000:05:00.0: firmware crashed! (guid 73bf7f34-1cb6-4cdc-90a8-15e5913458a6)
[43798.405466] ath10k_pci 0000:05:00.0: qca9377 hw1.1 target 0x05020001 chip_id 0x003821ff sub 17aa:0901
[43798.405480] ath10k_pci 0000:05:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[43798.407173] ath10k_pci 0000:05:00.0: firmware ver WLAN.TF.1.0-00267-1 api 5 features ignore-otp crc32 79cea2c7
[43798.408288] ath10k_pci 0000:05:00.0: board_file api 2 bmi_id N/A crc32 93da0176
[43798.408308] ath10k_pci 0000:05:00.0: htt-ver 3.1 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[43798.410347] ath10k_pci 0000:05:00.0: firmware register dump:
[43798.410371] ath10k_pci 0000:05:00.0: [00]: 0x05020001 0x000015B3 0x00985B3A 0x00955B31
[43798.410385] ath10k_pci 0000:05:00.0: [04]: 0x00985B3A 0x00060730 0x00000004 0x00000000
[43798.410402] ath10k_pci 0000:05:00.0: [08]: 0x00955A00 0x00438830 0x00450888 0x00420970
[43798.410416] ath10k_pci 0000:05:00.0: [12]: 0x00000009 0x00000000 0x00952CD0 0x00952CE6
[43798.410430] ath10k_pci 0000:05:00.0: [16]: 0x00952CC4 0x0091080D 0x00000000 0x00000000
[43798.410445] ath10k_pci 0000:05:00.0: [20]: 0x40985B3A 0x0040E788 0x00400000 0x00421888
[43798.410458] ath10k_pci 0000:05:00.0: [24]: 0x809BF546 0x0040E7E8 0x00426470 0xC0985B3A
[43798.410473] ath10k_pci 0000:05:00.0: [28]: 0x809B90D8 0x0040E958 0x00000018 0x0042EA0C
[43798.410486] ath10k_pci 0000:05:00.0: [32]: 0x809B859A 0x0040E9A8 0x0040E9CC 0x00428D74
[43798.410501] ath10k_pci 0000:05:00.0: [36]: 0x8091D252 0x0040E9C8 0x00000000 0x00000001
[43798.410514] ath10k_pci 0000:05:00.0: [40]: 0x809EDD7B 0x0040EA78 0x00437544 0x00429428
[43798.410527] ath10k_pci 0000:05:00.0: [44]: 0x809EB6A6 0x0040EA98 0x00437544 0x00000001
[43798.410541] ath10k_pci 0000:05:00.0: [48]: 0x80911210 0x0040EAE8 0x00000010 0x004041D0
[43798.410555] ath10k_pci 0000:05:00.0: [52]: 0x80911154 0x0040EB28 0x00400000 0x00000000
[43798.410569] ath10k_pci 0000:05:00.0: [56]: 0x8091122D 0x0040EB48 0x00000000 0x00400600
[43798.410580] ath10k_pci 0000:05:00.0: Copy Engine register dump:
[43798.410609] ath10k_pci 0000:05:00.0: [00]: 0x00034400 5 5 3 3
[43798.410637] ath10k_pci 0000:05:00.0: [01]: 0x00034800 26 26 327 328
[43798.410666] ath10k_pci 0000:05:00.0: [02]: 0x00034c00 16 16 15 16
[43798.410694] ath10k_pci 0000:05:00.0: [03]: 0x00035000 29 29 30 29
[43798.410723] ath10k_pci 0000:05:00.0: [04]: 0x00035400 2767 2767 169 105
[43798.410750] ath10k_pci 0000:05:00.0: [05]: 0x00035800 0 0 0 0
[43798.410777] ath10k_pci 0000:05:00.0: [06]: 0x00035c00 25 25 25 25
[43798.410805] ath10k_pci 0000:05:00.0: [07]: 0x00036000 1 1 1 1
[43798.521863] ieee80211 phy0: Hardware restart was requested
[43799.226364] ath10k_pci 0000:05:00.0: device successfully recovered
[43929.850037] wlp5s0: AP 18:0f:76:8d:5...

Read more...

Download full text (3.4 KiB)

I'm having a different behaviour, problem persist but at least I don't have to reboot the system:

Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: firmware crashed! (guid ad6e82f6-325e-4f0f-a7c5-2116e186d000)
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: qca9377 hw1.1 target 0x05020001 chip_id 0x003821ff sub 17aa:0901
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 0 testmode 0
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: firmware ver WLAN.TF.2.1-00021-QCARMSWP-1 api 6 features wowlan,ignore-otp crc32 42e41877
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: board_file api 2 bmi_id N/A crc32 8aedfa4a
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: htt-ver 3.56 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: firmware register dump:
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [00]: 0x05020001 0x00000000 0x009F97CC 0x00000003
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [04]: 0x009F97CC 0x00060133 0x00000008 0x00000002
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [08]: 0x0040A054 0xFFFFFFFF 0x00411820 0x00000000
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [12]: 0x00000009 0xFFFFFFFF 0x00952F6C 0x00952F77
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [16]: 0x00952CC4 0x0091080D 0x00000000 0x0091080D
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [20]: 0x409F97CC 0x0040E9E8 0x00000000 0x0045A000
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [24]: 0x8093426E 0x0040EA48 0x00000001 0xC09F97CC
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [28]: 0x809BC439 0x0040EA68 0x0040A054 0x00000080
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [32]: 0x809BC408 0x0040EA88 0x0040A054 0x00000001
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [36]: 0x809F7212 0x0040EAA8 0x0040A054 0x00000000
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [40]: 0x80911210 0x0040EAC8 0x0000000B 0x0040416C
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [44]: 0x80911154 0x0040EB28 0x00400000 0x00000000
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [48]: 0x8091122D 0x0040EB48 0x00000000 0x00400600
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [52]: 0x40910024 0x0040EB78 0x0040AB98 0x0040AB98
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [56]: 0x00000000 0x0040EB98 0x009BB001 0x00040020
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: Copy Engine register dump:
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [00]: 0x00034400 11 11 3 3
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [01]: 0x00034800 4 4 337 338
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [02]: 0x00034c00 42 42 41 42
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [03]: 0x00035000 4 4 6 4
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [04]: 0x00035400 3213 3213 136 72
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [05]: 0x00035800 0 0 64 0
Apr 1 17:41:27 leyla kernel: ath10k_pci 0000:05:00.0: [06]: 0x00035c00 21 21 7 7
Apr 1 17:41:27 leyla kernel: ath10k_...

Read more...

Download full text (4.6 KiB)

Apparently linux-firmware-20190213-93.git710963fe.fc28.noarch have a problem with Acer Swift 7:

lspci | grep Ather
01:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)

cat /var/log/messages | grep ath
Apr 7 22:18:42 localhost kernel: ath10k_pci 0000:01:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
Apr 7 22:18:43 localhost kernel: ath10k_pci 0000:01:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 11ad:0807
Apr 7 22:18:43 localhost kernel: ath10k_pci 0000:01:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 0 testmode 0
Apr 7 22:18:43 localhost kernel: ath10k_pci 0000:01:00.0: firmware ver RM.4.4.1.c2-00057-QCARMSWP-1 api 6 features wowlan,ignore-otp,no-4addr-pad,raw-mode crc32 e061250a
Apr 7 22:18:43 localhost kernel: ath10k_pci 0000:01:00.0: board_file api 2 bmi_id N/A crc32 4ed3569e
Apr 7 22:18:44 localhost kernel: ath10k_pci 0000:01:00.0: failed to receive control response completion, polling..
Apr 7 22:18:44 localhost kernel: ath10k_pci 0000:01:00.0: failed to wake target for write32 of 0x00000001 at 0x00034430: -110
Apr 7 22:18:44 localhost kernel: ath10k_pci 0000:01:00.0: failed to wake target for read32 at 0x00034444: -110
Apr 7 22:18:49 localhost kernel: ath10k_warn: 110 callbacks suppressed
<omitted>
Apr 7 23:30:53 localhost kernel: ath10k_pci 0000:01:00.0: failed to wake target for read32 at 0x0003a028: -110
Apr 7 23:30:53 localhost kernel: ath10k_pci 0000:01:00.0: failed to read device register, device is gone
Apr 7 23:30:53 localhost kernel: ath10k_pci 0000:01:00.0: failed to reset chip: -5
Apr 7 23:30:54 localhost kernel: ath10k_pci: probe of 0000:01:00.0 failed with error -5

Solution is to remove or move files board.bin firmware-6.bin notice_ath10k_firmware-6.txt from /lib/firmware/ath10k/QCA6174/hw3.0 directory and then

sudo rmmod ath10k_pci
sudo modprobe ath10k_pci

cat /var/log/messages | grep ath
Apr 8 02:29:37 localhost kernel: ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
Apr 8 02:29:37 localhost kernel: ath10k_pci 0000:01:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 11ad:0807
Apr 8 02:29:37 localhost kernel: ath10k_pci 0000:01:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 0 testmode 0
Apr 8 02:29:37 localhost kernel: ath10k_pci 0000:01:00.0: firmware ver WLAN.RM.2.0-00180-QCARMSWPZ-1 api 4 features wowlan,ignore-otp,no-4addr-pad crc32 75dee6c5
Apr 8 02:29:37 localhost kernel: ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/board-2.bin failed with error -2
Apr 8 02:29:37 localhost kernel: ath10k_pci 0000:01:00.0: board_file api 1 bmi_id N/A crc32 ed5f849a
Apr 8 02:29:40 localhost kernel: ath10k_pci 0000:01:00.0: failed to ping firmware: -110
Apr 8 02:29:40 localhost kernel: ath10k_pci 0000:01:00.0: failed to reset rx filter: -110
Apr 8 02:29:40 localhost kernel: ath10k_pci 0000:01:00.0: could not init core (-110)
Apr 8 02:29:40 localhost kernel: ath10k_pci 0000:01:00.0: could not probe fw (-110)
Apr 8 02:31:34 localhost kernel: ath10k_pci 0000:01:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
Apr 8 02:31:34 localhost kernel...

Read more...

Steph Gosling (n-steph) wrote :

I have had some success (3 suspends now and not a crash) by using a newer version of the firmware from upstream, specifically this version: https://github.com/kvalo/ath10k-firmware/blob/master/QCA6174/hw3.0/4.4.1.c2/firmware-6.bin_RM.4.4.1.c2-00057-QCARMSWP-1

Download that, and replace the file /lib/firmware/ath10k/QCA6174/hw3.0/firmware-6.bin with it then rebuild your initrd (update-initramfs -uk all) and reboot. Obviously that is not going to survive an upgrade of linux-firmware when it comes, but that version works for me, at least.

Created attachment 1601215
Fedora 30 ath10k firmware crash: `journalctl -b -1` for the relevant boot

grep ath10k to find the most relevant entries

Can we please re-open this bug? Because it's back!

I just upgraded from Fedora 29 to Fedora 30 and find I'm unable to use the wireless card under the 5.2.5-200.fc30.x86_64 kernel that came with the upgrade. It still works under kernel 5.1.20.fc29.x86_64

The apparent cause of the failure is in the ath10k_pci driver which crashes at regular intervals but never seems able to recover, essentially as described in this bug report.

Disabling and re-enabling the wireless does not restore functionality.

The hardware is a Dell XPS 9550.

I've attached my system logs showing the firmware crash. Let me know what else might be useful and I can get it for you.

This problem happens for me, with newest firmware, newest kernel, as of today - but turns out only in the following situation:

- wireless router supports both 2.4 and 5 GHz
- same SSID name is used for both ranges

I.e. after disabling 5 GHz support on the router, the wifi card no longer crashes. Hope it helps anyone who wants a stable connection.

Shahar Or (mightyiam) wrote :

@mangoo-wpkg, that seems like valuable information upstream. Does anyone know the procedure to get it upstream, please?

Changed in linux-firmware (Fedora):
importance: Unknown → High
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.