Comment 38 for bug 160413

This is server edition Jaunty so no NetworkManager. I did make some
modifications to /etc/network/interfaces tho. Let me know if this makes a
difference.

Here is my /etc/network/interfaces:

iface eth0 inet dchp
up ethtool -s eth0 wol g
address 192.168.0.3
netmask 255.255.255.0
gateway 192.168.0.1

auto lo
iface lo inet loopback

auto eth0

2009/5/6 Pierre-Yves <email address hidden>

> Hi Geoff,
>
> I tried to use the Realtek r8168-8.011.00 driver in combination with
> "NETDOWN=no" in /etc/init.d/halt but WOL still does not work. Did you
> remove NetworkManager ? Until now, removing NetworkManager was the only
> way for me to get WOL working (but I haven't tested yet on Jaunty, I'll
> try it soon).
>
> PY
>
> --
> Wake on LAN (WOL) not working with r8169 driver
> https://bugs.launchpad.net/bugs/160413
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: In Progress
> Status in “linux” source package in Ubuntu: Confirmed
> Status in “linux-source-2.6.22” source package in Ubuntu: Won't Fix
>
> Bug description:
> I Cannot make WOL (Wake on LAN) work with r8169 driver (Gigabyte A P35-DSP3
> Motherboard under Gutsy AMD64).
> Since I'am slightly game addicted I have a second partition with Windows XP
> and I can tell that after shutting down from XP WOL is working OK (WOL from
> my DD-WRT router).
> After shutting down from Gutsy there is no way to wake up my PC.
> I have tried many things as suggested in different forums :
> - adding startup scripts to enable WOL through the "ethtool -s eth0 wol g"
> command (command is executed without any error and 'ethtool eth0' returns
> consistent WOL flags)
> - removing '-i' option on the 'halt' command from the /etc/init.d/halt
> script
> - using the Realtek official driver ( r8168 ) in place of the Gutsy
> provided r8169
> - forcing network shutdown (ifdown -a --force) before 'halt' command in
> /etc/init.d/halt script
>
> In particular it seems to me that my issue is not related to the bug
> #127010 (https://bugs.launchpad.net/ubuntu/+source/sysvinit/+bug/127010)
>
>
>
> ethtool output :
>
> Settings for eth0:
> Supported ports: [ TP ]
> Supported link modes: 10baseT/Half 10baseT/Full
> 100baseT/Half 100baseT/Full
> 1000baseT/Full
> Supports auto-negotiation: Yes
> Advertised link modes: 10baseT/Half 10baseT/Full
> 100baseT/Half 100baseT/Full
> 1000baseT/Full
> Advertised auto-negotiation: Yes
> Speed: 100Mb/s
> Duplex: Full
> Port: Twisted Pair
> PHYAD: 0
> Transceiver: internal
> Auto-negotiation: on
> Supports Wake-on: pumbg
> Wake-on: g
> Current message level: 0x00000033 (51)
> Link detected: yes
>
> lspci -nn output :
>
> 04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd.
> RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 01)
>

--
Geoff Wright
<email address hidden>
(+44)-788-202-3327