Ubuntu

Wake on LAN (WOL) not working with r8169 driver

Reported by Pierre-Yves on 2007-11-06
64
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Low
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

I Cannot make WOL (Wake on LAN) work with r8169 driver (Gigabyte A P35-DSP3 Motherboard under Gutsy AMD64).
Since I'am slightly game addicted I have a second partition with Windows XP and I can tell that after shutting down from XP WOL is working OK (WOL from my DD-WRT router).
After shutting down from Gutsy there is no way to wake up my PC.
I have tried many things as suggested in different forums :
- adding startup scripts to enable WOL through the "ethtool -s eth0 wol g" command (command is executed without any error and 'ethtool eth0' returns consistent WOL flags)
- removing '-i' option on the 'halt' command from the /etc/init.d/halt script
- using the Realtek official driver ( r8168 ) in place of the Gutsy provided r8169
- forcing network shutdown (ifdown -a --force) before 'halt' command in /etc/init.d/halt script

In particular it seems to me that my issue is not related to the bug #127010 (https://bugs.launchpad.net/ubuntu/+source/sysvinit/+bug/127010)

ethtool output :

Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000033 (51)
Link detected: yes

lspci -nn output :

04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 01)

Richard Samson (richard) wrote :

Hi,

I got the same issue on a P35-DS3 mainboad with the same network card :
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
WOL works fine if I shutdown manually computer before Ubuntu loaded, for instance at Grub menu.

SK (stephantom) wrote :

According to launchpad's search, the r8169 driver is only found in kernel-source-2.6.10. Assigning this bug to the specified package.

Changed in kernel-source-2.6.10:
assignee: nobody → ubuntu-kernel-team
Brian Murray (brian-murray) wrote :

I've changed the package to linux-source-2.6.22 which is the kernel used for Gutsy.

Changed in kernel-source-2.6.10:
assignee: ubuntu-kernel-team → nobody

The Hardy Heron kernel was recently uploaded for testing. We'd really appreciate it if you could try testing with this newer kernel and verify if this issue still exists. Unfortunately, the Hardy Heron Alpha1 LiveCD was released with the older 2.6.22 kernel. You'll have to manually install the newer Hardy Heron kernel in order to test. This should not be the case for Alpha2. However, here are the instructions to install (if you choose to do so):

1) edit the file /etc/apt/sources.list and add the following line:

deb http://archive.ubuntu.com/ubuntu hardy main restricted

2) sudo apt-get update
3) sudo apt-get install linux-image-2.6.24-1-generic
4) reboot and select the new kernel from the grub menu

After you've tested, please feel free to revert back - ie boot into the old kernel, sudo apt-get remove linux-image-2.6.24-1-generic, and remove the line from /etc/apt/sources.list . Please update this report with your results. Thanks in advance!

Changed in linux:
importance: Undecided → Medium
status: New → Incomplete
Pierre-Yves (py-bretecher) wrote :

Hi,

I have just tested the 2.6.24-1-generic kernel and there is no difference with 2.6.22 (I have also checked that it is still working after a windows XP shutdown). With this new kernel boot process is not complete since I guess my nvidia modules does not match the new kernel but I could check that, inside the console, I can ping other machines, so network interface is alive and working.

I have recently check the development activity on r8169.c inside git (http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=history;f=drivers/net/r8169.c;hb=f23e7fdad166a4968f1f7f56964b75acfdcf57a4): no activity related to WOL and I think I can't contact directly the contributors. So ...

Regards

Well there are maybe a few options you could do to get this noticed by upstream:

1) Open a bug report at bugzilla.kernel.org regarding this issue. Afterwards, we can then easily link this launchpad bug report to the upstream kernel bugzilla bug report you created.
2) You could attempt to contact the driver maintainer/mailing list to see if they would work on this issue.

Note that I'm going to close this report against linux-source-2.6.22 as it does not meet the criteria for a stable release update. However, against the actively developed kernel it will remain open. You can learn more about the stable release update process at https://wiki.ubuntu.com/StableReleaseUpdates . Thanks!

Changed in linux:
status: Incomplete → Won't Fix
status: Won't Fix → Triaged
Changed in linux-source-2.6.22:
status: New → Won't Fix
Changed in linux:
assignee: nobody → ubuntu-kernel-team
Richard Samson (richard) wrote :

I'm not sure it's a kernel bug. I tried latest vanilla kernel and Ubuntu Hardy, I got the same issue with wake on lan.
If I stopped computer with halt command (no call to init 6 or 0), then wol from another computer works fine.

Pierre-Yves (py-bretecher) wrote :

hello Richard,

I just tried to shutdown my box using the halt command under Ubuntu Hardy : WOL is still not working on my box (I also verified that after a boot/shutdown with Win XP WOL is always OK). Did you use special options ?

Regards

PY

Richard Samson (richard) wrote :

hi Pierre-Yves,

I have tried halt command few weeks ago, i forgot something, i can't get wol working now.
Perhaps I've started a Windows before booting Ubuntu.

Thanks for the bug report http://bugzilla.kernel.org/show_bug.cgi?id=9512, I just subscribed to it.

Pierre-Yves (py-bretecher) wrote :

Hello Richard,

On my side, booting linux after windows does not change anything :
- Shutting down from windows : works whatever the OS I ran before
- Shutting down from linux : does not work whatever the OS I ran before

Anyway, I feel less alone !

Changed in linux:
status: Unknown → In Progress
John Cass (johnpcass) wrote :

Hello

I wonder if there has been any progress on this?
I would like to report that since upgrading to Gutsy (from Edgy) - without changing the hardware at all - WOL has stopped working : it used to work perfectly.
My card is an 8139 type ethernet card. I set it correctly with ethtool but during the shutdown, somehow the system decides to power down the ethernet card (no LED).
Im starting to think its a problem related to ACPI, perhaps the DSDT table?
Does anyone have any other ideas we could try?

Regards

John

Richard Samson (richard) wrote :

Hello,

Works fine on Hardy with kernel-image-2.6.24-11-generic. Tested with wakeonlan and wol binaries from openwrt on gateway and from mac os x.
I didn't change anything, just follow Hardy updates.

Pierre-yves could you try with Hardy on host ?

Regards.
Richard

John Cass (johnpcass) wrote :

Hi Richard

Did you update just the kernel from Heron to Gutsy, or did you do a 'full update'? I tried just upgrading just the kernel (using this procedure: http://ubuntuforums.org/showthread.php?t=646755) and it is still NOT working for me. Could you let us know exactly what you have done so I can try it out?

Regards

John

Richard Samson (richard) wrote :

Hello,

I used Hardy, I didn't try Hardy kernel on Gutsy. This bug don't seem depend on kernel.

Regards.
Richard

Pierre-Yves (py-bretecher) wrote :

Hello,

I'm currently on vacation, I hope to test the latetst kernel release this week end.

Regards

Pierre-Yves

John Cass (johnpcass) wrote :

Hmmm.

Tried booting from the latest (alpha 5) heron xubuntu live cd, got thrown into ash in initramfs ;-(

Also tried booting from my previous edgy installation - in which wol worked for over a year - and now wol fails there too......

something in the bios changed by installing gutsy? i dont know enough about it but could it be an acpi-dsdt issue? - is this upgraded by the ubuntu installation?

an even more confused John

John Cass (johnpcass) wrote :

Just found this (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/181561), which could solve my CD boot problem, I'll try again tonight...

John

Lucas Nussbaum (lucas) wrote :

It seems that the problem is that shutting down the NIC during shutdown disables WOL.

If I shutdown using "poweroff -f", WOL works fine. (Warning: poweroff -f doesn't go through the normal shutdown procedure, and might cause data loss)

Running 2.6.24 from Debian. Can someone double-check using 2.6.22 or 2.6.24 from Ubuntu?

Lucas Nussbaum (lucas) wrote :

Another way to double-check that is to edit /etc/init.d/networking, look for:
stop)
        if sed -n 's/^[^ ]* \([^ ]*\) \([^ ]*\) .*$/\2/p' /proc/mounts |
                grep -qE '^(nfs[1234]?|smbfs|ncp|ncpfs|coda|cifs)$'; then
            log_warning_msg "not deconfiguring network interfaces: network shares still mounted."
            exit 0
        fi

        log_action_begin_msg "Deconfiguring network interfaces"
        if ifdown -a --exclude=lo; then
            log_action_end_msg $?
        else
            log_action_end_msg $?
        fi
        ;;

And change:
if ifdown -a --exclude=lo; then
by:
if true; then
(or anything else that prevents ifdown from running)

Then do a normal shutdown. This way to test is safer than the other one, too :-)

Pierre-Yves (py-bretecher) wrote :

Hi,

I tried both the new kernel revision and the network init script hack and ... no luck for me. Again, I checked right after each attempt that a shutdown after a Win XP boot re-enables WOL.

Pierre-Yves

John Cass (johnpcass) wrote :

Confusingly, my system now DOES work with WOL - using Ubuntu Gutsy standard kernel 2.6.22-14
I dont know what has changed...
The system does turn off the light on the ethernet card but it does respond to magic packets.
If I find out what changed I will add a comment.

Regards

John

(note: my system uses a PCI 8139 type ethernet card)

On 09/03/08 at 11:27 -0000, John Cass wrote:
> (note: my system uses a PCI 8139 type ethernet card)

I think that 8139 is a different NIC, and you might use a different
driver. Are you sure that you are using r8169?
--
| Lucas Nussbaum
| <email address hidden> http://www.lucas-nussbaum.net/ |
| jabber: <email address hidden> GPG: 1024D/023B3F4F |

Lucas

I am indeed using a 8139 type nic, not a 8169 - sorry for any confusion.

John

http://www.linuxquestions.org/questions/linux-networking-3/realtek-813981688169-on-2.6.21.3-or-newer-593495/

speaks of a setting in Windows XP which prevents same from leaving the NIC in a state from which the linux drivers cannot recover.

That all said I am suspicious of network-manager given the reports that this problem only emerges when the full gui is booted.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Pierre-Yves (py-bretecher) wrote :

I have quickly tested the Kubuntu Intrepid Alpha, and the problem still exist.
As mentioned in the kernel bug report ( http://bugzilla.kernel.org/show_bug.cgi?id=9512 ) the issue is related to Network Manager that stops the interface before shutdown (it shouldn't be a problem normally). The r8169 driver hasn't changed since a quite long time. The r8168 from Realtek has recently changed, I could have a try with it ...

Pierre-Yves (py-bretecher) wrote :

Just tested the r8168-8.008.00 module from Realtek and WOL doesn't work as long as NetworkManager is used (I tested that if NM is removed WOL just works normally).
So, the issue still remains.

Richard Samson (richard) wrote :

Pierre-Yves, this bug disappeared during Hardy development, since august with first Network Manager 0.7 upload on Intrepid, WOL stopped working. NM 0.7 seems to ignore network system settings.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

This bug was reported a while ago but there hasn't been any recent comments or updates. Is this still an issue with the latest pre-release of Jaunty 9.04? Refer to http://www.ubuntu.com/testing/jaunty/beta . Please let us know.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Pierre-Yves (py-bretecher) wrote :

A quick test with jaunty does not show any improvement on my machine (still the same as in my first post.

For me WOL magically started working - I tried a couple of times during the last few days. The weird thing is that I am still running Intrepid on the machine, i.e.:
  Linux andromeda 2.6.27-11-generic #1 SMP Wed Apr 1 20:53:41 UTC 2009 x86_64 GNU/Linux

The only thing I changed kernel-wise during the last weeks (except for applying security updates if any) was that I migrated from KVM to VirtualBox, so kvm-intel is no longer loaded.

@Pierre-Yves: Are you by chance using kvm or is the module loaded on your machine (lsmod | grep kvm should do the trick)?

Hi my problem is a little different. I was using Kubuntu 8.10 till the update to 9.04 with Wake On Lan.

Just 3 things needed to be done in my case additional to enabling wol.

- Deinstallation des Networkmanagers
I guess because it messes with the settings
- Editieren der /etc/init.de/halt (NETDOWN=no)
You know why
- Editieren der /etc/network/interfaces (pre-down false)
To stop bringing the Interface down.

But since the Update ... it stopped working ... and I am looking for someone who can tell me why or even how to fix it.

Maybe some of you can try it.

Cheers wangweilin

Amit Kucheria (amitk) on 2009-04-28
Changed in linux (Ubuntu):
importance: Medium → Low
status: Incomplete → Confirmed
Amit Kucheria (amitk) on 2009-04-28
tags: added: ct-rev
Geoff (gpwright) wrote :

Just upgraded from Hardy to Jaunty and my wake on lan stopped working. I'm using a realtek 8168 on board NIC, although I notice the driver is 8169. Have tried editing halt script, using ethtool and disabling ifdown commands in /etc/init.d/networking all to no avail.

Does anyone have a fix? Should I try replacing the driver with the 8168 from realteks website? I downloaded it but couldn't figure out how to make it compile.

Thanks...
Geoff

Geoff (gpwright) wrote :

For anyone who is having the above problem, the fix for me was to replace the 8169 driver with realteks latest 8168 driver from their website. This in combination with NETWORKDOWN=no in the /etc/init.d/halt script worked for me - WOL is now working nicely again.

I guess there is a small problem with jaunty upgrade that it is installing the wrong driver.

Geoff

Amit Kucheria (amitk) on 2009-05-03
summary: - Wake on LAN (WOL) not working with r8169 driver on Gutsy
+ Wake on LAN (WOL) not working with r8169 driver
Pierre-Yves (py-bretecher) wrote :

Hi Geoff,

I tried to use the Realtek r8168-8.011.00 driver in combination with "NETDOWN=no" in /etc/init.d/halt but WOL still does not work. Did you remove NetworkManager ? Until now, removing NetworkManager was the only way for me to get WOL working (but I haven't tested yet on Jaunty, I'll try it soon).

PY

This is server edition Jaunty so no NetworkManager. I did make some
modifications to /etc/network/interfaces tho. Let me know if this makes a
difference.

Here is my /etc/network/interfaces:

iface eth0 inet dchp
up ethtool -s eth0 wol g
address 192.168.0.3
netmask 255.255.255.0
gateway 192.168.0.1

auto lo
iface lo inet loopback

auto eth0

2009/5/6 Pierre-Yves <email address hidden>

> Hi Geoff,
>
> I tried to use the Realtek r8168-8.011.00 driver in combination with
> "NETDOWN=no" in /etc/init.d/halt but WOL still does not work. Did you
> remove NetworkManager ? Until now, removing NetworkManager was the only
> way for me to get WOL working (but I haven't tested yet on Jaunty, I'll
> try it soon).
>
> PY
>
> --
> Wake on LAN (WOL) not working with r8169 driver
> https://bugs.launchpad.net/bugs/160413
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: In Progress
> Status in “linux” source package in Ubuntu: Confirmed
> Status in “linux-source-2.6.22” source package in Ubuntu: Won't Fix
>
> Bug description:
> I Cannot make WOL (Wake on LAN) work with r8169 driver (Gigabyte A P35-DSP3
> Motherboard under Gutsy AMD64).
> Since I'am slightly game addicted I have a second partition with Windows XP
> and I can tell that after shutting down from XP WOL is working OK (WOL from
> my DD-WRT router).
> After shutting down from Gutsy there is no way to wake up my PC.
> I have tried many things as suggested in different forums :
> - adding startup scripts to enable WOL through the "ethtool -s eth0 wol g"
> command (command is executed without any error and 'ethtool eth0' returns
> consistent WOL flags)
> - removing '-i' option on the 'halt' command from the /etc/init.d/halt
> script
> - using the Realtek official driver ( r8168 ) in place of the Gutsy
> provided r8169
> - forcing network shutdown (ifdown -a --force) before 'halt' command in
> /etc/init.d/halt script
>
> In particular it seems to me that my issue is not related to the bug
> #127010 (https://bugs.launchpad.net/ubuntu/+source/sysvinit/+bug/127010)
>
>
>
> ethtool output :
>
> Settings for eth0:
> Supported ports: [ TP ]
> Supported link modes: 10baseT/Half 10baseT/Full
> 100baseT/Half 100baseT/Full
> 1000baseT/Full
> Supports auto-negotiation: Yes
> Advertised link modes: 10baseT/Half 10baseT/Full
> 100baseT/Half 100baseT/Full
> 1000baseT/Full
> Advertised auto-negotiation: Yes
> Speed: 100Mb/s
> Duplex: Full
> Port: Twisted Pair
> PHYAD: 0
> Transceiver: internal
> Auto-negotiation: on
> Supports Wake-on: pumbg
> Wake-on: g
> Current message level: 0x00000033 (51)
> Link detected: yes
>
> lspci -nn output :
>
> 04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd.
> RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 01)
>

--
Geoff Wright
<email address hidden>
(+44)-788-202-3327

O. (olivierv) wrote :

I don't know if it's of any help, but on jaunty with wicd installed instead of NetworkManager, WOL still does not work.

HOWEVER, booting and then halting on hardy kernel (2.6.27-11) with no other change at all allows my computer to wake up.
So I guess it's a kernel (driver ?) problem.

concertedrxn (travisejones) wrote :

I found a solution to the problem. I have the same ethernet card as the original reporter of the bug, and I'm still running Intrepid (AMD64).

$ lspci -nn | grep Realtek

04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 01)

I solved the problem by downloading and compiling the driver for the r8168 from Realtek's web site: <http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=5&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false#RTL8111B/RTL8168B/RTL8111/RTL8168%3Cbr%3ERTL8111C/RTL8111CP/RTL8111D(L)%3Cbr%3ERTL8168C/RTL8111DP>.

To get it to compile I had to manually edit the Makefile in the src/ directory so it would point to the correct src/ directory. For whatever reason, the line "$(MAKE) -C $(KDIR) SUBDIRS=$(PWD)/src modules" wouldn't work, so I replaced "$(PWD)/src" with the actual path.

After a "sudo modprobe -r r8169 && sudo modprobe r8168" I was able to suspend my computer and wake it up with a MagicPacket without any other change to the configuration. I suppose I need to blacklist the r8169 module in /etc/modprobe.d/blacklist to keep it from loading on the next reboot, though.

Realtek's r8168 driver is licensed under the GPL. It would be great if it could be included in Ubuntu.

concertedrxn's fix works for me. Works perfectly. Thank you - you are now my best friend forever and ever!

one more thing - the makefile mod fixes the driver build. Then you have to run "sudo make" (which is odd, but anyway), then "sudo make install". I had to run "sudo depmod" before "sudo modprobe -r r8169 && sudo modprobe r8168" in order to activate the driver.

Pierre-Yves (py-bretecher) wrote :

Few days ago I had tested the r8168-8.011.00 module from Realtek without success. Following the latest comments, I tried the very last release (r8168-8.012.00) of the kernel module and ... it simply worked (I could even remove NETDOWN=no in /etc/init.de/halt).

In order to make it permanent don't forget to blacklist r8169 in /etc/modprobe.d/blacklist.conf and to rebuild the initrd :

sudo depmod -a
sudo mkinitramfs -o /boot/initrd.img-$(uname -r) $(uname -r)

I had the same issue. The new driver did the trick. I didn't had to change the Makefile like "concertedrxn". It just worked out of the box. I suggest to include the new driver into the kernel.

concertedrxn (travisejones) wrote :

After installing the r8168 module (v 8.012.00), I started having occasional kernel panics upon resuming from a suspended state. I thought the first one was a fluke, but recently they have become more common. I'm reverting back to the r8169 module until a new version of the r8168 becomes available. Is anyone else here experiencing the same problem?

Can confirm that the new driver solves the problem. WOL worked fine in 8.10 and before. After update to 9.04 it stopped working. After replacing the driver with r8168 it works fine again.

Can not confirm problem with suspended state (reported by concertedrxn), because I am not using suspend state.

Thanks for solution! Will the replaced driver be included in 9.10 out of the box?

Mario Di Nicola (warp99) wrote :

@concertedrxn

I'm also getting a kernel panic with the r8168 module on resume. The solution was to add a file in /etc/pm/config.d/ with the following contents:

SUSPEND_MODULES="r8168"

Now the system doesn't cause a kernel panic, but getting the module to reload automatically after resume is an issue. I made a small script in /etc/pm/sleep.d to get it loaded and according to lsmod it's loaded, but the interface isn't working. I have to manually remove and reload the module to get the interface up again.

Mario Di Nicola (warp99) wrote :

@concertedrxn

Success!!! I have been able to suspend/resume without a kernel panic and have the interface working. I reconfigured my script in /etc/pm/sleep.d to instead start|stop networking services using pm-utils hooks (see attached). This along with the suspend_modules file fixed the problem.

Changed in linux:
status: In Progress → Fix Released
Changed in linux:
importance: Unknown → Medium
Ivan Frederiks (idfred) wrote :

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
 Subsystem: ASUSTeK Computer Inc. M4A785TD Motherboard
Ubuntu 11.04, x86_64, kernel 2.6.38-13-generic #57-Ubuntu SMP

Wake on lan is not working. Seems that adapter is switched off completely during shutdown: both link and act leds are off.

Tried:
* Putting "ethtool -s eth0 wol g" almost everywhere.
* Installing latest (version 8.028.00) r8168 driver from Realtek
* Removing "-i" option form halt call
* Putting "pci-config -B 2 -#1 -S" before halt call
* Putting "echo -n "RLAN" >> /proc/acpi/wakeup" to rc.local
* Switching adapter on and off in BIOS
* Switching WOL option on and off in BIOS

Anyone?

Phillip Susi (psusi) wrote :

It looks like this was fixed upstream some time ago.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.