[Dell Alienware 13 R2] touchpad not working

Bug #1523738 reported by sean on 2015-12-08
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

Installed ubuntu 15.10 on alienware 13, touchpad is showing up in xinput list as expected, but is totally unresponsive. Was working fine on 14.05
---
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: sean 1610 F.... pulseaudio
CurrentDesktop: Unity
DistroRelease: Ubuntu 15.10
HibernationDevice: RESUME=UUID=ed54b297-8650-46ee-b615-6d543bb47b7a
InstallationDate: Installed on 2015-12-07 (0 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
MachineType: Alienware Alienware 13 R2
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-19-generic.efi.signed root=UUID=4c119f73-b6e4-4100-9d32-f6052a303bcf ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 4.2.0-19.23-generic 4.2.6
RelatedPackageVersions:
 linux-restricted-modules-4.2.0-19-generic N/A
 linux-backports-modules-4.2.0-19-generic N/A
 linux-firmware 1.149.3
Tags: wily
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
Uname: Linux 4.2.0-19-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 10/15/2015
dmi.bios.vendor: Alienware
dmi.bios.version: 1.2.0
dmi.board.name: Alienware 13 R2
dmi.board.vendor: Alienware
dmi.board.version: A00
dmi.chassis.type: 10
dmi.chassis.vendor: Alienware
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnAlienware:bvr1.2.0:bd10/15/2015:svnAlienware:pnAlienware13R2:pvr1.2.0:rvnAlienware:rnAlienware13R2:rvrA00:cvnAlienware:ct10:cvrNotSpecified:
dmi.product.name: Alienware 13 R2
dmi.product.version: 1.2.0
dmi.sys.vendor: Alienware

sean (read-sean62) wrote :

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1523738

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected wily
description: updated
sean (read-sean62) wrote : CRDA.txt

apport information

apport information

apport information

apport information

sean (read-sean62) wrote : Lspci.txt

apport information

sean (read-sean62) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: bios-outdated-1.2.2
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
sean (read-sean62) wrote :

Hey thanks for your suggestion,

output from command:
1.2.2
11/05/2015

after updating the bios there has been no change in the condition of the bug

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Oliver Paul (oliver-paul81) wrote :
Download full text (3.6 KiB)

Alienware 13 R2. Same Bug. Since 15.10 touchpad is gone.

~$ xinput
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Logitech Gaming Mouse G402 id=10 [slave pointer (2)]
⎜ ↳ Logitech Gaming Mouse G402 id=11 [slave pointer (2)]
⎜ ↳ SynPS/2 Synaptics TouchPad id=14 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Video Bus id=8 [slave keyboard (3)]
    ↳ Power Button id=9 [slave keyboard (3)]
    ↳ Integrated_Webcam_HD id=12 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=13 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=15 [slave keyboard (3)]

dmesg | grep SynPS
[ 1.951842] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input6

cat /var/log/Xorg.0.log | grep SynPS
[ 14.435] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event6)
[ 14.435] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[ 14.435] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[ 14.435] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
[ 14.435] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[ 14.435] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
[ 14.435] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[ 14.435] (**) SynPS/2 Synaptics TouchPad: always reports core events
[ 14.488] (II) synaptics: SynPS/2 Synaptics TouchPad: found clickpad property
[ 14.488] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1282 - 5656 (res 0)
[ 14.488] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1160 - 4692 (res 0)
[ 14.488] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[ 14.488] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[ 14.488] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left double triple
[ 14.488] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[ 14.488] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[ 14.488] (**) SynPS/2 Synaptics TouchPad: always reports core events
[ 14.528] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 14)
[ 14.528] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[ 14.528] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MaxSpeed is now 1.75
[ 14.528] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) AccelFactor is now 0.036
[ 14.528] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[ 14.528] (**) SynPS/2 Synap...

Read more...

sean, could you please test the latest upstream kernel available from the very top line at the top of the page from http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D (the release names are irrelevant for testing, and please do not test the daily folder)? Install instructions are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds . This will allow additional upstream developers to examine the issue.

If the latest kernel did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this issue is fixed in the mainline kernel, please add the following tags by clicking on the yellow circle with a black pencil icon, next to the word Tags, located at the bottom of the report description:
kernel-fixed-upstream
kernel-fixed-upstream-X.Y-rcZ

Where X, and Y are the first two numbers of the kernel version, and Z is the release candidate number if it exists.

If the mainline kernel does not fix the issue, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-X.Y-rcZ

Please note, an error to install the kernel does not fit the criteria of kernel-bug-exists-upstream.

Once testing of the latest upstream kernel is complete, please mark this report's Status as Confirmed. Please let us know your results.

Thank you for your understanding.

tags: added: latest-bios-1.2.2
removed: bios-outdated-1.2.2
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
sean (read-sean62) wrote :

Installed the latest kernel (4.4 rc5), booted with kernel, still no change in the touchpad problem

tags: added: kernel-bug-exists-upstream kernel-bug-exists-upstream-4.4-rc5
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

sean, the issue you are reporting is an upstream one. Could you please report this problem following the instructions verbatim at https://wiki.ubuntu.com/Bugs/Upstream/kernel to the appropriate mailing list (linux-input)?

Please provide a direct URL to your post to the mailing list when it becomes available so that it may be tracked.

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Confirmed → Triaged
summary: - touchpad not working alienware 13 on ubuntu 15.10
+ [Dell Alienware 13 R2] touchpad not working
Yafar Uasani (taikamilla) wrote :

Hi guys
I found an solution:

 Type in the terminal

   sudo su
   echo 'blacklist i2c_hid' >> /etc/modprobe.d/blacklist.conf
   depmod -a
   update-initramfs -u

 and reboot

Hope did work for you!!

sean (read-sean62) wrote :

Hey sorry for the delayed response, I can confirm that Yafar's solution worked for me fine on linux mint 18 (ubuntu 16.04)

adin (adin-rivera) wrote :

I tried #24 but it didn't work for me. Same status as before. I'm on a Alienware 17R3 under ubuntu 16.04, though.

adin (adin-rivera) wrote :

Updated to Ubuntu 16.10, and the problem persists.

Vella (mpvella) wrote :

Thanks Yafar! I know this is an older post, but I just went through a dual boot config on my alienware 13 r2, running Ubuntu 16.04 and Win10. And of course, touchpad wasn't working. I ran the blacklist comment line, but still wasn't working - until I ran the depmod and update commands. Touchpad now working!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers