Comment 16 for bug 1485246

Sigurd (sigurof) wrote :

I am also a Samsung Chronos 7 user on a fresh dual boot of Linux Mint with Windows 10.

For me, a brightness bar appeared an moved according to me pressing Fn+F2/F3, but the actual brightness would stay the same. If I pressed Fn+F2 until the brightness bar was 0 the screen would turn off.
I could see that the value stored in /sys/class/backlight/intel_backlight/brightness changes when I press Fn+F2/F3 but this wasn't changing the brightness as I said.

When I found the current bug report I replaced the line
[GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"]
with
[GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=linux acpi_backlight=video"]
Then I ran [sudo update-grub] in the terminal and restarted my system.

When I had done so, a directory named /sys/class/backlight/acpi_video0 appeared.
The value in /sys/class/backlight/acpi_video0/brightness was 50. I edited it to be 30, and my brightness suddenly changed!!

Fn+F2/F3 was still not working so I tred a tip I've read several other places by writing the 20-intel.conf file to /usr/share/X11/xorg.conf.d/20-intel.conf
The contents of 20-intel.conf:

Section "Device"
    Identifier "Intel Graphics"
    Driver "i915"
    Option "AccelMethod" "sna"
    Option "Backlight" "acpi_video0"
    BusID "PCI:0:2:0"
EndSection

I had before used
Driver "intel"
unsuccessfully but changing it to "i915" seems it may have done the trick. You can find which driver you are using by "lspci -k" and searching throught the list for your graphics card.
Also before I used
Option "Backlight" "intel_backlight"
but this time I used "acpi_video0" because the brightness actually responds to value in acpi_video0/brightness and not to the one in intel_backlight/brightness.

After shutting down my system once more, my Fn+F2/F3 screen brightness buttons work!
A last check:
cat /sys/class/acpi_video0/brightness
cat /sys/class/intel_backlight/brightness
shows that only the former's value changes when I use Fn+F2/F3 now, as one would guess.

Chronos 7 is getting old but maybe this can help someone else too.