Backlight issue - Samsung Chronos 7 (model - NP770Z5E)

Bug #1485246 reported by Mark Pettengell on 2015-08-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Control of screen backlight is broken with a default clean install of Ubuntu 15.04 on my Samsung Series 7 Laptop (NP770Z5E). Setting kernel parameter 'acpi_backlight=vendor' fixes the issue after two reboots. Debugging information attached as per - https://wiki.ubuntu.com/Kernel/Debugging/Backlight

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: linux-image-3.19.0-25-generic 3.19.0-25.26
ProcVersionSignature: Ubuntu 3.19.0-25.26-generic 3.19.8-ckt2
Uname: Linux 3.19.0-25-generic x86_64
ApportVersion: 2.17.2-0ubuntu1.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mark 1699 F.... pulseaudio
Date: Sat Aug 15 21:36:20 2015
HibernationDevice: RESUME=UUID=c4899b44-3e19-4e62-921d-cf0a1cef97ec
InstallationDate: Installed on 2015-08-12 (3 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
MachineType: SAMSUNG ELECTRONICS CO., LTD. 770Z5E/780Z5E
ProcFB:
 0 inteldrmfb
 1 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-25-generic root=UUID=5a02817b-1f9b-4abc-93a3-b10d5d9278ed ro quiet splash acpi_backlight=vendor vt.handoff=7
PulseList:
 Error: command ['pacmd', 'list'] failed with exit code 1: Home directory not accessible: Permission denied
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.19.0-25-generic N/A
 linux-backports-modules-3.19.0-25-generic N/A
 linux-firmware 1.143.3
SourcePackage: linux
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/05/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P05ABU.142.130905.SK
dmi.board.asset.tag: No Asset Tag
dmi.board.name: NP770Z5E-S02UK
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: SEC_SW_REVISION_1234567890ABCD
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP05ABU.142.130905.SK:bd09/05/2013:svnSAMSUNGELECTRONICSCO.,LTD.:pn770Z5E/780Z5E:pvrP05ABU:rvnSAMSUNGELECTRONICSCO.,LTD.:rnNP770Z5E-S02UK:rvrSEC_SW_REVISION_1234567890ABCD:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvrN/A:
dmi.product.name: 770Z5E/780Z5E
dmi.product.version: P05ABU
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

description: updated

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Update: upon further reboots with acpi_backlight=vendor, trying to adjust the brightness using the laptop hotkeys causes the brightness to immediately descend to minimum levels and the brightness change notification panel becomes locked.

Joseph Salisbury (jsalisbury) wrote :

Did this issue start happening after an update/upgrade? Was there a prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.2 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.2-rc7-unstable/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete

The issue occurred on a fresh install of Ubuntu 15.04 but as I was previously running 14.04, you could describe it as an upgrade (though it was not through the upgrade mechanism). There was certainly a previous kernel version where this was not causing a problem, but I am unable to tell you which it was having now wiped out the previous install with the fresh install.

I will try the upstream kernel and report back. Thanks for your feedback/input.

Right, so I have re-tested having installed the 4.2.0-040200rc7-generic kernel. The behaviour seems to be identical to the stock Ubuntu 15.04 kernel.

A few things I have noticed having carried out several reboots and suspends in the process of testing this. These apply to both the stock kernel and the 4.2 kernel:

With kernel parameter acpi_backlight=vendor
1. On first boot the brightness of the screen is about 60% brightness and attempts to change the brightness setting via the hotkeys causes the brightness level notification to flicker and the brightness level cannot be altered
2. After a suspend the brightness returns to about 100% and using the hotkeys may then work (i.e brightness controls have been properly restored). This occurs on about 2 in 3 wakes from suspend, the other 1 in 3 the brighness is 100% but control over brightness still non-functional

with no acpi_backlight kernel param
1. The initial boot brightness is approximately the same as above. Attempts to change this successfully move the brightness level in the indicator, but have no impact on the actual screen brighness.
2. wake from suspend results in the 100% brightness as above, but no control of screen brightness still

Not sure if any of that actually helps any...

Let me know if I can extract any further useful information to help with debugging.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-bug-exists-upstream
Erwin (erwin-gaubitzer-6) wrote :

I also have the NP770Z5E. What helped me was to change the grub kernel boot parameter to

acpi_osi=linux acpi_backlight=video

in /etc/default/grub (line GRUB_CMDLINE_LINUX_DEFAULT=) (I have Debian Linux). Hint was found at
https://wiki.archlinux.org/index.php/Backlight#Kernel_command-line_options

After command "update-grub" and reboot changing brightness was possible again.

I just created an account to thank you, Erwin.

I've spent weeks going mad looking for a solution (no idea how I didn't come across this), and your fix helped.

Note: My laptop's model is slightly different, NP780Z5E.

Sigurd (sigurof) wrote :

I am also a Samsung Chronos 7 user on a fresh dual boot of Linux Mint with Windows 10.

For me, a brightness bar appeared an moved according to me pressing Fn+F2/F3, but the actual brightness would stay the same. If I pressed Fn+F2 until the brightness bar was 0 the screen would turn off.
I could see that the value stored in /sys/class/backlight/intel_backlight/brightness changes when I press Fn+F2/F3 but this wasn't changing the brightness as I said.

When I found the current bug report I replaced the line
[GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"]
with
[GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=linux acpi_backlight=video"]
Then I ran [sudo update-grub] in the terminal and restarted my system.

When I had done so, a directory named /sys/class/backlight/acpi_video0 appeared.
The value in /sys/class/backlight/acpi_video0/brightness was 50. I edited it to be 30, and my brightness suddenly changed!!

Fn+F2/F3 was still not working so I tred a tip I've read several other places by writing the 20-intel.conf file to /usr/share/X11/xorg.conf.d/20-intel.conf
The contents of 20-intel.conf:

Section "Device"
    Identifier "Intel Graphics"
    Driver "i915"
    Option "AccelMethod" "sna"
    Option "Backlight" "acpi_video0"
    BusID "PCI:0:2:0"
EndSection

I had before used
Driver "intel"
unsuccessfully but changing it to "i915" seems it may have done the trick. You can find which driver you are using by "lspci -k" and searching throught the list for your graphics card.
Also before I used
Option "Backlight" "intel_backlight"
but this time I used "acpi_video0" because the brightness actually responds to value in acpi_video0/brightness and not to the one in intel_backlight/brightness.

After shutting down my system once more, my Fn+F2/F3 screen brightness buttons work!
A last check:
cat /sys/class/acpi_video0/brightness
cat /sys/class/intel_backlight/brightness
shows that only the former's value changes when I use Fn+F2/F3 now, as one would guess.

Chronos 7 is getting old but maybe this can help someone else too.

Kai-Heng Feng (kaihengfeng) wrote :

Hi, please try kernel in [1], without any "acpi*" kernel parameter.

[1] https://people.canonical.com/~khfeng/lp1485246

Lucas Wohlhart (lwohlhart) wrote :

Thank you very much ~sigurof you just made my day!

Brad Figg (brad-figg) on 2019-07-24
tags: added: cscc
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers