Touchpad on Acer Aspire ES1-311-C37D does not work with kernel > 3.14.39-031439.

Bug #1449252 reported by Martin on 2015-04-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I upgraded my (l)ubuntu to 15.04, which resulted in a non-detected touchpad, i.e., xinput does not list it. I then tried various mainline kernels, with the following results.

With the following kernels, the touchpad works:

Linux Martin-Laptop 3.13.0-49-generic #83-Ubuntu SMP Fri Apr 10 20:11:33 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
Linux Martin-Laptop 3.14.39-031439-generic #201504211206 SMP Tue Apr 21 11:09:35 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

With the following kernels, it doesn't:

Linux Martin-Laptop 3.15.0-031500-generic #201406131105 SMP Fri Jun 13 15:06:46 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
Linux Martin-Laptop 3.15.10-031510-generic #201408132333 SMP Thu Aug 14 03:35:00 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
Linux Martin-Laptop 3.16.0-34-generic #47-Ubuntu SMP Fri Apr 10 18:02:58 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
Linux Martin-Laptop 3.19.0-15-generic #15-Ubuntu SMP Thu Apr 16 23:32:37 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

4.0.0-040000-generic did not work either.

On the other hand, 3.19.0-15-generic #15-Ubuntu SMP Thu Apr 16 23:32:37 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux appears to be the first kernel with which screen brightness control works...

WORKAROUND: In the BIOS, change Touchpad option from Advanced to Basic.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: linux-image-3.19.0-15-generic 3.19.0-15.15
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
Uname: Linux 3.19.0-15-generic x86_64
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: martin 1909 F.... pulseaudio
CurrentDesktop: LXDE
Date: Mon Apr 27 22:21:38 2015
HibernationDevice: RESUME=UUID=1b425cd9-2680-4489-9729-1e9bbc024f85
InstallationDate: Installed on 2015-02-11 (75 days ago)
InstallationMedia:

MachineType: Acer Aspire ES1-311
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-15-generic root=UUID=980e7810-c6a4-4211-b478-cc8152085b9a ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.19.0-15-generic N/A
 linux-backports-modules-3.19.0-15-generic N/A
 linux-firmware 1.143
SourcePackage: linux
UpgradeStatus: Upgraded to vivid on 2015-04-27 (0 days ago)
dmi.bios.date: 10/24/2014
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: V1.10
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: Aspire ES1-311
dmi.board.vendor: Acer
dmi.board.version: V1.10
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.10
dmi.modalias: dmi:bvnInsydeCorp.:bvrV1.10:bd10/24/2014:svnAcer:pnAspireES1-311:pvrV1.10:rvnAcer:rnAspireES1-311:rvrV1.10:cvnAcer:ct10:cvrV1.10:
dmi.product.name: Aspire ES1-311
dmi.product.version: V1.10
dmi.sys.vendor: Acer

Martin (axiomize) wrote :
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.0 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.1-rc1-vivid/

Changed in linux (Ubuntu):
importance: Undecided → Medium

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: trusty
Martin (axiomize) wrote :

Per request of #2, I also tried 4.1.0-040100rc1-generic #201504270235 SMP Mon Apr 27 02:36:47 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux, with the same results: no touchpad, brightness control works. Don't know about shutdown yet :-)

Thank you!

tags: added: kernel-bug-exists-upstream
Martin (axiomize) wrote :

This looks actually quite similar to bug #1428962, except that the bios version there is V1.07.

Martin (axiomize) wrote :

One further datapoint: I noticed a setting in the bios menu: touchpad "advanced" vs "basic". Switching to "basic" makes the touchpad work in 4.1.0rc1. That's very nice although I have no idea what the difference between the two might be. Maybe I'll find out some day.

Now only the shutdown issue remains...

Martin (axiomize) wrote :

I should have added: the bios says with regard to the "advanced" touchpad:

    ... take care the I2C driver is loaded first if using advanced setting...

This seems to have helped other people, too, eg.in bug #1385937

Martin, the next step is to fully commit bisect from kernel 3.14 to 3.15 in order to identify the last good kernel commit, followed immediately by the first bad one. This will allow for a more expedited analysis of the root cause of your issue. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection ?

Please note, finding adjacent kernel versions is not fully commit bisecting.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

tags: added: latest-bios-1.1 needs-bisect regression-release
removed: brightness shutdown touchpad trusty
description: updated
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Martin (axiomize) wrote :

OK, will do tomorrow. Thanks for you attention!

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers