utopic alternate install CD doesn't boot

Bug #1363180 reported by Fritz Hudnut on 2014-08-29
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Gardner
Utopic
Medium
Tim Gardner

Bug Description

During testing for PPC 14.10 alternate install CD on iBook G4 the process got as far as the Yaboot window boot prompt . . . entering various commands resulted in response: "claim error, can't allocate e00000 at 0 x c2000000; claim error, can't allocate kernel memory." Built 20140826.1 No further testing could be done.
---
AcpiTables:

AlsaDevices:
 total 0
 crw-rw---T+ 1 root audio 116, 1 Sep 1 2014 seq
 crw-rw---T+ 1 root audio 116, 33 Sep 1 2014 timer
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices: aplay: device_list:252: no soundcards found...
ApportVersion: 2.0.1-0ubuntu17.7
Architecture: powerpc
ArecordDevices: arecord: device_list:252: no soundcards found...
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CRDA: Error: [Errno 2] No such file or directory
CurrentDmesg:
 [ 42.846793] eth0: no IPv6 routers present
 [ 42.904664] input: Mouseemu virtual keyboard as /devices/virtual/input/input5
 [ 42.915426] input: Mouseemu virtual mouse as /devices/virtual/input/input6
 [ 101.468774] init: network-manager main process (963) killed by TRAP signal
 [ 101.469044] init: network-manager main process ended, respawning
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=111ee215-f0ae-4fb1-ad99-30a4e7f280df
Lsusb:
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 002: ID 05ac:1006 Apple, Inc. Hub in Aluminum Keyboard
 Bus 002 Device 003: ID 05ac:0220 Apple, Inc. Aluminum Keyboard (ANSI)
 Bus 002 Device 004: ID 047d:1029 Kensington Mouse*in*a*Box Optical Elite
MarkForUpload: True
Package: linux (not installed)
PciMultimedia:

ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 OFfb NVDA,NVMac
ProcKernelCmdLine: root=UUID=98ab2c76-e668-4d8d-a684-d30381117f49 ro quiet splash
ProcVersionSignature: Ubuntu 3.2.0-68.102-powerpc-smp 3.2.62
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-68-powerpc-smp N/A
 linux-backports-modules-3.2.0-68-powerpc-smp N/A
 linux-firmware 1.79.16
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Tags: precise
Uname: Linux 3.2.0-68-powerpc-smp ppc
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dialout dip fax floppy fuse lpadmin plugdev sambashare sudo tape video

affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1363180

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Fritz Hudnut (este-el-paz) wrote :

Running the "apport-collect 1363180" seemed to not go through . . . various error windows could not be read in the desktop because the new install of 14.04 has left problems with the GUI . . . no time to deal with it. This bug report was filed as part of the QA testing process . . . I have marked it as "confirmed" . . . the hardware stuff was sent to clipit: https://gist.github.com/29c30a0634400329d4ba

The "system" list did not show my Apple iBook G4 933MHz 6xxMB RAM . . . so could not complete that part of the QA process. 12.04 ran very well on this computer . . . .

Fritz Hudnut (este-el-paz) wrote :

Problem "replicated" using the desktop iso downloaded today build 20140829 got to the Yaboot boot prompt window, entering "live" and various other choices offered under "tab" brings identical "claim error" . . . adding on some "radeonfb= items brings "invalid device" . . . . So, I would again say that "testing failed" on the G4 iBook with 14.10 beta . . . could not proceed past the Yaboot window . . . .

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1363180

tags: added: iso-testing
Fritz Hudnut (este-el-paz) wrote :

Problem was replicated while trying to "boot" the live Desktop in my iMac G4 800 Mhz w/1GB RAM . . . identical "claim error" and "invalid device" responses as with the iBook. Couldn't get the iMac registered with QA because the Xubuntu/Lubuntu 12.04 system "could not find gist" . . . took a while to get apt to suggest "yorick" . . . but then running the long command to generate a clipit statement did not provide a URL . . . . Anyway, same failure to get past the Yaboot window was discovered using daily build 20140829 on the iMac . . . .

apport information

tags: added: apport-collected precise
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Fritz Hudnut (este-el-paz) wrote :

Folks:

All of this recent activity 9/1/14 was via the iMac 800 running "apport-collect 1363180" in the Xubun 12.04 partition . . . trying to run "hardinfo -ram devices.so | sed '/\*\*\*\*\*\*\*/,/\*\*\*\*\*\*\*/d' | gist-paste | clipit -c" . . . generates an error something about "gnome keyring" . . . possibly due to "gist" not being installed . . . "yorick" was . . . . So, since there is no paste-binit address generated I don't think I can complete the process of adding the iMac to the QA tracker . . . . It also appears that running the "apport-collect" in the iBook running now 14.04 . . . did not go through here in bugz report??? Although I believe that unit is added into the QA Tracker of computers . . . don't know if I would need to run that command again or not?

As it is I've tried the desktop PPC DVD in both of my PPC computers and have had the same issue . . . . BTW, while watching the Terminal in the iMac I saw the line "linux is not installed" . . . but, it is . . . and I was booted up in 12.04 when I ran the "apport" command . . . .

e.e.p.

tags: added: needs-bisect regression-release
Changed in linux (Ubuntu):
importance: Undecided → Medium
Wouter Lippe (wouterlippe) wrote :

I got the same message when I used the utopic-desktop installation DVD (20140906). And also when I upgraded my freshly installed Lubuntu 14.04.1 to 14.10.
My hardware is a iBook G3 600Mhz.

The hardware specs can be found here: https://gist.github.com/66e1b550cc5f9b766096.

After the upgrade I stil boot using the 14.04.1 kernel (3.13.0-35-powerpc-smp). The 14.10 kernel is 3.16.0-14-powerpc-smp.

Adam Conrad (adconrad) wrote :

-CONFIG_KERNEL_START=0xc0000000
-CONFIG_PHYSICAL_START=0x00000000
+CONFIG_KERNEL_START=0xc2000000
+CONFIG_PHYSICAL_START=0x02000000

^-- Could be this config change between trusty and utopic.

Adam Conrad (adconrad) wrote :

Okay, looks like this is bug #745358 popping back up because CRASHDUMP was accidentally re-enabled on ppc-smp. Sorting now with Tim.

Changed in linux (Ubuntu):
assignee: nobody → Tim Gardner (timg-tpi)
Adam Conrad (adconrad) wrote :

FWIW, this won't be fixed in time for the beta, so the beta PPC CDs will only boot/install on 64-bit systems, but dailies shortly after the beta should be good to go on 32-bit systems again.

Tim Gardner (timg-tpi) wrote :

CRASH_DUMP=n for powerpc-smp and powerpc-e500mc

Changed in linux (Ubuntu Utopic):
status: Confirmed → Fix Committed

@Adam:

OK, thanks for that info on the beta, I won't waste time fiddling around
with it . . . but maybe I'll check into the dailies . . . whenever that
would be . . . and try to test for boot-up . . . . So far the 14.04 ppc on
the iBook has rough window dragging . . . slow scrolling . . . . Might try
to install 14.10 if it looks better than 14.04.

F/ e.e.p.

On Wed, Sep 24, 2014 at 12:04 PM, Adam Conrad <adconrad@0c3.net> wrote:

> FWIW, this won't be fixed in time for the beta, so the beta PPC CDs will
> only boot/install on 64-bit systems, but dailies shortly after the beta
> should be good to go on 32-bit systems again.
>
> --
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.16.0-18.25

---------------
linux (3.16.0-18.25) utopic; urgency=low

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1373682
 -- Tim Gardner <email address hidden> Wed, 24 Sep 2014 19:23:23 -0600

Changed in linux (Ubuntu Utopic):
status: Fix Committed → Fix Released
Fritz Hudnut (este-el-paz) wrote :

Great!! Glad there was a way to deal with the issue . . . I'll check into the dailies in a week or so . . . .

e.e.p.

Wouter Lippe (wouterlippe) wrote :

Great! Lots of thanks to the developers. Such a shame that I cannot test this soon, because I don't have access to my iBook.

Lars Noodén (larsnooden) wrote :

Still present in the daily from 2014-10-02 on a PowerBook Titanium 1GHz 7455

The duplicate bug #1367448 has a better description of the kernel error.

Fritz Hudnut (este-el-paz) wrote :

Lars, et al:

Thanks for the update, I guess "fixed" has many meanings; I'll give it a
few weeks, hopefully before my iBook takes its final KP episode. But, I
checked the duplicate description, seems almost verbatim "the same" . . .
so, uh, yeah I can see how that one is "better" . . . . <shrug> It's
really the same bug, same problem, which appears to not be fixed yet, right?

F

On Thu, Oct 2, 2014 at 8:36 AM, Lars Noodén <email address hidden> wrote:

> Still present in the daily from 2014-10-02 on a PowerBook Titanium 1GHz
> 7455
>
> The duplicate bug #1367448 has a better description of the kernel error.
>
> --
>

Walter Lapchynski (wxl) wrote :

@Fritz it's apparently not fixed for Lars but we need others to
confirm that. Please include your report. Final release is due on the
23rd, btw.

Fritz Hudnut (este-el-paz) wrote :

@Walter:

Alrighty, be a few days before I can download and burn the iso . . . I'll
post back when I've at least tried to boot or run the installer . . . .

F

On Thu, Oct 2, 2014 at 10:42 AM, Walter Lapchynski <
<email address hidden>> wrote:

> @Fritz it's apparently not fixed for Lars but we need others to
> confirm that. Please include your report. Final release is due on the
> 23rd, btw.
>
>
>

Fritz Hudnut (este-el-paz) wrote :

Folks:

OK, with today's daily 10/3 powerpc I was able to get passed the Yaboot
boot screen, in both my iMac 800 and my iBook, so that's the good news. In
the iMac I just used the live video=ofonly??? the semi default boot
parameter and eventually got to a black screen . . . I would need to be
reminded on what the boot parameters for the iMac are . . . .

However, on the iBook, which I might actually try the install on, I used
"live-nosplash-powerpc video=radeonfb: 1024x768-32@60" . . . . And that
got me to a clean resolution GUI desktop!!! But, when I tried to set the
time so that I could use Gmail to post this report . . . the screen "froze"
on the drop down menu of time zones. I rebooted and tried again, this time
I tried to just adjust the time without doing the timezone and . . . it
didn't "synchronize" . . . . Then, just for humor I wanted to check the
"window dragging" capacity, which is not good in 14.04 on this same
computer . . . and, the cursor turned into the 'clenched hand" . . . the
window moved a few spaces, then stopped . . . I released the mouse button .
. . and the clenched fist stayed clenched . . . nothing else responded . .
. system frozen . . . shut it down and rebooted back into OSX.

So, it looks "closer" but, still no cigar in terms of stability such that
QA testing could be done . . . couldn't take the time to try an install,
etc.

F

On Thu, Oct 2, 2014 at 12:12 PM, Fritz Hudnut <email address hidden> wrote:

> @Walter:
>
> Alrighty, be a few days before I can download and burn the iso . . . I'll
> post back when I've at least tried to boot or run the installer . . . .
>
> F
>
> On Thu, Oct 2, 2014 at 10:42 AM, Walter Lapchynski <
> <email address hidden>> wrote:
>
>> @Fritz it's apparently not fixed for Lars but we need others to
>> confirm that. Please include your report. Final release is due on the
>> 23rd, btw.
>>
>>
>>
>

Walter Lapchynski (wxl) wrote :

On Fri, Oct 3, 2014 at 6:38 PM, Fritz Hudnut <email address hidden> wrote:
> OK, with today's daily 10/3 powerpc I was able to get passed the Yaboot
> boot screen, in both my iMac 800 and my iBook, so that's the good news.

that means this one's fixed.

> the iMac I just used the live video=ofonly??? the semi default boot
> parameter and eventually got to a black screen . . . I would need to be
> reminded on what the boot parameters for the iMac are . . . .

for fixing general issues with ppc, refer to this:
https://wiki.ubuntu.com/PowerPCFAQ
(there are many paragraphs of discussion about proper boot parameters
and different options for different graphics chips)

however, this may still be an issue:
https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/1371651

> However, on the iBook, which I might actually try the install on, I used
> "live-nosplash-powerpc video=radeonfb: 1024x768-32@60" . . . . And that
> got me to a clean resolution GUI desktop!!!

the fix that i have seen for the blank GUI is "quiet splash" but
perhaps the nosplash fixed it in this case?

Fritz Hudnut (este-el-paz) wrote :

Yes, for me this bug is fixed.

>
> that means this one's fixed.
>

Thanks for the link, I may check into it, but low probability of time to
get 14.10 running on the iMac . . . I'm simply assuming it is "unsupported"
. . . vis video drivers . . . I heard "nv" is no longer available, etc.

>
>
> https://wiki.ubuntu.com/PowerPCFAQ
> (there are many paragraphs of discussion about proper boot parameters
> and different options for different graphics chips)
>

This 1371651***might*** be an issue on the iMac, since the screen went
green/black to black, as it does w/o proper xorg.conf file . . . I can't
tell if it gets to lightdm, of course on the "live desktop" I think it just
goes to the desktop, right? And, same thing on iBook, since I booted the
live version it just went to Desktop.

>
> however, this may still be an issue:
> https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/1371651
>
> On the iBook it is not a "blank GUI" . . . it is a GUI that freezes or I
guess we could say, "crashes" . . . but leaving the GUI present . . . all
the buttons and windows are there, but nothing responds. I would assume
that is a bug of some type, when I get time I'll try to file or find an
appropriate bug for the new problem . . . which isn't exactly new, since in
14.04 on the iBook, window dragging is "blotchy" . . . slow, and scrolling
is slow . . . . So, whatever that issue is has either not been handled or
has possibly worsened on the PPC platform?

The "nosplash" thing I got from the Yaboot "tab" key . . . the "quiet
splash" thing had to do with the fix for another bug on "gdm" or lightdm??

F

>
> the fix that i have seen for the blank GUI is "quiet splash" but
> perhaps the nosplash fixed it in this case?
>
> --
>

Lars Noodén (larsnooden) wrote :

Yes, it is fixed for me, too, now. The 2014-10-05 Desktop ppc image boots. Even the graphics work without passing boot parameters! Nicely done.

Wouter Lippe (wouterlippe) wrote :

Yes, it is fixed for me (iBook G3 600 Mhz) too.
I ran an update which installed kernel 3.16.0-22.29-powerpc-smp. I didn't test the iso yet.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers