Daily does not boot into graphical interface after installation

Bug #1371651 reported by Daniel Kessel on 2014-09-19
86
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Light Display Manager
Undecided
Unassigned
lightdm (Ubuntu)
Critical
James Hunt
linux (Ubuntu)
Critical
Andy Whitcroft
plymouth (Ubuntu)
Critical
Andy Whitcroft

Bug Description

used the daily iso 2015-09-19 i386
ran installation on virtualbox 4.3.16

after installation, the system won't boot into the graphical interface. instead, switching to vt1 and back to vt7 reveals the attached errors.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.16.0-16.22-generic 3.16.2
Uname: Linux 3.16.0-16-generic i686
ApportVersion: 2.14.7-0ubuntu2
Architecture: i386
Date: Fri Sep 19 17:09:17 2014
InstallCmdLine: file=/cdrom/preseed/xubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- debian-installer/language=de keyboard-configuration/layoutcode?=de
InstallationDate: Installed on 2014-09-19 (0 days ago)
InstallationMedia: Xubuntu 14.10 "Utopic Unicorn" - Alpha i386 (20140919)
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Daniel Kessel (dkessel) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1371651

tags: added: iso-testing
Elfy (elfy) on 2014-09-19
summary: - xubuntu does not boot into graphical interface after installation
+ Daily does not boot into graphical interface after installation
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Elfy (elfy) wrote :

confirmed in both xubuntu and ubuntu, slight difference in console output in Ubuntu

Elfy (elfy) wrote :

in vt1 for both tested variants

service lightdm status is stop/waiting

service lightdm start gets login dialogue

affects: ubiquity (Ubuntu) → lightdm (Ubuntu)
Elfy (elfy) on 2014-09-19
tags: added: amd64 ubuntu xubuntu
Brendan Perrine (walterorlin) wrote :

Also happens in Lubuntu with the desktop iso haven't tried the alternate yet.

Elfy (elfy) on 2014-09-19
tags: added: lightdm
removed: ubiquity-2.19.8
Jean-Baptiste Lallement (jibel) wrote :

Confirmed in qemu with Ubuntu Desktop i386 20140921

Changed in lightdm (Ubuntu):
importance: Undecided → Critical
Jean-Baptiste Lallement (jibel) wrote :

If I disable "quiet splash", lightdm starts normally. I looks racy.

syslog with debug mode enabled and lightdm failing to start.

Elfy (elfy) wrote :

On Xubuntu - if I remove quiet splash I just land at vt1

Changed in lightdm (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Robert Ancell (robert-ancell) wrote :

Can anyone get /var/log/lightdm/lightdm.log after this occurs?

When this occurs /var/log/lightdm/ is empty.

Changed in lightdm (Ubuntu):
status: Confirmed → Triaged
Changed in lightdm:
status: New → Confirmed
Elfy (elfy) wrote :

not sure if this helps - but booting with systemd and all is well

Elfy (elfy) wrote :

edited grub.cfg

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash init=/lib/systemd/systemd "

update grub and it works as expected

Walter Lapchynski (wxl) wrote :

does this work ok on real installs?

Robert Ancell (robert-ancell) wrote :

Also, what version of LightDM? This might have occurred with 1.11.8 which was used at the time the ISO was built. It had an issue where some video hardware wasn't being detected as usable including in VMs. It has since been replaced with 1.11.9 which should start fine.

Brendan Perrine (walterorlin) wrote :

I can confirm lightdm 1.11.9 works on real hardware of an nvidia gt 5200 I am still able to reproduce the bug with in virtualbox with 1.11.9.

Elfy (elfy) wrote :

@robert-ancell - live image is 1.11.9

output of initctl --system list

syslog with --debug and utopic desktop i386 20140923

lightdm starts when running: sudo initctl --system emit plymouth-ready

there is no PRIMARY_DEVICE_FOR_DISPLAY in /var/log/udev
and vesafb is not loaded

Sebastien Bacher (seb128) wrote :

James started helping to debug that on IRC today and that seems like an upstart script issue rather than a lightdm one so reassigning

Changed in lightdm (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → James Hunt (jamesodhunt)
James Hunt (jamesodhunt) wrote :

As discussed on irc, the problem seemed to be that the plymouth-ready event was not being emitted since udev was not tagging a graphics device with PRIMARY_DEVICE_FOR_DISPLAY, so it looked like the problem was udev/kernel related.

According to jibel, if he enters the grub boot menu lightdm will reliably start suggesting that grub is possibly setting up the framebuffer which for some reason is not happening normally.

Looking at the log in #22, we can also see that plymouth itself is crashing (SEGV). This may also suggest a problem with the graphics setup.

I've just tried utopic-desktop-amd64.iso (20140923) under kvm and do not see the issue reported.

James Hunt (jamesodhunt) wrote :

I have now recreated using utopic-desktop-amd64.iso (20140923) and http://people.canonical.com/~jhunt/upstart/conf/rebooter.conf to force continuous reboots.

It appears that the problem only occurs if "quiet splash" is specified since I ran 25 boots without those options and was unable to recreate the issue.

----

[1] - http://people.canonical.com/~jhunt/upstart/conf/rebooter.conf

James Hunt (jamesodhunt) wrote :

Note also that I do have PRIMARY_DEVICE_FOR_DISPLAY=1 in /var/log/udev.

Recreation is under kvm.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1371651

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Laércio de Sousa (lbssousa) wrote :

A similar problem was observed with VirtualBox at bug #1365336. I guess the root of both problems can be the same: in recent VirtualBox versions, no framebuffer device is being exposed by the kernel "a priori" in a guest Ubuntu-daily system.

Have you tried to boot on a VMware virtual machine?

James Hunt (jamesodhunt) wrote :

It's looking like either "quiet" or more likely "splash" is the triggering factor here.

Changed in lightdm:
status: Confirmed → Invalid
Changed in lightdm (Ubuntu):
status: Triaged → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Critical
Elfy (elfy) wrote :

64 bit virtual box

booting without quiet or splash lands me at tty1

service lightdm status = stop/waiting

James Hunt (jamesodhunt) wrote :

After removing both 'quiet' and 'splash' options from GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub, and running 'sudo update-grub', I am no longer able to recreate the bug (over 100 boots on a 64-bit kvm instance using utopic-desktop-amd64.iso (20140923)).

@elfy: can you provide details on how reliable this failure is for you? Do you see it on every boot?

James Hunt (jamesodhunt) wrote :

205 boots and no problem with the 2 options removed.

Laércio de Sousa (lbssousa) wrote :

Try to enable vesafb at boot -- append e.g. vga=771 or vga=788 to grub command line. I think it should be better with option video=uvesafb:..., but this one requires /sbin/v86d to be installed.

Chris J Arges (arges) wrote :

I can reproduce this bug with today's desktop amd64 utopic iso in KVM. After installing, I had to reboot the VM about 4 times before I was presented with a solid purple screen. Switching to another VT I was able to type 'sudo service lightdm start' and was presented with the proper login screen.

James Hunt (jamesodhunt) wrote :

@arges: can you try reproducing without "quiet splash" as that seems to be the best lead we have so far.

Elfy (elfy) wrote :

@jamesodhunt - each and every time that I've tried since this bug surfaced - I've not got anyway to sit here doing hundreds manually obviously :)

Chris J Arges (arges) wrote :

@jamesodhunt
Disabling 'quiet splash' doesn't seem to reproduce the issue in the 20 reboots I attempted.

Elfy (elfy) wrote :

bah - wishing you could edit comments

I wonder if there's another issue - eg I'm always trying to do this from a vbox installed in a utopic install

Andy Whitcroft (apw) wrote :

Talking to the vbox startup "hangs" only, I have reproduced this locally and we can see that plymouthd is SIGSEGVing during initialisation. This would most likley trigger the lack of events and prevent lightdm startup. Am investigating.

Andy Whitcroft (apw) on 2014-09-25
Changed in linux (Ubuntu):
status: Incomplete → Triaged
assignee: nobody → Andy Whitcroft (apw)
Changed in plymouth (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Andy Whitcroft (apw)
Andy Whitcroft (apw) wrote :

This looks to be a bug in plymouth terminal handling. Specifically it appears that seat->terminal may be null and we should avoid attempting to instantiate a text terminal on it in this case.

The attached patch gets us past this issue and up to lightdm. I am unsure if the splash is actually working correctly with it.

I have applied this patch for testing and pushed updated binaries to the PPA below:

    https://launchpad.net/~apw/+archive/ubuntu/lp1371651

If anyone affected by this could install these and test to see if they resolve the issue.

Andy Whitcroft (apw) wrote :

@Lerico --- that looks to be a more comprensive version of the fix I have applied. We should likely use that.

Elfy (elfy) wrote :

@apw - installed PPA to a clean install with the beta 2 image

drops to tty1 still

service lightdm status still reports stop/waiting

Jason Gerard DeRose (jderose) wrote :

I'm not sure whether this can provide any clues, but this Ubiquity oem-config crash rings a bit similar in that it's only happening when running under KVM, not when running on hardware:

https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1374193

Haven't tried it yet on Virtual Box, though.

Cee Gee (cynicalgargoyle) wrote :

Hi there,

I am experiencing what seems to be the same issue.

When booting, LightDM greeter sounds but screen is black. This happens if I logout as well. Closing the lid of the laptop to make it go to sleep and re-opening allows me to see lightDM login screen.

TTYs are also blank when lightdm does not start.

Happy to provide any logs that you need.

Andy Whitcroft (apw) wrote :

@Cee Gee -- I believe your issue is not the same because lightdm has started, that sounds more like a brightness issue and I would recommend filing a new bug for that. Feel free to add that bug number here.

Changed in linux (Ubuntu):
status: Triaged → Invalid
Changed in lightdm (Ubuntu):
status: Confirmed → Invalid
Changed in plymouth (Ubuntu):
status: Triaged → In Progress
Ian Bruntlett (ian-bruntlett) wrote :

I've experienced the "no GUI after installing lubuntu" problem.

Here are the details relevant to my case:-

Here are the technical details:-
-rw-rw-r-- 1 ian ian 630M Sep 28 17:10 lubuntu-14.10-beta2-alternate-i386.iso
-rw-rw-r-- 1 ian ian 444 Sep 28 17:07 MD5SUMS_lubuntu
ian@rutherford:~/isos$ md5sum lubuntu-14.10-beta2-alternate-i386.iso
62da9daeaa314fa22b6fbced57568827 lubuntu-14.10-beta2-alternate-i386.iso

It installed OK with no problems. However, when booted up, apart from the BIOS screen, nothing is displayed. This PC originally had a working lubuntu 14.04LTS running on it perfectly.

Hardware used:-
Dell Optiplex GX50
1.3GHz Celeron
512MB RAM
20GB Hard disc
CD-ROM drive

Grub2 does run. I've switched it on and pressed the left shift button to get to the Grub2 screen and played around with that to no a

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.9.0-0ubuntu6

---------------
plymouth (0.9.0-0ubuntu6) utopic; urgency=medium

  * d/p/ubuntu-seat-terminal-may-be-null.patch -- check that the
    seat->terminal/keyboard is valid before instantiating a text terminal
    on it. (LP: #1371651)
 -- Andy Whitcroft <email address hidden> Thu, 25 Sep 2014 18:31:09 +0100

Changed in plymouth (Ubuntu):
status: In Progress → Fix Released
Elfy (elfy) wrote :

Booted a previously installed vm of beta 2 on vbox.

Updated and upgraded - thermald only package available. Enabled -proposed updated plymouth and associated packages.

Rebooted.

No change here, lightdm status still stop/waiting.

Can only boot to desktop with service lightdm start and then login.

Brendan Perrine (walterorlin) wrote :

a fresh i386 vm in virtualbox using 20140929 -lubuntu-desktopi386 boots with lightdm booting. I am using plymouth 0.9.0.0-ubuntu6.

Cee Gee (cynicalgargoyle) wrote :

@Andy Whitcroft Thanks!

I've submitted a new bug with all the logs I could think of here
https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/1375528

Good luck with this bug!

Elfy (elfy) wrote :

zynced to today's daily

installed and rebooted

still have to service lightdm start

still have service lightdm status =stop/waiting

doesn't look like it's fixed to me here unfortunately

James Hunt (jamesodhunt) wrote :

@elfy - is plymouth is still crashing for you?

$ sudo grep SEGV /var/log/syslog

Elfy (elfy) wrote :

@jamesodhunt - nothing found

Elfy (elfy) wrote :

Deleted exisiting zsynced image and redownloaded todays daily.

Reinstalled.

Boot fails - same symptoms - lightdm is stop/waiting.

Plymouth is 0.9.0-0ubuntu6

sudo grep SEGV /var/log/syslog echoes nothing

Andy Whitcroft (apw) wrote :

@Elf -- if there is no SEGV then this is likely different. A quick test here for me with todays image gets to lightdm ok. So in the short term we should file a new bug for your issue. You may want to put the bug number here for anyone following along.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers