Ubuntu

[Dell XPS 12-9Q33] Touchpad not recognized

Reported by Olivier Berten on 2013-08-30
192
This bug affects 28 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

With the new XPS 12 (haswell), the touchpad gets detected as "PS/2 Generic Mouse".
cat /proc/bus/input/devices
I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input13
U: Uniq=
H: Handlers=mouse2 event13
B: PROP=0
B: EV=7
B: KEY=700

Upstream URL: http://www.spinics.net/lists/linux-input/msg27737.html

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: linux-image-3.11.0-4-generic 3.11.0-4.9
ProcVersionSignature: Ubuntu 3.11.0-4.9-generic 3.11.0-rc7
Uname: Linux 3.11.0-4-generic x86_64
ApportVersion: 2.12.1-0ubuntu2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: oli 1862 F.... pulseaudio
 /dev/snd/controlC0: oli 1862 F.... pulseaudio
Date: Fri Aug 30 17:03:26 2013
HibernationDevice: RESUME=UUID=6d351a70-8a00-4f2c-a48d-a79cb070a939
InstallationDate: Installed on 2013-08-25 (4 days ago)
InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Alpha amd64 (20130825)
MachineType: Dell Inc. XPS 12-9Q33
MarkForUpload: True
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-4-generic.efi.signed root=UUID=5d13cb7e-817c-4234-b758-0d79e4eade0b ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-4-generic N/A
 linux-backports-modules-3.11.0-4-generic N/A
 linux-firmware 1.113
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/26/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A02
dmi.board.name: XPS 12-9Q33
dmi.board.vendor: Dell Inc.
dmi.board.version: A02
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvrA02:bd07/26/2013:svnDellInc.:pnXPS12-9Q33:pvrA02:rvnDellInc.:rnXPS12-9Q33:rvrA02:cvnDellInc.:ct8:cvrNotSpecified:
dmi.product.name: XPS 12-9Q33
dmi.product.version: A02
dmi.sys.vendor: Dell Inc.

Olivier Berten (olivier-berten) wrote :
Olivier Berten (olivier-berten) wrote :

Forgot to say it's a Dell computer ;-)

As asked on https://wiki.ubuntu.com/DebuggingTouchpadDetection here are some more informations

Olivier Berten (olivier-berten) wrote :
Olivier Berten (olivier-berten) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: latest-bios-a02

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.11 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11-saucy/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Olivier Berten (olivier-berten) wrote :

Not fixed but the output of the revious commands is a bit different

Olivier Berten (olivier-berten) wrote :
Olivier Berten (olivier-berten) wrote :
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-bug-exists-upstream
C. Loose (loosec-launchpad) wrote :

Hi, I have a similar problem on the same XPS 12 model.

I'm running Ubuntu 13.04 with a 3.11 kernel from saucy:
3.11.0-4-generic #9-Ubuntu SMP Mon Aug 26 15:21:06 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

I think the problem is that the touchpad and touchscreen are both recognized by the i2c_hid module.
The corresponding lines from dmesg:
 input: DLL05E3:01 06CB:2734 as /devices/pci0000:00/INT33C3:00/i2c-8/8-002c/input/input8
 hid-generic 0018:06CB:2734.0006: input,hidraw3: <UNKNOWN> HID v1.00 Pointer [DLL05E3:01 06CB:2734] on
 ACPI Warning: 0x0000000000001828-0x000000000000182f SystemIO conflicts with Region \PMIO 1 (20130517/utaddress-251)
 ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver

DLL05E3 is the touchpad in xinput.

When the psmouse module tries to use the touchpad as a synaptics device, it fails.
 psmouse serio1: synaptics: Unable to query device.

I found a way to make the touchpad work with the synaptics driver.
You can blacklist the i2c_hid module. The psmouse module can access the touchpad then and all functions (tapping, scrolling etc.) work as expected. The problem is that the touchscreen also uses the i2c_hid module and doesn't work with this fix. When I try to load the i2c_hid module after psmouse, it causes a kernel panic. I also tried to blacklist only the hid_generic module (used for the touchpad) and not the hid_multitouch module (used for the touchscreen). Unfortunately this still causes a kernel panic.

Does anyone know if it is possible to use the synaptics driver together with the i2c_hid module without psmouse? It seems to me that psmouse contains a lot of synaptics specific code. An alternative would be to prevent i2c_hid from accessing the touchpad, which might prevent the kernel panic.

C. Loose (loosec-launchpad) wrote :

Just tested kubuntu 13.10 beta 1, it shows the same bug.

Same laptop, same bug :-(

I'm running Saucy development, recently upgraded to kernel 3.11.0-7. Still no luck.

Overlooked this bug report and reported a duplicate here:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1219753

FYI: With kernel 3.8 the touchpad *does* work, but other things don't: touchscreen and (more importantly) wifi.

C. Loose (loosec-launchpad) wrote :

Hi Wouter. As described above, you can make the touchpad work fine with 3.11, but at expense of the touchscreen.

So I've read, indeed. But it would be nice to have both touchscreen and touchpad working.

Would you say that the proper solution is to fix the i2c_hid module, so it will only recognize the touchscreen and not the touchpad?

Joseph Salisbury (jsalisbury) wrote :

The v3.12-rc1 kernel was just released. Can you also test this kernel to see if it exhibits this bug:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-rc1-saucy/

  • devices Edit (3.3 KiB, application/octet-stream; name=devices)
  • xinput Edit (992 bytes, application/octet-stream; name=xinput)
  • Xorg.0.log Edit (24.3 KiB, application/octet-stream; name="Xorg.0.log")

Still not better...

2013/9/17 Joseph Salisbury <email address hidden>

> The v3.12-rc1 kernel was just released. Can you also test this kernel to
> see if it exhibits this bug:
> http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-rc1-saucy/
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1218973
>
> Title:
> XPS 12-9Q33 touchpad not recognized
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1218973/+subscriptions
>

Thank you, but kernel 3.12-rc1 does not fix the issue.

Oddly, my xinput list says "PS/2 Synaptics TouchPad" as well as "DLL05E3:01 06CB:2734", though I'm sure these are the same device.

Also strange: Olivier sees PS/2 Generic Mouse instead of Synaptics. Perhaps caused by a difference in install procedure? I've dist-upgraded from 13.04 raring to 13.10 saucy and Olivier did a fresh install of saucy alpha. Or could a BIOS version difference be the cause? I'm on A01, Olivier on A02. Aside from this difference, we're experiencing the same problem.

Shark Cow (sharkcow) wrote :

I'm also affected. Bios A02, fresh install of kubuntu 13.10 beta 1. My xinput looks like Wouter's.

Given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We are approaching release and would like to confirm if this bug is still present. Please test again with the latest development kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.11.0-7.14

I just bought this laptop and I can confirm that the problem is still there with the last version of the kernel... I'm on the last version of the bios A02 and (hoping that it is useful) this is my xinput --list

Changed in linux (Ubuntu):
status: Incomplete → Opinion
status: Opinion → Confirmed

My xinput list is the same as Filippo's on the latest dev kernel 3.11.0-8 and on 3.12rc1. Bug still exists. Touchpad is still not recognized as Synaptics.

Bug still exists in kernel 3.12rc3 with same devices and xinput list output.

Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report[0]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

Please follow the instructions on the wiki page[0]. The first step is to email the appropriate mailing list. If no response is received, then a bug may be opened on bugzilla.kernel.org.

Once this bug is reported upstream, please add the tag: 'kernel-bug-reported-upstream'.

[0] https://wiki.ubuntu.com/Bugs/Upstream/kernel

I've mailed the linux-input kernel mailing list. Is there another list or maintainer I should contact?

tags: added: kernel-bug-reported-upstream

I've received a response from one of the kernel HID developers. This bug was expected to happen someday; the i2c-hid driver for Synaptics is not ready, yet. The developer working on the driver has to ping Synaptics again to this extend. However, he told me he's not able to do anything before Nov. 1st.

Changed in linux (Ubuntu):
status: Confirmed → Triaged

Wouter van der Graaf, could you please provide a direct URL to your mailing list post?

tags: added: bot-stop-nagging needs-bisect regression-release
removed: kernel-request-3.11.0-7.14

Linux kernel (linux-input) mailing list post:

http://www.spinics.net/lists/linux-input/msg27737.html

Reponse from Benjamin Tissoires (driver developer), CC Jiri Kosina (HID maintainer):

http://www.spinics.net/lists/linux-input/msg27768.html

I have not received any further updates on this matter.

Olivier Berten, did this problem not occur in a release prior to Saucy?

tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Triaged → Incomplete

I haven't tried... but according to comment #10 it was occuring in Raring.

Benjamin Tissoires, hid driver developer, contacted Andrew Duggan of Synaptics. They are still working on it. Linux input mailing list post:

http://www.spinics.net/lists/linux-input/msg28282.html

"
It is located here:
https://github.com/mightybigcar/synaptics-rmi4/commits/rmihid

As mentioned by Andrew, any feedback are welcome.
"

In Raring with kernel 3.8, the touchpad did work, but the touchscreen and wifi did not. Since kernel 3.10, touchscreen is detected by i2c-hid kernel module, but also the touchpad. However, according to the kernel maintainers, the i2c-hid mode driver for Synaptics touchpad is missing. That's why it's is not detected as a touchpad.

Olivier Berten, getting back to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1218973/comments/37 so you personally have not tested a release prior to Saucy correct?

Correct.

Craig (cuserk) wrote :

I have a Dell XPS 12 9Q33 (Haswell), BIOS A03.

With Precise (12.04) - no wifi, unable to drag and drop windows (window will jump all over the screen, randomly. Touchpad doesn't appear to work correctly with 2 fingers on the touchpad. It seems confused. No 2 finger scroll.)
   xinput list
      SynPS/2 Synaptics TouchPad

Craig, so your hardware may be tracked, could you please file a new report via a terminal:
ubuntu-bug linux

Craig (cuserk) wrote :

Currently unable to file a new report. The Dell XPS 12 does not have a local network port, and the wifi does not work.

The wifi does work starting from 13.04. But there is still no 2 finger scrolling.

Craig, file in 13.04. Any further questions, please take them off report to more appropriate forum.

As requested, I filed a new report for hardware tracking:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1253554

Download full text (3.3 KiB)

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button"
P: Phys=PNP0C0C/button/input0
S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input0
U: Uniq=
H: Handlers=kbd event0
B: PROP=0
B: EV=3
B: KEY=10000000000000 0

I: Bus=0019 Vendor=0000 Product=0005 Version=0000
N: Name="Lid Switch"
P: Phys=PNP0C0D/button/input0
S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input1
U: Uniq=
H: Handlers=event1
B: PROP=0
B: EV=21
B: SW=1

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button"
P: Phys=LNXPWRBN/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
U: Uniq=
H: Handlers=kbd event2
B: PROP=0
B: EV=3
B: KEY=10000000000000 0

I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/devices/platform/i8042/serio0/input/input3
U: Uniq=
H: Handlers=sysrq kbd event3
B: PROP=0
B: EV=120013
B: KEY=1100f02902000 8380307cf910f001 feffffdfffefffff fffffffffffffffe
B: MSC=10
B: LED=7

I: Bus=0019 Vendor=0000 Product=0000 Version=0000
N: Name="Dell WMI hotkeys"
P: Phys=wmi/input0
S: Sysfs=/devices/virtual/input/input4
U: Uniq=
H: Handlers=rfkill kbd event4
B: PROP=0
B: EV=13
B: KEY=1500b00000000 200300000 0 0
B: MSC=10

I: Bus=0018 Vendor=06cb Product=2734 Version=0100
N: Name="DLL05E3:01 06CB:2734"
P: Phys=
S: Sysfs=/devices/pci0000:00/INT33C3:00/i2c-0/0-002c/input/input5
U: Uniq=
H: Handlers=mouse0 event5
B: PROP=0
B: EV=17
B: KEY=30000 0 0 0 0
B: REL=3
B: MSC=10

I: Bus=0018 Vendor=03eb Product=8430 Version=0100
N: Name="ATML1000:00 03EB:8430"
P: Phys=
S: Sysfs=/devices/pci0000:00/INT33C3:00/i2c-0/0-004b/input/input6
U: Uniq=
H: Handlers=mouse1 event6
B: PROP=2
B: EV=b
B: KEY=400 0 0 0 0 0
B: ABS=260800000000003

I: Bus=0003 Vendor=0bda Product=5716 Version=3204
N: Name="Integrated Webcam"
P: Phys=usb-0000:00:14.0-5/button
S: Sysfs=/devices/pci0000:00/0000:00:14.0/usb2/2-5/2-5:1.0/input/input7
U: Uniq=
H: Handlers=kbd event7
B: PROP=0
B: EV=3
B: KEY=100000 0 0 0

I: Bus=0019 Vendor=0000 Product=0006 Version=0000
N: Name="Video Bus"
P: Phys=LNXVIDEO/video/input0
S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:00/input/input8
U: Uniq=
H: Handlers=kbd event8
B: PROP=0
B: EV=3
B: KEY=3e000b00000000 0 0 0

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel PCH Headphone"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:1b.0/sound/card1/input9
U: Uniq=
H: Handlers=event9
B: PROP=0
B: EV=21
B: SW=4

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel MID HDMI/DP,pcm=8"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:03.0/sound/card0/input10
U: Uniq=
H: Handlers=event10
B: PROP=0
B: EV=21
B: SW=140

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel MID HDMI/DP,pcm=7"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:03.0/sound/card0/input11
U: Uniq=
H: Handlers=event11
B: PROP=0
B: EV=21
B: SW=140

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel MID HDMI/DP,pcm=3"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:03.0/sound/card0/input12
U: Uniq=
H: Handlers=event12
B: PROP=0
B: EV=21
B: SW=140

I: Bus=0011 Vendor=0002 Produc...

Read more...

By the way, I don't mean to be rude but what are you trying to figure out since the reason of the problem has been found... and is on the way to be fixed?

description: updated

From our devices list, the following is the actual hardware reference to the touchpad:

I: Bus=0018 Vendor=06cb Product=2734 Version=0100
N: Name="DLL05E3:01 06CB:2734"
P: Phys=
S: Sysfs=/devices/pci0000:00/INT33C3:00/i2c-0/0-002c/input/input5
U: Uniq=
H: Handlers=mouse0 event5
B: PROP=0
B: EV=17
B: KEY=30000 0 0 0 0
B: REL=3
B: MSC=10

Changed in linux (Ubuntu):
importance: Medium → High
tags: removed: needs-bisect
tags: added: kernel-da-key trusty
Olli Ries (ories) wrote :

added HW config to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1256989

installed mainline kernel per Joseph's instructions:
Linux mini-con 3.11.0-13-generic #20-Ubuntu SMP Wed Oct 23 07:38:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

I am on BIOS A02, will need to update to A03 but this requires some fiddling with a WIN install first.

Olli Ries (ories) wrote :
Olli Ries (ories) wrote :

xinput --list
 Virtual core pointer id=2 [master pointer (3)]
   ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
   ↳ Logitech USB Receiver id=11 [slave pointer (2)]
   ↳ DLL05E3:01 06CB:2734 id=13 [slave pointer (2)]
   ↳ ATML1000:00 03EB:8430 id=14 [slave pointer (2)]
 Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ HD Webcam C525 id=9 [slave keyboard (3)]
    ↳ Logitech USB Receiver id=10 [slave keyboard (3)]
    ↳ Integrated Webcam id=12 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=15 [slave keyboard (3)]
    ↳ Dell WMI hotkeys

Olli Ries (ories) wrote :

OS version, apt-get update on 12/2/13

olli@mini-con:~$ cat /etc/os-release
NAME="Ubuntu"
VERSION="13.10, Saucy Salamander"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 13.10"
VERSION_ID="13.10"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"

olli@mini-con:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=13.10
DISTRIB_CODENAME=saucy
DISTRIB_DESCRIPTION="Ubuntu 13.10"

Olli Ries (ories) wrote :

ad comment #52: that was still the saucy default kernel

now running on Linux mini-con 3.13.0-031300rc2-generic #201311291635 SMP Fri Nov 29 21:36:49 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux as per Joseph's instructions

xinput --list
Virtual core pointer id=2 [master pointer (3)]
   ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
   ↳ Logitech USB Receiver id=11 [slave pointer (2)]
   ↳ ATML1000:00 03EB:8430 id=13 [slave pointer (2)]
   ↳ DLL05E3:01 06CB:2734 id=14 [slave pointer (2)]
Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ HD Webcam C525 id=9 [slave keyboard (3)]
    ↳ Logitech USB Receiver id=10 [slave keyboard (3)]
    ↳ Integrated Webcam id=12 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=15 [slave keyboard (3)]
    ↳ Dell WMI hotkeys

Olli Ries (ories) wrote :
Olli Ries (ories) wrote :

touchpad is not working (test case: 2 finger scroll in Chromium & xchat2, system settings module not available)

Changed in linux (Ubuntu):
status: Incomplete → Triaged
newmanrs (newmanrs) wrote :

Accidentally changed status while looking for what 'triaged' exactly meant. Unable to change back. My apologies.

Changed in linux (Ubuntu):
status: Triaged → Confirmed
tags: added: bios-outdated-a03
removed: latest-bios-a02
tags: added: kernel-bug-exists-upstream-v3.12-rc1
removed: kernel-bug-exists-upstream
summary: - XPS 12-9Q33 touchpad not recognized
+ [Dell XPS 12-9Q33] Touchpad not recognized
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Andy Anderson (andyanderso) wrote :

I am pretty new to this process. Is there anything I can do to help with fixing this bug? I am an inexperienced coder and not sure what I can contribute, but I would like to help.

tags: added: needs-bisect
removed: kernel-bug-reported-upstream
description: updated

If your brave enough, you can try compiling your kernel with the new driver: https://github.com/mightybigcar/synaptics-rmi4/tree/rmihid

C. Loose (loosec-launchpad) wrote :

For simplification, you could use the kernel I compiled with the above patches from here:

https://www.fs.tum.de/~edelmann/synaptics-rmi

Now my touchpad is recognized as full synaptics touchpad, and the touchscreen still works.

An additional, minor change: When the XPS12 screen is flipped, the touchpad is now not disabled, as was the case earlier. The keyboard is disabled as before.

I haven't noticed any side effects while working with this kernel in the past few weeks.

It would be great if these patches work their way into Trusty.

Thanks a lot!

Paul Rensing (prensing) wrote :

C. Loose's kernel works for me (Dell XPS12), but I cannot install the linux-header package because of a missing dependency. That means I can't compile any DKMS drivers, so in fact, I can't really use the kernel :-( It does seem to fix the touchpad while still having the touch screen work.

Ethan Y (ethanayonker) wrote :

Using the kernel that C. Loose posted:
xinput --list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ ATML1000:00 03EB:842F id=10 [slave pointer (2)]
⎜ ↳ Synaptics RMI4 TouchPad Sensor id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Integrated Webcam id=9 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=13 [slave keyboard (3)]

I also had issues installing the header package due to dependency issues. Maybe I'll try compiling a kernel myself with the RMI4 source when I have more time.

C. Loose (loosec-launchpad) wrote :

I forgot to compile the header package. It's available now at the same URL. Sorry!

Ethan Y (ethanayonker) wrote :

I merged the rmi4 code from the rmi4hid branch of https://github.com/mightybigcar/synaptics-rmi4/tree/rmihid into the ubuntu-saucy kernel, master branch and compiled my own kernel and tested it successfully. I created the following patch set:

http://paste.ubuntu.com/6838915/

OR

http://techerrata.com/dees_troy/rmi4.patch

So it should be easier for others to apply the rmi4 driver and compile their own now as they see fit. Let me know if I can be of any further assistance.

Mads (mad3) wrote :

I'm trying to get this patch working on Gentoo with a vanilla kernel, and I cannot for the life of me figure out what kernel modules are supposed to be loaded to make this work... (the patch applies nicely on 3.12-kernels, testing this on 3.12.9...)

Should i2c-hid be loaded?
What about hid_multitouch? i2c_designware_platform/core?

Do I need any special synaptics driver within Xorg? Currently having xf86-input-synaptics and xf86-input-evdev installed...

Are there some kernel options I need to know about? Replicated the CONFIG_RMI4_* options so they look the same as your patch, no dice... (as in, rmi_hid as module, core,control,fwlib,i2c,f11 and virtual_button is built-in)

rmi_hid gets autoloaded during boot, so something seems to work..

Do you think you could paste xinput details, lsmod and such? Or do you know of something else that I need besides rmi4.patch on vanilla 3.12.9 for making this work?

Mads (mad3) wrote :

When I used the .config from the .deb that C. Loose provided (linux-image-3.12.0-7-generic_3.12.0-7.15_amd64.deb), it worked! Hope I can figure out what I did wrong with my own .config...

Daniel (theboze) wrote :

C. Loose's kernel works for me (yay for two-finger scolling)!

$ xinput
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ ATML1000:00 03EB:842F id=10 [slave pointer (2)]
⎜ ↳ Synaptics RMI4 TouchPad Sensor id=12 [slave pointer (2)]

C. Loose, you mentioned the track pad is no longer disabled when the screen is flipped. This actually never worked for me on 13.10 on 3.11 before or after being upgraded.

One quirk I have notice with this patch: When I click-to-drag, clicking with one finger and dragging with another no longer functions. Instead, I must move the same finger I depress the trackpad with to drag. Is anyone else experiencing this?

I was just going to say the same. Left and right click at the bottom of the trackpad don't work anymore. It's easy to replace but it's surprising when you couldn't use double finger gestures for a while ;-)

Daniel (theboze) wrote :

I am experienceing the trackpad no longer functioning coming out of suspend now as well.

C. Loose (loosec-launchpad) wrote :

To fix the left, middle, and right buttons at the bottom of the touchpad I put the attached file in /etc/X11/xorg.conf.d/

The important lines are
Option "ClickPad" "on"
Option "SoftButtonAreas" "60% 0 82% 0 40% 59% 82% 0"

The ClickPad is not automatically recognized and the soft-button areas are not set reasonably by default. After restarting the X server with these settings the buttons work normally (even include a middle button).

The touchpad sometimes stops working after waking up from suspend. To fix this I reload the rmi_hid kernel module after suspending.

Petr Burian (kruxik) wrote :

Kubutnu 14.04, kernel 3.13.0-14-generic: same issue.

This workaround works for me:

1. Open /etc/modprobe.d/blacklist.conf in your favorite text editor.
2. Add the line 'blacklist i2c-hid' (no quotes)
3. Save and reboot

SynPS/2 Synaptics TouchPad is now detected and working

xyzzy (paysinger) wrote :

Bug still exists in Kernel 3.14.0-999.201403040405
And with Bios A04

Barry (barry-magicrd) wrote :

Running development of 14.04 (beta).

Havin this same issue reported here (ie. after default install, the touchpad and touchscreen both half-work - can click, but no multi-touch, swipe, drag gestures work)

After blacklisting i2c_hid in /etc/modules.d then touchpad works as expected. However, now touchscreen doesn't register anything at all.

Reading this bug report, I see a references to rmi4 driver to fix this...further I see synaptics_i2c_rmi4 driver in kernel/staging - however upon loading can detect no difference in functionality.

Perhaps I need to disable / enable some other kernel module in conjunction with rmi4 to get this to work?

tags: added: bios-outdated-a04
removed: bios-outdated-a03
tags: added: kernel-key
removed: needs-bisect
sigman (sigmeneu) wrote :

Workaround from #74 works but it would be nice to have touchscreen working as well. Has anyone came up with a full solution yet?

Driver is still in development. You could, however, try installing a custom kernel with this driver. Read from comment #61 down.

tags: removed: kernel-key
AceLan Kao (acelankao) wrote :

Try this, it should work well
https://github.com/bentiss/hid-rmi

Andreas Ehrle (andreasehrle) wrote :

not for me.

https://github.com/bentiss/hid-rmi

taints the kernel (3.13.0-23) due to module verification fails.

make install:
make -C /lib/modules/3.13.0-23-generic/build SUBDIRS=/home/halbamy/Downloads/hid-rmi-master modules_install
make[1]: Betrete Verzeichnis '/usr/src/linux-headers-3.13.0-23-generic'
  INSTALL /home/halbamy/Downloads/hid-rmi-master/hid-rmi.ko
Can't read private key
  DEPMOD 3.13.0-23-generic
make[1]: Verlasse Verzeichnis '/usr/src/linux-headers-3.13.0-23-generic'
/bin/bash install.sh hid-rmi hid-generic

dmesg:
[ 2.239480] hid_rmi: module verification failed: signature and/or required key missing - tainting kernel

Download full text (3.4 KiB)

Works for me, but you must have i2c_hid enabled also. (previous suggestions were to blacklist this, so make no blacklisted in /etc/modprobe.d)

On Apr 10, 2014, at 2:37 PM, Andreas Ehrle <email address hidden> wrote:

> not for me.
>
> https://github.com/bentiss/hid-rmi
>
> taints the kernel (3.13.0-23) due to module verification fails.
>
> make install:
> make -C /lib/modules/3.13.0-23-generic/build SUBDIRS=/home/halbamy/Downloads/hid-rmi-master modules_install
> make[1]: Betrete Verzeichnis '/usr/src/linux-headers-3.13.0-23-generic'
> INSTALL /home/halbamy/Downloads/hid-rmi-master/hid-rmi.ko
> Can't read private key
> DEPMOD 3.13.0-23-generic
> make[1]: Verlasse Verzeichnis '/usr/src/linux-headers-3.13.0-23-generic'
> /bin/bash install.sh hid-rmi hid-generic
>
> dmesg:
> [ 2.239480] hid_rmi: module verification failed: signature and/or required key missing - tainting kernel
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1218973
>
> Title:
> [Dell XPS 12-9Q33] Touchpad not recognized
>
> Status in “linux” package in Ubuntu:
> Triaged
>
> Bug description:
> With the new XPS 12 (haswell), the touchpad gets detected as "PS/2 Generic Mouse".
> cat /proc/bus/input/devices
> I: Bus=0011 Vendor=0002 Product=0001 Version=0000
> N: Name="PS/2 Generic Mouse"
> P: Phys=isa0060/serio1/input0
> S: Sysfs=/devices/platform/i8042/serio1/input/input13
> U: Uniq=
> H: Handlers=mouse2 event13
> B: PROP=0
> B: EV=7
> B: KEY=700
>
> Upstream URL: http://www.spinics.net/lists/linux-input/msg27737.html
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.10
> Package: linux-image-3.11.0-4-generic 3.11.0-4.9
> ProcVersionSignature: Ubuntu 3.11.0-4.9-generic 3.11.0-rc7
> Uname: Linux 3.11.0-4-generic x86_64
> ApportVersion: 2.12.1-0ubuntu2
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC1: oli 1862 F.... pulseaudio
> /dev/snd/controlC0: oli 1862 F.... pulseaudio
> Date: Fri Aug 30 17:03:26 2013
> HibernationDevice: RESUME=UUID=6d351a70-8a00-4f2c-a48d-a79cb070a939
> InstallationDate: Installed on 2013-08-25 (4 days ago)
> InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Alpha amd64 (20130825)
> MachineType: Dell Inc. XPS 12-9Q33
> MarkForUpload: True
> ProcFB: 0 inteldrmfb
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-4-generic.efi.signed root=UUID=5d13cb7e-817c-4234-b758-0d79e4eade0b ro quiet splash vt.handoff=7
> RelatedPackageVersions:
> linux-restricted-modules-3.11.0-4-generic N/A
> linux-backports-modules-3.11.0-4-generic N/A
> linux-firmware 1.113
> SourcePackage: linux
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 07/26/2013
> dmi.bios.vendor: Dell Inc.
> dmi.bios.version: A02
> dmi.board.name: XPS 12-9Q33
> dmi.board.vendor: Dell Inc.
> dmi.board.version: A02
> dmi.chassis.type: 8
> dmi.chassis.vendor: Dell Inc.
> dmi.chassis.version: Not Specified
> dmi.modalias: dmi:bvnDellInc.:bvrA02:bd07/26/2013:svnDellInc.:pnXPS12-9Q33:pvrA02:rvnDellInc.:rnXPS12-9Q33:rvrA02:cvnDell...

Read more...

Andreas Ehrle (andreasehrle) wrote :

I have not blacklisted i2c_hid.
Previously I was running a custom kernel from https://github.com/mightybigcar/synaptics-rmi4/tree/rmihid.
I just wanted to try this module with the 3.13.0-23-generic kernel from the repro.

Barry (barry-magicrd) wrote :
Download full text (5.7 KiB)

To be honest, there are few strange issues related to using trackpad / touchscreen. Sometimes can't two-finger scroll after using touchscreen, etc.

But for reference, here is my config:

dell-xps12:~$ uname -a
Linux dell-xps12 3.13.0-23-generic #45-Ubuntu SMP Fri Apr 4 06:58:38 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

y@dell-xps12:~/devel/hid-rmi$ lsmod
Module Size Used by
hid_multitouch 17407 0
i2c_hid 18704 0
hid_rmi 17520 0
ctr 13049 1
ccm 17773 1
ipt_MASQUERADE 12880 3
iptable_nat 13011 1
nf_nat_ipv4 13263 1 iptable_nat
nf_nat 21798 3 ipt_MASQUERADE,nf_nat_ipv4,iptable_nat
nf_conntrack_ipv4 15012 2
nf_defrag_ipv4 12758 1 nf_conntrack_ipv4
xt_conntrack 12760 1
nf_conntrack 96976 6 ipt_MASQUERADE,nf_nat,nf_nat_ipv4,xt_conntrack,iptable_nat,nf_conntrack_ipv4
ipt_REJECT 12541 2
xt_CHECKSUM 12549 1
iptable_mangle 12695 1
xt_tcpudp 12884 6
bridge 110754 0
stp 12976 1 bridge
llc 14552 2 stp,bridge
joydev 17381 0
ip6table_filter 12815 0
ip6_tables 27025 1 ip6table_filter
iptable_filter 12810 1
ip_tables 27239 3 iptable_filter,iptable_mangle,iptable_nat
ebtable_nat 12807 0
ebtables 30913 1 ebtable_nat
x_tables 34059 11 ip6table_filter,xt_CHECKSUM,ip_tables,xt_tcpudp,ipt_MASQUERADE,xt_conntrack,iptable_filter,ebtables,ipt_REJECT,iptable_mangle,ip6_tables
arc4 12608 2
dm_crypt 23177 1
iwlmvm 189774 0
hid_sensor_magn_3d 13209 0
hid_sensor_gyro_3d 13209 0
mac80211 626489 1 iwlmvm
hid_sensor_accel_3d 13221 0
hid_sensor_trigger 12916 3 hid_sensor_gyro_3d,hid_sensor_accel_3d,hid_sensor_magn_3d
industrialio_triggered_buffer 12882 3 hid_sensor_gyro_3d,hid_sensor_accel_3d,hid_sensor_magn_3d
kfifo_buf 13379 1 industrialio_triggered_buffer
industrialio 54069 6 hid_sensor_trigger,hid_sensor_gyro_3d,industrialio_triggered_buffer,hid_sensor_accel_3d,kfifo_buf,hid_sensor_magn_3d
hid_sensor_iio_common 13755 3 hid_sensor_gyro_3d,hid_sensor_accel_3d,hid_sensor_magn_3d
pn544_mei 12787 0
mei_phy 13881 1 pn544_mei
pn544 18174 1 pn544_mei
hci 44425 2 pn544,mei_phy
nfc 95012 2 hci,pn544
dell_wmi 12761 0
sparse_keymap 13948 1 dell_wmi
dell_laptop 18168 0
dcdbas 14928 1 dell_laptop
hid_sensor_hub 19536 5 hid_sensor_trigger,hid_sensor_gyro_3d,hid_sensor_accel_3d,hid_sensor_magn_3d,hid_sensor_iio_common
uvcvideo 80885 0
videobuf2_vmalloc 13216 1 uvcvideo
videobuf2_memops 13362 1 videobuf2_vmalloc
videobuf2_core 40664 1 uvcvideo
videodev 134688 2 uvcvideo,videobuf2_core
dm_multipath 22873 0
scsi_dh 14882 1 dm_multipath
in...

Read more...

AceLan Kao (acelankao) wrote :

Andreas, could you attach the result of lsmod and dmesg.

Barry, this never happened to me.
Could you find out a more reproducible way, so that I can help to verify it.

Andreas Ehrle (andreasehrle) wrote :

attatched dmesg and lsmod

Andreas Ehrle (andreasehrle) wrote :

lsmod

Andreas Ehrle (andreasehrle) wrote :

I just noticed in my logs that the hid-rmi module is not loaded. So I did make uninstall, make clean, make, make install but still nothing. If I inset the module with insmod I get
[ 478.948118] hid_rmi: module verification failed: signature and/or required key missing - tainting kernel
Anything else I can do?

Andreas Ehrle (andreasehrle) wrote :

It is working now.
I did a rmmod hid_generic, rmmod hid_rmi, modprobe hid_rmi.
So I blacklisted hid_generic and everything is working after a reboot.

Andreas Ehrle (andreasehrle) wrote :

I was too quick about the restart. Blacklisting hid_generic causes the touchscreen to be non functional.
But after rmmod hid_generic, rmmod hid_rmi, modprobe hid_rmi all is well.

AceLan Kao (acelankao) wrote :

Andreas,
Yes, you found the correct path to fix it.
Don't know why udev rules doesn't work every time.
BTW, you can add a file under /etc/modprobe.d/ to automatically remove hid_generic
$ cat /etc/modprobe.d/hid-rmi.conf
   install hid_rmi rmmod hid_generic ; modprobe --ignore-install hid_rmi

Barry (barry-magicrd) wrote :

AceLan:

After further investigation I think its working fine. Turns out after I blacklisted hid-generic all seems ok now.

Dreas van Donselaar (dreas-9) wrote :

I'm a n00b here. I downloaded hid-rmi as above, ran make, and sudo make install. According to lsmod, hid-rmi is not running. If I run insmod hid-rmi.ko and then rmmod hid-general, I have a kernel crash. What steps am I missing? modprobe hid-rmi doesn't find the module.

Barry (barry-magicrd) wrote :

Hi Dreas:

Quick steps from memory.

1. make/make install of hid-rmi
2. Manually run 'sudo depmod -a' (wouldn't find it without this step).
3. Ensure that you can modprobe it and that its found now, if so proceed. No point proceeding unless you get this sorted.
4. Ensured that i2c_hid wasn't blacklisted and was loading.
5. Created /etc/modprobe.d/hid-rmi.conf as follows:

install hid_rmi rmmod hid_generic ; modprobe --ignore-install hid_rmi

6. Reboot and make sure all was loading. (If correct both touchscreen will work and touchpad will register correctly under System Settings->Mouse - otherwise touchpad just appears as regular mouse unter System Settings->Mouse)

Dreas van Donselaar (dreas-9) wrote :

Thanks Barry. modprobe indeed worked, however after reboot my system quickly freezes with a kernel panic. Removing /etc/modprobe.d/hid-rmi.conf in recovery mode gave me access to things again. Anyway I can help troubleshoot that?

Barry (barry-magicrd) wrote :

Hi Dreas:

Please see my curent working lsmod and uname attached.

I can only imagine that you are either missing a module or that an extra is loading that conflicts.

Dreas van Donselaar (dreas-9) wrote :

Hmm, that's quite different. Attached my list. I'm running a 3.11 kernel though so perhaps that's the problem?

Barry (barry-magicrd) wrote :

Could well be, but I don't know enough about the internals of hid-rmi to confirm.

But, yes I'm running this on 14.04 (beta), so no doubt lots of changes.

Dreas van Donselaar (dreas-9) wrote :

On 3.13 I indeed get no more kernel panics and things seem to work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers