[Dell Vostro 5460] Right key on the touchpad is not working

Bug #1188025 reported by Po-Hsu Lin on 2013-06-06
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
HWE Next
High
AceLan Kao
Trusty
High
AceLan Kao
linux (Ubuntu)
High
AceLan Kao
Declined for Raring by Ara Pulido
Trusty
Undecided
AceLan Kao

Bug Description

CID: 201211-12070, 201211-12071, 201211-12072, 201211-12073

Tried with 12.04.2 + update and 13.04
The right key on the touchpad of these four systems is not working.
Verified with the pre-install version, right key does work on it.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.5.0-32-generic 3.5.0-32.53~precise1
ProcVersionSignature: Ubuntu 3.5.0-32.53~precise1-generic 3.5.7.11
Uname: Linux 3.5.0-32-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
ApportVersion: 2.0.1-0ubuntu17.2
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC290 Analog [ALC290 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1555 F.... pulseaudio
CRDA:
 country TW:
  (2402 - 2472 @ 40), (3, 27)
  (5270 - 5330 @ 40), (3, 17), DFS
  (5735 - 5815 @ 40), (3, 30)
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf2610000 irq 47'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:10ec0290,102805d9,00100003 HDA:80862806,80860101,00100000'
   Controls : 28
   Simple ctrls : 12
Date: Thu Jun 6 14:18:49 2013
HibernationDevice: RESUME=UUID=6a753cbc-8331-4503-b189-7581e8fffe50
InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64 (20130213)
MachineType: Dell Inc. Vostro 5460
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-32-generic root=UUID=e94d2ab1-eaf2-420f-87ae-7a5d6b5e4dd1 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-32-generic N/A
 linux-backports-modules-3.5.0-32-generic N/A
 linux-firmware 1.79.4
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/19/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X11
dmi.board.name: TIE3C1
dmi.board.vendor: Dell Inc.
dmi.board.version: X00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrX11:bd11/19/2012:svnDellInc.:pnVostro5460:pvr:rvnDellInc.:rnTIE3C1:rvrX00:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Vostro 5460
dmi.sys.vendor: Dell Inc.

Po-Hsu Lin (cypressyew) wrote :
description: updated
Po-Hsu Lin (cypressyew) wrote :
Po-Hsu Lin (cypressyew) wrote :

evtest log
Click twice on the left key, then twice on right key.

Po-Hsu Lin (cypressyew) wrote :

xev log
Click twice on the left key, then twice on the right key.

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Tried with 3.10rc4 kernel, problem persists.

Daniel Manrique (roadmr) on 2013-06-06
Changed in linux (Ubuntu):
importance: Undecided → Medium
Anthony Wong (anthonywong) wrote :

HI Po-Hsu, this should be a regression. Can you please re-install with a fresh 12.04, and then try the following kernels one by one and report back which one works and which one doesn't, thanks.

- linux-image-3.2.0-32
- linux-image-3.2.0-33
- linux-image-3.2.0-34

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Changed in hwe-next:
status: New → Incomplete
importance: Undecided → Medium
Po-Hsu Lin (cypressyew) wrote :

Verified with these 3 kernels, right key does not work with any of them.
And the wireless stop working as well. ( Intel Wireless-N 2230 [8086:0887])

Changed in hwe-next:
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
summary: - [Dell Vostro 5460] Right key on the touchapd is not working
+ [Dell Vostro 5460] Right key on the touchpad is not working
Anthony Wong (anthonywong) wrote :

@Po-Hsu,
Mainstream engineer informed that linux-image-3.2.0-26 had been working, could you please confirm if the right button can work in this version or not, thanks.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Po-Hsu Lin (cypressyew) wrote :

Hello Anthony,
Verified with a clean-install 12.04 + linux-image-3.2.0-26 on 201211-12070
Yes, the right button can work.
(It also works on stock 12.04 / 3.2.0-23)

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Anthony Wong (anthonywong) wrote :

Communicated with Po-Hsu on IRC, right button works on kernel 3.2.0-31.50. Per comment #9, the first kernel that does not work is 3.2.0-32. That leaves us a few commits to verify that leads to the regression.

Anthony Wong (anthonywong) wrote :

Po-Hsu, can you try the kernel in http://people.canonical.com/~ypwong/lp1188025/step1 and see if the issue happens or not?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Po-Hsu Lin (cypressyew) wrote :

Hello Anthony,
I've 201211-12070 verified with the kernel from your link.
The right button works fine.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Anthony Wong (anthonywong) wrote :

Thanks, next let's verify another kernel: http://people.canonical.com/~ypwong/lp1188025/step2/

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Po-Hsu Lin (cypressyew) wrote :

Hello Anthony,
right button does not work with this kernel.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Anthony Wong (anthonywong) wrote :

Thanks, let's try the next kernel: http://people.canonical.com/~ypwong/lp1188025/step3/

Po-Hsu Lin (cypressyew) wrote :

Hello Anthony,
right button does not work with this kernel too.

Po-Hsu Lin (cypressyew) wrote :

Xorg.log for 13.04 on 201211-12070

Anthony Wong (anthonywong) wrote :

The last git bisect brings us to this commit:

140a77989ae164ca87ac8b7bbda9f3afa0237599 is the first bad commit
commit 140a77989ae164ca87ac8b7bbda9f3afa0237599
Author: JJ Ding <email address hidden>
Date: Tue Apr 10 00:30:12 2012 -0700

    Input: elantech - v4 is a clickpad, with only one button

    BugLink: http://bugs.launchpad.net/bugs/1033568

    Add pointer and buttonpad properties for v4 hardware.

    Also, Jachiet reported that on Asus UX31, right button has no effect.
    It turns out v4 has only one button, the right-button effect is
    implemented with software when Windows driver is installed, or in
    firmware when touchpad is in relative mode. So remove BTN_RIGHT
    while at it.

It seems to be intentional to remove the right button.

tags: added: bios-outdated-a05
Changed in linux (Ubuntu):
assignee: Anthony Wong (anthonywong) → AceLan Kao (acelankao)
Changed in linux (Ubuntu):
importance: Medium → High
Changed in hwe-next:
importance: Medium → High
Changed in hwe-next:
assignee: nobody → AceLan Kao (acelankao)
AceLan Kao (acelankao) on 2013-10-30
Changed in hwe-next:
status: Confirmed → In Progress
AceLan Kao (acelankao) wrote :

test on the latest mainstream kernel 3.12.0-031200rc7, it's still a issue.

And read the first bad commit more carefully,
it says elan v4 clickpad has only one button, it's not true for Dell V 5460.
I'm going to generate a new patch for it and discuss with upstream maintainer.

AceLan Kao (acelankao) on 2013-11-13
Changed in hwe-next:
status: In Progress → Confirmed
Po-Hsu Lin (cypressyew) wrote :

In contrast to a similar bug, bug 1252616
This bug cannot use the "enable-rightbutton.sh" script from wiki.ubuntu.com as a workaround.
The right click event cannot captured by xev at all.

[0] https://wiki.ubuntu.com/DebuggingTouchpadDetection

tags: added: bios-outdated-a07
removed: bios-outdated-a05
tags: added: bisect-done kernel-bug-exists-upstream-v3.12-rc7
tags: added: regression-release

This bug affects Vostro 5470 version too, I'm running Ubuntu 13.10 with 3.11 kernel

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Po-Hsu Lin (cypressyew) wrote :

Hello Christopher,
Base on these comments, I don't think it's BIOS related.

And... indeed, upgrade BIOS to A07(09/04/2013) does not help at all.

tags: removed: bios-outdated-a07
Po-Hsu Lin (cypressyew) wrote :

Verified on 201307-14037 with 12.04.3 (3.8.0-35)
This bug also affects Dell Vostro M5470,
which comes with the same ETPS/2 Elantech touchpad

Series nominated.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: 201307-14037
tags: added: latest-bios-a07

Po-Hsu Lin, thank you for updating your BIOS. Could you please confirm this issue exists with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, please just make a comment to this.

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc6

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Anthony Wong (anthonywong) wrote :

@PHLin

Can you give the mainline kernel, e.g. http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/2014-01-23-trusty/, a try? There is a patch in current mainline that probably fixes this bug.

commit c15bdfd5b9831e4cab8cfc118243956e267dd30e
Commit: Dmitry Torokhov <email address hidden>
CommitDate: Wed Dec 18 08:47:29 2013 -0800

    Input: elantech - improve clickpad detection

    The current assumption in the elantech driver that hw version 3 touchpads
    are never clickpads and hw version 4 touchpads are always clickpads is
    wrong.

    There are several bug reports for this, ie:
    https://bugzilla.redhat.com/show_bug.cgi?id=1030802
    http://superuser.com/questions/619582/right-elantech-touchpad-button-not-working-in-linux

    I've spend a couple of hours wading through various bugzillas, launchpads
    and forum posts to create a list of fw-versions and capabilities for
    different laptop models to find a good method to differentiate between
    clickpads and versions with separate hardware buttons.

    Which shows that a device being a clickpad is reliable indicated by bit 12
    being set in the fw_version. I've included the gathered list inside the
    driver, so that we've this info at hand if we need to revisit this later.

Firmware of this touchpad is 0x461f04, so bit 12 is 1.

Po-Hsu Lin (cypressyew) wrote :

Hello Anthony,
verified with 3.14.0-999 on 201211-12071
the right key still not working.

http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/2014-02-06-trusty/

anto samalona (saprianto97) wrote :

Use this..!!! i got this was problem,. I give the command which i got.

Elder Marco (eldermarco) wrote :

I had the same problem on Dell Vostro 5470. Since I'm a fedora user, I opened a bug on Red Hat bugzilla and the problem has been solved by Hans from Red Hat. The patch has been applied. Here is the commit:

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/drivers/input/mouse/elantech.c?id=cd9e83e2754465856097f31c7ab933ce74c473f8

Po-Hsu Lin (cypressyew) on 2014-06-13
tags: added: trusty
Po-Hsu Lin (cypressyew) wrote :

Still affecting Trusty

@anto, sorry your solution doesn't work for me, maybe I missed something?
@Elder, yes, the description in that commit exactly describes what happened, two buttons touchpad detected as a clickpad.

Another way to verify this hardware is to press and hold the left button, you will hear a "click"
And press the right button, you will hear another "click"
But only the left button is working, if you put a finger on the right button (don't press it), and click on the left button, it will be detected as a right click, just an expected behavior for clickpads.

Changed in linux (Ubuntu Trusty):
assignee: nobody → AceLan Kao (acelankao)
Po-Hsu Lin (cypressyew) wrote :

Also affects 201307-14038 Dell Vostro 5470

tags: added: 201307-14038
Ara Pulido (ara) on 2014-06-24
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: needs-upstream-testing
AceLan Kao (acelankao) wrote :

I built a test kernel here which including a patch mentioned in comment #32
http://people.canonical.com/~acelan/bugs/lp1323476/

Po-Hsu Lin (cypressyew) wrote :

Verified with the kernel provided by AceLan in comment #35 on 201307-14037 with Trusty
Rightkey works now.

Steps:
1. Install 14.04 + update (3.13.0-29)
2. Download 4 .deb files and install them, reboot
3. Test if right key works.

Changed in linux (Ubuntu Trusty):
status: New → Fix Released
status: Fix Released → New
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Po-Hsu Lin (cypressyew) wrote :

Verified on 201307-14038 Dell Vostro 5470 and 201211-12073 Dell Vostro 5460 with the proposed 3.13.0-35 kernel, rightkey works as expected, thanks

tags: added: verification-done-trusty
removed: verification-needed-trusty
Launchpad Janitor (janitor) wrote :
Download full text (38.9 KiB)

This bug was fixed in the package linux - 3.13.0-35.62

---------------
linux (3.13.0-35.62) trusty; urgency=low

  [ Joseph Salisbury ]

  * Release Tracking Bug
    - LP: #1357148

  [ Brad Figg ]

  * Start new release

  [ dann frazier ]

  * SAUCE: (no-up) Fix build failure on arm64
    - LP: #1353657
  * [debian] Allow for package revisions condusive for branching

  [ David Henningsson ]

  * SAUCE: Call broadwell specific functions from the hda driver
    - LP: #1317865

  [ Edward Lin ]

  * SAUCE: (no-up) Add use native backlight quirk for Dell Inspiron
    5547/5447
    - LP: #1332437

  [ Imre Deak ]

  * SAUCE: drm/i915: move power domain init earlier during system resume
    - LP: #1353405

  [ Jani Nikula ]

  * SAUCE: drm/i915: use lane count and link rate from VBT as minimums for
    eDP
    - LP: #1338582
  * SAUCE: drm/i915/dp: force eDP lane count to max available lanes on BDW
    - LP: #1338582
  * SAUCE: drm/i915: provide interface for audio driver to query cdclk
    - LP: #1188091
  * SAUCE: drm/i915: demote opregion excessive timeout WARN_ONCE to
    DRM_INFO_ONCE
    - LP: #1351014

  [ Joseph Salisbury ]

  * [Config] updateconfigs after Linux 3.13.11.6 updates

  [ Luis Henriques ]

  * Revert "[Packaging] linux-udeb-flavour -- standardise on linux prefix"

  [ Ming Lei ]

  * Revert "SAUCE: (no-up) ata: Fix the dma state machine lockup for the
    IDENTIFY DEVICE PIO mode command."
    - LP: #1335645

  [ Paulo Zanoni ]

  * SAUCE: drm/i915: consider the source max DP lane count too
    - LP: #1338582

  [ Tim Gardner ]

  * [Config] CONFIG_GPIO_SYSFS=y
    - LP: #1342153
  * [Config] CONFIG_KEYS_DEBUG_PROC_KEYS=y
    - LP: #1344405
  * [Config] updateconfigs
  * [Config] CONFIG_SCSI_IPR_TRACE=y, CONFIG_SCSI_IPR_DUMP=y
    - LP: #1343109
  * [Config] CONFIG_CONTEXT_TRACKING_FORCE=n
    - LP: #1349028

  [ Timo Aaltonen ]

  * SAUCE: Fix a typo in hda i915_bdw support.
    - LP: #1343140

  [ Upstream Kernel Changes ]

  * Revert "net/mlx4_en: Fix bad use of dev_id"
    - LP: #1347012
  * Revert "ACPI / AC: Remove AC's proc directory."
    - LP: #1356913
  * Revert "mac80211: move "bufferable MMPDU" check to fix AP mode scan"
    - LP: #1356913
  * mm, pcp: allow restoring percpu_pagelist_fraction default
    - LP: #1347088
  * net: Fix permission check in netlink_connect()
    - LP: #1312989
  * netlink: Rename netlink_capable netlink_allowed
    - LP: #1312989
  * net: Move the permission check in sock_diag_put_filterinfo to
    packet_diag_dump
    - LP: #1312989
  * net: Add variants of capable for use on on sockets
    - LP: #1312989
  * net: Add variants of capable for use on netlink messages
    - LP: #1312989
  * net: Use netlink_ns_capable to verify the permisions of netlink
    messages
    - LP: #1312989
  * netlink: Only check file credentials for implicit destinations
    - LP: #1312989
  * igb: fix stats for i210 rx_fifo_errors
    - LP: #1338893
  * HID: use multi input quirk for 22b9:2968
    - LP: #1339567
  * crypto/nx: disable NX on little endian builds
    - LP: #1338666
  * ACPI / video: Add Dell Inspiron 5737 to the blacklist
    - LP: #1250401
  * Input: elantech - deal with clickpads reportin...

Changed in linux (Ubuntu Trusty):
status: New → Fix Released
status: New → Fix Released
AceLan Kao (acelankao) on 2014-10-29
Changed in hwe-next:
status: Confirmed → Fix Released
Changed in linux (Ubuntu):
status: Confirmed → Fix Released

this problem returned on ubuntu 15.04

sorry my bad, a reboot fixed the problem

To post a comment you must log in.