Ubuntu

ATH9K wireless signal weak

Reported by Joey Stevense on 2013-03-26
206
This bug affects 39 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Gentoo Linux)
New
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

AR9485 Wireless Network Adapter has a low signal when in close range of station.

I disabled hardware encryption with putting:
  options ath9k nohwcrypt=1
in
  /etc/modprobe.d/ath9k.conf

That doesn't seemed to help.

The signal has 2 bars while it has full strength in windows. (I am 2 meters away from the wifi station)

s400ca:~$ rfkill list all
2: asus-wlan: Wireless LAN
 Soft blocked: no
 Hard blocked: no
3: asus-bluetooth: Bluetooth
 Soft blocked: no
 Hard blocked: no
4: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no
5: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-26-generic 3.5.0-26.42
ProcVersionSignature: Ubuntu 3.5.0-26.42-generic 3.5.7.6
Uname: Linux 3.5.0-26-generic x86_64
ApportVersion: 2.6.1-0ubuntu10
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jintux 1988 F.... pulseaudio
Date: Tue Mar 26 06:33:06 2013
InstallationDate: Installed on 2013-03-25 (0 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: ASUSTeK COMPUTER INC. S400CA
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-26-generic root=UUID=52689dee-4881-48b6-8cca-602e15292652 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-26-generic N/A
 linux-backports-modules-3.5.0-26-generic N/A
 linux-firmware 1.95
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/28/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: S400CA.203
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: S400CA
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrS400CA.203:bd09/28/2012:svnASUSTeKCOMPUTERINC.:pnS400CA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnS400CA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: S400CA
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Joey Stevense (joey2524) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.9 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-rc4-raring/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Download full text (4.1 KiB)

Hi Joseph,

No that is not possible because I use the installation for serious
purposes, like work.

Met vriendelijke groet, / Best regards,
*Joey Stevense*

On Tue, Mar 26, 2013 at 4:05 PM, Joseph Salisbury <
<email address hidden>> wrote:

> Would it be possible for you to test the latest upstream kernel? Refer
> to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest
> v3.9 kernel[0] (Not a kernel in the daily directory) and install both
> the linux-image and linux-image-extra .deb packages.
>
> If this bug is fixed in the mainline kernel, please add the following
> tag 'kernel-fixed-upstream'.
>
> If the mainline kernel does not fix this bug, please add the tag:
> 'kernel-bug-exists-upstream'.
>
> If you are unable to test the mainline kernel, for example it will not
> boot, please add the tag: 'kernel-unable-to-test-upstream'.
> Once testing of the upstream kernel is complete, please mark this bug as
> "Confirmed".
>
>
> Thanks in advance.
>
> [0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-rc4-raring/
>
>
> ** Changed in: linux (Ubuntu)
> Importance: Undecided => Medium
>
> ** Changed in: linux (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1160188
>
> Title:
> ATH9K wireless signal weak
>
> Status in “linux” package in Ubuntu:
> Incomplete
>
> Bug description:
> AR9485 Wireless Network Adapter has a low signal when in close range
> of station.
>
> I disabled hardware encryption with putting:
> options ath9k nohwcrypt=1
> in
> /etc/modprobe.d/ath9k.conf
>
> That doesn't seemed to help.
>
> The signal has 2 bars while it has full strength in windows. (I am 2
> meters away from the wifi station)
>
> s400ca:~$ rfkill list all
> 2: asus-wlan: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> 3: asus-bluetooth: Bluetooth
> Soft blocked: no
> Hard blocked: no
> 4: hci0: Bluetooth
> Soft blocked: no
> Hard blocked: no
> 5: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: no
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.10
> Package: linux-image-3.5.0-26-generic 3.5.0-26.42
> ProcVersionSignature: Ubuntu 3.5.0-26.42-generic 3.5.7.6
> Uname: Linux 3.5.0-26-generic x86_64
> ApportVersion: 2.6.1-0ubuntu10
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: jintux 1988 F.... pulseaudio
> Date: Tue Mar 26 06:33:06 2013
> InstallationDate: Installed on 2013-03-25 (0 days ago)
> InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64
> (20121017.5)
> MachineType: ASUSTeK COMPUTER INC. S400CA
> MarkForUpload: True
> ProcEnviron:
> TERM=xterm
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcFB: 0 inteldrmfb
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-26-generic
> root=UUID=52689dee-4881-48b6-8cca-602e15292652 ro quiet splash vt.handoff=7
> RelatedPackageVersions:
> linux-restricted-modules-3.5.0-26-generic N/A
> l...

Read more...

Roy Meissner (roymeissn) wrote :

I've tested Kernel 3.8.5 from upstream --> still the same problem

Tomasz Wysocki (tomwys) wrote :

I have the same problem on Asus Vivobook S500CA. Have tried all work-arounds I have found on the internet but none helped. I you have any solutions or workarounds it will be helpful. For now I'm buing USB wifi adapter to be able to use wifi.

I have Ubuntu 13.04 now, but problem also occures on 12.10.

lspci:
02:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)

uname -a
Linux tomwys-laptop 3.8.0-19-generic #29-Ubuntu SMP Wed Apr 17 18:16:28 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

PS. If you are interested in more details of my computer configuration please ask. I will try other GNU/Linux distributions today to check if any fixed this issue. I will send any results here.

i have same bug on ubuntu 13.04 64 bits

Asus Zenbook, Ux31e

Emilio Sansano (emsansan) wrote :

Same bug here, running ubuntu 13.04 64bits on Asus Zenbook ux31e. Very weak signal or no signal at all where Windows connects fine.

kernel: 3.8.0-19

Marcus Sundman (sundman) wrote :

It's not just the signal that is low, it also disconnects frequently. (Quantal neither had low signal nor disconnected in the same situation.)

Marcus Sundman (sundman) wrote :

When it disconnects it goes like so:
May 15 21:06:51 hal wpa_supplicant[1748]: wlan0: CTRL-EVENT-DISCONNECTED bssid=00:16:01:8c:50:08 reason=4
May 15 21:06:51 hal kernel: [507716.316710] cfg80211: Calling CRDA to update world regulatory domain
May 15 21:06:51 hal NetworkManager[10608]: <info> (wlan0): supplicant interface state: completed -> disconnected
May 15 21:06:51 hal kernel: [507716.329493] cfg80211: World regulatory domain updated:
May 15 21:06:51 hal kernel: [507716.329505] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
May 15 21:06:51 hal kernel: [507716.329515] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
May 15 21:06:51 hal kernel: [507716.329524] cfg80211: (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
May 15 21:06:51 hal kernel: [507716.329533] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
May 15 21:06:51 hal kernel: [507716.329541] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
May 15 21:06:51 hal kernel: [507716.329552] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
May 15 21:06:51 hal NetworkManager[10608]: <info> (wlan0): supplicant interface state: disconnected -> scanning
May 15 21:06:52 hal wpa_supplicant[1748]: wlan0: SME: Trying to authenticate with 00:16:01:8c:50:08 (SSID='bubba' freq=2452 MHz)
...

Guy Korland (gkorland) wrote :

I have the same issue with ubuntu 13.04 64 bits
Asus Zenbook, Ux31e

Emilio Sansano (emsansan) wrote :

I tried upgrading kernel to 3.9, but the poor connection signal persisted. Then I installed compat-drivers from:

http://drvbp1.linux-foundation.org/~mcgrof/rel-html/compat-drivers/

now the connection signal is better than before. Not as good as with windows, but I get to connect in places where I couldn't before.

To try this you need to:
- download the drivers that match your kernel version. In my case, I downloaded compat-drivers-v3.9-rc4-2 because I'm on 3.9 kernel (you can check your kernel v. with uname -r)
- extact tar file.
- cd Downloads/compat-drivers-3.9-rc4-2-su
- sudo make
- sudo make install
- sudo modprobe -r ath9k
- sudo modprobe ath9k

There is no known workaround for this yet.

I used to work well in Ubuntu 12.04, with "options ath9k nohwcrypt=1".

I am using Ubuntu 13.04 x86-64 with packages up to date.

Tried compat-drivers 3.8.3-2-snpu and 3.9-rc4-2-su with no luck.

I've tested Kernel 3.10.0-031000rc2-generic from upstream --> still the same problem

Asus Zenbook, ux31e

Also have the problem... The reception is horrible and works fine in windows.
from dmesg:
[ 220.903488] WARNING: at /build/buildd/linux-3.8.0/drivers/net/wireless/ath/ath9k/hw.c:794 ar9003_get_pll_sqsum_dvc+0xb6/0xc0 [ath9k_hw]()
[ 220.903492] Hardware name: UX31E
[ 220.903495] Modules linked in: usb_storage(F) ip6table_filter(F) ip6_tables(F) ebtable_nat(F) ebtables(F) snd_hrtimer(F) ipt_MASQUERADE(F) iptable_nat(F) nf_nat_ipv4(F) nf_nat(F) nf_conntrack_ipv4(F) nf_defrag_ipv4(F) xt_state(F) nf_conntrack(F) ipt_REJECT(F) xt_CHECKSUM(F) iptable_mangle(F) xt_tcpudp(F) iptable_filter(F) ip_tables(F) x_tables(F) bridge(F) stp(F) llc(F) joydev(F) dm_crypt(F) parport_pc(F) ppdev(F) rfcomm bnep kvm_intel kvm asus_nb_wmi asus_wmi sparse_keymap snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep(F) rts5139(C) snd_pcm(F) snd_page_alloc(F) snd_seq_midi(F) snd_seq_midi_event(F) snd_rawmidi(F) snd_seq(F) uvcvideo videobuf2_vmalloc arc4(F) videobuf2_memops videobuf2_core videodev ath9k ath9k_common ath9k_hw snd_seq_device(F) snd_timer(F) ath mac80211 mac_hid microcode(F) snd(F) coretemp cfg80211 ath3k mei btusb soundcore(F) lp(F) parport(F) bluetooth psmouse(F) serio_raw(F) lpc_ich ghash_clmulni_intel(F) aesni_intel(F) aes_x86_64(F) xts(F) lrw(F) gf128mul(F) ablk_helper(F) cryptd(F) wmi i915 video(F) i2c_algo_bit drm_kms_helper ahci(F) libahci(F) drm
[ 220.903633] Pid: 214, comm: kworker/u:5 Tainted: GF C 3.8.0-21-generic #32-Ubuntu
[ 220.903637] Call Trace:
[ 220.903650] [<ffffffff810587ef>] warn_slowpath_common+0x7f/0xc0
[ 220.903658] [<ffffffff8105884a>] warn_slowpath_null+0x1a/0x20
[ 220.903676] [<ffffffffa038e9a6>] ar9003_get_pll_sqsum_dvc+0xb6/0xc0 [ath9k_hw]
[ 220.903693] [<ffffffffa03fe2e3>] ath_hw_pll_work+0x53/0xd0 [ath9k]
[ 220.903702] [<ffffffff8107676c>] process_one_work+0x15c/0x4d0
[ 220.903710] [<ffffffff81077fce>] worker_thread+0x16e/0x480
[ 220.903718] [<ffffffff81077e60>] ? manage_workers+0x2a0/0x2a0
[ 220.903725] [<ffffffff8107d300>] kthread+0xc0/0xd0
[ 220.903732] [<ffffffff8107d240>] ? kthread_create_on_node+0x120/0x120
[ 220.903742] [<ffffffff816d372c>] ret_from_fork+0x7c/0xb0
[ 220.903748] [<ffffffff8107d240>] ? kthread_create_on_node+0x120/0x120
[ 220.903753] ---[ end trace 7faecf033a2db336 ]---
[ 220.903758] ath: phy0: PLL4 meaurement not done
[ 221.015326] ath: phy0: PLL4 meaurement not done
[ 221.127122] ath: phy0: PLL4 meaurement not done
[ 221.239037] ath: phy0: PLL4 meaurement not done
[ 221.350902] ath: phy0: PLL4 meaurement not done

imedina (imedina) wrote :

I have the same issue: very low connectivity or even none. Asus UX21 with 13.04 64bits.

I do not try compat-drivers yet.

description: updated
xcalin (xcalin16-gmail) wrote :

I have also this bug with the wireless and it's very annoying

My UX31E also disconnect often. I do have signal, but weak. It doesn't disconnect as often when I'm closer to the router.

What I want to report that I have not seen anyone else mention is that it will only behave like this when on battery. I have turned off power saving (iwconfig wlan0 power off) but that does not help.

Christoph Vogler (vogler-c) wrote :

I have the same Problem with all tested Kernels. Last was 3.10-rc3.
Signal is very weak even close to the Router. On Windows signal strength is fine.

xcalin (xcalin16-gmail) wrote :

I tested 3.6.3-030603-generic and here the signal it's a little good double than on 3.8 or 3.10

jintux (jintux) on 2013-06-02
tags: added: kernel-unable-to-test-upstream
tags: added: kernel-bug-exists-upstream
removed: kernel-unable-to-test-upstream
jintux (jintux) on 2013-06-02
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
hroost (hroostik) wrote :

I have also this bug with the wireless and it's very annoying too
UX31E 3.8.0-23-generic x86_64
One and a half years having this problems

bjornegil (bejohansen) wrote :

I have the same problem. UX31E. x86_64. The wireless signal has been a bit weak all the time - but my impression was that it got worse on updating to ubuntu 13.04.
I have tried 3.9 kernel and the compat drivers without any improvement.

Does anybody know if this problem is present in 32-bit version as well?

Pionero (dmerino76) wrote :
Download full text (3.4 KiB)

Yes, 32-bit ubuntu 13.04 has the same problem.

2013/6/6 bjornegil <email address hidden>

> I have the same problem. UX31E. x86_64. The wireless signal has been a bit
> weak all the time - but my impression was that it got worse on updating to
> ubuntu 13.04.
> I have tried 3.9 kernel and the compat drivers without any improvement.
>
> Does anybody know if this problem is present in 32-bit version as well?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1160188
>
> Title:
> ATH9K wireless signal weak
>
> Status in “linux” package in Ubuntu:
> Confirmed
>
> Bug description:
> AR9485 Wireless Network Adapter has a low signal when in close range
> of station.
>
> I disabled hardware encryption with putting:
> options ath9k nohwcrypt=1
> in
> /etc/modprobe.d/ath9k.conf
>
> That doesn't seemed to help.
>
> The signal has 2 bars while it has full strength in windows. (I am 2
> meters away from the wifi station)
>
> s400ca:~$ rfkill list all
> 2: asus-wlan: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> 3: asus-bluetooth: Bluetooth
> Soft blocked: no
> Hard blocked: no
> 4: hci0: Bluetooth
> Soft blocked: no
> Hard blocked: no
> 5: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: no
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.10
> Package: linux-image-3.5.0-26-generic 3.5.0-26.42
> ProcVersionSignature: Ubuntu 3.5.0-26.42-generic 3.5.7.6
> Uname: Linux 3.5.0-26-generic x86_64
> ApportVersion: 2.6.1-0ubuntu10
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: jintux 1988 F.... pulseaudio
> Date: Tue Mar 26 06:33:06 2013
> InstallationDate: Installed on 2013-03-25 (0 days ago)
> InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64
> (20121017.5)
> MachineType: ASUSTeK COMPUTER INC. S400CA
> MarkForUpload: True
> ProcEnviron:
> TERM=xterm
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcFB: 0 inteldrmfb
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-26-generic
> root=UUID=52689dee-4881-48b6-8cca-602e15292652 ro quiet splash vt.handoff=7
> RelatedPackageVersions:
> linux-restricted-modules-3.5.0-26-generic N/A
> linux-backports-modules-3.5.0-26-generic N/A
> linux-firmware 1.95
> SourcePackage: linux
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 09/28/2012
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: S400CA.203
> dmi.board.asset.tag: ATN12345678901234567
> dmi.board.name: S400CA
> dmi.board.vendor: ASUSTeK COMPUTER INC.
> dmi.board.version: 1.0
> dmi.chassis.asset.tag: No Asset Tag
> dmi.chassis.type: 10
> dmi.chassis.vendor: ASUSTeK COMPUTER INC.
> dmi.chassis.version: 1.0
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvrS400CA.203:bd09/28/2012:svnASUSTeKCOMPUTERINC.:pnS400CA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnS400CA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
> dmi.product.name: S400CA
> dmi.product.version: 1.0
> ...

Read more...

Anton Nikityuk (antony-sq) wrote :

Are there any news?

jief (jf.monfort) wrote :

Same problem here

Ubuntu 13.04
Kernel Linux laptop 3.9.5-030905-generic #201306071748 SMP Fri Jun 7 21:49:35 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Szilard Novaki (novaki) wrote :

This has been just fixed in 3.10 kernel: https://bugzilla.kernel.org/show_bug.cgi?id=49201

can someone backport it to 12.04.2 LTS?

xcalin (xcalin16-gmail) wrote :

I tested kernel 3.10.0-031000rc5-generic still not fixed.

here you could get the kernel
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.10-rc5-saucy/

xcalin (xcalin16-gmail) wrote :

from what i read in that article would be avalabile in 3.10.rc6

2013/6/15 Calin Sirian <email address hidden>

> I tested kernel 3.10.0-031000rc5-generic still not fixed.
>
> here you could get the kernel
> http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.10-rc5-saucy/
>

--

Software Developer Mobile: (+40) 728 574 471

**

S.C. MoreDevs S.R.L. Email: <email address hidden> ****

** **

This message can contain privileged or confidential information and it
is intended only for addressee. ****

Any unauthorized disclosure is strictly prohibited.

xcalin (xcalin16-gmail) wrote :

I've compiled a kernel 3.10-rc5 with the patch included

here is the script that downloads and installs modules and kernel i have
compiled
i tested it on ubuntu 13.04 64bit

wget -O kernel.sh http://ubuntuone.com/1iJaMuISila67x9wV07SW4 && chmod +x
kernel.sh

2013/6/15 Calin Sirian <email address hidden>

> from what i read in that article would be avalabile in 3.10.rc6
>
>
> 2013/6/15 Calin Sirian <email address hidden>
>
>> I tested kernel 3.10.0-031000rc5-generic still not fixed.
>>
>> here you could get the kernel
>> http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.10-rc5-saucy/
>>
>
>
>
> --
>
>
> Software Developer Mobile: (+40) 728 574 471
>
> **
>
> S.C. MoreDevs S.R.L. Email: <email address hidden> ****
>
> ** **
>
> This message can contain privileged or confidential information and it is intended only for addressee. ****
>
>
> Any unauthorized disclosure is strictly prohibited.
>
>

--

Software Developer Mobile: (+40) 728 574 471

**

S.C. MoreDevs S.R.L. Email: <email address hidden> ****

** **

This message can contain privileged or confidential information and it
is intended only for addressee. ****

Any unauthorized disclosure is strictly prohibited.

Christoph Vogler (vogler-c) wrote :

3.10-rc6 is available now.
Can someone test the kernel i'm not able this time.

bjornegil (bejohansen) wrote :
Download full text (3.3 KiB)

I tried the 3.10-rc6 on ubuntu 13.04 amd64. No improvement. I assume the
patch did not make it into rc6.

I tried the script for updated kernel 3.10-rc5 that Xcalin posted. I have
yet not tested it to depth but so far it seems to be working great. Better
connection. So far no disconnections. I am very satisfied.

Thanks a lot!

Bjørn

2013/6/16 Christoph Vogler <email address hidden>

> 3.10-rc6 is available now.
> Can someone test the kernel i'm not able this time.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1160188
>
> Title:
> ATH9K wireless signal weak
>
> Status in “linux” package in Ubuntu:
> Confirmed
>
> Bug description:
> AR9485 Wireless Network Adapter has a low signal when in close range
> of station.
>
> I disabled hardware encryption with putting:
> options ath9k nohwcrypt=1
> in
> /etc/modprobe.d/ath9k.conf
>
> That doesn't seemed to help.
>
> The signal has 2 bars while it has full strength in windows. (I am 2
> meters away from the wifi station)
>
> s400ca:~$ rfkill list all
> 2: asus-wlan: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> 3: asus-bluetooth: Bluetooth
> Soft blocked: no
> Hard blocked: no
> 4: hci0: Bluetooth
> Soft blocked: no
> Hard blocked: no
> 5: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: no
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.10
> Package: linux-image-3.5.0-26-generic 3.5.0-26.42
> ProcVersionSignature: Ubuntu 3.5.0-26.42-generic 3.5.7.6
> Uname: Linux 3.5.0-26-generic x86_64
> ApportVersion: 2.6.1-0ubuntu10
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: jintux 1988 F.... pulseaudio
> Date: Tue Mar 26 06:33:06 2013
> InstallationDate: Installed on 2013-03-25 (0 days ago)
> InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64
> (20121017.5)
> MachineType: ASUSTeK COMPUTER INC. S400CA
> MarkForUpload: True
> ProcEnviron:
> TERM=xterm
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcFB: 0 inteldrmfb
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-26-generic
> root=UUID=52689dee-4881-48b6-8cca-602e15292652 ro quiet splash vt.handoff=7
> RelatedPackageVersions:
> linux-restricted-modules-3.5.0-26-generic N/A
> linux-backports-modules-3.5.0-26-generic N/A
> linux-firmware 1.95
> SourcePackage: linux
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 09/28/2012
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: S400CA.203
> dmi.board.asset.tag: ATN12345678901234567
> dmi.board.name: S400CA
> dmi.board.vendor: ASUSTeK COMPUTER INC.
> dmi.board.version: 1.0
> dmi.chassis.asset.tag: No Asset Tag
> dmi.chassis.type: 10
> dmi.chassis.vendor: ASUSTeK COMPUTER INC.
> dmi.chassis.version: 1.0
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvrS400CA.203:bd09/28/2012:svnASUSTeKCOMPUTERINC.:pnS400CA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnS400CA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
> ...

Read more...

Szilard Novaki (novaki) wrote :

I've backported the patch from https://bugzilla.kernel.org/show_bug.cgi?id=49201 to precise. It can be applied to the source of 3.5.0-34-generic (cd /usr/src && sudo apt-get source linux-image-3.5.0-34-generic) after entering drivers/net/wireless/ath/ath9k directory.

I recompiled ath9k modules using this guide: http://www.codewhirl.com/2012/04/how-to-compile-a-single-module-in-ubuntu-linux/. Now the signal strength is the same as on other notebooks and it does not disconnect.

tags: added: patch
Mathieu Laurent (mla) wrote :

It will be possible to fix this in an update of linux-image of Ubuntu 12.04, 13.04 ?

Joseph Salisbury (jsalisbury) wrote :

It appears the patch[0] was sent to John Linville and <email address hidden>. However, the fix has not made it into Linus' tree as of v3.10-rc6.

[0] https://patchwork.kernel.org/patch/2718041/

Changed in linux:
importance: Unknown → Medium
status: Unknown → Fix Released

i tried kernel 3.10-rc7 on ux31e 64 bits... and it doesnt improve wifi signal .

Something else is necessary to install ?

xcalin (xcalin16-gmail) wrote :
Download full text (3.5 KiB)

I guess it's not yet implemented the patch

2013/6/25 Diego Carrera Gallego <email address hidden>

> i tried kernel 3.10-rc7 on ux31e 64 bits... and it doesnt improve wifi
> signal .
>
> Something else is necessary to install ?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1160188
>
> Title:
> ATH9K wireless signal weak
>
> Status in The Linux Kernel:
> Fix Released
> Status in “linux” package in Ubuntu:
> Confirmed
>
> Bug description:
> AR9485 Wireless Network Adapter has a low signal when in close range
> of station.
>
> I disabled hardware encryption with putting:
> options ath9k nohwcrypt=1
> in
> /etc/modprobe.d/ath9k.conf
>
> That doesn't seemed to help.
>
> The signal has 2 bars while it has full strength in windows. (I am 2
> meters away from the wifi station)
>
> s400ca:~$ rfkill list all
> 2: asus-wlan: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> 3: asus-bluetooth: Bluetooth
> Soft blocked: no
> Hard blocked: no
> 4: hci0: Bluetooth
> Soft blocked: no
> Hard blocked: no
> 5: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: no
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.10
> Package: linux-image-3.5.0-26-generic 3.5.0-26.42
> ProcVersionSignature: Ubuntu 3.5.0-26.42-generic 3.5.7.6
> Uname: Linux 3.5.0-26-generic x86_64
> ApportVersion: 2.6.1-0ubuntu10
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: jintux 1988 F.... pulseaudio
> Date: Tue Mar 26 06:33:06 2013
> InstallationDate: Installed on 2013-03-25 (0 days ago)
> InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64
> (20121017.5)
> MachineType: ASUSTeK COMPUTER INC. S400CA
> MarkForUpload: True
> ProcEnviron:
> TERM=xterm
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcFB: 0 inteldrmfb
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-26-generic
> root=UUID=52689dee-4881-48b6-8cca-602e15292652 ro quiet splash vt.handoff=7
> RelatedPackageVersions:
> linux-restricted-modules-3.5.0-26-generic N/A
> linux-backports-modules-3.5.0-26-generic N/A
> linux-firmware 1.95
> SourcePackage: linux
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 09/28/2012
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: S400CA.203
> dmi.board.asset.tag: ATN12345678901234567
> dmi.board.name: S400CA
> dmi.board.vendor: ASUSTeK COMPUTER INC.
> dmi.board.version: 1.0
> dmi.chassis.asset.tag: No Asset Tag
> dmi.chassis.type: 10
> dmi.chassis.vendor: ASUSTeK COMPUTER INC.
> dmi.chassis.version: 1.0
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvrS400CA.203:bd09/28/2012:svnASUSTeKCOMPUTERINC.:pnS400CA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnS400CA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
> dmi.product.name: S400CA
> dmi.product.version: 1.0
> dmi.sys.vendor: ASUSTeK COMPUTER INC.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linux/+bug...

Read more...

Marc Gondran (marc-gondran-n) wrote :

so how have we got to do ?

Marc Gondran (marc-gondran-n) wrote :

I've tryed that :
wget -O kernel.sh http://ubuntuone.com/1iJaMuISila67x9wV07SW4 && chmod +x
kernel.sh
and It works perfectly !!
Thanks

Marc Gondran (marc-gondran-n) wrote :

In fact i tryed that
wget -O kernel.tar.gz http://ubuntuone.com/4lW7ZCTMpOmwspUacREbFU
sudo su -c 'tar xzvf kernel.tar.gz ; mv linux-3.10-rc5 /usr/src/ ; cd /usr/src/linux-3.10-rc5 ; make modules_install ; make install ; cd /boot ; mkinitramfs -o initrd.img-3.10.0-rc5 3.10.0-rc5 ; update-grub'

I copy/past the kernel.sh

Hey @Marc, i made your steps on ubuntu 13.04 x64, but Ubuntu doesn't init properly.

It is neccesary more steps or maybe i'm doing something wrong? :(

Mathieu Laurent (mla) wrote :

This patch works very well. I use it with linux-3.10-rc5 on my asus zenbook ux31e.

Now, I have wireless on my balcony ;-) It was never possible before.

Christoph Vogler (vogler-c) wrote :

With this patch my wireless works very well, too. Now i have 44% signal strength, befor the network wasn't even recognized !

# These Steps are used to get an excelent wireless signal on ATH9K on ubuntu 13.04 x64
# see https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1160188
# https://bugzilla.kernel.org/show_bug.cgi?id=49201
# Thanks so much, all peoples from these tracker systems that has been reported
# and helped about it. @Sujith Manoharan @jkp @gfmichaud

# i hope this could help more people until appears in kernel.
# first we got the kernel from github/torvalds and set to kernel 3.10-rc5 because
# this patch is tested on it.
# this command will get a folder called linux
git clone https://github.com/torvalds/linux.git
git checkout v3.10-rc5

#apply this patches, first add AR9300_EXT_LNA_CTL_GPIO_AR9485 value,
# second fix an error in first, and add more parameters
https://patchwork.kernel.org/patch/2696121/
http://msujith.org/patches/wl/Jun-13-2013/0001-ath9k-Add-custom-parameters-for-CUS198.patch

# apply this modified patch
sudo su
mv linux /usr/src/linux-3.10-rc5;
cd /usr/src/linux-3.10-rc5;

# we start to compile the kernerl on ubuntu 13.04
# http://www.howopensource.com/2011/08/how-to-compile-and-install-linux-kernel-3-0-in-ubuntu-11-04-10-10-and-10-04/

make oldconfig
make
make modules_install install
mkinitramfs -o initrd.img-3.10.0-rc5 3.10.0-rc5
update-grub

When I paste the second command "checkout v3.10-rc5" it tells me that it's an invalid command.

I also tried:

"I've tryed that :
wget -O kernel.sh http://ubuntuone.com/1iJaMuISila67x9wV07SW4 && chmod +x
kernel.sh
and It works perfectly !!
Thanks"

Which didn't work for me.

Which of the above posts will patch this?

Thanks.

@Gerry. Confirm that you have git package as pre-requeriment to get works second command.
sudo apt-get install git

And apply this second command into the linux folder that has been cloned, just like:

git clone https://github.com/torvalds/linux.git
cd linux
git checkout v3.10-rc5
cd ..

Timo Hülsmann (thuelsmann82) wrote :

Zenbook UX31E with Ubuntu 13.04

The kernel.sh-approach worked for me.

The instructions for patching and compiling the kernel on my own didn't work. I got stuck at patching the kernel.

Thanks for the quick replies.

I got this at the end. Any suggestions?

grep: /boot/config-3.10.0-rc5: No such file or directory
WARNING: missing /lib/modules/3.10.0-rc5
Device driver support needs thus be built-in linux image!
ERROR: could not open directory /lib/modules/3.10.0-rc5: No such file or directory
FATAL: could not search modules: No such file or directory
WARNING: could not open /tmp/mkinitramfs_477dVU/lib/modules/3.10.0-rc5/modules.order: No such file or directory
WARNING: could not open /tmp/mkinitramfs_477dVU/lib/modules/3.10.0-rc5/modules.builtin: No such file or directory

@Gerry, Im not sure, but I seem to be missing some packages before compiling the kernel
And make sure that the git clone has been finished correctly

# see https://help.ubuntu.com/community/Kernel/Compile
# These are some package requerimentes before compile
sudo apt-get install fakeroot build-essential crash kexec-tools makedumpfile kernel-wedge
sudo apt-get build-dep linux
sudo apt-get install git-core libncurses5 libncurses5-dev libelf-dev asciidoc binutils-dev

I hope that it could help you.

Mark Mandel (mark-mandel) wrote :

Anyone know if this is meant to be fixed in 13.10? If so, I'm happy to test it out.

xcalin (xcalin16-gmail) wrote :

I tested and still not fixed
On Jul 2, 2013 5:45 AM, "Mark Mandel" <email address hidden> wrote:

> Anyone know if this is meant to be fixed in 13.10? If so, I'm happy to
> test it out.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1160188
>
> Title:
> ATH9K wireless signal weak
>
> Status in The Linux Kernel:
> Fix Released
> Status in “linux” package in Ubuntu:
> Confirmed
>
> Bug description:
> AR9485 Wireless Network Adapter has a low signal when in close range
> of station.
>
> I disabled hardware encryption with putting:
> options ath9k nohwcrypt=1
> in
> /etc/modprobe.d/ath9k.conf
>
> That doesn't seemed to help.
>
> The signal has 2 bars while it has full strength in windows. (I am 2
> meters away from the wifi station)
>
> s400ca:~$ rfkill list all
> 2: asus-wlan: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> 3: asus-bluetooth: Bluetooth
> Soft blocked: no
> Hard blocked: no
> 4: hci0: Bluetooth
> Soft blocked: no
> Hard blocked: no
> 5: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: no
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.10
> Package: linux-image-3.5.0-26-generic 3.5.0-26.42
> ProcVersionSignature: Ubuntu 3.5.0-26.42-generic 3.5.7.6
> Uname: Linux 3.5.0-26-generic x86_64
> ApportVersion: 2.6.1-0ubuntu10
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: jintux 1988 F.... pulseaudio
> Date: Tue Mar 26 06:33:06 2013
> InstallationDate: Installed on 2013-03-25 (0 days ago)
> InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64
> (20121017.5)
> MachineType: ASUSTeK COMPUTER INC. S400CA
> MarkForUpload: True
> ProcEnviron:
> TERM=xterm
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcFB: 0 inteldrmfb
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-26-generic
> root=UUID=52689dee-4881-48b6-8cca-602e15292652 ro quiet splash vt.handoff=7
> RelatedPackageVersions:
> linux-restricted-modules-3.5.0-26-generic N/A
> linux-backports-modules-3.5.0-26-generic N/A
> linux-firmware 1.95
> SourcePackage: linux
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 09/28/2012
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: S400CA.203
> dmi.board.asset.tag: ATN12345678901234567
> dmi.board.name: S400CA
> dmi.board.vendor: ASUSTeK COMPUTER INC.
> dmi.board.version: 1.0
> dmi.chassis.asset.tag: No Asset Tag
> dmi.chassis.type: 10
> dmi.chassis.vendor: ASUSTeK COMPUTER INC.
> dmi.chassis.version: 1.0
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvrS400CA.203:bd09/28/2012:svnASUSTeKCOMPUTERINC.:pnS400CA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnS400CA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
> dmi.product.name: S400CA
> dmi.product.version: 1.0
> dmi.sys.vendor: ASUSTeK COMPUTER INC.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linux/+bug/1160188/+subscriptions
>

Timo Jyrinki (timo-jyrinki) wrote :

As indicated in bug #971809, the fix is now part of Linux 3.11 and can be obtained via backports:

Get the latest package: https://www.kernel.org/pub/linux/kernel/projects/backports/2013/06/18/
Unpack.
make defconfig-ath9k && make && sudo make install
Reboot & enjoy. (until next kernel package update)

I'm having trouble with the make command. Could someone explain how to do this, or should I just wait for it to be released since this is over my head?

Timo Hülsmann (thuelsmann82) wrote :

The backport module works fine for me with kernel 2.8.0-27-generic.

Timo Jyrinki (timo-jyrinki) wrote :

Gerry and others: I'll try to give instructions that don't "skip" any steps, hopefully it'll help. Steps 2-7 are commands you should just copy paste in terminal.

1. Open Dash and search for Terminal and open it
2. wget https://www.kernel.org/pub/linux/kernel/projects/backports/2013/06/18/backports-20130618.tar.xz
3. tar xvf backports-20130618.tar.xz
4. cd backports-20130618
5. make defconfig-ath9k
6. make
7. sudo make install
8. (insert your password when sudo asks it).
9. Ready! Reboot the computer.

The new drivers should then be in use, but note you will need to do the steps 4-7 again if a Linux kernel update comes as a security update or otherwise.

Worked perfectly! Thank you so much.

The attachment "patch to apply in drivers/net/wireless/ath/ath9k dir" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

Any hope of having this problem fixed in an official kernel in raring? It seem to affect Packard Bell EasyNote LV,
http://www.linlap.com/packard_bell_easynote_lv . The network connection seem to fall out after a few minutes.

Joey Stevense (joey2524) wrote :
Download full text (3.3 KiB)

Buy a Mac and your problems are solved

On Friday, July 26, 2013, Petter Reinholdtsen wrote:

> Any hope of having this problem fixed in an official kernel in raring? It
> seem to affect Packard Bell EasyNote LV,
> http://www.linlap.com/packard_bell_easynote_lv . The network connection
> seem to fall out after a few minutes.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1160188
>
> Title:
> ATH9K wireless signal weak
>
> Status in The Linux Kernel:
> Fix Released
> Status in “linux” package in Ubuntu:
> Confirmed
> Status in “linux” package in Gentoo Linux:
> New
>
> Bug description:
> AR9485 Wireless Network Adapter has a low signal when in close range
> of station.
>
> I disabled hardware encryption with putting:
> options ath9k nohwcrypt=1
> in
> /etc/modprobe.d/ath9k.conf
>
> That doesn't seemed to help.
>
> The signal has 2 bars while it has full strength in windows. (I am 2
> meters away from the wifi station)
>
> s400ca:~$ rfkill list all
> 2: asus-wlan: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> 3: asus-bluetooth: Bluetooth
> Soft blocked: no
> Hard blocked: no
> 4: hci0: Bluetooth
> Soft blocked: no
> Hard blocked: no
> 5: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: no
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.10
> Package: linux-image-3.5.0-26-generic 3.5.0-26.42
> ProcVersionSignature: Ubuntu 3.5.0-26.42-generic 3.5.7.6
> Uname: Linux 3.5.0-26-generic x86_64
> ApportVersion: 2.6.1-0ubuntu10
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: jintux 1988 F.... pulseaudio
> Date: Tue Mar 26 06:33:06 2013
> InstallationDate: Installed on 2013-03-25 (0 days ago)
> InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64
> (20121017.5)
> MachineType: ASUSTeK COMPUTER INC. S400CA
> MarkForUpload: True
> ProcEnviron:
> TERM=xterm
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcFB: 0 inteldrmfb
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-26-generic
> root=UUID=52689dee-4881-48b6-8cca-602e15292652 ro quiet splash vt.handoff=7
> RelatedPackageVersions:
> linux-restricted-modules-3.5.0-26-generic N/A
> linux-backports-modules-3.5.0-26-generic N/A
> linux-firmware 1.95
> SourcePackage: linux
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 09/28/2012
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: S400CA.203
> dmi.board.asset.tag: ATN12345678901234567
> dmi.board.name: S400CA
> dmi.board.vendor: ASUSTeK COMPUTER INC.
> dmi.board.version: 1.0
> dmi.chassis.asset.tag: No Asset Tag
> dmi.chassis.type: 10
> dmi.chassis.vendor: ASUSTeK COMPUTER INC.
> dmi.chassis.version: 1.0
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvrS400CA.203:bd09/28/2012:svnASUSTeKCOMPUTERINC.:pnS400CA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnS400CA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
> dmi.product.name: S400CA
> dmi.produc...

Read more...

xcalin (xcalin16-gmail) wrote :
Download full text (3.4 KiB)

Hello all!

I just tried the latest 3.11 rc2 and the wireless it's working fine.
On Jul 26, 2013 11:55 PM, "Petter Reinholdtsen" <email address hidden> wrote:

> Any hope of having this problem fixed in an official kernel in raring? It
> seem to affect Packard Bell EasyNote LV,
> http://www.linlap.com/packard_bell_easynote_lv . The network connection
> seem to fall out after a few minutes.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1160188
>
> Title:
> ATH9K wireless signal weak
>
> Status in The Linux Kernel:
> Fix Released
> Status in “linux” package in Ubuntu:
> Confirmed
> Status in “linux” package in Gentoo Linux:
> New
>
> Bug description:
> AR9485 Wireless Network Adapter has a low signal when in close range
> of station.
>
> I disabled hardware encryption with putting:
> options ath9k nohwcrypt=1
> in
> /etc/modprobe.d/ath9k.conf
>
> That doesn't seemed to help.
>
> The signal has 2 bars while it has full strength in windows. (I am 2
> meters away from the wifi station)
>
> s400ca:~$ rfkill list all
> 2: asus-wlan: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> 3: asus-bluetooth: Bluetooth
> Soft blocked: no
> Hard blocked: no
> 4: hci0: Bluetooth
> Soft blocked: no
> Hard blocked: no
> 5: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: no
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.10
> Package: linux-image-3.5.0-26-generic 3.5.0-26.42
> ProcVersionSignature: Ubuntu 3.5.0-26.42-generic 3.5.7.6
> Uname: Linux 3.5.0-26-generic x86_64
> ApportVersion: 2.6.1-0ubuntu10
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: jintux 1988 F.... pulseaudio
> Date: Tue Mar 26 06:33:06 2013
> InstallationDate: Installed on 2013-03-25 (0 days ago)
> InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64
> (20121017.5)
> MachineType: ASUSTeK COMPUTER INC. S400CA
> MarkForUpload: True
> ProcEnviron:
> TERM=xterm
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcFB: 0 inteldrmfb
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-26-generic
> root=UUID=52689dee-4881-48b6-8cca-602e15292652 ro quiet splash vt.handoff=7
> RelatedPackageVersions:
> linux-restricted-modules-3.5.0-26-generic N/A
> linux-backports-modules-3.5.0-26-generic N/A
> linux-firmware 1.95
> SourcePackage: linux
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 09/28/2012
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: S400CA.203
> dmi.board.asset.tag: ATN12345678901234567
> dmi.board.name: S400CA
> dmi.board.vendor: ASUSTeK COMPUTER INC.
> dmi.board.version: 1.0
> dmi.chassis.asset.tag: No Asset Tag
> dmi.chassis.type: 10
> dmi.chassis.vendor: ASUSTeK COMPUTER INC.
> dmi.chassis.version: 1.0
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvrS400CA.203:bd09/28/2012:svnASUSTeKCOMPUTERINC.:pnS400CA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnS400CA:rvr1.0:cvnASUSTeKCOMPUTER...

Read more...

xcalin (xcalin16-gmail) wrote :
Download full text (6.9 KiB)

Here is the link for the compiled kernels ubuntu, it's also compatible with
raring:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11-rc2-saucy/

2013/7/26 Joey Stevense <email address hidden>

> Buy a Mac and your problems are solved
>
> On Friday, July 26, 2013, Petter Reinholdtsen wrote:
>
> > Any hope of having this problem fixed in an official kernel in raring?
> It
> > seem to affect Packard Bell EasyNote LV,
> > http://www.linlap.com/packard_bell_easynote_lv . The network connection
> > seem to fall out after a few minutes.
> >
> > --
> > You received this bug notification because you are subscribed to the bug
> > report.
> > https://bugs.launchpad.net/bugs/1160188
> >
> > Title:
> > ATH9K wireless signal weak
> >
> > Status in The Linux Kernel:
> > Fix Released
> > Status in “linux” package in Ubuntu:
> > Confirmed
> > Status in “linux” package in Gentoo Linux:
> > New
> >
> > Bug description:
> > AR9485 Wireless Network Adapter has a low signal when in close range
> > of station.
> >
> > I disabled hardware encryption with putting:
> > options ath9k nohwcrypt=1
> > in
> > /etc/modprobe.d/ath9k.conf
> >
> > That doesn't seemed to help.
> >
> > The signal has 2 bars while it has full strength in windows. (I am 2
> > meters away from the wifi station)
> >
> > s400ca:~$ rfkill list all
> > 2: asus-wlan: Wireless LAN
> > Soft blocked: no
> > Hard blocked: no
> > 3: asus-bluetooth: Bluetooth
> > Soft blocked: no
> > Hard blocked: no
> > 4: hci0: Bluetooth
> > Soft blocked: no
> > Hard blocked: no
> > 5: phy0: Wireless LAN
> > Soft blocked: no
> > Hard blocked: no
> >
> > ProblemType: Bug
> > DistroRelease: Ubuntu 12.10
> > Package: linux-image-3.5.0-26-generic 3.5.0-26.42
> > ProcVersionSignature: Ubuntu 3.5.0-26.42-generic 3.5.7.6
> > Uname: Linux 3.5.0-26-generic x86_64
> > ApportVersion: 2.6.1-0ubuntu10
> > Architecture: amd64
> > AudioDevicesInUse:
> > USER PID ACCESS COMMAND
> > /dev/snd/controlC0: jintux 1988 F.... pulseaudio
> > Date: Tue Mar 26 06:33:06 2013
> > InstallationDate: Installed on 2013-03-25 (0 days ago)
> > InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64
> > (20121017.5)
> > MachineType: ASUSTeK COMPUTER INC. S400CA
> > MarkForUpload: True
> > ProcEnviron:
> > TERM=xterm
> > PATH=(custom, no user)
> > XDG_RUNTIME_DIR=<set>
> > LANG=en_US.UTF-8
> > SHELL=/bin/bash
> > ProcFB: 0 inteldrmfb
> > ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-26-generic
> > root=UUID=52689dee-4881-48b6-8cca-602e15292652 ro quiet splash
> vt.handoff=7
> > RelatedPackageVersions:
> > linux-restricted-modules-3.5.0-26-generic N/A
> > linux-backports-modules-3.5.0-26-generic N/A
> > linux-firmware 1.95
> > SourcePackage: linux
> > UpgradeStatus: No upgrade log present (probably fresh install)
> > dmi.bios.date: 09/28/2012
> > dmi.bios.vendor: American Megatrends Inc.
> > dmi.bios.version: S400CA.203
> > dmi.board.asset.tag: ATN12345678901234567
> > dmi.board.name: S400CA
> > dmi.board.vendor: ASUSTeK COMPUTER INC.
> > dmi.board.version: ...

Read more...

On one of my Packard Bell EasyNote LV, the wireless network stop working some minutes after boot. Only a reboot get it working again. I tried to use the 3.11 rc2 kernel, but it reintroduced the black screen of death and thus was not a very good alternative. The machine need acpi_backlight=vendor in raring to not turn off the screen completely, and this setting no longer work with v3.11.

One of the other ones have not had this problem, but it might be caused by it running an earlier raring kernel. I'm testing it again with the latest kernel version now.

I booted the 3.11 kernel (uname said 3.11.0-031100rc2-generic) and used the Packard Bell EasyNote LV a bit, after
booting it with i915.invert_brightness=1 instead of using the acpi_backlight=vendor setting, but with this kernel too the network card stopped working after some minutes. I am not sure, but believe it took a bit longer than earlier before it locked up.

My problem seem to be the one reported as https://bugzilla.kernel.org/show_bug.cgi?id=56301 and the suggested workaround is to run "iw dev wlan0 set power_save off". I'm testing it now, and the wifi have not died yet. But I am not sure how to trigger the problem, and it might still show up.

Well, I added the patch once. Then I got an update (I'm on Lubuntu, though I'm not sure it makes any difference).
And the bug came back with some installation.

Any idea when it will be fixed and won't come back while installing updates, so I can continue to update my ubuntu safely?

Thanks

Yashik (dryashik108) wrote :

Timo Jyrinki is just BRILLIANT! Thank You. After many months of tinkering with this, trying other distros (and even using Windows 8!), this simple tut sorted it all out. Now I'm connected to wifi, at good speed, and it's not dropping the signal either. Excellent Stuff!

tags: added: bios-outdated-209
tags: added: regression-potential
Feniksa (feniksa) wrote :

Update: I had the same problem for Asus S400C. It contains Atheros AR9485 WIFI card.

# lspci
...
02:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)
...

Latest release candidate kernel https://www.kernel.org/pub/linux/kernel/v3.x/testing/linux-3.11-rc4.tar.xz contain bug fix for Atheros AR9485.

Just installed and it works for me

Timo Jyrinki (timo-jyrinki) wrote :

FYI 3.11 kernel landed in Ubuntu 13.10 development version, so this is now also fixed there without any tricks.

Ubuntu 13.04 is apparently getting a partial fix (not sure if it's enough, two patches were originally mentioned as being relevant) in its next kernel update (bug #1204666), and I've attached a patch to bug #971809 that would bring the other part there too if picked up by kernel stable release update team.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.