Unable to boot system in EFI unless acpi=off & "quiet splash" deleted from grub

Bug #1129511 reported by Lou Hurst on 2013-02-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

MSI notebook, Model GT70-0NC-008US; tag under the battery shows GT70-0NC-494US Am not running as a dual boot install. I unable to boot this system unless acpi=off and "quiet splash" is deleted from grub. I am running this as the only OS, NOT a dual boot. I am able to boot, install and run 12.04 Precise 64 bit on this system, BIOS in legacy mode for install and running from HDD. Following steps in Debugging ACPT - Ubuntu Wiki (https://wiki.ubuntu.com/DebuggingACPI) I have updated to the latest BIOS on the box.

WORKAROUND: Use legacy boot mode.

WORKAROUND: With 12.10 installed to HDD tried booting with all options given in the Wiki and with acpi=off and "quiet splash" deleted, system boots ok and into usable environment.

With acpi=noirq and "quiet splash" deleted system starts to boot and stops with the following as last line:
[drm] nouveau 0000:01:00.0: 0x9904: Init table command not found: 0xA9

With pnpacpi=off and "quiet splash" deleted system starts to boot and stops with the following as last line, same as above:
[drm] nouveau 0000:01:00.0: 0x9904: Init table command not found: 0xA9

With noapic and "quiet splash" deleted, system starts to boot and stops with the following as last line, same as above:
[drm] nouveau 0000:01:00.0: 0x9904: Init table command not found: 0xA9

With nolapic and "quiet splash" deleted, system starts to boot and stops with the following as last line, same as above:
[drm] nouveau 0000:01:00.0: 0x9904: Init table command not found: 0xA9

In the troubleshooting steps I was unable to suspend or hibernate the system so am unable to supply a /var/log/kern.log.0 file.

I am unable to include a tarball of /proc/acpi directory as that directory doesn't exist.

---
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: lou 1920 F.... pulseaudio
DistroRelease: Ubuntu 12.10
HibernationDevice: RESUME=UUID=13a3d49b-35d0-4f55-8983-20577f3f3704
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: Micro-Star International Co., Ltd. GT70
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.5.0-17-generic root=/dev/mapper/ubuntu-root ro acpi=off
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-17-generic N/A
 linux-backports-modules-3.5.0-17-generic N/A
 linux-firmware 1.95
StagingDrivers: rts_pstor
Tags: quantal running-unity staging
Uname: Linux 3.5.0-17-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 11/23/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: E1762IMS.50U
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: MS-1762
dmi.board.vendor: Micro-Star International Co., Ltd.
dmi.board.version: REV:1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Micro-Star International
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrE1762IMS.50U:bd11/23/2012:svnMicro-StarInternationalCo.,Ltd.:pnGT70:pvrREV1.0:rvnMicro-StarInternationalCo.,Ltd.:rnMS-1762:rvrREV1.0:cvnMicro-StarInternational:ct10:cvrN/A:
dmi.product.name: GT70
dmi.product.version: REV:1.0
dmi.sys.vendor: Micro-Star International Co., Ltd.

Lou Hurst (harphauler) on 2013-02-18
tags: added: quantal

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1129511/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Lou Hurst (harphauler) wrote :

I have used Plymouth as the package affected but don't know what specific package to report. Machine boots to the purple Plymouth screen that appears almost immediately after starting the system but prior to the Ubuntu splash. Machine stays at purple screen for approximately 10 seconds, screen blanks and systems hangs/freezes.

affects: ubuntu → plymouth (Ubuntu)
description: updated
Steve Langasek (vorlon) wrote :

Looks like this is a kernel issue of some kind. Reassigning.

affects: plymouth (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1129511

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected running-unity staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

From bug email -
>From a terminal window please run:
apport-collect 1129511
and then change the status of the bug to 'Confirmed'.<

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Lou Hurst (harphauler) wrote :

A quick additional info, I submitted bug #1129524 as I tend to think I have two separate issues but will go with the experts here. Forgive me if it's a duplicate.

In #1129524 I am unable to boot the machine at all with UEFI enabled in my BIOS.

In this bug I am able to boot the machine with a USB stick and install 12.04 with my BIOS set to Legacy and Fast Boot disabled. Setting the BIOS to Legacy also turns off Secure Boot by default. The box runs 12.04 with no known problems, I just need to keep the BIOS set to Legacy.

I can also boot 12.10 with a live USB stick and install it with my BIOS set as above. I just need as described in this bug to set acpi=off and delete the "quiet splash" in grub. After installation I need to do the same, set acpi=off and delete the "quiet splash" in grub or I have problems.

Booting 12.10 without these parameters the box gets through POST ok, then the purple plymouth screen, then a black screen with a flashing cursor in the upper left corner for about 10 seconds then the machine appears to go into suspend/hibernate and nothing further happens, the blinking cursor stops blinking and changes to an underscore that just sits.

Lou Hurst (harphauler) wrote :

One other observation. The machine won't shut down completely after choosing shut down from within Ubuntu. It goes through power down and ends the process with the usual System halted message but I have to manually turn it off from there.

If this is a separate issue I'll be happy to see if it's a duplicate of another bug or file a new report.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.8 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-raring/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Lou Hurst (harphauler) wrote :

Per instructions, installed both linux-image and linux-image-extra packages.

Machine boots normally into a usable OS with BIOS set to Legacy. Additionally, cooling fan now seems to operate and Synaptics touchpad works. System shuts down and restarts normally.

System won't boot with BIOS set to UEFI.

Thank you.

tags: added: kernel-fixed-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Lou Hurst (harphauler) wrote :

FWIW - I downloaded today's (2/21/2013) build of Raring Ringtail 13.04 (raring-desktop-amd64.iso)

I was unable to boot with BIOS set to UEFI from either a DVD or USB stick. It boots to the initial screen of Try Ubuntu, Install Ubuntu, etc. Choosing any option or editing start parameters all result in the screen blanking immediately and nothing further happens for the 30 minutes I let it sit.

It will boot normally with BIOS set to Legacy. I was able to try Ubuntu from the USB stick. It installed normally from USB stick and subsequently ran from HDD normally - I didn't spend any real time trying to stress or break it, just opened several apps and used them without any apparent problems.

I am happy with and willing to leave my BIOS set to Legacy and run the machine in this mode. I'm just reporting what is and isn't working.

If it's all the same to everyone watching this I would like to install 12.04LTS on the box to get it into normal daily use. If further information is needed I'll do my best to help out, it will take some time though if I need to reinstall 12.10 or 13.04.

Thanks!

Lou Hurst, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ . Please advise on your results.

description: updated
tags: added: bios-outdated-50x
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Lou Hurst (harphauler) wrote :

Have today upgraded my BIOS to the latest version, E1762IMS.50X.

Tried to boot via EFI today's (09/05/2013) build of Saucy without any success. It does however boot with the machine in legacy boot mode.

Thanks all!

description: updated
Lou Hurst (harphauler) wrote :

Correction to comment #28.

I am not able to boot the machine in legacy mode into yesterday's (09/05/13) of Suacy.

Thanks again!

Lou Hurst (harphauler) wrote :

Update,

I had a bad USB stick so -

With machine BIOS updated to the latest version -

I am not able to boot the machine in EFI with any flavor of Ubuntu back to 12.04, up to and including yesterday's (9/6/2013) build of Saucy.

With BIOS set to Legacy I AM able to boot the machine into any flavor of Ubuntu up to and including yesterday's (9/6/2013) build of Saucy, with no extra work involved - it works as designed.

Thanks!

Lou Hurst (harphauler) wrote :

Originally purchased with Win 8, no other OS.

Lou Hurst (harphauler) wrote :

Per comment 33:

E1762IMS.50X
01/21/2013

This is interesting - the date of the file at MSI download page is 2013-04-19. Entering my BIOS setup it shows the same info as dmicode. I don't recall the date of the BIOS I upgraded, sorry.

Thanks.

tags: added: latest-bios-50x
removed: bios-outdated-50x
tags: added: saucy
tags: added: kernel-bug-exists-upstream-v3.8 needs-upstream-testing
removed: kernel-fixed-upstream
summary: - Unable to boot system unless acpi=off & "quiet splash" deleted from grub
+ Unable to boot system in EFI unless acpi=off & "quiet splash" deleted
+ from grub
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Lou Hurst (harphauler) wrote :

Just noticed in summary

>>+ Unable to boot system in EFI unless acpi=off & "quiet splash" deleted<<

I am unable to boot the system even if acpi=off and "quiet splash" is deleted from grub.

As soon as I hit F10 from the edit screen to continue with boot the screen goes blank and all USB stick activity appears to stop. Have let it it sit up to 30 minutes in this state with no change.

Thanks

Lou Hurst (harphauler) wrote :

That is to say unable to boot in EFI only. Legacy all works great all versions.

Thanks and sorry for the omission.

Given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We are approaching release and would like to confirm if this bug is still present. Please test again with the latest development kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.11.0-7.14
Lou Hurst (harphauler) wrote :

Alas, still no joy.

I updated to the latest development kernel and as previously. In EFI, system stops immediately after startup.

I am able to boot with the latest development kernal when system is in LEGACY mode.

Additionally -

I downloaded the latest daily build (9/21/2013) of Saucy. Tried to boot via usb stick in EFI, no joy, system stops immediately after the Ubuntu try it, install it screen. Editing startup options to acpi=off & "quiet splash" deleted, same thing, immediate stop after hitting F10 to continue with boot.

System DOES boot Saucy flawlessly with system in LEGACY mode and the few tests I did it works fine.

Thanks again!

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers