Comment 25 for bug 1109029

I discussed the multipath-tools dependency in the context of Debian.
But for multipath it really is a dependency.
The bug will soon switch to closed (wont'fix)

Yet OTOH it only is that for multiapth-tools-boot and kpartx-boot.
These are optional installs - even multipath-tools only suggests that.
But these packages don't work correctly anymore if you switch to dracut.
Due to that it is "correct" to have a hard dependency.

Yet your need to be able to install dracut is fulfilled.
Only users who explicitly picked multipath-tools-boot will have to decide what they want.
The other packages are fixed.