Depend on linux-initramfs-tool

Bug #1109029 reported by Andrea Corbellini on 2013-01-29
70
This bug affects 14 people
Affects Status Importance Assigned to Milestone
apparmor (Ubuntu)
Undecided
Unassigned
console-setup (Ubuntu)
Wishlist
Unassigned
kbd (Ubuntu)
Wishlist
Unassigned
linux (Ubuntu)
Wishlist
Andy Whitcroft
lvm2 (Ubuntu)
Wishlist
Unassigned
multipath-tools (Debian)
Fix Released
Unknown
multipath-tools (Ubuntu)
Wishlist
Unassigned
plymouth (Ubuntu)
Undecided
Unassigned
ubuntu-meta (Ubuntu)
Wishlist
Unassigned
udev (Ubuntu)
Wishlist
Unassigned
watershed (Ubuntu)
Undecided
Unassigned

Bug Description

Many core packages depend on initramfs-tools when they should actually depend on linux-initramfs-tool (virtual package provided by initramfs-tools and dracut).

Debian seems to be using "Depends: initramfs-tools | linux-initramfs-tool" for almost every relevant package.

See also bug #1108987, which is about the fact that dracut shouldn't conflict with initramfs-tools.

description: updated

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1109029

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

Marking as high as this bug makes dracut impossible to install.

Changed in udev (Ubuntu):
status: New → Confirmed
Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed
Changed in multipath-tools (Ubuntu):
status: New → Confirmed
Changed in lvm2 (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in kbd (Ubuntu):
status: New → Confirmed
Changed in console-setup (Ubuntu):
status: New → Confirmed
Changed in udev (Ubuntu):
importance: Undecided → High
Changed in ubuntu-meta (Ubuntu):
importance: Undecided → High
Changed in multipath-tools (Ubuntu):
importance: Undecided → High
Changed in lvm2 (Ubuntu):
importance: Undecided → High
Changed in linux (Ubuntu):
importance: Undecided → High
Changed in console-setup (Ubuntu):
importance: Undecided → High
Changed in kbd (Ubuntu):
importance: Undecided → High
Adam Conrad (adconrad) wrote :

Unless dracut provides exactly the same interfaces for hook scripts and update-initramfs (I assume neither is true), this is more than just "updating dependencies". Sure, updating deps will allow you to install dracut, but it won't actually build initrds correctly without some package mangling, I assume.

It makes a lot more sense to wait for most of this to filter down from Debian, especially as swapping dracut in place of initramfs-tools is certainly not something Ubuntu has any immediate plans to support.

Changed in console-setup (Ubuntu):
importance: High → Low
Changed in kbd (Ubuntu):
importance: High → Wishlist
Changed in console-setup (Ubuntu):
importance: Low → Wishlist
Changed in linux (Ubuntu):
importance: High → Wishlist
Changed in lvm2 (Ubuntu):
importance: High → Wishlist
Changed in multipath-tools (Ubuntu):
importance: High → Wishlist
Changed in udev (Ubuntu):
importance: High → Wishlist
Changed in ubuntu-meta (Ubuntu):
importance: High → Wishlist
Changed in linux (Ubuntu):
status: Confirmed → Triaged

I disagree. Dracut builds fine from source and builds initrds which are usable. As dracut offers additional features compared to initramfs-tools, it is required in certain use cases. As dracut can be installed in parallel to initramfs-tools without interfering with its functionality, either this issue should be solved or dracut should not be conflicting with initramfs-tools.
If this issue is not solved and dracut continues to conflict with initramfs-tools, dracut cannot be installed. Thus either this issue has to be resolved, the conflict has to be removed or the package dracut needs to be dropped from Ubuntu. Either way, the importance of this bug is not "wishlist" in my opinion.

description: updated
Dimitri John Ledkov (xnox) wrote :

The above packages on a quick inspection do seem to depart from using Debian virtual package linux-initramfs-tool. They should probably be reviewed and include the alternative dependency.

Thanks for pointing this out.

It is wishlist on the basis that it's a new, previously not available, feature in ubuntu.

Dimitri John Ledkov (xnox) wrote :

why is dracut conflicting with initramfs-tools?
shouldn't that conflict be solved in Debian?
note there is no intention to support alternative initramfs implementations in Ubuntu main.

Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Invalid
Unit 193 (unit193) wrote :

The reason it conflicts is because it seemingly used to ship /usr/sbin/update-initramfs, See: https://bugs.debian.org/729809. Other than this alt dep, it looks like parts of plymouth would need to be merged, and dracut patched for plymouth not being in /usr.

Andy Whitcroft (apw) on 2015-03-11
Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
milestone: none → ubuntu-15.03
Andy Whitcroft (apw) on 2015-03-16
Changed in linux (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.19.0-10.10

---------------
linux (3.19.0-10.10) vivid; urgency=low

  [ Andy Whitcroft ]

  * [Packaging] control -- make element ordering deterministic
  * [Config] allow dracult to support initramfs as well
    - LP: #1109029
  * [Packaging] generate live watchdog blacklists
    - LP: #1432837

  [ Leann Ogasawara ]

  * [Config] CONFIG_KVM_GENERIC_DIRTYLOG_READ_PROTECT=y
    - LP: #1397860
  * rebase to v3.19.2

  [ Upstream Kernel Changes ]

  * thinkpad_acpi: support new BIOS version string pattern
    - LP: #1417915
  * arm64: Invalidate the TLB corresponding to intermediate page table
    levels
    - LP: #1432546
  * perf tools: Support parsing parameterized events
    - LP: #1430341
  * perf tools: Extend format_alias() to include event parameters
    - LP: #1430341
  * perf Documentation: Add event parameters
    - LP: #1430341
  * perf tools: Document parameterized and symbolic events
    - LP: #1430341
  * perf: provide sysfs_show for struct perf_pmu_events_attr
    - LP: #1430341
  * perf: add PMU_EVENT_ATTR_STRING() helper
    - LP: #1430341
  * perf: define EVENT_DEFINE_RANGE_FORMAT_LITE helper
    - LP: #1430341
  * powerpc/perf/hv-24x7: parse catalog and populate sysfs with events
    - LP: #1430341
  * powerpc/perf/{hv-gpci, hv-common}: generate requests with counters
    annotated
    - LP: #1430341
  * powerpc/perf/hv-gpci: add the remaining gpci requests
    - LP: #1430341
  * powerpc/perf/hv-24x7: Document sysfs event description entries
    - LP: #1430341
  * powerpc/iommu: Remove IOMMU device references via bus notifier
    - LP: #1425202
  * powerpc/pseries: Fix endian problems with LE migration
    - LP: #1428351
  * intel_idle: support additional Broadwell model
    - LP: #1400970
  * tools/power turbostat: support additional Broadwell model
    - LP: #1400970
  * KVM: x86: flush TLB when D bit is manually changed.
    - LP: #1397860
  * Optimize TLB flush in kvm_mmu_slot_remove_write_access.
    - LP: #1397860
  * KVM: Add generic support for dirty page logging
    - LP: #1397860
  * KVM: x86: switch to kvm_get_dirty_log_protect
    - LP: #1397860
  * KVM: Rename kvm_arch_mmu_write_protect_pt_masked to be more generic for
    log dirty
    - LP: #1397860
  * KVM: MMU: Add mmu help functions to support PML
    - LP: #1397860
  * KVM: MMU: Explicitly set D-bit for writable spte.
    - LP: #1397860
  * KVM: x86: Change parameter of kvm_mmu_slot_remove_write_access
    - LP: #1397860
  * KVM: x86: Add new dirty logging kvm_x86_ops for PML
    - LP: #1397860
  * KVM: VMX: Add PML support in VMX
    - LP: #1397860
  * HID: multitouch: add support of clickpads
  * HID: multitouch: Add support for button type usage

  [ Upstream Kernel Changes ]

  * rebase to v3.19.2
    - LP: #1428947
 -- Andy Whitcroft <email address hidden> Mon, 23 Mar 2015 15:28:16 +0000

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apparmor (Ubuntu):
status: New → Confirmed
Changed in plymouth (Ubuntu):
status: New → Confirmed
Changed in watershed (Ubuntu):
status: New → Confirmed
Unit 193 (unit193) on 2015-07-15
Changed in lvm2 (Ubuntu):
status: Confirmed → Invalid
Andy Whitcroft (apw) wrote :

Updated to indicate that the virtual package is linux-initramfs-tool (singular).

summary: - Depend on linux-initramfs-tools
+ Depend on linux-initramfs-tool
description: updated
Unit 193 (unit193) on 2015-07-15
description: updated
Andy Whitcroft (apw) wrote :

Unfortuantly this got applied to the kernel package in plural, as per the original bug. See LP: #1474810 for the fixes for that.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apparmor - 2.10-0ubuntu2

---------------
apparmor (2.10-0ubuntu2) wily; urgency=medium

  * debian/patches/aa-status-dont_require_python3-apparmor.patch:
    make aa-status(8) work even when python3-apparmor is not installed,
    otherwise dh_apparmor postinst snippets can fail (LP: #1480492)
  * debian/control: make apparmor-utils depend on the same package
    version of python3-apparmor

 -- Steve Beattie <email address hidden> Fri, 31 Jul 2015 16:35:03 -0700

Changed in apparmor (Ubuntu):
status: Confirmed → Fix Released
Morty (morty) wrote :

Actually the watershed package should not depend on initramfs-tools at all. Removing the dependency would fix this. I created a new bug for watershed: bug #1511669

Morty (morty) wrote :

Just in case someone is interested: I've built an ppa that allows installing draucut next to initramfs:
https://launchpad.net/~morty/+archive/ubuntu/dracut-release

And yes, they do conflict as they both want to build the init.rd. And initramfs-tools wins, because i comes after d. I fixed that using dpkg-divert.

Antony Messerli (antonym) wrote :

I tried out Morty's PPA and it works great. It gets rid of the conflict between dracut and initramfs-tools in Wily.

Unit 193 (unit193) wrote :

This bug was fixed in the package console-setup - 1.108ubuntu6

---------------
console-setup (1.108ubuntu6) wily; urgency=medium

  * debian/control: allow dracut to be installable by adding an alternate
    depends on linux-initramfs-tool for console-setup.

 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 08 Sep 2015 22:36:52 -0400

Changed in console-setup (Ubuntu):
status: Confirmed → Fix Released
Unit 193 (unit193) wrote :

This bug was fixed in the package kbd - 1.15.5-1ubuntu3

---------------
kbd (1.15.5-1ubuntu3) wily; urgency=medium

  * Drop initramfs-tools dependency. It causes other providers of
    linux-initramfs-tool (like dracut) to become uninstallable, and is an
    ancient Ubuntu-ism which has never been forwarded, nor is it kbd's place
    to dictate whether or not you should have an initramfs.

 -- Martin Pitt <email address hidden> Tue, 08 Sep 2015 12:50:53 +0200

Changed in kbd (Ubuntu):
status: Confirmed → Fix Released
Unit 193 (unit193) wrote :
Download full text (5.0 KiB)

This bug was fixed in the package plymouth - 0.9.2-3ubuntu1

---------------
plymouth (0.9.2-3ubuntu1) xenial; urgency=medium

  * Merged from debian unstable (first time ever…) Remaining changes:
    - include ubuntu theme logos:
      themes/ubuntu-logo/*, debian/source/include-binaries.
    - debian/libplymouth4.apport: add Apport hook.
    - Ship ubuntu-logo instead of debian-logo (debian/rules and
      debian/local/plymouth.hook).
    - Ship debian/source_plymouth.apport apport hook (debian/rules).
    - Add plymouth-label as a separate package and makes themes depending on
      it (debian/control, debian/plymouth-label.install,
      debian/plymouth-themes.install).
    - As log-viewer is disabled by default upstream and now in debian, don't
      ship its man page (debian/plymouth.links).
    - Ship plymouth-theme-ubuntu-logo and plymouth-theme-ubuntu-text specific
      themes (debian/plymouth-theme-ubuntu-* and debian/control) and add
      Recommends on it | plymouth-theme to accommodate flavors.
    - Remove debian/patches/0003-default-theme.patch as we handle our defaults
      via alternatives. (and refresh debian/patches/0008-show-delay.patch)
    - debian/patches/misc-changes.patch: old undocumented inline changes.
      export a new symbol added in debian/libplymouth4.symbols.
    - debian/patches/avoid-sigpipe.patch:
      Use first a socket connection before fallbacking to regular write()
    - debian:patches/details-short-prompt.patch: When we display bullets in the
      ubuntu details theme, shorten the prompt.
    - debian/patches/details-remove-separator.patch: Removed explicit printing
      of ':'.
    - debian/patches/details-update-status.patch: Implement update status (U)
      splash plugin function for details plugin, imply display those updates
      as text messages.
    - debian/patches/initramfsless-boot.patch: support intramfsless boot.
    - debian/patches/fix-split-writes.patch: fix split writes for long server
      responses.
    - debian/patches/ubuntu-add-splash-option.patch: add "splash" option as a
      condition to trigger plymouth.
    - debian/rules:
      - disable optimization is noopt found in $DEB_BUILD_OPTION
      - enable -Werror
      - use ubuntu-themes background color
    - debian/local/<initramfs scripts>: export OPTION=FRAMEBUFFER for user's
      command line argument explicitly disabling framebuffer.
    - We use alternatives instead of plymouth-set-default-theme tool:
      + debian/plymouth-themes.{prerm,postinst}: ensure we select one default
       plymouth logo and text themes through alternatives even when we remove
       ubuntu-base ones.
      + debian/rules, debian/plymouth.{install,links), don't ship non
        non alternative-based theme policy files and tools.
      + update plymouth.README.Debian to tell to use update-alternative
        instead of set-default-theme
      + change debian/local/plymouth.hook to use update-alternative to get
        default theme instead of set-default-theme. Also, don't copy
        deleted files to initramfs.
    - Add Breaks: against older themes versions as they are shipping ...

Read more...

Changed in plymouth (Ubuntu):
status: Confirmed → Fix Released

udev does not hold that dependency (anymore), so marking invalid.

Changed in udev (Ubuntu):
status: Confirmed → Invalid

For multipath-tools that should be fixed in Debian.
Although once that happened we need to fix the kpartx-boot package which is ubuntu only delta on top.
I filed https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=864381 for that.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package watershed - 9

---------------
watershed (9) artful; urgency=medium

  * debian/control: allow dracut to be installable by adding an alternate
    depends on linux-initramfs-tool for watershed (LP: #1109029).

 -- Christian Ehrhardt <email address hidden> Wed, 07 Jun 2017 11:31:09 -0600

Changed in watershed (Ubuntu):
status: Confirmed → Fix Released
Changed in multipath-tools (Debian):
status: Unknown → New

I discussed the multipath-tools dependency in the context of Debian.
But for multipath it really is a dependency.
The bug will soon switch to closed (wont'fix)

Yet OTOH it only is that for multiapth-tools-boot and kpartx-boot.
These are optional installs - even multipath-tools only suggests that.
But these packages don't work correctly anymore if you switch to dracut.
Due to that it is "correct" to have a hard dependency.

Yet your need to be able to install dracut is fulfilled.
Only users who explicitly picked multipath-tools-boot will have to decide what they want.
The other packages are fixed.

Changed in multipath-tools (Ubuntu):
status: Confirmed → Won't Fix
Changed in multipath-tools (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.