Ubuntu

0846:9041 NetGear, Inc. WNA1000M 802.11bgn [Realtek RTL8188CUS] does not connect to wireless networks

Reported by pdecat on 2012-11-07
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

On all of my Ubuntu Desktop 12.10 amd64 systems, the network manager will show the wireless card and networks, but will ask for the network password again after trying to connect.

In the attached logs from an pure Ubuntu Desktop 12.10 amd64 system (Live ISO booted from USB stick),
we can see that it worked once :
[ 123.224546] wlan0: associated

Internet access worked, but after disconnecting manually :
[ 129.742078] wlan0: deauthenticating from 00:17:33:b4:e4:44 by local choice (reason=3)

subsequent tentatives will fail with :
[ 143.300130] wlan0: deauthenticated from 00:17:33:b4:e4:44 (Reason: 15)

With Ubuntu 12.04 64bit live environment it connects only once but subsequent tries fail. I have to unplug then replug the adapter to make it work again.

The following upstream drivers load, but fail to activate the device (LED does not light):
* RTL819xCU_USB_linux_v3.4.2_3727.20120404.zip
* RTL819xCU_USB_linux_v3.4.3_4369.20120622.zip
* RTL819xC_USB_linux_v3.4.4_4749.20120806.zip

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-17-generic 3.5.0-17.28
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 3510 F.... pulseaudio
 /dev/snd/controlC2: ubuntu 3510 F.... pulseaudio
 /dev/snd/controlC0: ubuntu 3510 F.... pulseaudio
CasperVersion: 1.328
Date: Wed Nov 7 13:43:38 2012
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: Hewlett-Packard HP Compaq 8200 Elite CMT PC
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB:
 0 radeondrmfb
 1 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi.signed file=/cdrom/preseed/username.seed boot=casper quiet splash --
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-17-generic N/A
 linux-backports-modules-3.5.0-17-generic N/A
 linux-firmware 1.95
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/20/2012
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: J01 v02.21
dmi.board.name: 1494
dmi.board.vendor: Hewlett-Packard
dmi.chassis.type: 6
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvrJ01v02.21:bd06/20/2012:svnHewlett-Packard:pnHPCompaq8200EliteCMTPC:pvr:rvnHewlett-Packard:rn1494:rvr:cvnHewlett-Packard:ct6:cvr:
dmi.product.name: HP Compaq 8200 Elite CMT PC
dmi.sys.vendor: Hewlett-Packard

pdecat (pdecat) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Attached is the syslog from one of my main Ubuntu Desktop 12.10 amd64 with NetworkManager in debug level.

pdecat (pdecat) wrote :

I have reproduced this issue running Ubuntu Desktop 12.10 amd64 in Virtualbox: that will make testing easier if needed.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.7 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. Please only remove that one tag and leave the other tags. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.7-rc4-raring/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: needs-upstream-testing
tags: added: kernel-wifi
description: updated
pdecat (pdecat) wrote :

Same issue with kernel 3.7-rc4-raring (syslog attached).

tags: added: kernel-bug-exists-upstream kernel-bug-exists-upstream-v3.7-rc4
removed: needs-upstream-testing

pdecat, thank you for testing the newest mainline kernel. Could you please plug your Netgear USB device in, unplug all other USB devices, execute the following in a terminal, and post the results here:
lsusb -v

pdecat (pdecat) wrote :

Here you are.

pdecat (pdecat) wrote :

FWIW, with the Ubuntu Desktop 12.04 64bit Live DVD (ubuntu-12.04-dvd-amd64.iso),
it connects only once but subsequent tries fail. I have to unplug then replug the adapter to make it work again.

description: updated

pdecat, thank you for providing the requested information. Regarding your Bug Description:
>"Tried installing Realtek drivers (versions 3.4.2, 3.4.3 and 3.4.4) as suggested in #1030858, the 8192cu driver loads but it fails to activate the device (LED does not light)."

As the device identifies itself as a RTL8188CUS, have you tried the upstream Realtek driver version 3.4.4_4749 from http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=21&PFid=48&Level=5&Conn=4&DownTypeID=3&GetDown=false&Downloads=true#2742 ?

pdecat (pdecat) wrote :

Yes, I tried this one (it is the same download for RTL8188CUS and RTL8192CU).

pdecat (pdecat) wrote :

Tried :
* RTL819xCU_USB_linux_v3.4.2_3727.20120404.zip
* RTL819xCU_USB_linux_v3.4.3_4369.20120622.zip
* RTL819xC_USB_linux_v3.4.4_4749.20120806.zip

pdecat (pdecat) wrote :

Exact same behaviour with Ubuntu Desktop 11.10 64bit Live DVD (ubuntu-11.10-dvd-amd64.iso) :
* first connection works
* subsequent tries fail
* unplug/replug to repeat.

pdecat, thank you for providing the requested information. Could you please test for this in a Lucid live environment following http://releases.ubuntu.com/lucid/ ?

description: updated
tags: added: oneiric
tags: added: precise
pdecat (pdecat) wrote :

With Lucid (ubuntu-10.04.4-desktop-amd64.iso) and Maverick (ubuntu-10.10-desktop-amd64.iso), the adapter is not recognized.
Only message is "usb 1-1: new high speed USB device using ehci_hcd and address 2".

pdecat, thank you for testing Lucid and Maverick. Could you please test Natty via http://old-releases.ubuntu.com/releases/natty/ ?

pdecat (pdecat) wrote :

Same with Natty (ubuntu-11.04-desktop-amd64.iso), device not recognized.

pdecat, the issue you are reporting is an upstream one. Could you please report this problem through the appropriate channel by following the instructions _verbatim_ at https://wiki.ubuntu.com/Bugs/Upstream/kernel#KernelTeam.2BAC8-KernelTeamBugPolicies.Overview_on_Reporting_Bugs_Upstream ?

Thank you for your understanding.

Marking Triaged as newest mainline tested, and regression testing completed back to Lucid.

Changed in linux (Ubuntu):
status: Incomplete → Triaged
MixFix (awards) on 2013-05-30
Changed in linux (Ubuntu):
status: Triaged → Confirmed
summary: - "0846:9041 NetGear, Inc. WNA1000M 802.11bgn [Realtek RTL8188CUS]" does
- not connect to wireless networks
+ 0846:9041 NetGear, Inc. WNA1000M 802.11bgn [Realtek RTL8188CUS] does not
+ connect to wireless networks
tags: added: bios-outdated-2.23rev.a needs-upstream-testing
removed: kernel-bug-exists-upstream

pdecat, as per http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=5037951&prodTypeId=12454&prodSeriesId=5037949&swLang=13&taskId=135&swEnvOID=4060#120 an update is available for your BIOS (2.23 Rev. A). If you update to this, does it change anything?

If not, could you please provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.