Ubuntu

[SONY VAIO VPCS12L9E] Suspend doesn't work after dist-upgrade to Quantal 12.10

Reported by Salvatore Cristofaro on 2012-10-22
56
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Linux
Incomplete
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

Using a Sony VAIO VPCS12L9E notebook, I just upgraded from Kubuntu 12.04 to Kubuntu 12.10 (amd64), and suspend is not working anymore . When I select suspend from the Kde menu, suspend doesn't work:
- the screen goes black, but does not turn off
- num Lock works,
- caps Lock doesn't work
- notebook is on, and doesn't enter suspend mode.
In this state, i can only press power button (hard power off) or reboot with Stamp + Alt + B.

In Kubuntu 12.04 suspend work.

As describe in https://wiki.ubuntu.com/DebuggingKernelSuspend, i entered the following commands:
sudo sh -c "sync; echo 1 > /sys/power/pm_trace; pm-suspend"

Ubuntu kernel version bisect revealed regression going from 3.4.0-5.11 to 3.5.0-1.1.

WORKAROUND: http://shiba89.wordpress.com/2012/10/25/ubuntu-12-10-linux-3-5-e-sony-laptop/ code:
sudo add-apt-repository ppa:shiba89/vaio-kernel
sudo apt-get update
sudo apt-get install linux-headers-generic sony-laptop-dkms

It use the 3.4 kernel module with Absence Patches: http://www.absence.it/vaio-acpi/source/patches/

---
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: salvatore 3569 F.... pulseaudio
 /dev/snd/controlC0: salvatore 3569 F.... pulseaudio
CRDA:
 country IT:
  (2402 - 2482 @ 40), (N/A, 20)
  (5170 - 5250 @ 40), (N/A, 20)
  (5250 - 5330 @ 40), (N/A, 20), DFS
  (5490 - 5710 @ 40), (N/A, 27), DFS
DistroRelease: Ubuntu 12.10
HibernationDevice: RESUME=UUID=9d5b51a9-6a1e-413b-92cb-68a9688d9362
InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: Sony Corporation VPCS12L9E
NonfreeKernelModules: nvidia
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=1d0259e9-9edf-47f3-92c7-e0fe185d9da5 ro vga=792 splash quiet crashkernel=384M-2G:64M,2G-:128M quiet splash acpi_backlight=vendor acpi_sleep=nonvs vt.handoff=7
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-17-generic N/A
 linux-backports-modules-3.5.0-17-generic N/A
 linux-firmware 1.95
Tags: quantal
Uname: Linux 3.5.0-17-generic x86_64
UpgradeStatus: Upgraded to quantal on 2012-10-19 (5 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers
dmi.bios.date: 09/30/2010
dmi.bios.vendor: INSYDE
dmi.bios.version: R1160Q3
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnINSYDE:bvrR1160Q3:bd09/30/2010:svnSonyCorporation:pnVPCS12L9E:pvrC104H6ZD:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VPCS12L9E
dmi.product.version: C104H6ZD
dmi.sys.vendor: Sony Corporation

description: updated
Brad Figg (brad-figg) on 2012-10-22
Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: quantal
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.7 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. Please only remove that one tag and leave the other tags. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.7-rc2-raring/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: needs-upstream-testing

I tested with the indicated latest v3.7 kernel but problem persist (see log)

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Maurs, thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect BUGNUMBER
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

tags: added: needs-kernel-logs
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-bug-exists-upstream-v3.7-rc2-raring

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: regression-release
removed: needs-kernel-logs

Maurs, thank you for the apport-collect. Regarding the following kernel parameters you are using:
acpi_backlight=vendor acpi_sleep=nonvs

could you please remove both of these kernel parameters and provide the information following https://wiki.ubuntu.com/DebuggingKernelSuspend ? As well, could you please discuss why specifically you are passing these kernel parameters? Being presumptuous, acpi_backlight=vendor is for a backlight issue, and acpi_sleep=nonvs so suspend would work in Precise?

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
summary: - Suspend doesn't work after dist-upgrade to Quantum 12.10
+ Suspend doesn't work after dist-upgrade to Quantal 12.10

Hi, thank you for your fast reply.

I tried to remove both kernel parameters (acpi_backlight=vendor and acpi_sleep=nonvs) but problem persist. (see attached file).

In 12.04 (and in 11.10) I used a patched sony-laptop.ko module (please refer to http://www.absence.it/vaio-acpi/source/patches/ and http://code.google.com/p/vaio-f11-linux/issues/detail?id=6 ). It improved the management of energy savings through better driver support for backlight and environment light sensor with my Vaio. I believe that I introduced the kernel parameter acpi_backlight=vendor after applying this patch or, however, to improve support to brightness.
Just for your knowledge, after upgraded to 12.10, I could not apply this patch to current kernel (was incompatible with 3.5: patching result in a reject file).

The acpi_sleep=nonvs kernel parameter was not present when i used12.04.
I introduced it during last days after reading this post http://<email address hidden>/msg36825.html and other similar forum discussion, trying to fix the suspend feature, without success.

Thank you for support
Salvatore

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

I come back to 3.2.0-32-generic #51 kernel (patched with vaio-full-3.2.2.patch, see link above).
Suspend work great. May be useful to attach some log files?

Thanks,
Salvatore

Maurs, regarding your comments https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1069707/comments/28 :
>"I come back to 3.2.0-32-generic #51 kernel (patched with vaio-full-3.2.2.patch, see link above).
Suspend work great."

With 3.2.0-32-generic #51, if you remove the vaio-full-3.2.2.patch, and both kernel parameters:
acpi_backlight=vendor
acpi_sleep=nonvs

is suspend successful? If not, which combination of the above specifically allowed suspend to work and which did not?

description: updated
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

I tried both configuration:

- Linux svaio-kubuntu 3.2.0-32-generic #51-Ubuntu x86_64 with vaio-full-3.2.2.patch: it works. (without both acpi_backlight=vendor and acpi_sleep=nonvs)
- Linux svaio-kubuntu 3.2.0-32-generic #51-Ubuntu x86_64 (without patch): it works too. (without both acpi_backlight=vendor and acpi_sleep=nonvs)

So, the problem persist only with 3.5...

Thank you,
Salvatore

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: amd64

Maurs, thank you for providing the requested information. Continuing to not patch, or use acpi_backlight=vendor and acpi_sleep=nonvs, the next step is to perform a Ubuntu kernel bisect from 3.2.0-32 to 3.5.0-17.28, in order to identify the last good Ubuntu kernel version, followed immediately by the first bad one. As per https://launchpad.net/ubuntu/quantal/+source/linux we have:
3.2.0-24.37
3.4.0-1.1
3.4.0-1.2
3.4.0-1.3
3.4.0-2.4
3.4.0-2.5
3.4.0-2.6
3.4.0-3.7
3.4.0-3.8
3.4.0-4.9
3.4.0-4.10
3.4.0-5.11
3.5.0-1.1
3.5.0-2.2
3.5.0-3.3
3.5.0-4.4
3.5.0-5.5
3.5.0-6.6
3.5.0-7.7
3.5.0-8.8
3.5.0-9.9
3.5.0-10.10
3.5.0-11.11
3.5.0-12.12
3.5.0-13.13
3.5.0-13.14
3.5.0-14.15
3.5.0-14.16
3.5.0-14.17
3.5.0-14.18
3.5.0-14.19
3.5.0-15.20
3.5.0-15.21
3.5.0-15.22
3.5.0-15.23
3.5.0-16.24
3.5.0-16.25
3.5.0-17.26
3.5.0-17.27
3.5.0-17.28

Hence, could you please test 3.5.0-8.8 via https://launchpad.net/ubuntu/+source/linux/3.5.0-8.8/+build/3702770 ?

Once this test is complete, could you please continue to bisect following https://wiki.ubuntu.com/Kernel/KernelBisection ?

Thank you for your understanding.

Helpful bug reporting tips:
https://help.ubuntu.com/community/ReportingBugs

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
fenixk19 (fenixk19) wrote :

I've got the same problem. pm-suspend is ok on 3.2.0-32-generic, but breaks on Linux 3.5.0-18-generic.
I'll try to make some tests too.
Here is my dmesg for broken pm-suspend.

fenixk19, if you have a bug in Ubuntu, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Bug Control and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report may delay your problem being addressed as quickly as possible.

Thank you for your understanding.

Download full text (7.6 KiB)

Hello,

The problem come with 3.5.x kernel. I tested 3.4.0-5.11 kernel and (some) before and all work great.
From 3.5.0-1.1 kernel, the problem persist.
The major difference could be see in this dmesg extract: there's a kernel OOPS...

Kernel =>3.5.0-1.1 dmesg:

--- CUT ---

[...]
[ 35.333632] lp: driver loaded but no devices found
[ 35.571221] wmi: Mapper loaded
[ 35.576770] ACPI Warning: 0x0000000000000460-0x000000000000047f SystemIO conflicts with Region \PMIO 1 (20120320/utaddress-251)
[ 35.576774] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 35.576775] lpc_ich: Resource conflict(s) found affecting iTCO_wdt
[ 35.576782] ACPI Warning: 0x0000000000000428-0x000000000000042f SystemIO conflicts with Region \PMIO 1 (20120320/utaddress-251)
[ 35.576788] ACPI Warning: 0x0000000000000428-0x000000000000042f SystemIO conflicts with Region \_SB_.PCI0.IEIT.SGPE 2 (20120320/utaddress-251)
[ 35.576789] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 35.576796] ACPI Warning: 0x0000000000000500-0x000000000000057f SystemIO conflicts with Region \GPIO 1 (20120320/utaddress-251)
[ 35.576798] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 35.576799] lpc_ich: Resource conflict(s) found affecting gpio_ich
[ 35.649026] sony_laptop: Sony Notebook Control Driver v0.6
[ 35.751202] microcode: CPU0 sig=0x20652, pf=0x10, revision=0xc
[ 35.755192] evbug: Connected device: input0 (Power Button at PNP0C0C/button/input0)
[ 35.755197] evbug: Connected device: input1 (Lid Switch at PNP0C0D/button/input0)
[ 35.755199] evbug: Connected device: input2 (Power Button at LNXPWRBN/button/input0)
[ 35.755202] evbug: Connected device: input3 (AT Translated Set 2 keyboard at isa0060/serio0/input0)
[ 35.790263] BUG: unable to handle kernel paging request at 0000000000ff1000
[ 35.790313] IP: [<ffffffff8132a77d>] memcpy+0xd/0x110
[ 35.790340] PGD 1290a7067 PUD 107c9b067 PMD 0
[ 35.790360] Oops: 0000 [#1] SMP
[ 35.790376] CPU 3
[ 35.790394] Modules linked in: evbug microcode(+) sony_laptop(+) mac_hid lpc_ich wmi lp parport vesafb video firewire_ohci firewire_core atl1c sdhci_pci sdhci crc_itu_t
[ 35.790460]
[ 35.790470] Pid: 628, comm: modprobe Not tainted 3.5.0-1-generic #1-Ubuntu Sony Corporation VPCS12L9E/VAIO
[ 35.790516] RIP: 0010:[<ffffffff8132a77d>] [<ffffffff8132a77d>] memcpy+0xd/0x110
[ 35.790547] RSP: 0000:ffff880107d45c50 EFLAGS: 00010246
[ 35.790570] RAX: ffff880107d45ca0 RBX: ffff8801290245e0 RCX: 0000000000000001
[ 35.790600] RDX: 0000000000000000 RSI: 0000000000ff1000 RDI: ffff880107d45ca0
[ 35.790630] RBP: ffff880107d45c68 R08: ffff880107c26e00 R09: 0000000180400019
[ 35.790660] R10: 0000000000000000 R11: ffffffff813a1ae9 R12: ffff880107d45ca0
[ 35.790689] R13: ffff880107d45cbf R14: ffff88012c9b0400 R15: 0000000000000135
[ 35.790720] FS: 00007fdd03db6700(0000) GS:ffff880137cc0000(0000) knlGS:0000000000000000
[ 35.790754] CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b
[ 35.790778] CR2: 0000000000ff1000 CR3: 0000000107c15000...

Read more...

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
summary: - Suspend doesn't work after dist-upgrade to Quantal 12.10
+ [SONY VAIO VPCS12L9E] Suspend doesn't work after dist-upgrade to Quantal
+ 12.10

Maurs, thank you for bisecting Ubuntu kernel versions. The next step is commit bisecting Ubuntu kernel versions from 3.4.0-5.11 to 3.5.0-1.1. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection#Commit_bisecting_Ubuntu_kernel_versions ?

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

I can't find either debian and debian.master:

[...]
#git log --oneline Ubuntu-3.4.0-5.11..Ubuntu-3.5.0-1.1
(see attached file)

#git bisect start Ubuntu-3.5.0-1.1 Ubuntu-3.4.0-5.11
Previous HEAD position was 76e10d1... Linux 3.4
Switched to branch 'mybisect'
Bisecting: a merge base must be tested
[76e10d158efb6d4516018846f60c2ab5501900bc] Linux 3.4

As written in the wiki, could be a "across non-linear tags" problem. How to resolve it?

Thanks,
Salvatore

Rafael Torres (rdtorres) wrote :
Download full text (4.1 KiB)

Hi,

I'm facing the exactly same problem with Fedora 16 dist. After an update from kernel 3.4.9-2 to 3.6.2-1 this issue started to happen. Basically my ACPI module is not loaded. so my laptop cannot suspend either.

My logs from kernel 3.6.2-1 :

[ 28.649495] BUG: unable to handle kernel paging request at 0000000000ff1000
[ 28.649503] IP: [<ffffffff812e1c0d>] memcpy+0xd/0x110
[ 28.649515] PGD 12fd62067 PUD 12da5c067 PMD 0
[ 28.649522] Oops: 0000 [#1] SMP
[ 28.649526] Modules linked in: sony_laptop(+) atl1c iTCO_wdt iTCO_vendor_support intel_ips soundcore snd_page_alloc i2c_i801 microcode rfkill joydev i2c_core lpc_ich mfd_core uinput sunrpc binfmt_misc mmc_block mxm_wmi crc32c_intel ghash_clmulni_intel sdhci_pci sdhci mmc_core firewire_ohci firewire_core crc_itu_t video wmi
[ 28.649555] CPU 2
[ 28.649559] Pid: 706, comm: modprobe Not tainted 3.6.2-1.fc16.x86_64 #1 Sony Corporation VPCS12V9E/VAIO
[ 28.649560] RIP: 0010:[<ffffffff812e1c0d>] [<ffffffff812e1c0d>] memcpy+0xd/0x110
[ 28.649563] RSP: 0018:ffff88012ea65c30 EFLAGS: 00010246
[ 28.649564] RAX: ffff88012ea65c60 RBX: ffff88012ca377c0 RCX: 0000000000000001
[ 28.649565] RDX: 0000000000000000 RSI: 0000000000ff1000 RDI: ffff88012ea65c60
[ 28.649566] RBP: ffff88012ea65c48 R08: 0000000000000001 R09: 0000000000000000
[ 28.649567] R10: 0000000000000000 R11: 0000000000000000 R12: ffff88012ea65c60
[ 28.649568] R13: ffff88012ffb8010 R14: ffff88013199a800 R15: 0000000000000100
[ 28.649569] FS: 00007f9da2756700(0000) GS:ffff880137c80000(0000) knlGS:0000000000000000
[ 28.649571] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 28.649572] CR2: 0000000000ff1000 CR3: 000000012d454000 CR4: 00000000000007e0
[ 28.649573] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[ 28.649574] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[ 28.649575] Process modprobe (pid: 706, threadinfo ffff88012ea64000, task ffff88013023c560)
[ 28.649576] Stack:
[ 28.649577] ffffffffa0138553 ffff88013199a800 0000000000000135 ffff88012ea65ca8
[ 28.649579] ffffffffa013861f 0000000000000009 0000000000000000 0000000000000000
[ 28.649581] 0000000000000000 0000000000000000 000000008a133f54 ffff88012ea65c98
[ 28.649583] Call Trace:
[ 28.649590] [<ffffffffa0138553>] ? sony_nc_buffer_call.constprop.11+0x43/0xa0 [sony_laptop]
[ 28.649593] [<ffffffffa013861f>] sony_nc_rfkill_setup+0x6f/0x1b0 [sony_laptop]
[ 28.649597] [<ffffffffa013a9ab>] sony_nc_function_setup+0x2ab/0x920 [sony_laptop]
[ 28.649600] [<ffffffffa013b21b>] sony_nc_add+0x1fb/0x650 [sony_laptop]
[ 28.649605] [<ffffffff812005ed>] ? sysfs_do_create_link+0xed/0x220
[ 28.649610] [<ffffffff81335f08>] acpi_device_probe+0x4e/0x11c
[ 28.649614] [<ffffffff813bd161>] driver_probe_device+0x91/0x3b0
[ 28.649616] [<ffffffff813bd52b>] __driver_attach+0xab/0xb0
[ 28.649618] [<ffffffff813bd480>] ? driver_probe_device+0x3b0/0x3b0
[ 28.649621] [<ffffffff813bb356>] bus_for_each_dev+0x56/0x90
[ 28.649623] [<ffffffff813bcbee>] driver_attach+0x1e/0x20
[ 28.649625] [<ffffffff813bc6f0>] bus_add_driver+0x1a0/0x2c0
[ 28.649627] [<ffffffffa014c000>] ? 0xffffffffa014bff...

Read more...

Rafael Torres, if you are having a problem with Fedora, please report this to their bug tracker.

Thank you for your understanding.

tags: added: needs-bisect
Rafael Torres (rdtorres) wrote :

Hi Christopher,

I already reported there. I'm here just tring to narrow down this issue to a possible common denominator between two distros. Sorry if I caused any problem. I'm just tring to help.

Thanks

I have a Sony VPCS137GG. Suspend worked perfectly with 12.04 and prior distributions (although each new distribution upgrade usually broke suspend before a fix was found).

I have installed a clean 12.10 system and suspend is broken (from the menu or laptop lid close). The only solution is to force a power down.

Damian Beltrami, if you have a bug in Ubuntu, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Bug Control and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report may delay your problem being addressed as quickly as possible.

Thank you for your understanding.

Hi Cristopher,

can you help me to continue kernel bisect, pls? I believe you miss my last post. if not, I apologize in advance.

Maurs, thank you for your efforts in bisecting. Regarding your comments https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1069707/comments/43 :
>"can you help me to continue kernel bisect, pls? I believe you miss my last post. if not, I apologize in advance."

I did see your last post, and I beg your pardon on not replying to it sooner. It does seem you have fell into the pitfall of non-linear tag bisecting as noted in https://wiki.ubuntu.com/Kernel/KernelBisection#Commit_bisecting_Ubuntu_kernel_versions_across_non-linear_tags .

A discussion on testing around non-linear tags, for a different bug report but same problem, has been occurring at https://lists.ubuntu.com/archives/kernel-team/2012-November/022632.html .

I'm working on distilling this information into the bisect article. However, until then, you are welcome to seek further bisect support from the Ubuntu Kernel team via https://wiki.ubuntu.com/KernelTeam#Communications .

I'll mark this bug Confirmed in the mean time.

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-bug-exists-upstream-v3.7-rc2
removed: kernel-bug-exists-upstream-v3.7-rc2-raring
description: updated

Thanks Christopher, i have filed a new report and subscribed you as requested.

Hello,

Here a temporany workaround to make suspend work on Ubuntu 12.10 using 3.5 family kernel:

http://shiba89.wordpress.com/2012/10/25/ubuntu-12-10-linux-3-5-e-sony-laptop/

Code:

sudo add-apt-repository ppa:shiba89/vaio-kernel
sudo apt-get update
sudo apt-get install linux-headers-generic sony-laptop-dkms

It use the 3.4 kernel module with Absence Patches: http://www.absence.it/vaio-acpi/source/patches/

description: updated

Thanks Salvatore - you are a life saver!
All is working well. Hopefully the kernel is patched properly shortly.

You are welcome Damian. I opened a bug on the acpi kernel mailing list:
https://bugzilla.kernel.org/show_bug.cgi?id=50111

You could post there...

P.S. To use environment sensor for automatic screen & keyboard brightness, you can use sony-acpid deamon
http://code.google.com/p/vaio-f11-linux/wiki/AutoDimmingBacklightDaemon (sorry for OT)

Fabrizio Narni (shiba89) wrote :

I'm sorry I saw this report only now, I'm the writer of the blog linked at #34 and I already reported the bug upstream:
https://bugzilla.kernel.org/show_bug.cgi?id=48671
There's a patch linked, but it has not been merged yet (don't know how this things work).

The problem with my PPA is that it only works with kernel 3.5, as of 3.6 the module fails to build. Waiting for the patch to be merged upstream, or patching stock sony-laptop.c in the PPA for raring without Absence patches.

Fabrizio Narni (shiba89) wrote :

This is the patch which fixes this issue. Many, many thanks to Mattia Dongili.

tags: added: patch

The temporary workaround that Salvatore supplied does not appear to be working any longer.

Fabrizio, how do you apply the patch?

Helio Loureiro (helioloureiro) wrote :

Hi,

I applied it a few day ago (7 to be exact), and it worked accordingly here. My laptop is a Vaio VPC-S110GB and I'm running a 3.5.0-21-lowlatency kernel.

Hi Helio,
Could you help me out specifically with how to apply the patch?
Thanks,
Damian.

Helio Loureiro (helioloureiro) wrote :

Hi,

I just followed these steps:

sudo add-apt-repository ppa:shiba89/vaio-kernel
sudo apt-get update
sudo apt-get install linux-headers-generic sony-laptop-dkms

Perhaps you need to have DKMS environment working properly. Is your DKMS compiling properly? You need to run:

sudo apt-get install dkms

as well...

not working for me anymore.

Salvatore Cristofaro, could you please test http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-rc4-raring/ ?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

Hello,

I tested http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-rc4-raring/ kernel. It doesn't freeze anymore but suspend doesn't work: my laptop didn't enter in suspend mode, but only show me unblock session dialog window (as it was just resumed from suspend).

Regards,
Salvatore

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-bug-exists-upstream-v3.8-rc4 needs-upstream-testing
removed: kernel-bug-exists-upstream kernel-bug-exists-upstream-v3.7-rc2

Salvatore Cristofaro, thank you for testing mainline kernel v3.8-rc4. Could you please test http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-rc5-raring/ ?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: resume
removed: hibernate

This patch resolve the problem for me, as I wrote here:

https://bugzilla.kernel.org/show_bug.cgi?id=50111

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: removed: needs-bisect
Changed in linux:
importance: Unknown → Medium
status: Unknown → Incomplete
Julian Wiedmann (jwiedmann) wrote :

Salvatore,
the referenced patch landed in quantal-updates with 3.5.0-24.36. Please test and close this bug if it's fixed.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.