1002:9641 [Lenovo ThinkPad E525] Screen black on resume

Bug #1034002 reported by Geoff Teale on 2012-08-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
DRI
Invalid
Medium
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

I did the kernel smoke test for the quantal kernel on precise.

I can suspend and resume however when I resume I the screen stays black. It looks like the backlight isn't coming on, but it's noteable that I don't see anything on my external screen either. I can see consoles on my external monitor (over HDMI) and if I disconnect the HDMI cable and reconnect it then I am also able to see my Unity session on that screen. This issue is present with both the quantal kernel and the stock 12.04 one.

WORKAROUND: Use fglrx.

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: Generic_1 [HD-Audio Generic], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: tealeg 2861 F.... pulseaudio
 /dev/snd/controlC0: tealeg 2861 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Generic'/'HD-Audio Generic at 0xf0b44000 irq 48'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 6
   Simple ctrls : 1
Card0.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card1.Amixer.info:
 Card hw:1 'Generic_1'/'HD-Audio Generic at 0xf0b40000 irq 16'
   Mixer name : 'Conexant CX20590'
   Components : 'HDA:14f1506e,17aa21ea,00100002'
   Controls : 18
   Simple ctrls : 10
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
DistroRelease: Ubuntu 12.04
HibernationDevice:
 # RESUME=/dev/sda5
 RESUME='UUID=61453936-e394-41de-8b00-5ee8f17023b3'
InstallationMedia: Ubuntu-Server 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129)
MachineType: LENOVO 12002KG
Package: linux 3.2.0.27.29
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-7-generic root=UUID=c2742c1e-158f-446d-9884-d6f037d7fa8c ro quiet splash elevator=deadline
ProcVersionSignature: Ubuntu 3.5.0-7.7~precise1-generic 3.5.0
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-7-generic N/A
 linux-backports-modules-3.5.0-7-generic N/A
 linux-firmware 1.79
Tags: precise running-unity
Uname: Linux 3.5.0-7-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip kvm libvirtd lpadmin plugdev sambashare sudo
WifiSyslog:

dmi.bios.date: 07/28/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8IET34WW(1.07)
dmi.board.asset.tag: Not Available
dmi.board.name: 12002KG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8IET34WW(1.07):bd07/28/2011:svnLENOVO:pn12002KG:pvrThinkPadE525:rvnLENOVO:rn12002KG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 12002KG
dmi.product.version: ThinkPad E525
dmi.sys.vendor: LENOVO

Created attachment 54422
dmesg showing suspend/resume

I have installed Fedora 16 on my new ASUS K53TA laptop that has these devices:

# lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] Family 12h Processor Root Complex
00:01.0 VGA compatible controller: ATI Technologies Inc Device 9648
00:01.1 Audio device: ATI Technologies Inc Device 1714
00:02.0 PCI bridge: Advanced Micro Devices [AMD] Family 12h Processor Root Port
00:04.0 PCI bridge: Advanced Micro Devices [AMD] Family 12h Processor Root Port
00:05.0 PCI bridge: Advanced Micro Devices [AMD] Family 12h Processor Root Port
00:10.0 USB controller: Advanced Micro Devices [AMD] Hudson USB XHCI Controller (rev 03)
00:11.0 SATA controller: Advanced Micro Devices [AMD] Hudson SATA Controller [AHCI mode] (rev 40)
00:12.0 USB controller: Advanced Micro Devices [AMD] Hudson USB OHCI Controller (rev 11)
00:12.2 USB controller: Advanced Micro Devices [AMD] Hudson USB EHCI Controller (rev 11)
00:14.0 SMBus: Advanced Micro Devices [AMD] Hudson SMBus Controller (rev 13)
00:14.2 Audio device: Advanced Micro Devices [AMD] Hudson Azalia Controller (rev 01)
00:14.3 ISA bridge: Advanced Micro Devices [AMD] Hudson LPC Bridge (rev 11)
00:14.4 PCI bridge: Advanced Micro Devices [AMD] Hudson PCI Bridge (rev 40)
00:14.7 SD Host controller: Advanced Micro Devices [AMD] Hudson SD Flash Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 0 (rev 43)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 6
00:18.6 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 5
00:18.7 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 7
01:00.0 VGA compatible controller: ATI Technologies Inc Whistler [AMD Radeon HD 6600M Series] (rev ff)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

I had to install kernel-3.2.0-0.rc5.git1.1.fc17.x86_64 from Rawhide to make KMS work on the integrated video.

I tried suspend/resume by closing the lid, suspend worked. Resume woke up the
machine but left the screen black. dmesg for the suspend/resume is attached.

Created attachment 55194
difference of `radeontool regmatch \*` from before and after suspend

HP G4-1215DX with an A4-3300 APU here. Everything comes back but the display on a resume from a suspend. I can ssh into the machine and get any kind of debugging info needed.

Created attachment 55303
difference of `radeonreg regs dce4` from before and after suspend

I have the full before and after dumps still if you need them also.

against drm-next or Linus' git.

No- these patches leave my screen dark after KMS kicks in.

Same for me - black screen.

*** Bug 49281 has been marked as a duplicate of this bug. ***

38 comments hidden view all 105 comments
Geoff Teale (tealeg) wrote :
description: updated
Brad Figg (brad-figg) on 2012-08-07
Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: quantal
2 comments hidden view all 105 comments
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1034002

tags: added: package-qa-testing
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.5kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. Please only remove that one tag and leave the other tags. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc1-quantal/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Joseph Salisbury (jsalisbury) wrote :

It would also be helpful if you could submit apport logs with the following command:

apport-collect 1034002

apport information

tags: added: apport-collected precise running-unity
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Tested with mainstream and bug updated as per you request. Thanks jsalisbury.

tags: added: kernel-bug-exists-upstream
tags: removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Geoff Teale (tealeg) wrote :

Reported via e-Mail upstream.

Geoff Teale (tealeg) wrote :

Reported on upstream bugzilla and linked.

Geoff Teale (tealeg) wrote :

The original bug was marked as a duplicate of this one.

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in dri:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in linux:
status: Confirmed → Fix Released
33 comments hidden view all 105 comments

Created attachment 85691
dmesg+Xorg.0.log

Same bug here...
HP laptop (dv6-6174la), dual GPU:
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] BeaverCreek [Radeon HD 6520G] [1002:9647] (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M] [1002:6741] (prog-if 00 [VGA controller])
Linux hostname 3.11.0-7-generic #13-Ubuntu SMP Tue Sep 10 20:55:38 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

workaround: use an external monitor (HDMI and VGA worked, with some problems though, but that is unrelated [you can see some warning and backtraces] and didn't happen before)

attached: whole dmesg, Xorg.0.log files after two consecutive suspend/resume cycles plus some testing with external monitors, and .diff files (from other session) showing messages logged only after suspend to RAM.

I have the exact same problem here but with a radeon HD 7310. I can try patches.

Sorry, I forgot to precise it was with kernel 3.11 and dpm activated.

(In reply to comment #32)
> (In reply to comment #31)
> > Created attachment 84276 [details] [review] [review]
> > possible fix 2/2
> >
> > Please apply both patches in this set.
>
> Unfortunately these patches do not help.

same for me, the patches didn't work.

Created attachment 86031
dmesg, xorg

I installed 3.12-rc1 from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-rc1-saucy/ , it didn't help :(
Attached are the logs from dmesg (before and after running pm-suspend) and Xorg.0.log (there were no messages after resuming from suspend)

I'm not sure if I have the same issue. In particular, I could not find this error in my dmesg:
..
[drm:radeon_acpi_init] *ERROR* Cannot find a backlight controller
..

But I do have the issue that my laptop does not wake up fully (the screen is black).

There is some noise starts in the notebook and led indicators start blinking, but the screen does not turn ON.

I know, there are many possible reasons, but it worked with Catalyst, so, I think it has to be connected to video driver (dri, kms, xf86-video-ati, whatever..).

$ lspci | grep VGA
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] BeaverCreek [Radeon HD 6520G]
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series]

$ uname -a
Linux pilat-book 3.11.1-2-ARCH #1 SMP PREEMPT Sun Sep 22 19:45:00 CEST 2013 x86_64 GNU/Linux

I use radeon.dpm=1 in the kernel options;

Here's the bug-report to Archlinux tracker, but they suggested to file the bug here:
https://bugs.archlinux.org/task/37078

Same issue with me. I have an HP with an A8-3550MX (6620G graphics). This issue as plagued me (and I am sure others) for quite some time. I have pretty much relegated myself to using the fglrx binary blob.

Any process? This is the most annoying thing about using Linux..

Same issue for my A8-450M laptop with Integrated or Discrete GPU set.
I made some tests from kernel 3.8.0 to 3.12-RC6 on Ubuntu.
I got same result with other distro like ArchLinux or Fedora.

# lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1
fh) Processor Root Complex
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Trinit
y [Radeon HD 7640G]

Some other tests on my main kernel 3.11.6 (Ubuntu PPA)
(CPU and GPU firmware has been updated to latest version)

 - After suspend and resume, with ssh I can check brightness control on /sys/class/blacklight/radeon_bl0/brightness and change the value but nothing change on screen (always black screen)
 - no syslog entry give information on the problem
 - no more information with drm.debug on kernel
 - fglrx doesn't have the same problem, suspend and resume work fine
   (but fglrx don't allow to change brightness).

So, this concern seems to come from the drm driver and not from kernel or acpi,
but I don't have enough knowledge to go further to identify the root cause in xorg

tags: added: bios-outdated-1.13
Changed in linux (Ubuntu):
status: Triaged → Incomplete
1 comments hidden view all 105 comments

I'm using kernel 3.13-rc0 from: http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-next/2013-11-14-trusty/
3.12.0-996-generic #201311140516
and this is still happening...
I guess I'll have to go back to fglrx.
I wished I could help devs, but this is driving me crazy. Not being able to resume from suspend is why I wanted to test the open-source driver in the first place...

So, updating my BIOS, sadly, did not fix the problem. The result was exactly the same. I suspend the laptop, then resume it. The machine resumes from suspend in every respect except that it doesn't turn the backlight on the screen back on.

With the new BIOS, the output of `sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date` is:

8IET41WW(1.14)
02/26/2013

tags: added: latest-bios-1.14
removed: bios-outdated-1.13
summary: - Lenovo E525 screen black on resume
+ 1002:9641 [Lenovo ThinkPad E525] Screen black on resume
1 comments hidden view all 105 comments
Geoff Teale (tealeg) wrote :

Hi.

I've confirmed that the bug still exists with kernel 3.13.0 (and tagged as requested) - I will try with a clean install from the daily ISO when I get a little time to do so, hopefully in the next few days.

tags: added: kernel-bug-exists-upstream-v3.13.0
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Geoff Teale, did this problem not occur in a release prior to Precise?

tags: added: kernel-bug-exists-upstream-v3.13-rc1
removed: kernel-bug-exists-upstream-v3.13.0
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-suspend-logs
Download full text (5.3 KiB)

I don't think I ever had a release prior to precise running on the laptop -
I was using the development ISOs when I first got the machine about 2 years
ago. As I recall it was really hard to get it running at all (I had to use
the server CD) - things have improved since then ;-)

On Mon, Nov 25, 2013 at 1:01 PM, Christopher M. Penalver <
<email address hidden>> wrote:

> Geoff Teale, did this problem not occur in a release prior to Precise?
>
> ** Tags removed: kernel-bug-exists-upstream-v3.13.0
> ** Tags added: kernel-bug-exists-upstream-v3.13-rc1
>
> ** Changed in: linux (Ubuntu)
> Status: Confirmed => Incomplete
>
> ** Tags added: needs-suspend-logs
>
> ** Attachment removed: "/proc/version_signature"
>
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1034002/+attachment/3251356/+files/version.log
>
> ** Attachment removed: "lspci output"
>
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1034002/+attachment/3251355/+files/lspci
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1034002
>
> Title:
> 1002:9641 [Lenovo ThinkPad E525] Screen black on resume
>
> Status in Direct Rendering Infrastructure:
> Confirmed
> Status in The Linux Kernel:
> Fix Released
> Status in “linux” package in Ubuntu:
> Incomplete
>
> Bug description:
> I did the kernel smoke test for the quantal kernel on precise.
>
> I can suspend and resume however when I resume I the screen stays
> black. It looks like the backlight isn't coming on, but it's
> noteable that I don't see anything on my external screen either. I
> can see consoles on my external monitor (over HDMI) and if I
> disconnect the HDMI cable and reconnect it then I am also able to see
> my Unity session on that screen.
>
> This issue is present with both the quantal kernel and the stock 12.04
> one.
>
> My setup is a Lenovo Thinkpad E525, AMD A8-3500m.
> ---
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
> ApportVersion: 2.0.1-0ubuntu12
> Architecture: amd64
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 1: Generic_1 [HD-Audio Generic], device 0: CONEXANT Analog
> [CONEXANT Analog]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC1: tealeg 2861 F.... pulseaudio
> /dev/snd/controlC0: tealeg 2861 F.... pulseaudio
> Card0.Amixer.info:
> Card hw:0 'Generic'/'HD-Audio Generic at 0xf0b44000 irq 48'
> Mixer name : 'ATI R6xx HDMI'
> Components : 'HDA:1002aa01,00aa0100,00100200'
> Controls : 6
> Simple ctrls : 1
> Card0.Amixer.values:
> Simple mixer control 'IEC958',0
> Capabilities: pswitch pswitch-joined penum
> Playback channels: Mono
> Mono: Playback [on]
> Card1.Amixer.info:
> Card hw:1 'Generic_1'/'HD-Audio Generic at 0xf0b40000 irq 16'
> Mixer name : 'Conexant CX20590'
> Components : 'HDA:14f1506e,17aa21ea,00100002'
> Controls : 18
> Simple ctrls : 10
> Card29.Amixer.info:
> Card hw:29 'ThinkPadEC'/'ThinkPad Console Audi...

Read more...

Geoff Teale, could you please provide the information following https://wiki.ubuntu.com/DebuggingKernelSuspend ?

Geoff Teale (tealeg) wrote :

Attached wakeup file.

Geoff Teale (tealeg) wrote :

This attachment contains the full output of dmesg following the "resume-trace" procedure described on https://wiki.ubuntu.com/DebuggingKernelSuspend

tags: removed: needs-suspend-logs
Changed in linux (Ubuntu):
status: Incomplete → Triaged
1 comments hidden view all 105 comments
Geoff Teale (tealeg) wrote :

Christopher. Thanks for your help. That kernel bug was marked as resolved, but the DRI bug (already linked here and on the kernel bug) is still in New status and many people are reporting the same issues there still. Is it really worth re-raising the Kernel bug?

summary: - 1002:9641 [Lenovo ThinkPad E525] Screen black on resume
+ 1002:9641 1002:9641 [Lenovo ThinkPad E525] Screen black on resume

Geoff Teale, given the DRI report is similar problem, different hardware model, and it has many "Me too!" comments, those types of reports tend to be lost in the shuffle.

However, a couple of follow up questions:
1) Just to clarify, did the patch mentioned in https://bugzilla.kernel.org/show_bug.cgi?id=46241#c8 address your problem?
2) Did this problem not occur in a release prior to Precise?
3) Does fglrx provide a WORKAROUND?

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Geoff Teale (tealeg) wrote :

Christopher.

The answers:

1. No.
2. I'm having to think back two years now, but I believe I had to install from Ubuntu Server and install FGLRX to get it working on oneiric and alpha versions of precise. I know for sure that the desktop install CD would hang prior to precise. Would you like me to try install oneiric server on it again to see exactly what happens?
3. Yes, suspend/resume with FGLRX does work perfectly on both this AMD A8-3500M and on my wife's AMD A10-5750M based machine.

summary: - 1002:9641 1002:9641 [Lenovo ThinkPad E525] Screen black on resume
+ 1002:9641 [Lenovo ThinkPad E525] Screen black on resume
description: updated

Geoff:

>"Would you like me to try install oneiric server on it again to see exactly what happens?"

No, this should be enough info. Given the upstream patch didn't address your issue, and the upstream bug was closed, it woudn't hurt utilizing the upstream format in https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Kernel.org_Format to e-mail linux-pm CC Alex on how the upstream patch didn't address the issue.

Changed in linux (Ubuntu):
status: Incomplete → Triaged

Same problem here running on a HP Laptop Pavillion G7 with AMD A6-3400M CPU/GPU.

Currently running 3.12.5 kernel from openSuse Tumbleweed, though ive had this problem for ages.

This bug is really old and really annoying as it makes the laptops unusable for suspend -- what kind of traces would be required to understand the core of the problem, from what I can tell the display engine is in a severely hosed state, but I lack documentation to understand what is wrong.

Does setting out a bounty for this bug help? I'm willing to immediately cash in at $300.

Any updates one this?
Kernel 3.14-rc6 + mesa 10.2-git (I tested it a couple weeks ago), still the same.
Any clues on where to look for bugs and/or how to debug?

(In reply to comment #45)
> Any updates one this?
> Kernel 3.14-rc6 + mesa 10.2-git (I tested it a couple weeks ago), still the
> same.
> Any clues on where to look for bugs and/or how to debug?

I also want a status on this. This is 1% to make Linux 100% perfect.

Kernel 3.14-rc8 (with PRIME) + mesa 10.2-git (radeon driver with kms and dpm)
Still the same issue, suspend + resume works fine but the laptop's screen does not turn back on. Using an external monitor confirms that the system itself is functional after resume. When running fglrx, there is no issue.
HP dv6z 6100 CTO QE (ca. 2011). CPU: AMD 18-3510mx, iGPU: Radeon HD 6620g, dGPU: Radeon HD 6750m.

I got the same issue here.

After I suspend my machine and try to wake up, the screen does not display anything else. And I'd have to blindly switch to tty terminal and type reboot.

Info:
Linux 3.13.8-1 (Arch linux)
Mesa - 10.1.0

Radeon 7520G

I have a similar issue with a samsumg series 3 laptop with "VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] BeaverCreek [Radeon HD 6620G]" and "VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series]". after resume an external monitor show the system is still responsive.

BUT I can make the screen turn on after suspend with the next command:
sudo pm-suspend --quirk-test --quirk-s3-bios

so if you can try and this work maybe we can kick this issue.

(In reply to comment #49)
> I have a similar issue with a samsumg series 3 laptop with "VGA compatible
> controller: Advanced Micro Devices, Inc. [AMD/ATI] BeaverCreek [Radeon HD
> 6620G]" and "VGA compatible controller: Advanced Micro Devices, Inc.
> [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series]". after resume an external
> monitor show the system is still responsive.
>
> BUT I can make the screen turn on after suspend with the next command:
> sudo pm-suspend --quirk-test --quirk-s3-bios

whoa, that worked as well for me! I'll try to dissect unless someone else jumps to it, and then make good on my promise above :)

maybe the same issue? https://bugs.freedesktop.org/show_bug.cgi?id=42960

also, isn't pm-utils somehow deprecated?
if we add the parameter in /etc/pm/config.d/ will the command "systemctl suspend" be able to turn on the screen? i think that "systemctl suspend" doesn't rely on pm-utils

(In reply to comment #51)
> maybe the same issue? https://bugs.freedesktop.org/show_bug.cgi?id=42960
>
> also, isn't pm-utils somehow deprecated?
> if we add the parameter in /etc/pm/config.d/ will the command "systemctl
> suspend" be able to turn on the screen? i think that "systemctl suspend"
> doesn't rely on pm-utils

I looked in the pm-utils sourcecode, and adding acpi_sleep=s3_bios to the cmdline fix it for me.

You can read a little about it here: https://www.kernel.org/doc/Documentation/power/video.txt

Seems to work for me too. I'm sure one of Alex's patches helped out too, so thank you Alex.

I do get this on resume, but that's probably for another bug:
[ 117.375124] [drm:atom_op_jump] *ERROR* atombios stuck in loop for more than 5secs aborting
[ 117.375127] [drm:atom_execute_table_locked] *ERROR* atombios stuck executing E442 (len 2585, WS 4, PS 4) @ 0xEB2C
[ 117.436913] [drm:radeon_dp_link_train_cr] *ERROR* clock recovery reached max voltage
[ 117.436914] [drm:radeon_dp_link_train_cr] *ERROR* clock recovery failed

Awesome. To spell it out a little more explicitly, here is what I did (Arch x86_64 3.14-mainline) to have this apparently accomplished automatically from now on:

sudo su

echo 'ADD_PARAMETERS="--quirk-test --quirk-s3-bios"' >> /etc/pm/config.d/00-fix_dv6z_suspend_screen

pm-suspend --quirk-test --quirk-s3-bios --store-quirks-as-lkw

Which should save the quirks, perhaps with some redundancy. Checking the contents of the (new)

/etc/pm/last_known_working.quirkdb

file should show the matches made against your particular system, especially e.g. hardware and firmware details. I guess these could be patched into (for my HP at least)

/usr/lib/pm-utils/video-quirks/20-video-quirk-pm-hp.quirkdb

with some of the returned information, given that this file is supposed to have a fairly up-to-date {white,black,broken}-list.

Obviously follow this only at your own risk, etc. I have no idea how this would work when it comes to fglrx, or even how stable it is against kernel/pm/upower/whatever updates. Here are some more good references for information:

https://trisquel.info/en/wiki/troubleshooting-suspendhibernate

https://wiki.archlinux.org/index.php/pm-utils

(In reply to comment #49)
> I have a similar issue with a samsumg series 3 laptop with "VGA compatible
> controller: Advanced Micro Devices, Inc. [AMD/ATI] BeaverCreek [Radeon HD
> 6620G]" and "VGA compatible controller: Advanced Micro Devices, Inc.
> [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series]". after resume an external
> monitor show the system is still responsive.
>
> BUT I can make the screen turn on after suspend with the next command:
> sudo pm-suspend --quirk-test --quirk-s3-bios
>
> so if you can try and this work maybe we can kick this issue.

GREAT, it works for me, thank you very much!
I did try pm-suspend with different flags some months ago.. I guess my testing was too conservative :(
@ <email address hidden> and <email address hidden> , thank you too! and once again, thanks AMD devs :)

(In reply to comment #54)
> Awesome. To spell it out a little more explicitly, here is what I did (Arch
> x86_64 3.14-mainline) to have this apparently accomplished automatically
> from now on:
>
> sudo su
>
> echo 'ADD_PARAMETERS="--quirk-test --quirk-s3-bios"' >>
> /etc/pm/config.d/00-fix_dv6z_suspend_screen
>
> pm-suspend --quirk-test --quirk-s3-bios --store-quirks-as-lkw
>
> Which should save the quirks, perhaps with some redundancy. Checking the
> contents of the (new)
>
> /etc/pm/last_known_working.quirkdb
>
> file should show the matches made against your particular system, especially
> e.g. hardware and firmware details. I guess these could be patched into (for
> my HP at least)
>
> /usr/lib/pm-utils/video-quirks/20-video-quirk-pm-hp.quirkdb
>
> with some of the returned information, given that this file is supposed to
> have a fairly up-to-date {white,black,broken}-list.
>
> Obviously follow this only at your own risk, etc. I have no idea how this
> would work when it comes to fglrx, or even how stable it is against
> kernel/pm/upower/whatever updates. Here are some more good references for
> information:
>
> https://trisquel.info/en/wiki/troubleshooting-suspendhibernate
>
> https://wiki.archlinux.org/index.php/pm-utils

Hmm. I just did:
sudo nano /etc/default/grub
found GRUB_CMDLINE_LINUX_DEFAULT and added acpi_sleep=s3_bios just before quiet
ctrl+o and ctrl+x
sudo grub-mkconfig -o /boot/grub/grub.cfg

(In reply to comment #55)
> (In reply to comment #49)
> > I have a similar issue with a samsumg series 3 laptop with "VGA compatible
> > controller: Advanced Micro Devices, Inc. [AMD/ATI] BeaverCreek [Radeon HD
> > 6620G]" and "VGA compatible controller: Advanced Micro Devices, Inc.
> > [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series]". after resume an external
> > monitor show the system is still responsive.
> >
> > BUT I can make the screen turn on after suspend with the next command:
> > sudo pm-suspend --quirk-test --quirk-s3-bios
> >
> > so if you can try and this work maybe we can kick this issue.
>
> GREAT, it works for me, thank you very much!
> I did try pm-suspend with different flags some months ago.. I guess my
> testing was too conservative :(
> @ <email address hidden> and <email address hidden> , thank you too! and
> once again, thanks AMD devs :)

I see now... I DID test the '--quirk-s3-bios' flag, but I need '--quirk-test', which is not documented in the manpage...

from pm-utils-1.4.1/README.debugging:
"* To override the usual quirk filtering (for kernel modesetting, binary drivers, and exotic hardware), pass --quirk-test along with any other quirks you want to try. This may make your system crash in new and exciting ways by conflicting with the kernel when suspending or resuming, but is very useful for debugging. You have been warned."
Oh, well, I'm happy that someone found a solution and shared it with us all :D

*** This bug has been marked as a duplicate of bug 42960 ***

Changed in dri:
status: Confirmed → Invalid
Displaying first 40 and last 40 comments. View all 105 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.