Ubuntu

Dell Lattitude 2120 Touchscreen worked in Ubuntu 11.10, does not work in 12.04

Reported by Jeff Lane on 2012-07-18
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Undecided
Unassigned
linux (Ubuntu)
High
Unassigned
Declined for Natty by Chris Van Hoof
Declined for Oneiric by Chris Van Hoof
Precise
High
Ming Lei
Quantal
High
Unassigned

Bug Description

SRU Justification:

Impact:
        - without the patch, touchpad(1cb6:6651) can't be used on Precise
Fix:
        - After applying the patch, touchpad(1cb6:6651) can be used on Precise

Original Reporter: John Maydew

NOTE: This came in via answers.launchpad.net for the cert programme. I have played with the touch screen on a suitably configured 2120 and can confirm that on older releases the touch screen DID work fine as a single touch device (In my limited exposure to it). According to the user who submitted this, he was fine with 11.10, but on upgrading to 12.04, the touch screen stopped working. Going back to 11.10 and it works. Thus, this appears to be a regression in 12.04

The ubuntu certification for this netbook does not mention that the touch-screen is unsupported in Ubuntu 12.04

Initially I had Ubuntu 11.10 installed on this netbook, the touch-screen worked without issue. Upgrading to 12.04, however, has rendered the touch-screen useless. The touch-screen itself is an Ideacom IDC 6651. I've had no luck so far in locating proprietary drivers.

lsusb lists all my other devices correctly, apart from the touchscreen, which is displayed as such:

Bus 004 Device 002: ID 1cb6:6651

xinput does not list it directly, but I believe it to be the Virtual Core XTEST pointer, shown below.

Virtual core pointer id=2 [master pointer (3)]
↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
↳ SynPS/2 Synaptics TouchPad id=11 [slave pointer (2)]

Additionally, lshal shows the following information also related to the touchscreen

udi = '/org/freedesktop/Hal/devices/usb_device_1cb6_6651_noserial_if0'
info.linux.driver = 'usbhid' (string)
info.parent = '/org/freedesktop/Hal/devices/usb_device_1cb6_6651_noserial' (string)
info.product = 'USB HID Interface' (string)

info.subsystem = 'usb' (string)
info.udi = '/org/freedesktop/Hal/devices/usb_device_1cb6_6651_noserial_if0' (string)
linux.hotplug_type = 2 (0x2) (int)

linux.subsystem = 'usb' (string)
linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1d.2/usb4/4-2/4-2:1.0' (string) usb.bus_number = 4 (0x4) (int)
usb.can_wake_up = true (bool)
usb.configuration_value = 1 (0x1) (int)

usb.device_class = 0 (0x0) (int)
usb.device_protocol = 0 (0x0) (int)
usb.device_revision_bcd = 4097 (0x1001) (int)
usb.device_subclass = 0 (0x0) (int)

usb.interface.class = 3 (0x3) (int)
usb.interface.number = 0 (0x0) (int)
usb.interface.protocol = 0 (0x0) (int)

usb.interface.subclass = 0 (0x0) (int)
usb.is_self_powered = false (bool)
usb.linux.device_number = 2 (0x2) (int)
usb.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1d.2/usb4/4-2/4-2:1.0' (string)
usb.max_power = 100 (0x64) (int)
usb.num_configurations = 1 (0x1) (int)
usb.num_interfaces = 1 (0x1) (int)

usb.num_ports = 0 (0x0) (int)
usb.product = 'USB HID Interface' (string)
usb.product_id = 26193 (0x6651) (int)
usb.speed = 12.0 (12) (double)
usb.vendor = 'IDEACOM' (string)
usb.vendor_id = 7350 (0x1cb6) (int) usb.version = 1.1 (1.1) (double)

--
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu11
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: john 1895 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6dfc000 irq 46'
   Mixer name : 'Realtek ALC269VB'
   Components : 'HDA:10ec0269,102804a5,00100100'
   Controls : 18
   Simple ctrls : 10
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=e4be4a3d-130b-4a18-9266-dad012ec4e7e
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
MachineType: Dell Inc. Latitude 2120
NonfreeKernelModules: wl
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-26-generic root=UUID=2330b4ff-4a77-476f-a94a-bf5552872ea5 ro quiet splash
ProcVersionSignature: Ubuntu 3.2.0-26.41-generic 3.2.19
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-26-generic N/A
 linux-backports-modules-3.2.0-26-generic N/A
 linux-firmware 1.79
StagingDrivers: rts_pstor
Tags: precise running-unity staging
Uname: Linux 3.2.0-26-generic i686
UpgradeStatus: Upgraded to precise on 2012-06-25 (23 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 10/27/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A00
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA00:bd10/27/2010:svnDellInc.:pnLatitude2120:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude 2120
dmi.sys.vendor: Dell Inc.

Jeff Lane (bladernr) on 2012-07-18
affects: ubuntu-certification → linux (Ubuntu)
summary: - Dell Insprion 2120 Touchscreen worked in Ubuntu 11.10, does not work in
+ Dell Lattitude 2120 Touchscreen worked in Ubuntu 11.10, does not work in
12.04

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1026174

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: oneiric
Changed in linux (Ubuntu):
importance: Undecided → Medium

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu11
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: john 1895 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6dfc000 irq 46'
   Mixer name : 'Realtek ALC269VB'
   Components : 'HDA:10ec0269,102804a5,00100100'
   Controls : 18
   Simple ctrls : 10
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=e4be4a3d-130b-4a18-9266-dad012ec4e7e
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
MachineType: Dell Inc. Latitude 2120
NonfreeKernelModules: wl
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-26-generic root=UUID=2330b4ff-4a77-476f-a94a-bf5552872ea5 ro quiet splash
ProcVersionSignature: Ubuntu 3.2.0-26.41-generic 3.2.19
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-26-generic N/A
 linux-backports-modules-3.2.0-26-generic N/A
 linux-firmware 1.79
StagingDrivers: rts_pstor
Tags: precise running-unity staging
Uname: Linux 3.2.0-26-generic i686
UpgradeStatus: Upgraded to precise on 2012-06-25 (23 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 10/27/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A00
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA00:bd10/27/2010:svnDellInc.:pnLatitude2120:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude 2120
dmi.sys.vendor: Dell Inc.

tags: added: apport-collected precise running-unity staging

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

John Maydew, thank you for reporting this and helping make Ubuntu better. If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. As well, please comment on which kernel version specifically you tested.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream', and comment as to why specifically you were unable to test it.

Please let us know your results. Thanks in advance.

description: updated
tags: added: needs-upstream-testing regression-release
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
John Maydew (johnmaydew) on 2012-07-23
tags: added: bug-exists-upstream
removed: needs-upstream-testing
John Maydew (johnmaydew) wrote :

Tested with kernel v3.3.7-precise (latest version I could find for my version of Ubuntu, apologies if this is incorrect).

Issue still exists; still unable to use the touchscreen. lsusb, lshal and xinput still report the same data as they did before (see original description).

I _did_ have to boot the kernel in recovery mode and then continue with normal boot, not sure if this would've skewed the results. This was because the computer didn't seem to want to boot when I selected the kernel from GRUB. This was almost certainly a blunder on my part, though, so I'll see if it's possible to try again.

description: updated
tags: added: kernel-bug-exists-upstream
removed: bug-exists-upstream
tags: added: kernel-input
John Maydew (johnmaydew) on 2012-07-23
tags: added: kernel-fixed-upstream
removed: kernel-bug-exists-upstream
John Maydew (johnmaydew) wrote :

Touchscreen is working with single touch in Kernel v3.5-rc7-quantal. Calibration is a bit off but that's just teething problems I think.

Thanks all.

Changed in linux (Ubuntu):
status: Incomplete → Fix Committed
Changed in linux (Ubuntu):
status: Fix Committed → Confirmed
Changed in linux:
status: New → Invalid

Marking Triaged as mainline tested and kernel-fixed-upstream-v3.5-rc7-quantal.

tags: added: kernel-fixed-upstream-v3.5-rc7-quantal
Changed in linux (Ubuntu):
status: Confirmed → Triaged
tags: added: blocks-hwcert-enablement
Anthony Wong (anthonywong) wrote :

Sorry for the incorrect natty and oneiric nomination, which is done by an automatic script, please feel free to decline it.

Hi,

Could you test the kernel image in the below link which integrates the
upstream commit 71078b0deba8420e00b0c5e39ea359dbcaa11114?

       http://kernel.ubuntu.com/~ming/bugs/1026174/

Thanks,
--
Ming Lei

John Maydew (johnmaydew) wrote :

Ming,

Is there a 32 bit version of that kernel available?

John

Chris Van Hoof (vanhoof) wrote :

On 08/06/2012 03:24 AM, Anthony Wong wrote:
> Sorry for the incorrect natty and oneiric nomination, which is done by
> an automatic script, please feel free to decline it.

Heya Anthony -- Fixed that up and set the appropriate nominations.

Changed in linux (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High
Changed in linux (Ubuntu Quantal):
importance: Medium → High
status: Triaged → Fix Released
Changed in linux (Ubuntu Precise):
assignee: nobody → Ming Lei (tom-leiming)
milestone: none → precise-updates
Ming Lei (tom-leiming) wrote :

On Tue, Aug 7, 2012 at 12:34 AM, John Maydew <email address hidden> wrote:
> Ming,
>
> Is there a 32 bit version of that kernel available?

See http://kernel.ubuntu.com/~ming/bugs/1026174/i386.

Thanks,
--
Ming Lei

John Maydew (johnmaydew) wrote :

Ming,

Just gave that kernel a test. Everything works great; calibration is fine 'out of the box'.
There doesn't seem to be any support for multi-touch gestures, though.

John

description: updated
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Precise in -proposed solves the problem (3.2.0-30.47). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
John Maydew (johnmaydew) wrote :

No dice; the touch-screen no longer works with the new proposed kernel.

Ming Lei (tom-leiming) wrote :

On Tue, Aug 21, 2012 at 7:27 PM, John Maydew <email address hidden> wrote:
> No dice; the touch-screen no longer works with the new proposed kernel.

Could you post the 'dmesg' out?

Thanks,
--
Ming Lei

John Maydew (johnmaydew) wrote :

My bad, sorry, it seems to work now. Might have just needed another reboot. I'll update if it does turn out to be finicky.

I've attached the dmesg output anyway, just in case.

John Maydew (johnmaydew) wrote :

Just restarted; use of the touch-screen is a bit hit-and-miss.

Touching the screen moves the cursor, but I can't click anything. Oddly, I can select areas of text in the terminal output but this doesn't apply to anything else that I know of.

If I tap the screen to move the cursor, moving the touchpad or shifting the USB mouse makes the cursor jump back to where it was originally before being controlled as normal.

I've attached another dmesg output.

Chris Van Hoof (vanhoof) wrote :

@John does what you experience now differ from your initial positive feedback in Comment #31 ?

Ming Lei (tom-leiming) wrote :

On Wed, Aug 22, 2012 at 7:51 PM, John Maydew <email address hidden> wrote:
> Just restarted; use of the touch-screen is a bit hit-and-miss.
>
> Touching the screen moves the cursor, but I can't click anything. Oddly,
> I can select areas of text in the terminal output but this doesn't apply
> to anything else that I know of.

Maybe it is caused by unity or upper layer software, could you reproduce
it every time? or it just happened one time?

> If I tap the screen to move the cursor, moving the touchpad or shifting
> the USB mouse makes the cursor jump back to where it was originally
> before being controlled as normal.
>
> I've attached another dmesg output.

Your dmesg output shows some other failure about acpi video:

[ 17.488435] [Firmware Bug]: Duplicate ACPI video bus devices for
the same VGA controller, please try module parameter
"video.allow_duplicates=1"if the current driver doesn't work.

But this is nothing to do with touchpad driver.

thanks,
--
Ming Lei

John Maydew (johnmaydew) wrote :

I can't find any method of reproducing the issue every time; it's fairly irregular (only occurred twice in the past couple of weeks). I'll report back if I can find what's causing it, but I don't see that happening anytime soon. I have been having some issues with xorg, but I can't tell if that's related or not.

I'm not sure what the ACPI video error is; but I've had no issues with the screen or a dual-screen setup using the VGA output so I'm happy to just ignore that.

Ming Lei (tom-leiming) wrote :

On Fri, Aug 24, 2012 at 8:15 PM, John Maydew <email address hidden> wrote:
> I can't find any method of reproducing the issue every time; it's fairly
> irregular (only occurred twice in the past couple of weeks). I'll report
> back if I can find what's causing it, but I don't see that happening
> anytime soon. I have been having some issues with xorg, but I can't tell
> if that's related or not.

OK, so that looks like a new problem, and the patch should make the
touchscreen workable basically.

Suggest you open a new bug entry once you reproduce the new problem.

Thanks,
--
Ming Lei

Luis Henriques (henrix) wrote :

Ming: I guess that's a good idea. Furthermore, the patch that should fix this issue (the original issue reported here) came from a mainline stable update, so it should not be reverted.

I am tagging this bug as verified in Precise, although we still have an issue with this touchscreen.

John, feel free to add a comment here with the link to the new bug report.

Thank you everyone.

tags: added: verification-done-precise
removed: verification-needed-precise
Jeff Lane (bladernr) wrote :

John, if you revert back to the current Precise kernel, is the issue easier to reproduce (at least indicating that SOMETHING in the proposed kernel is mitigating the problem).

Just curious. I'm trying to get one of my teammates to verify this on our 2120, but he and it are in Taiwan, so it may be a while before he can get back to me with any sort of result.

Chris Van Hoof (vanhoof) on 2012-08-24
Changed in linux (Ubuntu Precise):
status: Triaged → Fix Committed
Tim Chen (ctf) wrote :

This bug is fixed with kernel 3.2.0-30.48(in propose) on Precise.

Launchpad Janitor (janitor) wrote :
Download full text (13.6 KiB)

This bug was fixed in the package linux - 3.2.0-30.48

---------------
linux (3.2.0-30.48) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1041217

  [ Upstream Kernel Changes ]

  * mutex: Place lock in contended state after fastpath_lock failure
    - LP: #1041114

linux (3.2.0-30.47) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1036581

  [ Andy Whitcroft ]

  * add support for generating binary device trees and install them in
    /lib/firmware
    - LP: #1030600
  * [Config] add dtb_file configuration for highbank
    - LP: #1030600

  [ Chris Van Hoof ]

  * SAUCE: dell-laptop: additional rfkill blacklist Dell XPS 13
    - LP: #1030957
  * [Config] Add cifs support to the nfs-modules list
    - LP: #1031398

  [ Daniel P. Berrange ]

  * SAUCE: (drop after 3.6) Forbid invocation of kexec_load() outside
    initial PID namespace
    - LP: #1034125

  [ Dann Frazier ]

  * [Config] Compile the rtc-pl031 driver builtin on the highbank kernel
    flavour
    - LP: #1035110

  [ Douglas Bagnall ]

  * SAUCE: Unlock the rc_dev lock when the raw device is missing
    - LP: #1015836

  [ Rob Herring ]

  * SAUCE: ARM: highbank: add soft power and reset key event handling
    - LP: #1033853
  * SAUCE: ARM: highbank: use writel_relaxed variant for pwr requests
    - LP: #1033853
  * SAUCE: ahci: un-staticize ahci_dev_classify
    - LP: #1033853
  * SAUCE: ahci_platform: add custom hard reset for Calxeda ahci ctrlr
    - LP: #1033853

  [ Stefan Bader ]

  * (pre-stable) KVM: VMX: Set CPU_BASED_RDPMC_EXITING for nested
    - LP: #1031090

  [ Tim Gardner ]

  * [Config] updateconfigs

  [ Upstream Kernel Changes ]

  * ideapad: generate valid key event only
    - LP: #1029834
  * mm: reduce the amount of work done when updating min_free_kbytes
    - LP: #1032640
  * mm: compaction: allow compaction to isolate dirty pages
    - LP: #1032640
  * mm: compaction: determine if dirty pages can be migrated without
    blocking within ->migratepage
    - LP: #1032640
  * mm: page allocator: do not call direct reclaim for THP allocations
    while compaction is deferred
    - LP: #1032640
  * mm: compaction: make isolate_lru_page() filter-aware again
    - LP: #1032640
  * mm: compaction: introduce sync-light migration for use by compaction
    - LP: #1032640
  * mm: vmscan: when reclaiming for compaction, ensure there are sufficient
    free pages available
    - LP: #1032640
  * mm: vmscan: do not OOM if aborting reclaim to start compaction
    - LP: #1032640
  * mm: vmscan: check if reclaim should really abort even if
    compaction_ready() is true for one zone
    - LP: #1032640
  * vmscan: promote shared file mapped pages
    - LP: #1032640
  * vmscan: activate executable pages after first usage
    - LP: #1032640
  * mm/vmscan.c: consider swap space when deciding whether to continue
    reclaim
    - LP: #1032640
  * mm: test PageSwapBacked in lumpy reclaim
    - LP: #1032640
  * mm: vmscan: convert global reclaim to per-memcg LRU lists
    - LP: #1032640
  * cpuset: mm: reduce large amounts of memory barrier related damage v3
    - LP: #1032640
  * mm/hugetlb: fix warni...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions