Quantal Desktop AMD64+Mac on MacMini: BUG: unable to handle kernel NULL pointer dereference at 00000000000000a0

Bug #1008905 reported by Jean-Baptiste Lallement on 2012-06-05
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Seth Forshee
Quantal
High
Seth Forshee

Bug Description

Quantal Deskop amd64+mac on Mac Mini 20120604.2

During installation when Ubiquity is detecting hardware

Trace from dmesg
"""
[ 1123.091114] BUG: unable to handle kernel NULL pointer dereference at 00000000000000a0
[ 1123.091214] IP: [<ffffffff8106c4e5>] drain_workqueue+0x25/0x1e0
[ 1123.091290] PGD 574a067 PUD 149fe067 PMD 0
[ 1123.091343] Oops: 0000 [#1] SMP
[ 1123.091385] CPU 0
[ 1123.091407] Modules linked in: ufs qnx4 hfsplus hfs minix ntfs msdos xfs reiserfs jfs btrfs zlib_deflate libcrc32c vfat fat ext2 usbmouse pcspkr iTCO_wdt iTCO_vendor_support dm_crypt snd_hda_codec_hdmi snd_hda_codec_cirrus snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_seq_midi snd_rawmidi b43(-) snd_seq_midi_event snd_seq mac80211 snd_timer snd_seq_device cfg80211 snd coretemp ghash_clmulni_intel btusb aesni_intel ssb applesmc apple_gmux mei(C) rfcomm cryptd shpchp soundcore bnep parport_pc aes_x86_64 bcma snd_page_alloc bluetooth joydev input_polldev ppdev microcode mac_hid lp dm_multipath parport squashfs overlayfs nls_utf8 isofs dm_mirror dm_region_hash dm_log hid_apple sdhci_pci sdhci firewire_ohci firewire_core crc_itu_t tg3 i915 drm_kms_helper usbhid hid drm i2c_algo_bit video usb_storage
[ 1123.092432]
[ 1123.092467] Pid: 20380, comm: modprobe Tainted: G C 3.4.0-3-generic #8-Ubuntu Apple Inc. Macmini5,1/Mac-8ED6AF5B48C039E1
[ 1123.092674] RIP: 0010:[<ffffffff8106c4e5>] [<ffffffff8106c4e5>] drain_workqueue+0x25/0x1e0
[ 1123.092832] RSP: 0018:ffff8800057c1d48 EFLAGS: 00010246
[ 1123.092893] RAX: 00000000005d005d RBX: 0000000000000000 RCX: 000000000000005d
[ 1123.092968] RDX: 000000000000005d RSI: 0000000000000282 RDI: ffffffff81e4a800
[ 1123.093042] RBP: ffff8800057c1d88 R08: ffffffff81cd8480 R09: 0000000000000100
[ 1123.093116] R10: 0000000071394d01 R11: ffffffff811e95bf R12: 0000000000000000
[ 1123.093189] R13: ffff880079a0e070 R14: 0000000000000000 R15: 0000000000000000
[ 1123.093264] FS: 00007f2390ea2700(0000) GS:ffff880100200000(0000) knlGS:0000000000000000
[ 1123.093348] CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b
[ 1123.093407] CR2: 00000000000000a0 CR3: 000000006d979000 CR4: 00000000000407f0
[ 1123.093481] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[ 1123.093556] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[ 1123.093631] Process modprobe (pid: 20380, threadinfo ffff8800057c0000, task ffff88006e00c4d0)
[ 1123.093717] Stack:
[ 1123.093739] ffff8800057c1d68 ffff8800057c1d68 0000000000000282 ffff88006ea3c580
[ 1123.093825] 0000000000000000 ffff880079a0e070 0000000000000000 0000000000000000
[ 1123.093909] ffff8800057c1db8 ffffffff8106c6b8 ffff88006ea3c580 ffff8800799ef800
[ 1123.093993] Call Trace:
[ 1123.094028] [<ffffffff8106c6b8>] destroy_workqueue+0x18/0x190
[ 1123.094114] [<ffffffffa032d1c9>] ieee80211_unregister_hw+0xe9/0x120 [mac80211]
[ 1123.094202] [<ffffffffa03aeed2>] b43_bcma_remove+0x42/0x70 [b43]
[ 1123.094275] [<ffffffffa01c9132>] bcma_device_remove+0x22/0x30 [bcma]
[ 1123.094348] [<ffffffff81402c7c>] __device_release_driver+0x7c/0xe0
[ 1123.094419] [<ffffffff81403348>] driver_detach+0xc8/0xd0
[ 1123.094482] [<ffffffff814027f1>] bus_remove_driver+0x81/0xe0
[ 1123.094547] [<ffffffff81403832>] driver_unregister+0x62/0xa0
[ 1123.094615] [<ffffffffa01c9252>] bcma_driver_unregister+0x12/0x20 [bcma]
[ 1123.094699] [<ffffffffa03d7834>] b43_exit+0x1c/0x28 [b43]
[ 1123.094761] [<ffffffff810afb32>] sys_delete_module+0x152/0x280
[ 1123.094827] [<ffffffff81145529>] ? vm_munmap+0x59/0x70
[ 1123.094886] [<ffffffff81682029>] system_call_fastpath+0x16/0x1b
[ 1123.094948] Code: 84 00 00 00 00 00 55 48 89 e5 41 57 41 56 41 55 41 54 53 48 83 ec 18 66 66 66 66 90 48 89 fb 48 c7 c7 00 a8 e4 81 e8 0b d9 60 00 <8b> 83 a0 00 00 00 8d 50 01 85 c0 89 93 a0 00 00 00 75 03 83 0b
[ 1123.095286] RIP [<ffffffff8106c4e5>] drain_workqueue+0x25/0x1e0
[ 1123.095355] RSP <ffff8800057c1d48>
[ 1123.095392] CR2: 00000000000000a0
[ 1123.175060] ---[ end trace 6c0311b53bafffe7 ]---

"""

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.4.0-3-generic 3.4.0-3.8
ProcVersionSignature: Ubuntu 3.4.0-3.8-generic 3.4.0
Uname: Linux 3.4.0-3-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
ApportVersion: 2.1.1-0ubuntu2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 3419 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0x90900000 irq 47'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10134206,106b2100,00100302 HDA:80862805,80860101,00100000'
   Controls : 38
   Simple ctrls : 11
CasperVersion: 1.317
Date: Tue Jun 5 11:04:13 2012
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64+mac (20120604.3)
MachineType: Apple Inc. Macmini5,1
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
RelatedPackageVersions:
 linux-restricted-modules-3.4.0-3-generic N/A
 linux-backports-modules-3.4.0-3-generic N/A
 linux-firmware 1.80
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/20/2011
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MM51.88Z.0077.B0F.1110201309
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-8ED6AF5B48C039E1
dmi.board.vendor: Apple Inc.
dmi.board.version: Macmini5,1
dmi.chassis.type: 16
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-8ED6AF5B48C039E1
dmi.modalias: dmi:bvnAppleInc.:bvrMM51.88Z.0077.B0F.1110201309:bd10/20/2011:svnAppleInc.:pnMacmini5,1:pvr1.0:rvnAppleInc.:rnMac-8ED6AF5B48C039E1:rvrMacmini5,1:cvnAppleInc.:ct16:cvrMac-8ED6AF5B48C039E1:
dmi.product.name: Macmini5,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Jean-Baptiste Lallement (jibel) wrote :
summary: - Quantal Desktop QMD65+Mac on MacMini: BUG: unable to handle kernel NULL
+ Quantal Desktop AMD64+Mac on MacMini: BUG: unable to handle kernel NULL
pointer dereference at 00000000000000a0
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1008905

tags: added: iso-testing
Brad Figg (brad-figg) on 2012-06-05
Changed in linux (Ubuntu):
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Reproduced on successive tries.

Changed in linux (Ubuntu Quantal):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Changed in linux (Ubuntu Quantal):
importance: Undecided → High
Joseph Salisbury (jsalisbury) wrote :

Hi Jean-Baptiste,

Do you know if this bug also happens when installing prior releases?

tags: added: kernel-da-key kernel-key
tags: added: drain-workqueue
tags: added: regression-release
Jean-Baptiste Lallement (jibel) wrote :

I installed Precise Final on the same HW, I didn't try dailies.

Seth Forshee (sforshee) wrote :

I've reproduced this bug on a Mac Mini, and I'm currently building with a patch sent to the b43-dev list which purports to fix the issue.

I suspect the following commit introduced the issue, which would make 3.4-rc1 the first version to have this bug. The commit moves requesting firmware to a workqueue. Previously failure to find the firmware would cause probe to fail. Now it's done after probe, but the device isn't registered with ieee80211 unless the firmware is successfully loaded. b43's remove callback doesn't take this into account and calls ieee80211_unregister_hw() even though the device was never registered.

commit 6b6fa5868eec26bdc6a83543cebb8cf832a2645a
Author: Larry Finger <email address hidden>
Date: Thu Mar 8 22:27:46 2012 -0600

    b43: Load firmware from a work queue and not from the probe routine

    Recent changes in udev are causing problems for drivers that load firmware
    from the probe routine. As b43 has such a structure, it must be changed.
    As this driver loads more than 1 firmware file, changing to the asynchronous routine
    request_firmware_nowait() would be complicated. In this implementation, the probe
    routine starts a queue that calls the firmware loading routines.

Seth Forshee (sforshee) wrote :

The problem is fixed for me by the patch linked to below. Unfortunately upstream's taken no action on it as of yet, so I'll respond to see if I can get things moving.

http://lists.infradead.org/pipermail/b43-dev/2012-June/002517.html

Changed in linux (Ubuntu Quantal):
assignee: Canonical Kernel Team (canonical-kernel-team) → Seth Forshee (sforshee)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.4.0-5.11

---------------
linux (3.4.0-5.11) quantal-proposed; urgency=low

  [ Leann Ogasawara ]

  * [Config] Disable CONFIG_ARM_LPAE
    - LP: #1009061

  [ Oleksij Rempel ]

  * SAUCE: b43: do not call ieee80211_unregister_hw if we are not registred
    - LP: #1008905

  [ Paolo Pisati ]

  * [Config] omap3: MFD_OMAP_USB_HOST is usb host in omap2+.
    - LP: #1009061
 -- Leann Ogasawara <email address hidden> Tue, 05 Jun 2012 08:06:28 -0700

Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Released
Walter Waelten (gh-walter) wrote :

Ubuntu Quantal crashes the same way, when I use/connect my Apple Wireless keyboard with my non-Apple Computer.
If you neen more details, let me know ....
Walter

Seth Forshee (sforshee) wrote :

Walter: This bug has been fixed, so your problem is different. Please file a new bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers