Suspend fails on Asus 1215B

Bug #1006918 reported by dreamerchant on 2012-05-31
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Suspend fails on Asus 1215B
ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-24-generic 3.2.0-24.39
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: fglrx wl
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: SB [HDA ATI SB], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: dreamerchant 2038 F.... pulseaudio
 /dev/snd/controlC0: dreamerchant 2038 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'Generic'/'HD-Audio Generic at 0xfeb44000 irq 43'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 6
   Simple ctrls : 1
Card0.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card1.Amixer.info:
 Card hw:1 'SB'/'HDA ATI SB at 0xfeb40000 irq 16'
   Mixer name : 'Realtek ALC269VB'
   Components : 'HDA:10ec0269,1043841c,00100100'
   Controls : 17
   Simple ctrls : 10
Date: Thu May 31 17:41:17 2012
HibernationDevice: RESUME=UUID=b32be894-a271-4bad-9a9b-acc43dc99068
InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120423)
MachineType: ASUSTeK Computer INC. 1215B
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=c4983df2-c8f4-4558-867e-6b3eb200f65d ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-24-generic N/A
 linux-backports-modules-3.2.0-24-generic N/A
 linux-firmware 1.79
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/30/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0503
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: 1215B
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0503:bd11/30/2011:svnASUSTeKComputerINC.:pn1215B:pvrx.x:rvnASUSTeKComputerINC.:rn1215B:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1215B
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.

dreamerchant (dreamerchant) wrote :
Brad Figg (brad-figg) on 2012-05-31
Changed in linux (Ubuntu):
status: New → Confirmed
summary: - Bug #856711
+ Suspend fails on Asus 1215B
description: updated

dreamerchant, thank you for reporting this and helping make Ubuntu better. Could you please provide the information following https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume ?
As well, please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/daily/current/ . If the issue remains, please run the following command in the development release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.

Please let us know your results. Thanks in advance.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-upstream-testing resume suspend
UrkoM (urko-masse) wrote :

I have the same problem: suspend doesn't work. When I try to suspend on my Asus 1215B, the only way to get it back is removing battery and AC power. As the original bug report, I am using the AMD/ATI fglrx proprietary driver.

I tried mainline kernel 3.3.7, but I can't use it with the ATI fglrx proprietary driver.

===== Using uswsusp =============
As somewhat of a workaround, using uswsusp works somewhat better: suspend works fairly reliably, by adding these lines to /etc/pm/config.d/modules:

SLEEP_MODULE="uswsusp"
S2RAM_OPTS="-f -a 2"
SUSPEND_MODULES="rfkill xhci_hcd button bluetooth"

However, as soon as you suspend at least once, the laptop will not be able to reboot.
On the next boot process, after the BIOS splash screen, only a black screen with a cursor. After some time, an error message that no boot media is available.
Removing battery and AC power solves the issue.

It seems uswsusp leaves the SATA controller or something related in an unreliable state. If we can find a fix for this, uswsusp provides a viable workaround.

================================

UrkoM (urko-masse) wrote :

I removed fglrx driver, using radeon, and kernel 3.3.7, same problem:
Suspend seems to work.
But next reboot fails, hard disk not found or not working.

(And with kernel 3.3.7, I don't have wireless or sound...)

UrkoM (urko-masse) wrote :

Sorry, my mistake: using the radeon driver and kernel 3.3.7, things are a bit better, it behaves just like uswsusp with ATI proprietary drivers.

UrkoM, please file a new report by executing the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug linux

Thanks!

Changed in linux (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
costavi (costavi) wrote :

I found this bug report and I see that it is expired. Does that mean that there's no hope that the bug will be fixed?

I have this bug in my Asus 1215b with amd c-60 APU. I currently run kubuntu 12.04.1 and run kernel 3.2.0-32.
I tried most of the tips and recipes found all over the internet and none of them worked.

When I try to suspend my pc I randomly have success or not in waking it up again. In 50-60% percent of the times it does not wake up and when it works, it does not work at the second attempt most of the times.
To recover the computer I need to remove the power cord and the battery, and put them back in place, otherwise the laptop does not boot anymore.

Changing options in the BIOS or changing from Radeon driver to fglrx doesn't make any difference.

I tried also to install kernel version 3.5.7 from http://kernel.ubuntu.com/~kernel-ppa/
and the bug is still there.

I hope the bug will be reopened for discussion, because It is VERY annoying for an ultra-portable like the 12'' asus 1215b. Besides it is not old or obsolete hardware, it is quite new.

Thank for any help or suggestion

Changed in linux (Ubuntu):
status: Expired → Confirmed

costavi, if you have a bug in Ubuntu, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Kernel team article:
https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports

the Ubuntu Bug Control and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report may delay your problem being addressed as quickly as possible.

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers