Tribe 4 - no ICH8 Mobile PATA Controller support for pciid 0x8086 0x2850

Bug #127163 reported by Persio on 2007-07-20
68
Affects Status Importance Assigned to Milestone
linux-source-2.6.22 (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: linux-source-2.6.22

I installed Gutsy tribe-2 in this notebook Lenovo 3000 V200 using the Alternate CD. After the installation I noted that the CDROM wasn't working. the fstab file shows that it should be at /dev/hda, but there is no such device. This bug persisted even after upgrade to kernel 2.6.22-8.
After some googling I found out that it is an old problem related to the sata hard disk (which is working).
I also found that I can access the CDROM with "sudo modprobe ide-generic", but then I have no DMA to the drive.

Persio

Chuck Short (zulcss) wrote :

Please attach the output of lspci -nvv as an attachment.

Thanks
chuck

Changed in linux-source-2.6.22:
status: New → Incomplete
Persio (persiobarros) wrote :

Here is the output of "lspci -nvv"

Persio (persiobarros) wrote :

Hi,
I found out that a bug that may be related to this one is being discussed at the kernel bugzilla:
http://bugzilla.kernel.org/show_bug.cgi?id=8784

Persio (persiobarros) wrote :

The problem was solved by the kernel.org team. The problem was the new santa rosa Intel chipset that was not recognised by the ata_pxii module. See: http://bugzilla.kernel.org/show_bug.cgi?id=8835
Now is up to the Ubuntu maintainers to apply the patch to the kernel source.
Thanks
Persio

Chuck Short (zulcss) wrote :

I have this in my git tree now.

Changed in linux-source-2.6.22:
status: Incomplete → Fix Committed

I am seeing this bug too on a HP Compaq 6710b - waiting for the next kernel package upload to test the fix.

Lothar (lothar-tradescape) wrote :

I have a SATA disk in the Ultrabay of my Lenovo ThinkPad T61 and whatever I try it does never show up as
SATA. It is not even discovered as ATA unless I load the ide_generic module
by hand, but then it does not do DMA and is slow.

There's a lengthy description of the problem from Theodore Tso at http://mailman.linux-thinkpad.org/pipermail/linux-thinkpad/2007-July/039701.html

Does this fix make it show up as SATA?

When will there be an updated Kernel from Ubuntu available?

P.S.
I use (K)Ubuntu Gutsy Tribe 4

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → High
Graham Whelan (gawhelan) wrote :

I have a Zepto Znote 6625WD which uses the same mobile IDE controller and am experiencing the same problem, my dvd drive is not being recognized. Unlike some of the other users above doing a "sudo modprobe ide-generic" doesn't seem to help.

Matthew Haughton (snafu109) wrote :

New kernel (2.6.22-10-generic) fixed it for me on a Dell Inspiron 1420. Optical drive is detected and just played a DVD without issue.

Graham Whelan (gawhelan) wrote :

The fix in the new 2.6.22-10-generic kernel hasn't worked for me. DVD drive is still not recognized on my Zepto Znote 6625WD.

Graham Whelan (gawhelan) wrote :

Standard info

output of "uname -a":
Linux graham-laptop 2.6.22-10-generic #1 SMP Wed Aug 22 08:11:52 GMT 2007 i686 GNU/Linux

output of "cat /proc/version":
Linux version 2.6.22-10-generic (buildd@palmer) (gcc version 4.1.3 20070812 (prerelease) (Ubuntu 4.1.2-15ubuntu2)) #1 SMP Wed Aug 22 08:11:52 GMT 2007

output of "cat /proc/version_signature":
Ubuntu 2.6.22-10.30-generic

Tim Gardner (timg-tpi) on 2007-08-23
Changed in linux-source-2.6.22:
status: Fix Committed → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.