Update toshiba_acpi.c to version 0.19a

Bug #77026 reported by Emil Soleyman on 2006-12-24
38
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Colin Ian King
linux-source-2.6.20 (Ubuntu)
Medium
Ben Collins
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: linux-image-2.6.20-2-generic

The current kernel image contains the 0.18 version of the toshiba_acpi.c file. This version does not respect the hotkeys_over_acpi parameter and as a result hotkey support is broken on Toshiba laptops. The Ubuntu Edgy kernel (2.6.17.10) has the 0.19a version of the file as part of the kernel source. I kindly request that the 0.19a version be included in the next update of the Feisty kernel. I am providing the necessary details from modprobe and dmesg below:

MODPROBE ERROR

emil@shamash:~$ sudo modprobe toshiba_acpi
Password:
FATAL: Error inserting toshiba_acpi (/lib/modules/2.6.20-2-generic/kernel/drivers/acpi/toshiba_acpi.ko): Unknown symbol in module, or unknown parameter (see dmesg)

DMESG

[72107.448000] toshiba_acpi: Unknown parameter 'hotkeys_over_acpi'

Changed in linux-source-2.6.20:
status: Unconfirmed → Fix Committed
Changed in linux-source-2.6.20:
status: Fix Committed → Fix Released
Justin Dugger (jldugger) wrote :

This has been set to fix released, but with today's kernel update it still appears to be broken.

jldugger@jldugger-tablet:~$ uname -a
Linux jldugger-tablet 2.6.20-4-generic #2 SMP Fri Jan 5 04:31:55 UTC 2007 i686 GNU/Linux

jldugger@jldugger-tablet:~$ sudo modprobe toshiba_acpi
FATAL: Error inserting toshiba_acpi (/lib/modules/2.6.20-4-generic/kernel/drivers/acpi/toshiba_acpi.ko): Unknown symbol in module, or unknown parameter (see dmesg)

Is there another version still in the release queue somewhere for this?

Emil Soleyman (emilsoleyman) wrote :

Ben, can you re-open this bug as it still affected kernel upto and including 2.6.20-5.7?

emil@shamash:~$ uname -a
Linux shamash 2.6.20-5-generic #2 SMP Sat Jan 6 14:50:47 UTC 2007 i686 GNU/Linux

emil@shamash:~$ sudo modprobe toshiba_acpi
FATAL: Error inserting toshiba_acpi (/lib/modules/2.6.20-5-generic/kernel/drivers/acpi/toshiba_acpi.ko): Unknown symbol in module, or unknown parameter (see dmesg)

Emil Soleyman (emilsoleyman) wrote :

Ben,

I made a patch diffing the toshiba_acpi.c files from the linux-source-2.6.17 and linux-source-2.6.20 packages. The linux-source-2.6.17 package contains a more up-to-date toshiba_acpi.c file which specifically includes support for hotkeys_over_acpi.

Thanks for your help with this issue.

Justin Dugger (jldugger) wrote :

On Hobbsee's recommendation, I've changed this back to Unconfirmed, in hopes someone might see it again.

Changed in linux-source-2.6.20:
status: Fix Released → Unconfirmed
Emil Soleyman (emilsoleyman) wrote :

Justin, thanks for changing the status to unconfirmed as I was unable to find the option or process to do this. I hope Ben sees this bug again and applies the patch. :)

Ante Karamatić (ivoks) wrote :

I would say that 2.6.20 has newer toshiba_acpi (http://memebeam.org/free-software/toshiba_acpi/).

This patch would result in downgrading driver. It would work, but it would be older driver.

Ante Karamatić (ivoks) wrote :

(I could be wrong :)

Emil Soleyman (emilsoleyman) wrote :

Ante,

The 2.6.20 kernel source does not have the most up-to-date toshiba_acpi.c file because it is missing support for the hotkeys_over_acpi parameter.

Vincenzo Ciancia (vincenzo-ml) wrote :

If I inset the toshiba_acpi module without the hotkeys_over_acpi parameter, I can press the key to lower screen brightness, but the process blocks right after dimming the display. The same happens to /etc/acpi/toshbright.sh, it blocks but it correctly sets the brightness, then I can kill it. Do I have to wait to report these bugs or are them unrelated in your opinion?

Vincenzo Ciancia (vincenzo-ml) wrote :

I meant: do I have to wait for this bug to settle, or should I report other bugs related to brightness and ACPI in general?

Hi,
I have a Toshiba Portégé R200 notebook and I can confirm the bugs explained above. The module won't insert with the hotkeys options. I too can change the brightness just by echoing it in the lcd file and the screen will dim but the process will hang there, the console is not freed upon execution. These problems could be related.

If you need some testing you can find me on IRC, often.

Emil Soleyman (emilsoleyman) wrote :

I have taken some time last night to create a newer patch against the linux-source-2.6.20-6-generic tree using the bits and pieces from the toshiba_acpi.c driver found in linux-source-2.6.17 tree. This new patch is a combination of the backlight feature and the hotkeys functionality.

I am uploading the patch and the toshiba_acpi.ko module built against the 2.6.20-6-generic tree. Please let me know if any of them are useful to you.

Emil Soleyman (emilsoleyman) wrote :

Please test this module using the following command: "insmod toshiba_acpi.ko"

Vincenzo Ciancia (vincenzo-ml) wrote :

Hotkeys are working now to set brightness and all the rest, even if I commented "options toshiba_acpi hotkeys_over_acpi=1" in /etc/modprobe.d. I have troubles with gnome-power-manager: if I move the slider to set the brightness when on battery, screen "flashes", it is clear that the correct brightness is set and then immediately restored to the maximum value. The same happens when plugging out the AC adaptor. This might be unrelated to toshiba_acpi of course.

Hi Emil,

it seems obvious you are the saviour of the Toshiba laptop and notebook owners. Your module works. Here are is the output of dmesg while modprobing the module first and afterwards removing it and then insmoding the module:
[ 371.520000] toshiba_acpi: Toshiba Laptop ACPI Extras version 0.19a-dev
[ 371.520000] toshiba_acpi: HCI method: \_SB_.VALZ.GHCI
[ 371.524000] toshiba_acpi: Toshiba hotkeys are sent as ACPI events
[ 371.524000] toshiba_acpi: ktoshkeyd will check 2 times per second
[ 371.544000] toshiba_acpi: Dropped 0 keys from the queue on startup
[ 888.540000] toshiba_acpi: Toshiba Laptop ACPI Extras version 0.19a-dev
[ 888.540000] toshiba_acpi: HCI method: \_SB_.VALZ.GHCI
[ 888.552000] toshiba_acpi: Toshiba hotkeys are sent as ACPI events
[ 888.552000] toshiba_acpi: ktoshkeyd will check 2 times per second
[ 888.616000] toshiba_acpi: Dropped 11 keys from the queue on startup
My concerns are about the Dropped keys. What are these? The brightness keys function correctly in both ways of loading the module. The other keys do not function at all, like muting the sound or hibernate and standby. Where should these be configured?

Thank you for this module as it is very important to adjust the brightness of the screen.

Emil Soleyman (emilsoleyman) wrote :

Maximilian1st,

The hotkeys for muting, hibernating, and display brightness adjustment work fine for me as I have a Toshiba Satellite M35-S456. The hotkey for suspend does not work at the current moment and I will be looking at it shortly.

Emil Soleyman (emilsoleyman) wrote :

Maximilian1st,

Please open gconf-editor and go to apps -> gnome-power-manager. Look for the keys marked action_button_* where * means hibernate, power, suspend and make sure the value is setting to something other than 'nothing'.

Let me know if that helps as it helped me getting the suspend working on my laptop.

Changed in linux-source-2.6.20:
assignee: nobody → ben-collins
importance: Undecided → Medium
status: Unconfirmed → Fix Committed
Vincenzo Ciancia (vincenzo-ml) wrote :

Shall I report other problems I mentioned in interaction with gnome-power-manager as a separate bug? This is a regression w.r.t. edgy.

Justin Dugger (jldugger) wrote :

Tested on 2.6.20-8-generic:
[ 18.988000] toshiba_acpi: Toshiba Laptop ACPI Extras version 0.19a-dev
[ 18.988000] toshiba_acpi: HCI method: \_SB_.VALZ.GHCI
[ 18.988000] toshiba_acpi: Toshiba hotkeys are sent as ACPI events
[ 18.988000] toshiba_acpi: ktoshkeyd will check 2 times per second
[ 18.988000] toshiba_acpi: Dropped 0 keys from the queue on startup
Hotkeys and changing brightness on AC status work fine now. Thanks!

U Sri, 14. 02. 2007., u 18:08 +0000, Justin Dugger je napisao/la:

> Hotkeys and changing brightness on AC status work fine now. Thanks!

Really? It works like crap for me. Whole screen goes in sleep when i try
changing brightness :/ It worked fine in -27, but in -28 is unusable.

tehdon (rabbit-cluster) wrote :

Toshiba Tecra M1 w/1.4ghz 1gb ram confirmed fix with above kernel module, at least for screen brightness change.

Changed in linux-source-2.6.20:
status: Fix Committed → Fix Released
Ante Karamatić (ivoks) wrote :

Reopening this bug for Gutsy.

Changed in linux-source-2.6.22:
importance: Undecided → Medium
Justin Dugger (jldugger) wrote :

What are the exact symptoms you're seeing in Gutsy? At least for yesterday, my LCD brightness and Fn-keys worked fine, even though there's a warning in dmesg about tosh_hotkeys not found.

You should probably provide kernel version as well as symptoms.

Ante Karamatić (ivoks) wrote :

Justin Dugger wrote:

> You should probably provide kernel version as well as symptoms.

toshiba_acpi is unloadable cause of the option provided in
modprobe.d/toshiba_acpi.modprobe. Commenting that out, module loads, but
toshset doesn't work.

Working:
Fn+ESC/F3/F4/F5 - mute,STR,STD

Partially working:
Fn+F6/F7 - brightness; when i add or reduce brightness, my whole screen
goes off (really off, like vbetool dpms off) - this was 'fixed' with
unloading 'video' module, but that solution doesn't work anymore

Not working:
Fn+F2/F8 - battery info and bluetooth/wifi switch (i'm now unable to
turn on bluetooth) - this is cause toshet doesn't work (required kernel
toshiba support not enabled.)

All worked in Feisty (with addition of unloading video module for
brightness).

Kernel is, as bug report says, 2.6.22-8-generic, and toshiba model is
Satellite Pro U200.

Ante Karamatić (ivoks) wrote :

New kernel, linux-image-2.6.22-9 closes this issue in Gutsy:

  * update toshiba_acpi to 0.19a-dev

Changed in linux-source-2.6.22:
status: New → Fix Released
Ante Karamatić (ivoks) wrote :

Re-opening this bug for hardy. Loading toshiba_acpi produces:

toshiba_acpi: Unknown parameter `hotkeys_over_acpi'
Toshiba System Managment Mode driver v1.11 26/9/2001

toshset utility and hotkey don't work.

Vincenzo Ciancia (vincenzo-ml) wrote :

I can surely confirm the regression.

Changed in linux-source-2.6.24:
status: New → Confirmed
eSe (snaker) wrote :

I can confirm the regression in hardy :(

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in linux:
assignee: ubuntu-kernel-team → colin-king
status: Triaged → In Progress
Changed in linux:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.24-12.21

---------------
linux (2.6.24-12.21) hardy; urgency=low

  [Ben Collins]

  * build: Fix vesafb module inclusion into initrd subdir
    - LP: #129910
  * net/bluetooth: POWERBOOK => APPLE, fix for apple keyboard patch
  * custom/xen: Remove asix portion of xen patch, breaks driver
    - LP: #199296

  [Colin Ian King]

  * SAUCE: fix Udma not fully available in Acer 1694 Wlmi
    - LP: #187121
  * SAUCE: Update toshiba_acpi.c to version 0.19a
    - LP: #77026

  [Stefan Bader]

  * x86: Clear DF before calling signal handler
  * Enable FN key on Apple aluminum bluetooth keyboard
    - LP: #162083

 -- Ben Collins <email address hidden> Tue, 11 Mar 2008 13:20:49 -0400

Changed in linux:
status: Fix Committed → Fix Released
Philippe LUC (philfifi) wrote :

The new update fix the issue on my toshiba u200-163. FN keys are now working as expected. Thanks.

Fix the issue for my computer too.

Ante Karamatić (ivoks) wrote :

On Sat, 15 Mar 2008 08:44:25 -0000
Stéphane Démurget <email address hidden> wrote:

> Fix the issue for my computer too.

Hm... I now have some of the keys working, but not all. Fn+F4 doesn't
hibernate machine and Fn+F8 only powers off or on wireless card (in
<=gutsy it could start wifi, bluetooth+wifi or none
- /etc/acpi/tosh-wireless.sh).

But since I have exactly the same model as Philippe, and since that
driver version is known to work, it could be something wrong with my
computer/setup.

Philippe LUC (philfifi) wrote :

Ante Karamatić a écrit :
> But since I have exactly the same model as Philippe, and since that
> driver version is known to work, it could be something wrong with my
> computer/setup.
>
Being more precise:
I installed Alpha6 and completly upgraded it. After this:
- All FN buttons are seen by acpid (events written in /var/log/acpid)
- FN3 and 4 (suspend to ram and hybernate) work as expected (which was
not completely the case for feisty ;-) )
- FN"wireless" does not seems to act on bluetooth/wifi. I think is comes
from the script executed. But this is not related to the current bug.
-FN"mute" ticks the "mute" box in sound properties, but does not switch
sound off. (but a known issue with this laptop)

Ante Karamatić (ivoks) wrote :

Philippe, could you add output of:

sudo lshw | grep -i satellite

Thanks.

Philippe LUC (philfifi) wrote :

Hi,
lshw gives:
    description: Notebook
    product: SATELLITE U200
    vendor: TOSHIBA
    version: PLUA0E-01801GFR
    serial: 66864922G

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers