libata fail to initialize LITE-ON LTR-40125S

Bug #103410 reported by Xarafaxz on 2007-04-05
64
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned

Bug Description

After i upgraded kernel from 2.6.20-13 to ..-14 libata setup (initrd stage) takes very long time.
On display i've get:
ata 2.01 failed to set xfermode err_mask = 0x4
ata 2.01 failed to set xfermode err_mask = 0x4
...
When system is booted disks are under /dev/sda not /dev/hda

I've got nforce2 chipset based mainboard.

Xarafaxz (xarafaxz) wrote :

Here is a dmesg.

Xarafaxz (xarafaxz) on 2007-04-05
description: updated
Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux-source-2.6.20.

Christoph Reiter (lazka) wrote :

I've got the same problems.
My LITE-ON CD-RW and my Asus DVD-rom fail to initialize. (both IDE)
also a nforce2 board (Asus a7n8x)

I've marked mine as a duplicate..

Donkyhotay (donkjunk) wrote :

I also have a LITE-ON CD-RW drive (model LTR-52246S) that gives me the exact same error message on booting (ata 2.01 failed to set xfermode err_mask = 0x4).

Donkyhotay (donkjunk) wrote :

recieved exact same error after upgrading to 2.6.20 with a LITE-ON CD-RW

Changed in linux-source-2.6.20:
status: Unconfirmed → Confirmed
canter690 (sam-corbo) wrote :

looks like I am having the same problem - also have a LITE-ON LTR-54226S.

Christoph Reiter (lazka) on 2007-04-09
Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
Christoph Reiter (lazka) wrote :

another two people having that problem: http://ubuntuforums.org/showthread.php?t=405230

does anyone know how to get attention, cause I'm a little bit worried because of kernel freeze.. :(

Tim Butler (timbutler) wrote :

There's a discussion about this bug that may be of some assistance to the developers here: http://<email address hidden>/msg03088.html

yeti (utu) wrote :

I think you've probably identified my problem stated in 105353,
and maybe also for 103780, 95105, 96857 and 95407.

I have an ide lite-on cdrw that's not mounting, and probably slowing down booting by about two minutes besides.

Here's what some of my dmesg looks like (probably during the two minutes hang-up).

dmesg | less | grep ata2.01
[ 26.182996] ata2.01: ATAPI, max UDMA/33
[ 56.141638] ata2.01: qc timeout (cmd 0xef)
[ 56.141650] ata2.01: failed to set xfermode (err_mask=0x4)
[ 91.586051] ata2.01: qc timeout (cmd 0xef)
[ 91.586063] ata2.01: failed to set xfermode (err_mask=0x4)
[ 91.586071] ata2.01: limiting speed to UDMA/33:PIO3
[ 127.030464] ata2.01: qc timeout (cmd 0xef)
[ 127.030475] ata2.01: failed to set xfermode (err_mask=0x4)
[ 127.030481] ata2.01: disabled

So, is this something *I* can fix, or what?

Christoph Reiter (lazka) wrote :

there is this fix available: http://lkml.org/lkml/2007/3/4/259

imho it could be integrated since they want to send it upstream anyway (http://lkml.org/lkml/2007/3/9/157)
or backport it if it's already in..

since I'm a noob when it comes to bugtrackers - is this a reason to change the bug to "fix released" or is this only for devs?

yeti (utu) wrote :

In the context of the previous material,
*I* have no idea how to 'patch' anything.
I presume that is what kernel developers do.

I'm interested if there is a work-around for mere mortals prior to a kernel fix.

yeti (utu) wrote :

Comments on Bug 96857 may indicate that a possible solution for this problem, or part of it, is being worked by the kernel group.

Christoph Reiter (lazka) wrote :

- different error message
- started with a different kernel version
- is about a virtual cdrom device

i would call this a wild guess..

yeti (utu) wrote :

You could be right, lazka.
Maybe a bad guess, or a wild hope; we'll see.
I hope they're working on this problem.

Christoph Reiter (lazka) wrote :

2.6.20-15.25 still doesn't fix it here.

yeti (utu) wrote :

2.6.20-15.25 doesn't fix it here, either.

Also no need for kernel upgrades to over-write /boot/grub/menu.lst if the kernel descriptor is not changed. This unnecessarily spoils mult-boot menu.lst constructions. 2.6.20-15.24 and .25 are both called 2.6.20-15-generic in menu.lst.

Christoph Reiter (lazka) wrote :

everything back to normal with 2.6.20-26.
2 confirmations in IRC.

devices are now /dev/hdx again.

Changed in linux-source-2.6.20:
status: Confirmed → Fix Committed
yeti (utu) wrote :

Do you mean 2.6.20-15.26?
It's not on my Synaptic yet.
Good to hear, if true.
Ready to tune out if not.

yeti (utu) wrote :

2.6.20-15.27 doesn't fix it for me.
Still long bootup delay.
Still no /dev entry for cdrw;
my /etc/fstab expects /dev/ scd-something.
No /dev/sc* or /dev/hd*

Perhaps with my ICH5 hardware, I may have to wait for 2.6.22?
That may be what this link is about:
http://lkml.org/lkml/2007/3/9/214

This is a tough problem. It goes back to Bug 8196 for some folks.

triton (liang-ge) wrote :

I'm having the same problem with ICH4.

triton (liang-ge) wrote :

I'm able to fix the problem using vanilla kernel 2.6.20.7 with ata_piix drive disabled. The bug might be related to this discussion here:
http://<email address hidden>/msg04893.html

Raffo (raffo-uppuiu) wrote :

I'm still experiencing this bug with ubuntu 7.04 (final). I'm not able to find a solution. I'm running 2.6.20-15.27 kernel...
Please let me know how can I help you.

Raffo

Žydrunas Jackobsonas (jurgis) wrote :

Me too. Please, fix it... :(

flyingbrass (jdmckim) wrote :

Same problem here. Lite-On CD burner, ICH5 controller.

The last kernel that worked was 2.6.20-13.

nexcis (eltaito) wrote :

I seem to be having the same problem with my LITE-ON LTR-32123S CR-RW drive on Feisty. Drive has an fstab entry of scd1 but will not mount (will if I boot with a CD in the drive though). I'm running 2.6.20-15-generic.

yeti (utu) wrote :

Bug 105437 observation holds the key to my LITE-ON problems:
- solves the delay problem;
- creates /dev/scd0 and mounts scd0 as a cdrom; and
- also allows /dev/scd0 to work as a cdrw.

I'm using 2.6.20-15.27 kernel.

yeti (utu) wrote :

Perhaps the *kernel* part of this problem (here) has been solved,
and the remaining issues resides *elsewhere* in the Ubuntu source.

Two clues in this regard:

1-Similar LITE-ON problems (here) exist in PCLinuxOS with 2.6.18 kernel are also *resolved* with the Bug 105437 approach; and

2-Fedora Core 6, with 2.6.18 kernel does *not* have the LITE-ON problem (here).

The (here) qualifier means maybe my problems are related to SATA/PATA mixed drives and Intel ICH5 driver as well as LITE-ON peculiarities of my hardware setup.

yeti (utu) wrote :

Bug 96826 wins the prize for solving my LITE-ON problems,
Just add irqpoll as a kernel option.

No more need to 'beat the clock' opening the cdrw before booting,
the runner-up solution from Bug 105437.

Jonathan Baby (baby-jonathan) wrote :

The add of irqpool as kernel option in the /boot/grub/menu.lst solved the problem for me too with a LITE-ON LTR CD-RW :
- no more "failed to set xfermode" errors when booting (and thus, no more slowing)
- the LITE-ON is correctly detected bythe system (available in Gnome CD/DVD writer" tool for example)

I.Ruau (iruau) wrote :

Today's kernel update (2.6.20-16.28) solved the problem for me, now both my LITE-ON and LG CD/DVD burners are correctly recognized *without* needing to use the irqpoll workaround. Thanks everyone who worked on the fix.

yeti (utu) wrote :

Re Today's 2.6.20,
irqpoll still needed here.
My lite-on is 48125W cdrw.

Marking this as 'Fix Released'. If you are still experiencing problems, please test with the latest Hardy Alpha release (http://cdimage.ubuntu.com/releases/hardy/). You should be able to test via the LiveCD. If this issue still exists in the Hardy release, please open a new bug report against the 'linux' package. Starting with the Hardy release the ubuntu kernel source package naming convention switched from 'linux-source-2.6.x' to just 'linux'. Thanks.

Changed in linux-source-2.6.20:
status: Fix Committed → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments