APIC error on CPU0: 40(40)

Bug #66900 reported by Ralf Hildebrandt on 2006-10-19
80
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Invalid
Medium
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.17 (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image-2.6.17-10-generic

Regression from linux-image-2.6.15-26-amd64-k8:
linux-image-2.6.17-10-generic reports an insane amount of:

[181417.740928] APIC error on CPU0: 40(40)
[181419.020533] APIC error on CPU0: 40(40)
[181421.199806] APIC error on CPU0: 40(40)
[181421.239789] APIC error on CPU0: 40(40)
[181421.307765] APIC error on CPU0: 40(40)

errors.

# cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 36
model name : AMD Turion(tm) 64 Mobile Technology ML-30
stepping : 2
cpu MHz : 1600.000
cache size : 1024 KB
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow up pni lahf_lm
bogomips : 3187.20
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc

I grep dmesg and found 2849 entries in 1780 seconds:

# dmesg | head --lines=2
r on CPU0: 40(40)
[179724.813190] APIC error on CPU0: 40(40)

# dmesg | tail --lines=1
[181504.918821] APIC error on CPU0: 40(40)

# bc
181504.918821 - 179724.813190
1780.105631

# dmesg |grep "APIC error on CPU0:" | wc --lines
2849

root@knarzkiste:~# cat /proc/interrupts
           CPU0
  0: 82750810 local-APIC-edge timer
  1: 335 IO-APIC-edge i8042
  8: 0 IO-APIC-edge rtc
  9: 0 IO-APIC-edge acpi
 12: 2898 IO-APIC-edge i8042
 14: 689215 IO-APIC-edge ide0
 15: 2978334 IO-APIC-edge ide1
169: 0 IO-APIC-level eth0
177: 76 IO-APIC-level ehci_hcd:usb1, ohci_hcd:usb2, ohci_hcd:usb3, yenta
185: 0 IO-APIC-level yenta
193: 19850110 IO-APIC-level ATI IXP Modem, ATI IXP, fglrx
209: 2581926444 IO-APIC-level ohci1394
217: 10858440 IO-APIC-level ra0
NMI: 279691
LOC: 82750584
ERR: 240534
MIS: 0

root@knarzkiste:~# lspci
00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge (rev 10)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 10)
00:14.1 IDE interface: ATI Technologies Inc Standard Dual Channel PCI IDE Controller ATI
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 01)
00:14.6 Modem: ATI Technologies Inc ATI SB400 - AC'97 Modem Controller (rev 01)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc ATI Radeon XPRESS 200M 5955 (PCIE)
02:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:04.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)
02:04.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)
02:04.2 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 04)
02:09.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)

Manuel Lucena (mlucena) wrote :

Same problem for me:

cat /proc/cpuinfo

processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 39
model name : AMD Athlon(tm) 64 Processor 3700+
stepping : 1
cpu MHz : 1000.000
cache size : 1024 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow up pni lahf_lm ts fid vid ttp tm stc
bogomips : 2001.37

dmesg |grep "APIC error on CPU0:" | wc --lines

1694

Cory Prowse (cory-prowse) wrote :

I too am experiencing this on an Acer Ferrari 4005.
It occurs every few seconds, and ends up filling up dmesg completely.
I have attached an output of "sudo lspci -vv".
All of this ws captured without the broadcom (bcm43xx) module loaded.

If there is any other information I can provide, please let me know.

----------
$ cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 36
model name : AMD Turion(tm) 64 Mobile Technology ML-37
stepping : 2
cpu MHz : 800.000
cache size : 1024 KB
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow up pni lahf_lm
bogomips : 1601.71
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc

$ cat /proc/interrupts
           CPU0
  0: 3121568 local-APIC-edge timer
  1: 3078 IO-APIC-edge i8042
  7: 2 IO-APIC-edge parport0
  8: 0 IO-APIC-edge rtc
  9: 0 IO-APIC-edge acpi
 12: 380092 IO-APIC-edge i8042
 14: 42573 IO-APIC-edge ide0
 15: 111649 IO-APIC-edge ide1
169: 797341 IO-APIC-level eth0, fglrx
177: 1 IO-APIC-level yenta, tifm_7xx1
209: 1796 IO-APIC-level ATI IXP Modem, ATI IXP
225: 1 IO-APIC-level ohci_hcd:usb1, ohci_hcd:usb2, ehci_hcd:usb3
233: 978784082 IO-APIC-level ohci1394
NMI: 10265
LOC: 3121400
ERR: 7211
MIS: 0

Cory Prowse (cory-prowse) wrote :

I have attached the dmesg log captured soon after a bootup.
I am using a fixed DSDT for the Ferrari 4005 (which I fixed myself).

[NOTE: While looking over the log file it eventually filled up the dmesg buffer, but I noticed the "many lost ticks" warning at the end]

A quick analysis shows these interesting entries:

[ 19.151590] PCI: No mmconfig possible on device 0:18
..
[ 19.222130] PCI: Bus #07 (-#0a) is hidden behind transparent bridge #06 (-#07) (try 'pci=assign-busses')
[ 19.222133] Please report the result to linux-kernel to fix this permanently
..
[ 20.242636] pnp: PnP ACPI init
[ 20.243507] pnp: PnPACPI: METHOD_NAME__CRS failure for PNP0a03
[ 20.246577] pnp: PnP ACPI: found 11 devices
[ 20.246618] PCI: Using ACPI for IRQ routing
[ 20.246621] PCI: If a device doesn't work, try "pci=routeirq". If it helps, post a report
[ 20.246748] PCI-DMA: Disabling IOMMU.
..
[ 20.285270] PCI: Setting latency timer of device 0000:00:02.0 to 64
[ 20.285275] pcie_portdrv_probe->Dev[5a34:1002] has invalid IRQ. Check vendor BIOS
[ 20.285290] assign_interrupt_mode Found MSI capability
[ 20.285330] Allocate Port Service[0000:00:02.0:pcie00]
[ 20.285363] Allocate Port Service[0000:00:02.0:pcie01]
[ 20.285392] PCI: Setting latency timer of device 0000:00:06.0 to 64
[ 20.285395] pcie_portdrv_probe->Dev[5a38:1002] has invalid IRQ. Check vendor BIOS
[ 20.285410] assign_interrupt_mode Found MSI capability
[ 20.285430] Allocate Port Service[0000:00:06.0:pcie00]
[ 20.285455] Allocate Port Service[0000:00:06.0:pcie01]..
..
[ 26.887398] irq 233: nobody cared (try booting with the "irqpoll" option)
[ 26.887403]
[ 26.887404] Call Trace: <IRQ> <ffffffff802b68a5>{__report_bad_irq+53}
[ 26.887418] <ffffffff802b6b20>{note_interrupt+544} <ffffffff802b6190>{__do_IRQ+224}
[ 26.887428] <ffffffff802737e2>{do_IRQ+66} <ffffffff80265d08>{ret_from_intr+0} <EOI>
[ 26.887437] <ffffffff802089ff>{__handle_mm_fault+1391} <ffffffff8026b578>{_spin_unlock_irqrestore+8}
[ 26.887447] <ffffffff8026d989>{do_page_fault+1273} <ffffffff8026580e>{system_call+126}
[ 26.887459] <ffffffff802664a1>{error_exit+0}
[ 26.887467] handlers:
[ 26.887469] [<ffffffff8810c0c0>] (ohci_irq_handler+0x0/0x7ff [ohci1394])
[ 26.887480] Disabling IRQ #233
..
[ 39.748618] APIC error on CPU0: 00(40)
[ 39.820528] Losing some ticks... checking if CPU frequency changed.
..
[ 85.542940] ibm_acpi: ec object not found
[ 85.571130] pcc_acpi: loading...
..
[ 93.860670] ttyS0: LSR safety check engaged!
..
[ 95.185772] ttyS1: LSR safety check engaged!
..
[ 514.657380] APIC error on CPU0: 40(40)
[ 514.658974] warning: many lost ticks.
[ 514.658975] Your time source seems to be instable or some driver is hogging interupts
[ 514.658991] rip acpi_processor_idle+0x1d9/0x466 [processor]
[ 514.662171] APIC error on CPU0: 40(40)

same here for me after edgy final on my acer ferrari 4005. not sure what apic does, but maybe that's why my wireless networking, battery status, and 3D acceleration all are broken in edgy whereas they were working in dapper. makes edgy unusable at the moment. :(

Changed in linux-source-2.6.17:
status: Unconfirmed → Confirmed
Cory Prowse (cory-prowse) wrote :

I managed to reduce (but not completely solve) this by appending some kernel command line params which I've details here:
  https://launchpad.net/distros/ubuntu/+bug/69026

Cory Prowse (cory-prowse) wrote :

I've found the cause of these errors on my machine.

All I need to do is remove the ohci1394 module ie:
  sudo modprobe -r ohci1394
and the messages immediately go away.

I haven't yet found a way to disable this module on bootup (blacklisting it doesn't prevent it from loading).

So it appears to be a firewire issue?
Ben Collins works on the Linux1394 project, perhaps he knows of the cause and correct fix?

Manuel/Ralf: Does this remove your error messages as well?

* Cory Prowse <email address hidden>:
> I've found the cause of these errors on my machine.
>
> All I need to do is remove the ohci1394 module ie:
> sudo modprobe -r ohci1394
> and the messages immediately go away.

sudo rmmod ohci1394

> I haven't yet found a way to disable this module on bootup (blacklisting
> it doesn't prevent it from loading).

I guess it's explicitly loaded by dbug or discover...

> So it appears to be a firewire issue?
> Ben Collins works on the Linux1394 project, perhaps he knows of the cause and correct fix?
>
> Manuel/Ralf: Does this remove your error messages as well?

I'm trying this out as we speak. Last message I'm seeing is the module
removal message.

Removal seems to work for me.

--
Ralf Hildebrandt (i.A. des IT-Zentrums) <email address hidden>
Charite - Universitätsmedizin Berlin Tel. +49 (0)30-450 570-155
Gemeinsame Einrichtung von FU- und HU-Berlin Fax. +49 (0)30-450 570-962
IT-Zentrum Standort CBF send no mail to <email address hidden>

cgdrake (cgdrake) wrote :
Download full text (4.3 KiB)

Same problem on my Acer Ferrari 4005 since upgrading to Edgy , with a custom 2.6.18 kernel.

I've tried removing the ochi1394 as suggested by Ralf but that does not resolve the peoblem for me. I still see frequent APIC errors, although they seem to be reduced (slightly) since removing the ohci module.

lsmod output is:

Module Size Used by
binfmt_misc 9868 1
rfcomm 34608 0
hidp 13440 2
l2cap 19976 10 rfcomm,hidp
ipv6 250464 10
hci_usb 15708 2
bluetooth 45796 8 rfcomm,hidp,l2cap,hci_usb
nfsd 248936 13
exportfs 4928 1 nfsd
lockd 61648 2 nfsd
sunrpc 147656 8 nfsd,lockd
capability 4552 0
commoncap 6336 1 capability
fglrx 455540 8
driverloader 296096 0
powernow_k8 10584 0
cpufreq_userspace 3924 0
cpufreq_stats 5256 0
freq_table 4040 2 powernow_k8,cpufreq_stats
cpufreq_powersave 1984 0
cpufreq_ondemand 6064 1
cpufreq_conservative 7108 0
video 16392 0
sbs 14456 0
i2c_ec 4928 1 sbs
dock 5968 0
button 6240 0
battery 9288 0
container 3904 0
ac 4616 0
asus_acpi 16420 0
af_packet 17612 4
nls_iso8859_1 5504 1
nls_cp437 7168 1
vfat 12032 1
fat 47280 1 vfat
dm_mod 52464 0
md_mod 71452 0
sr_mod 14820 0
sbp2 22792 0
scsi_mod 135664 2 sr_mod,sbp2
lp 11080 0
joydev 9984 0
pcmcia 33624 0
snd_atiixp_modem 13516 0
snd_atiixp 17236 1
snd_seq_dummy 3460 0
snd_seq_oss 31616 0
snd_seq_midi 7680 0
snd_rawmidi 22272 1 snd_seq_midi
snd_seq_midi_event 7104 2 snd_seq_oss,snd_seq_midi
psmouse 39056 0
serio_raw 6340 0
snd_ac97_codec 103448 2 snd_atiixp_modem,snd_atiixp
snd_ac97_bus 2688 1 snd_ac97_codec
snd_pcm_oss 43392 0
snd_mixer_oss 16384 1 snd_pcm_oss
parport_pc 34088 1
parport 35468 2 lp,parport_pc
evdev 9856 2
yenta_socket 25100 1
rsrc_nonstatic 10944 1 yenta_socket
pcmcia_core 36380 3 pcmcia,yenta_socket,rsrc_nonstatic
snd_pcm 76620 4 snd_atiixp_modem,snd_atiixp,snd_ac97_codec,snd_pcm_oss
pcspkr 2944 0
shpchp 35624 0
pci_hotplug 29804 1 shpchp
i2c_piix4 8908 0
i2c_core 19032 2 i2c_ec,i2c_piix4
snd_seq 50400 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 20424 2 snd_pcm,snd_seq
snd_seq_device 7508 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq...

Read more...

The bug also occurs on
$ uname -a
Linux knarzkiste 2.6.19-7-lowlatency #2 SMP Wed Nov 29 03:36:17 UTC 2006 x86_64 GNU/Linux

in Feisty

Update BIOS?

The update bios comment is really helpful.
(note the irony here!)
How do I update the BIOS WITHOUT (!) having to install Windows?

Disregard my last comment. I created a bootcd from FreeDOS and was able to perform a BIOS upgrade. Let's see how it goes!

Ben Collins (ben-collins) wrote :

Please retest against 2.6.20-2 when it is available in the feisty archive.

Changed in linux-source-2.6.19:
status: Unconfirmed → Needs Info
Jani Kytölä (j-kytola) wrote :

with me it didn't help
same messages appears
is there any information i can provide

Changed in linux-source-2.6.20:
status: Needs Info → Unconfirmed
Jani Kytölä (j-kytola) wrote :

output of dmesg

Ben Collins (ben-collins) wrote :

Yeah, tell me if the BIOS update worked. Seems it did for others. Seems it did for others.

Changed in linux-source-2.6.20:
status: Unconfirmed → Needs Info

Pliss close report, not is problem of Ubuntu. It is problem of vendedor of hardware. Update BIOS and not problem.

Not is problem of Ubuntu (Kernel). It is problem of BIOS. Update BIOS and not problem.

Changed in linux-source-2.6.20:
status: Needs Info → Rejected
Changed in linux-source-2.6.17:
status: Confirmed → Rejected

there was a similar problem with Dapper where updating the BIOS fixed it, but this is not it. as Jani reported above and i can confirm, this problem is still there running with fully updated BIOS. i'm not an expert at these things, but it looks like Edgy simply does not handle interrupts properly on these systems.

Changed in linux-source-2.6.17:
status: Rejected → Confirmed
Kristian Rink (kawazu) wrote :

Adding myself to the list as I see the same problem on a Toshiba Tecra A8:

kr@n428:~> cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel(R) Core(TM)2 CPU T7200 @ 2.00GHz
stepping : 6
cpu MHz : 1000.000
cache size : 4096 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe lm constant_tsc pni monitor ds_cpl vmx est tm2 cx16 xtpr lahf_lm
bogomips : 3994.84

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel(R) Core(TM)2 CPU T7200 @ 2.00GHz
stepping : 6
cpu MHz : 1000.000
cache size : 4096 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe lm constant_tsc pni monitor ds_cpl vmx est tm2 cx16 xtpr lahf_lm
bogomips : 3990.09

Not sure whether it is the same issue but at least the phenomenon is the same (log file filling up with "APIC error on CPUx"). Seems to start only if the system is put to some load, though (launching Eclipse, VMWare or a database server).

Removing the ohci1394 module doesn't help, either:

[...]
[17183117.352000] APIC error on CPU1: 40(40)
[17183117.352000] APIC error on CPU0: 40(40)
[17183117.448000] APIC error on CPU1: 40(40)
[17183117.448000] APIC error on CPU0: 40(40)
[17183131.544000] ieee1394: Node removed: ID:BUS[0-00:1023] GUID[0000390000a62cac]
[17183195.636000] APIC error on CPU1: 40(40)
[17183195.636000] APIC error on CPU0: 40(40)
[17183195.708000] APIC error on CPU1: 40(40)
[17183195.708000] APIC error on CPU0: 40(40)
[...]

I don't know whether this is really causing any trouble or just being an "aesthetic" thing, but I would like to have getting it fixed anyhow. Kernel is 2.6.17-10-generic from Edgy.

Thanks,
Kristian

i haven't checked feisty yet. can anyone confirm?

Changed in linux-source-2.6.20:
status: Rejected → Unconfirmed
James Tait (jamestait) wrote :

I'm willing to add my experience as to whether the BIOS update fixes the problem, but I need to get a bootable DOS medium in order to flash the BIOS. I've had no luck so far getting my USB key to boot into FreeDOS and I don't have a floppy drive available. As soon as I figure it out I'll post the results back here.

Tom Verdaat (tom-verdaat) wrote :
Download full text (8.1 KiB)

I've got the same errors on my Asus L5800C laptop. Even worse: i've had no problems running breezy and dapper but I am since recently experiencing random hangups in Edgy.

This results in the keyboards (1 onboard, 1 ps/2 through usb) not responding (mouse and touchpad still do). Then either no program in gnome starts anymore or when I can make it reboot it hangs on errors from the bcm43xx Broadcom wifi driver. I have to do a hard reset and then at boot when I have to enter my boot password set in the bios only the laptop keyboard works, the external one does not until linux boots.

Just did a completely clean install of Edgy yesterday and this still seems to occur. Sometimes nothing happens for two days straight and sometimes it hangs three times in one day.

I hope these data will help:

$ uname -a
Linux toMeloos 2.6.17-10-generic #2 SMP Tue Dec 5 22:28:26 UTC 2006 i686 GNU/Linux

$ uptime
10:29:13 up 9:11, 2 users, load average: 0.14, 0.10, 0.09
$ dmesg |grep "APIC error on CPU0:" | wc --lines
56

=> please note that during this uptime it was idle for all but about one hour.

$ lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 645xx (rev 03)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO] (rev 14)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.3 FireWire (IEEE 1394): Silicon Integrated Systems [SiS] FireWire Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:0a.0 CardBus bridge: ENE Technology Inc CB-720/2/4 Cardbus Controller (rev 01)
00:0a.1 CardBus bridge: ENE Technology Inc CB-720/2/4 Cardbus Controller (rev 01)
00:0a.2 FLASH memory: ENE Technology Inc CB710 Memory Card Reader Controller
00:0c.0 Network controller: Broadcom Corporation BCM4303 802.11b Wireless LAN Controller (rev 02)
00:0d.0 Ethernet controller: 3Com Corporation 3c940 10/100/1000Base-T [Marvell] (rev 12)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 Lf [FireGL 9000] (rev 01)
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

$ lsmod
Module Size Used by
binfmt_misc 13448 1
rfcomm 42260 2
l2cap 27136 5 rfcomm
nfs 250316 1
lockd 67976 2 nfs
sunrpc 165948 3 nfs,lockd
ipv6 272288 12
radeon 118816 2
drm 74644 3 radeon
speedstep_lib 5764 0
cpufreq_userspace 5408 0
cpufreq_stats 7744 0
freq_table 6048 1 cp...

Read more...

James Tait (jamestait) wrote :

Ben, Cristian: As Alvin pointed out above, updating the BIOS on Acer Ferrari 4005 WLMi does not solve this problem. I just updated from BIOS 3A19 to 3A23 and still have as many of these messages in my dmesg output. Upgrading the BIOS is not the answer.

James Tait (jamestait) wrote :

However, the BIOS update coupled with the irqpoll kernel option at boot does appear to have stopped the APIC error messages.

James Tait (jamestait) wrote :

Output of dmesg with irqpoll option after upgrading BIOS to 3A23.

James Tait (jamestait) wrote :

Output of lspci -vv with irqpoll after BIOS update to 3A23.

Changed in linux-source-2.6.20:
status: Unconfirmed → Confirmed

I seem to be getting the same - on my Toshiba M500.
Had installed edgy 4 days ago and things were fine. Since yesterday, machine has been behaving slowly - apps coming up after sometime. Today morning the boot process stopped twice at the same point (after local mounting of drives). However, if I resort to safe boot - and then "do nothing" and an exit, the xserver comes up fine (though app launch times are quite large)

Checked logs and saw a lot of the APIC error messages showing up. Then chanced on this thread.

Any inputs required, pls update and will mail in the same.

Rgds
Sridhar

Vincenzo Ciancia (vincenzo-ml) wrote :

On feisty I still have this problem, even after removing the firewire module:

[ 6466.632000] ieee1394: Node removed: ID:BUS[0-00:1023] GUID[00003900009dffe0]
[ 6469.344000] APIC error on CPU0: 40(40)
[ 6469.484000] APIC error on CPU0: 40(40)
[ 6470.884000] APIC error on CPU0: 40(40)
[ 6470.928000] APIC error on CPU0: 40(40)

On 2/5/07, Vincenzo Ciancia <email address hidden> wrote:
> On feisty I still have this problem, even after removing the firewire
> module:
>
> [ 6466.632000] ieee1394: Node removed: ID:BUS[0-00:1023] GUID[00003900009dffe0]
> [ 6469.344000] APIC error on CPU0: 40(40)
> [ 6469.484000] APIC error on CPU0: 40(40)
> [ 6470.884000] APIC error on CPU0: 40(40)
> [ 6470.928000] APIC error on CPU0: 40(40)

Vincenzo update BIOS?
--
Cristian Aravena Romero

I test proyect http://www.linuxfirmwarekit.org/. The BIOS is very bad, many bugs. Problem not is kernel. Pliss test of and create report in http://www.linuxfirmwarekit.org/feedback.php

In DVD of Open Suse 10.2 in start DVD option test in menu. Is good create in cd install test?

* Install OEM
* Recovery...
* Others ....
* _Test firmware_

Abstract report in the notebook compaq presario v2417LA (List moderate http://www.bughost.org/pipermail/firmwarekit-results/ ):
* BIOS F.27 (Date: 09-2006)
* Linux-ready Firmware Developer Kit - Release 1 (Date 12-2006)
** 5 fails, 2 warn, 12 pass, 19 total in BIOS : -O

James Tait (jamestait) wrote :

I have recently upgraded to Feisty (linux-image-2.6.20-9-generic) and the frequency of these messages is greatly reduced, although they are not eliminated completely. I intend to take a look at the Linux Firmware Kit suggested by Cristian above, but something has clearly changed in the kernel that has at least reduced the severity of the problem.

I note that when I boot, I see the message "MP-BIOS bug: 8254 timer not connected to IO-APIC" before the usplash screen. See attached dmesg output.

James Tait (jamestait) wrote :

I have submitted a Linux Firmware Kit report for the Acer Ferrari 4005 WLMi with BIOS 3A23. It is currently awaiting moderator approval, but should be available via the archives at http://www.bughost.org/pipermail/firmwarekit-results/ soon.

On 3/7/07, James Tait <email address hidden> wrote:
> I have submitted a Linux Firmware Kit report for the Acer Ferrari 4005
> WLMi with BIOS 3A23. It is currently awaiting moderator approval, but
> should be available via the archives at http://www.bughost.org/pipermail
> /firmwarekit-results/ soon.

http://www.bughost.org/pipermail/firmwarekit-results/2007-March/000097.html
--
Cristian

Fırat Küçük (firatkucuk) wrote :

same problem

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel(R) Core(TM)2 CPU T7200 @ 2.00GHz
stepping : 6
cpu MHz : 1000.000
cache size : 4096 KB
physical id : 0
siblings : 1
core id : 255
cpu cores : 1
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe lm constant_tsc pni monitor ds_cpl vmx est tm2 cx16 xtpr lahf_lm
bogomips : 3994.86

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel(R) Core(TM)2 CPU T7200 @ 2.00GHz
stepping : 6
cpu MHz : 1000.000
cache size : 4096 KB
physical id : 1
siblings : 1
core id : 255
cpu cores : 1
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe lm constant_tsc pni monitor ds_cpl vmx est tm2 cx16 xtpr lahf_lm
bogomips : 3990.00

Kristian Rink (kawazu) wrote :

removing myself from the list. For the Tecra A8, a new BIOS (3.30) has been released in early 2007 which seems to have fixed the problem.

Thanks anyhow. :)

Ben Collins (ben-collins) wrote :

This really looks like a hw/BIOS bug. Please re-open if that proves to not be the case.

Changed in linux-source-2.6.20:
status: Confirmed → Rejected
Changed in linux-source-2.6.17:
status: Confirmed → Rejected
dioid (prj17) wrote :

I experienced the same problem (only installed ubuntu Edgy Eft a day ago)
prj@gordon:~$ grep "APIC error" /var/log/* | wc -l
335551

Tried updating to latest known BIOS version (1.04c AMI) for Fujitsu-Siemens Amilo 7640W didn't help. Neither did adding boot options noapic (then sound device died and Gnome wouldn't come up) nor nolapic (same thing) or trying to set various i8042 boot options. What seems to have cured it is setting the boot option irqpoll (add it in /boot/group/menu.lst on line beginning with kernel). Not trying to reopen the issue, just adding a comment with workaround that might help others with same problem. This discussion was first hit on google when I searched for the problem. I spent lots of time reading forum posts all over the net about this. Maybe there is no general solution, and it's not really a BIOS problem (at least not only, though it might be for some) and all those "solutions" are workarounds for linux kernel not to alert about faulty hardware. Well, those are my 5 cents. Thanks for good work on making Ubuntu.

Maurice (m1625) wrote :

As a newbie with the same error, could you give me a specific line entry for 'irqpoll' I'm not quite sure how to enter it and don't want to muck things up. Thanks

James Tait (jamestait) wrote :

Certainly. When you first boot, before the Ubuntu splash/progress screen, GRUB should present you with a list of options. The first should be something along the lines of "Ubuntu, kernel 2.6.20-15-generic Default" (I believe it will be 2.6.17 for Edgy).

Press 'e' to edit the boot configuration. You should see a list of options like the kernel, root device, initrd image. Use the cursor keys to select the kernel line.

Press 'e' to edit the boot options. You should be presented with the current boot options, something along the lines of "/boot/vmlinuz root=UUID=e9c019e5-d78a-4cc0-8c4a-129eadbe0e3b ro quiet splash" although the line is so long it will probably have been wrapped so you will only see the latter part of it. Simply add " irqpoll" (note the leading space) to this line, then hit enter.

You should be taken back to the boot configuration screen. Press 'b' to boot.

You can make the option permanent, if you so wish, by editing /boot/grub/menu.lst and adding it to the line "# kopt=root=UUID=e9c019e5-d78a-4cc0-8c4a-129eadbe0e3b ro" in the "Default kernel options" section, then running "sudo update-grub"

Maurice (m1625) wrote :

Hi James,

Sorry for the delay in reply. I have followed your advice and made a
permanent change to my grub. The APIC error message has now
disappeared. Thank you. Maurice

James Tait wrote:
> Certainly. When you first boot, before the Ubuntu splash/progress
> screen, GRUB should present you with a list of options. The first
> should be something along the lines of "Ubuntu, kernel 2.6.20-15-generic
> Default" (I believe it will be 2.6.17 for Edgy).
>
> Press 'e' to edit the boot configuration. You should see a list of
> options like the kernel, root device, initrd image. Use the cursor keys
> to select the kernel line.
>
> Press 'e' to edit the boot options. You should be presented with the
> current boot options, something along the lines of "/boot/vmlinuz
> root=UUID=e9c019e5-d78a-4cc0-8c4a-129eadbe0e3b ro quiet splash" although
> the line is so long it will probably have been wrapped so you will only
> see the latter part of it. Simply add " irqpoll" (note the leading
> space) to this line, then hit enter.
>
> You should be taken back to the boot configuration screen. Press 'b' to
> boot.
>
> You can make the option permanent, if you so wish, by editing
> /boot/grub/menu.lst and adding it to the line "# kopt=root=UUID=e9c019e5
> -d78a-4cc0-8c4a-129eadbe0e3b ro" in the "Default kernel options"
> section, then running "sudo update-grub"
>
>

--
I use Ubuntu 6.10...
ubuntu - linux for human beings <http://www.ubuntu.com>

intel (intel-tg) wrote :
Larry Hartman (larryhartman50) wrote :

I use a HP dv8000 laptop with AMD Turion ML-37 processor. I have had this error in both Edgy and Feisty..Fesity as an upgrade and as a clean install. I will add the irqpoll option and report back results

Had tried based on the May 9th feedback

a) irqpoll did not help
b) looked at updated 3.5 version bios - that sorted out the issue.
However, now during direct boot, I do not get the grub selection menu. (But it is manageable - by instinctively selecting the first or last option in my dual boot)

Interestingly, if I do a reboot (instead of shutdown), the grub options come up fine.

Larry Hartman (larryhartman50) wrote :

I added irqpoll by itself, then irqpoll with noapic, then irqpoll with nolapic. irqpoll by itself did not affect any changes. adding it with nopaic caused system stop at very beginning of boot process. Same thing with nolapic, but a different error. I am researching flashing the BIOS att. Report back when I figure that out.

Krzysztof Wyszyński (goomior) wrote :

BIOS upgrade on Toshiba Tecra A8-183 to version 3.40 fixes this issue.

Dyson (dyson) wrote :

Try recompiling the kernel without IDE support. Use the pata_sis module and /dev/sda instead. You will have to redo grub and initrd.

This got rid of the APIC error on CPU0: 40(40) on a SiS 755 chipset + Athlon64 using 2.6.22-rc6-git2 kernel. The motherboard board is a Foxconn K8S755A-6EKRS.

RobC (rccase) wrote :

Problem started occurring for me when upgrading edgy server to latest kernel (2.6.17-12-server).
No errors before upgrade, even with 296 day uptime.

Within 1 day of uptime, here is the output:
dmesg | grep "APIC error on CPU0:"
[43019949.080000] APIC error on CPU0: 00(40)
[43020069.080000] APIC error on CPU0: 40(40)
[43036449.200000] APIC error on CPU0: 40(40)

Processor is AMD Athlon Barton 2500+
Here is /proc/cpuinfo

cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 6
model : 10
model name : AMD Athlon(tm) XP 2500+
stepping : 0
cpu MHz : 1837.524
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow up ts
bogomips : 3678.35

Nanley Chery (nanoman) wrote :

I have this error on Hardy Heron Alpha 4 on my Acer Aspire 3000.

Please confirm if you BIOS is up to date. Thanks.

Changed in linux:
status: New → Incomplete
James Tait (jamestait) wrote :

Now operating on Gutsy, still on an Acer Ferrari 4005WLMi, BIOS 3A23.

$ uname -a
Linux ferrari 2.6.22-14-generic #1 SMP Thu Jan 31 23:33:13 UTC 2008 x86_64 GNU/Linux

$ cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 36
model name : AMD Turion(tm) 64 Mobile Technology ML-37
stepping : 2
cpu MHz : 2000.000
cache size : 1024 KB
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow up pni lahf_lm
bogomips : 3983.68
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc

I'm still seeing the same problem.

[ 8445.724668] APIC error on CPU0: 40(40)
[ 8451.620726] APIC error on CPU0: 40(40)

cbinusa (cbinusa) wrote :

It is up to date. Am forced to still do nolapic noapic in grub boot file
or else it freezes with that error.
On Fri, 08 Feb 2008 14:05:19 -0800, Leann Ogasawara <email address hidden>
wrote:

> Please confirm if you BIOS is up to date. Thanks.
>
> ** Changed in: linux (Ubuntu)
> Status: New => Incomplete
>

--
Using Opera's revolutionary e-mail client: http://www.opera.com/mail/

Nanley Chery (nanoman) wrote :

My BIOS is up to date as well. On my Acer Aspire 3004WCLi, I have version 3A32 - the latest (and probably the last) bios release.

Changed in linux:
status: Incomplete → New

Hi Nanley,

Since it appears you are running the latest Hardy Alpha release, per the kernel team's bug policy, can you please attach the following information. Please be sure to attach each file as a separate attachment.

* uname -a > uname-a.log
* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

Changed in linux:
status: New → Incomplete
Nanley Chery (nanoman) wrote :

The files you've requested...
By the way, adding the noapic option to grub stops this error from occurring. Would anyone know, by any chance, what this option does - or what it stops the OS from doing? Thank you.

Nanley Chery (nanoman) wrote :
Nanley Chery (nanoman) wrote :
Nanley Chery (nanoman) wrote :
Nanley Chery (nanoman) wrote :

Adding the noapic option has caused some errors. My cd drive will not operate, and running software like brasero crashes.

Przemek K. (azrael) wrote :

The guys on http://bugzilla.kernel.org say that this message is just a symptom, not necessarily the same bug. I have this message too and I don't think it is connected with any abnormal activity. If your system works fine then you should just ignore it. If not, you can search the kernel's bugzilla for a bug that is most probably connected to your hardware.

Przemek K. (azrael) wrote :

There is an interesting comment in Bug #69026:
"I must remove the "ohci1394" module or dmesg gets constantly flooded with APIC error on CPU0: 40(40)"
Maybe this will solve the problem for some of us? (especially if you don't use firewire - if you do, then don't remove that module)

cbinusa (cbinusa) wrote :

It freezes pc after a few of the APIC errors.
On Sat, 23 Feb 2008 10:27:32 -0800, Przemysław Kulczycki
<email address hidden> wrote:

> The guys on http://bugzilla.kernel.org say that this message is just a
> symptom, not necessarily the same bug. I have this message too and I
> don't think it is connected with any abnormal activity. If your system
> works fine then you should just ignore it. If not, you can search the
> kernel's bugzilla for a bug that is most probably connected to your
> hardware.
>

--
Using Opera's revolutionary e-mail client: http://www.opera.com/mail/

Nanley Chery (nanoman) wrote :

Well, my system seems to work normally when I ignore the errors, but I can't help but think there is some "polling" going on that is wasting resources. Here are my boot logs (normal, and noapic).

Annabelle Van Gelder (waxje) wrote :

i know there are several reasons why this bug could be apearing
I happend to get this error to in my log 100's of times. I tried blacklisting my firewire modules as i assumed they were the problem but the are not.

I found out this error only gets printed in my log when my cpu fan is turning and not when it is silent, this error also apears a lot when the fan just starts to rotate.

I have an acer aspire 7720z (not with latest bios but that wil be installed this weekend and that might solve the error)
Hope this might help someone to find a sollution for at least on of these errors

Changed in linux:
status: Unknown → Confirmed
Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
Annabelle Van Gelder (waxje) wrote :

i recently installed ubuntu 64 bit on my acer. With 32 bit it gives die apic error, with the 64 bit it does not. I hope it stayes this way :D
Also the fan seems to be more quiet

Annabelle Van Gelder (waxje) wrote :

don't mind my previous 64 bit comment. in stead of the apic 40 error i get this.

Jun 4 15:34:38 wax-laptop kernel: [ 2510.915820] CPU1: Temperature/speed normal
Jun 4 15:34:38 wax-laptop kernel: [ 2510.915826] CPU0: Temperature/speed normal
Jun 4 15:40:56 wax-laptop kernel: [ 2542.067397] CPU0: Temperature/speed normal
Jun 4 15:40:56 wax-laptop kernel: [ 2542.067404] CPU1: Temperature/speed normal
Jun 4 15:47:16 wax-laptop kernel: [ 2572.746282] CPU0: Temperature/speed normal
Jun 4 15:47:16 wax-laptop kernel: [ 2572.746298] CPU1: Temperature/speed normal
Jun 4 15:53:35 wax-laptop kernel: [ 2603.084965] CPU0: Temperature/speed normal
Jun 4 15:53:35 wax-laptop kernel: [ 2603.084972] CPU1: Temperature/speed normal
Jun 4 15:58:43 wax-laptop kernel: [ 2652.019441] CPU1: Temperature/speed normal
Jun 4 15:58:43 wax-laptop kernel: [ 2652.019455] CPU0: Temperature/speed normal
Jun 4 16:03:43 wax-laptop kernel: [ 2710.473087] CPU0: Temperature/speed normal
Jun 4 16:03:43 wax-laptop kernel: [ 2710.473094] CPU1: Temperature/speed normal
Jun 4 16:25:03 wax-laptop kernel: [ 3005.939799] CPU0: Temperature/speed normal
Jun 4 16:25:03 wax-laptop kernel: [ 3005.939803] CPU1: Temperature/speed normal
Jun 4 16:30:52 wax-laptop kernel: [ 3095.868357] CPU0: Temperature/speed normal
Jun 4 16:30:52 wax-laptop kernel: [ 3095.868378] CPU1: Temperature/speed normal
Jun 4 16:36:02 wax-laptop kernel: [ 3146.825850] CPU1: Temperature/speed normal
Jun 4 16:36:02 wax-laptop kernel: [ 3146.825864] CPU0: Temperature/speed normal
Jun 4 16:41:55 wax-laptop kernel: [ 3224.724215] CPU1: Temperature/speed normal
Jun 4 16:41:55 wax-laptop kernel: [ 3224.724222] CPU0: Temperature/speed normal
Jun 4 16:49:13 wax-laptop kernel: [ 3402.454530] CPU1: Temperature/speed normal
Jun 4 16:49:13 wax-laptop kernel: [ 3402.454540] CPU0: Temperature/speed normal
Jun 4 16:55:29 wax-laptop kernel: [ 3553.418420] CPU0: Temperature/speed normal
Jun 4 16:55:29 wax-laptop kernel: [ 3553.418440] CPU1: Temperature/speed normal

not the same, but i similiar problem here https://bugs.launchpad.net/ubuntu/+source/linux/+bug/188739

Annabelle Van Gelder (waxje) wrote :

I upgraded my bios yesterday (from version 1.22 to 1.40)and got rid of the" CPU1: Temperature/speed normal message" in 64 bit mode. I asume this is the apic(40) error in 32 bit mode.
My cpu is now running a lot cooler.

So the people with acer asprire 7720 might fix this with a bios upgrade

Changed in linux:
status: Confirmed → Invalid
Larry Hartman (larryhartman50) wrote :

For the bug triagers.....if you wish to mark this bug as invalid, please give us the courtesy of explaining your rationale.

Richard Seguin (sectech) wrote :

Larry,

It appears as one of the remote bug trackers marked part of the bug as invalid... The remote bug trackers watch upstream bug reports and update launchpad appropriately, chances are an explanation was given upstream.

Richard Seguin (sectech) wrote :

Paste from upstream

------- Comment #19 From Miha 2008-06-14 09:50:15 [reply] -------

Well, Acer finally fixed BIOS. Now there are no APIC at all. Updated to 1.40
version from 1.21

Link: ftp://ftp.work.acer-euro.com/notebook/aspire_7720/vista/Bios
There are many bugs fixed referring to Changelog.

Thanks for help guys.

------- Comment #20 From Natalie Protasevich 2008-06-14 20:50:28 [reply] -------

Thanks for the update. Closing the bug.

James Tait (jamestait) wrote :

And for those of us experiencing this on a machine other than an Acer Aspire 7720? I note that Acer appear to have a new BIOS available for the Ferrari 4005WLMi (version 3A27 I think, see ftp://ftp.work.acer-euro.com/notebook/ferrari_4000/vista/BIOS/BIOS.zip) but it is labelled as "Bios for MS Windows Vista". This seems to tally with Richard Seguin's link above, but can anyone verify my assumption that this BIOS will be safe to use with Ubuntu?

mp (m-p) wrote :

i must misunderstand something here......

what about the rest of the world not using Acer?

the bug fix is to change machine and update BIOS?

Richard Seguin wrote:
> Paste from upstream
>
> ------- Comment #19 From Miha 2008-06-14 09:50:15 [reply] -------
>
> Well, Acer finally fixed BIOS. Now there are no APIC at all. Updated to 1.40
> version from 1.21
>
> Link: ftp://ftp.work.acer-euro.com/notebook/aspire_7720/vista/Bios
> There are many bugs fixed referring to Changelog.
>
> Thanks for help guys.
>
>
> ------- Comment #20 From Natalie Protasevich 2008-06-14 20:50:28 [reply] -------
>
> Thanks for the update. Closing the bug.
>

Richard Seguin (sectech) wrote :

Ralf, since you are the original reporter is this issue fixed for you?

As for the rest of you experiencing this same problem I understand that it is still very frustrating for you and it would be helpful if we could fix your APIC issues as well. It appears as this bug was hardware specific and as a result I am asking whoever else is having this problem to please submit a separate bug report (** and please indicate what your hardware is **) so we can move forward with this issue.

Thank you,

Richard Seguin

Richard Seguin (sectech) wrote :

* Status: Won't Fix on linux-source-2.6.22 as we seem to have different hardware types in this bug and as far as I can tell the original reporter did not report against this version

Changed in linux-source-2.6.22:
status: New → Won't Fix

* Richard Seguin <email address hidden>:

> Ralf, since you are the original reporter is this issue fixed for you?

I have to try it.

> As for the rest of you experiencing this same problem I understand that
> it is still very frustrating for you and it would be helpful if we
> could fix your APIC issues as well. It appears as this bug was
> hardware specific and as a result I am asking whoever else is having
> this problem to please submit a separate bug report (** and please
> indicate what your hardware is **) so we can move forward with this
> issue.

What is the fix? Is it supposedly fixed in a recent kernel?
I haven't seen the error in a while :)

--
Ralf Hildebrandt (i.A. des IT-Zentrums) <email address hidden>
Charite - Universitätsmedizin Berlin Tel. +49 (0)30-450 570-155
Gemeinsame Einrichtung von FU- und HU-Berlin Fax. +49 (0)30-450 570-962
IT-Zentrum Standort CBF send no mail to <email address hidden>

Richard Seguin (sectech) wrote :

This is where this bug gets confusing, there are few people here with the same symptoms... The original fix was a bios upgrade...

What kernel are you running now? and just to confirm your not having this problem anymore?

mp (m-p) wrote :
Download full text (3.6 KiB)

Richard Seguin wrote:
> This is where this bug gets confusing, there are few people here with
> the same symptoms... The original fix was a bios upgrade...
>
> What kernel are you running now?

Linux XXX 2.6.24-19-generic #1 SMP Wed Jun 4 16:35:01 UTC 2008 i686
GNU/Linux

:~$ lspci
00:00.0 Host bridge: ATI Technologies Inc Unknown device 5a31 (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:06.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:12.0 IDE interface: ATI Technologies Inc IXP SB400 Serial ATA
Controller (rev 80)
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host
Controller (rev 80)
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host
Controller (rev 80)
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host
Controller (rev 80)
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 82)
00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller
(rev 80)
00:14.2 Audio device: ATI Technologies Inc IXP SB4x0 High Definition
Audio Controller (rev 01)
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80)
01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon
Xpress 200M]
02:00.0 Ethernet controller: Atheros Communications Inc. AR242x
802.11abg Wireless PCI Express Adapter (rev 01)
03:06.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
03:06.3 SD Host controller: Texas Instruments PCIxx12 SDA Standard
Compliant SD Host Controller
03:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)

Toshiba Satellite Pro A120

> and just to confirm your not having
> this problem anymore?

[30229.002483] sd 10:0:0:1: [sdd] Attached SCSI removable disk
[30229.002536] sd 10:0:0:1: Attached scsi generic sg3 type 0
[30230.133159] APIC error on CPU0: 40(40)
[30232.445400] APIC error on CPU0: 40(40)
[30257.597618] APIC error on CPU0: 40(40)
[30258.329543] APIC error on CPU0: 40(40)
[30259.002362] APIC error on CPU0: 40(40)
[30259.652527] APIC error on CPU0: 40(40)
[30317.652977] APIC error on CPU0: 40(40)
[30318.201678] APIC error on CPU0: 40(40)
[30354.314290] APIC error on CPU0: 40(40)
[30355.190048] APIC error on CPU0: 40(40)
[30356.180058] APIC error on CPU0: 40(40)
[30362.415721] APIC error on CPU0: 40(40)
[30377.134030] APIC error on CPU0: 40(40)
[30401.363443] APIC error on CPU0: 40(40)
[30416.576264] APIC error on CPU0: 40(40)
[30418.685355] APIC error on CPU0: 40(40)
[30421.747034] APIC error on CPU0: 40(40)
[30423.158860] APIC error on CPU0: 40(40)
[30423.952675] APIC error on CPU0: 40(40)
[30467.627058] APIC error on CPU0: 40(40)
[30492.058407] APIC error on CPU0: 40(40)
[30643.658522] APIC error on CPU0: 40(40)
[30677.259140] APIC error on CPU0: 40(40)
[30696.831020] APIC error on CPU0: 40(40)
[30737.236757] APIC error on CPU0: 40(40)
[30841.267699] APIC error on CPU0: 40(40)
[30857.140719] APIC error on CPU0: 40(40)
[31015.847300] APIC error on CPU0: 40(40)
[31037.130477] APIC error on CPU0: 40(40)
[31041.443041] APIC error on CPU0: 40(40)
[31063.915039] APIC error on CPU0: 40(40)
[31067.505716] APIC err...

Read more...

Richard Seguin (sectech) wrote :

mp,

Unless you have exactly the same hardware as Ralf could you please submit a separate bug report for your hardware.

Thanks,

Richard Seguin

* Richard Seguin <email address hidden>:
> This is where this bug gets confusing, there are few people here with
> the same symptoms... The original fix was a bios upgrade...
>
> What kernel are you running now? and just to confirm your not having
> this problem anymore?

$ uname -a
Linux acerbus 2.6.24-18-generic #1 SMP Wed May 28 19:28:38 UTC 2008 x86_64 GNU/Linux

$ dmesg |grep -i apic
$

So it's gone for me.

--
Ralf Hildebrandt (i.A. des IT-Zentrums) <email address hidden>
Charite - Universitätsmedizin Berlin Tel. +49 (0)30-450 570-155
Gemeinsame Einrichtung von FU- und HU-Berlin Fax. +49 (0)30-450 570-962
IT-Zentrum Standort CBF send no mail to <email address hidden>

Richard Seguin (sectech) wrote :

Good enough. Closing this issue out as it was hardware specific and the original reporter is no longer having the problem. If you are still experiencing this problem please refile a new bug report.

Changed in linux:
importance: Medium → Undecided
status: Triaged → Invalid

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.