Kernel panic - not syncing, when installing Ubuntu on PCs with VIA motherboards

Bug #63134 reported by Anders Berg on 2006-09-30
128
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fedora
Fix Released
High
Ubuntu
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.17 (Ubuntu)
Medium
Ben Collins
linux-source-2.6.20 (Baltix)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned
linux-source-2.6.24 (Ubuntu)
Undecided
Unassigned

Bug Description

Installation of 6.10 Beta1 fails with a "kernel panic - not syncing: Attempted to kill init!".
My system is a Via EPIA-SP (Mini-ITX). Edgy Eft Knot3 did not have this problem.

Including a picture of the screen at the krasch moment

I can confirm this problem on a Via EPIA-SP13000 board.
Booting with acpi = off makes no difference.

lspci:
00:00.0 Host bridge: VIA Technologies, Inc. CN400/PM880 Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. CN400/PM880 Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. CN400/PM880 Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. CN400/PM880 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. CN400/PM880 Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. CN400/PM880 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:0d.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 80)
00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
01:00.0 VGA compatible controller: VIA Technologies, Inc. S3 Unichrome Pro VGA Adapter (rev 02)

Lucas Maneos (ubuntu-subs) wrote :

I get the same (EIP also at acpi_hw_low_level_read+0xa/0x7c) on an EPIA EN1200. For what it's worth, FC6test3 also panics at acpi_hw_low_level_read, and dapper boots just fine.

Jan Claeys (janc) on 2006-10-13
Changed in linux-source-2.6.17:
status: Unconfirmed → Confirmed
Lucas Maneos (ubuntu-subs) wrote :

Another data point: the kernel from daily debian-installer (http://people.debian.org/~joeyh/d-i/images/daily/netboot/debian-installer/i386/), version 2.6.17-2-486, also boots fine.

Description of problem:

When booting FC 5.92 on an EPIA EN1200 board the kernel panics. I can't capture
the console output, but the call trace in the screenshot at
<https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.17/+bug/63134> is
exactly what I'm seeing (modulo timestamps & offsets).

Finally managed to boot the machine with pci=off, did a basic installation and
recompiled the kernel with the contents of the quirk_via_abnormal_poweroff
function commented out, which fixed the problem.

Version-Release number of selected component (if applicable):

Problem is present in all kernels I've tried between whatever version the 5.91
installer comes with and 2.6.18-1.2784.fc6. 5.90 boots fine (but I couldn't get
much further with it due to installer bugs).

How reproducible:

Every time.

Steps to Reproduce:
1. Boot 5.91 or 5.92 installation media or netboot

Actual results:

Kernel panic.

Expected results:

Successful boot.

Additional info:

Lucas Maneos (ubuntu-subs) wrote :

Some more info:

I've experimented with all the BIOS settings but they made no difference. However booting is possible with "pci=off" (or "pci=conf2", seems to have the same effect), although the machine is not in a terribly useful state that way (no network, slow disk I/O etc).

I managed to get fc6 installed (didn't have edgy isos at hand and network install wasn't possible) and built a kernel with the contents of quirk_via_abnormal_poweroff commented out which boots fine.

For the release kernel for FC6 (which I'm building today), I've removed this
function. I'll chase it upstream and see if I can get a better fix out in an
update.

*** Bug 210993 has been marked as a duplicate of this bug. ***

Just to confirm, kernel-2.6.18-1.2798.fc6 boots ok.

turns out ACPI is already doing the same thing. So it looks like upstream will
also be removing this function.

> Problem is present in all kernels I've tried between whatever
> version the 5.91 installer comes with and 2.6.18-1.2784.fc6.

> Just to confirm, kernel-2.6.18-1.2798.fc6 boots ok.

Lucas, Can you clarify if this means that 2.6.18* always works,
or that at some point it workes and some point it failed like
2.6.17 did?

2.6.18-1.2784.fc6 also panicked, until I rebuilt it with
quirk_via_abnormal_poweroff() neutered. There are no other 2.6.18 kernels in my
yum.log.

Thanks, and kernel-2.6.18-1.2798.fc6 worked without any modification?

Yes, unmodified straight-out-of-the-rpm kernel-2.6.18-1.2798.fc6 boots without a
panic.

As far as I can see, this bug is not fixed with the last kernel update. Will it be fixed for the Edgy release? Otherwise all Epia users will fail to install Edgy on their system...

uj (urs-jaeggi) wrote :

Same problem. Release Candidate kernel doesn't work with my VIA EPIA EN12000EG.

derk (pavel-ogi) wrote :

Final Edgy release also contains this bug and liveCD is not starting :(

Same problem using final Edgy release. Could boot and install the system using pci=off, but the kernel of the system has the same problem. Don't know if is the same kernel of the liveCD...

Thonix (thonix) wrote :

I have the same problem. After dist-upgrade 6.06 -> 6.10. It's possible to boot the system with the old dapper kernel (2.4.15-27). The live CD also dosen't work.

Systemdata:
00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host
Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8235 PCI Bridge
00:07.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller
(rev 46)
00:08.0 RAID bus controller: Promise Technology, Inc. PDC20376 (FastTrak 376)
(rev 02)
00:09.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)
00:0f.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 0a)
00:0f.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev
0a)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R200 QL [Radeon
8500 LE]

Steven Walter (stevenrwalter) wrote :

Patch to fix

Rocco (rocco) wrote :

Is this fixed going to be released in a new edgy kernel? Lot's of machines have stopped working here (callcenter) since we upgraded from Dapper, and a fix is needed badly.

Hallo,

I have an Athlon64 3200 on an Asus K8-VX motherboard. I was experiencing all the same issues described above.

Booting with pci=off works, but the system is basically useless.

What worked for me was disabling APM, Cool&Quiet and ACPI 2.0 in the motherboard's BIOS.

Now installing is going forward, I'm keeping my fingers crossed :-)

regards

Carlos

Changed in linux-source-2.6.17:
importance: Undecided → Medium
Łukasz Halman (lukasz-halman) wrote :

This bug renders all KT400/KT600 motherboard totally unusable. I cannot boot Edgy on any of my Athlon boxes.

Kernel option "acpi=force" seems to also do the trick for me.

On 11/13/06, Łukasz Halman <email address hidden> wrote:
>
> This bug renders all KT400/KT600 motherboard totally unusable. I cannot boot Edgy on any of my Athlon boxes.
>
> --
> Kernel panic - not syncing, when installing Edgy Beta1
> https://launchpad.net/bugs/63134
>

--
===================
Carlos M. Martinez
http://cgm-consulting.net
===================

My Via SP-13000 also booted ok with acpi=force. Thanks!

Hervé Fache (rvfh) wrote :

FYI, the bug first appeared in 2.6.17-8.

Hervé Fache (rvfh) wrote :
Hervé Fache (rvfh) wrote :

Just noticed that everybody else fixed it already and the patch has been available right here for the last two weeks too. So why is the status not Fix-Committed?

Also, why is it set to low-urgency, being a show-stopper bug? I would have thought it to be critical: the machine won't boot at all!

Jussi Kukkonen (jku) wrote :

Upstream uses the patch in the stable kernel (actually used in the last one, 2.6.18.2, already): http://kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.18.2

I hope the reason for not putting this forward is not the low urgency/importance settings -- those must surely be wrong. As already stated this is a show-stopper that prevents new installs and breaks upgraded systems.

apanloco (apanloco) wrote :

Got the same bug today upgrading from Dapper to Edgy on my VIA SP13000.

RFScheer (rfs) wrote :

Can't install Edgy on new Via EN12000G either with standard desktop 386 cd or alternative or xubuntu. All same kernel panic as this thread.

linpin (bernd-pier) wrote :

did you use the boot option "acpi=off"? with this one i was able to install edgy and it`s working fine.

Hervé Fache (rvfh) wrote :

I think you want to try acpi=force rather than acpi=off...

RFScheer (rfs) wrote :

Thanks Herve and linpin!! I used acpi=force and it worked great. Didn't try acpi=off.

linpin (bernd-pier) wrote :

yes you`re right hervé i mean force not off.

Hervé Fache (rvfh) wrote :

Can someone (Ben?) please apply the patch and change the status to Fix Committed?
Let's get rid of this easy-to-fix bug!

I did an apt-get dist-upgrade on my home server to move from dapper->edgy and experienced this bug. I never tried the liveCD - that box probably wouldn't handle it. Until I see a new kernel come through I'm sticking with the dapper kernel.

no more panic'ing without noapic; great that made wireless work!

Dhvik (dan-handevik) wrote :

I had the same problem using a EPIA-EN15000G and installing Ubuntu 6.10. Adding acpi=force as kernel parameters worked though.
Thanks.

disabling noapic makes usb not working :(

I think I've found it:

acpi=force irqpoll

yay!

Have a KT400/KT600 VIA board. Edgy with the 2.6.15 kernel works, but the acpi=force setting has to be used to get 2.6.17-11 kernel not to panic.

I installed latest feisty server beta (kernel 2.6.20-12-server) on a Via Epia MII - install CD booted fine and installed OS, but kernel panics on boot from installation (grr!) - acpi=force or pci=off don't help :(

Jussi Kukkonen (jku) wrote :

hackeron, that is quite probably another bug altogether. All kernels >=2.6.18.2 have the fix...

Check the function names in the panic screen and if they aren't the same as in the screenshot that's attached to this bug, file a new bug for your issue.

hackeron (hackeron) wrote :

Yes, it looks like it is, I installed a generic kernel after booting from the install CD which fixed the problem, it looks like a bug with the server kernel - I'll fine another bug.

kaleidoscopeit (jaater) wrote :

I have the same problem, beginning from Edgy (Kernel 2.6.17), with my laptop PackardBell Easynote R1902 with VIA chipset.

I always fix the problem by appending "acpi=force irqpoll" to kernel string.

I have to do that in grub configuration file, at every kernel upgrade.

I think this is a tremendous problem.

we immagine a new desktop user that it come from others operative systems... or an "open mind" IT consultant of a corporation that it succeeds to install 20 pc with Ubuntu, and a morning, the job jams because of a stupid kernel problem that only an extraordinary maintenance can resolve.

Bye.

Jussi Kukkonen (jku) wrote :

kaleidoscopeit, you do not have to fix this after every kernel upgrade if you edit your grub configuration properly. Please see the comments in "/boot/grub/menu.lst" and "man update-grub" for more info ("Default kernel options" is what you are looking for...)

By the way, commenting in a bug management system without adding new information is usually not a good choice, forums are better for that.

kaleidoscopeit (jaater) wrote :

Tankyou Jussi, I agree with you.

With my post I have underlined that with the PackardBell Easynote 1902 whith VIA chipset , beginning from Edgy to actual Feisty, this BUG has not been resolved yet.

I gave simply my experience as a contibution to the developers.
Further comments I wrote, are only my thoughs.

I say that, if this kernel bug will not be fixed, many inexperienced users with a pc similar to mine (probably all with VIA Pn800 chipset), attracted by the notorious easiest of Ubuntu will return back to ours old OSs.

I have your same exact laptop, and I confirm the issue is still there. IIRC it is not on feisty anymore, when I tried one of the alpha live cds... but I'm not sure

bye

here's a patch http://lkml.org/lkml/2006/10/17/62 which seems to fix this issue; could it be applied, finally?

2007/5/1, NoWhereMan <email address hidden>:
>
> here's a patch http://lkml.org/lkml/2006/10/17/62 which seems to fix
> this issue; could it be applied, finally?
>
> --
> Kernel panic - not syncing, when installing Edgy Beta1
> https://bugs.launchpad.net/bugs/63134
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

thanks but now I use version 7.04 (feisty fawn) of ubuntu
and it functions good

<email address hidden>

the issue is still there on feisty, even though well hidden; acpi must be still forced (fails cutoff...) and therefore irqpoll must be set in order to make the wireless driver to work. packard bell easynote r1938 with via mainboard

Changed in linux-source-2.6.17:
assignee: nobody → ubuntu-kernel-team
assignee: ubuntu-kernel-team → ubuntu-kernel-acpi

this bug has been there on *feisty* and on *gutsy* where irqpoll is not a viable way to boot; here are finally two patches addressing both the issues
http://bugzilla.kernel.org/show_bug.cgi?id=8896

wrong distro, sorry

sorry, I've added baltix to the list

Hi All,

Just wanted to add some information. . .First, the patch mentioned here http://lkml.org/lkml/2006/10/17/62 was automatically included in both the Feisty and Gusty releases. This is because the Ubuntu kernel syncs with the upstream kernel.

NoWhereMan, thank you for the reference to the bugzilla.kernel.org report. However, I'm a little concerned with some of the comments posted by the developer of the patch:

"But in fact the above problems are related to BIOS. So it is more appropriate to fix this bug by updateing BIOS than the workaround patch."

and

"The above two patches in comment #127 and #128 can fix the problems for this bug. But they seem ugly and I am not willing to send the patches to kernel."

Have you actually verified these patches resolve your issue? It is a lot of extra work for the Ubuntu kernel team to maintain out of tree patches. As such they require evidence of upstream submission before considering to maintain community patches locally. Since the developer of the patches commented he's unwilling to send the patches upstream, this might not qualify against the team's standard. Also is seems the patches are really just to bandaid a buggy BIOS, in which case I'm not sure they'd be accepted upstream nor maintained separately for Ubuntu. I'll defer to the kernel team for their comment. Thanks.

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Incomplete

Something else you might want to try. . .

The Hardy Heron kernel was recently uploaded for testing. We'd really appreciate it if you could try testing with this newer kernel and verify if this issue still exists. Unfortunately, the Hardy Heron Alpha1 LiveCD was released with the older 2.6.22 kernel. You'll have to manually install the newer Hardy Heron kernel in order to test. This should not be the case for Alpha2 which is set to come out around Dec 20. However, here are the instructions to install if you choose to do so, otherwise just wait for Alpha2 to come out:

1) edit the file /etc/apt/sources.list and add the following line:

deb http://archive.ubuntu.com/ubuntu hardy main restricted

2) sudo apt-get update
3) sudo apt-get install linux-image-2.6.24-1-generic
4) reboot and select the new kernel from the grub menu

After you've tested, please feel free to revert back - ie boot into the old kernel, sudo apt-get remove linux-image-2.6.24-1-generic, and remove the line from /etc/apt/sources.list . Please update this report with your results. Thanks in advance!

Changed in linux:
status: New → Incomplete

> NoWhereMan, thank you for the reference to the bugzilla.kernel.org
> report. However, I'm a little concerned with some of the comments
> posted by the developer of the patch:
>
> "But in fact the above problems are related to BIOS. So it is more
> appropriate to fix this bug by updateing BIOS than the workaround
> patch."

unfortunately (I'm the e.vacchi of the bugreport) the released updates
for the bios does not work as expected; from other reports here on
launchpad IIRC it looks like they don't addres this issue at all

> "The above two patches in comment #127 and #128 can fix the problems for
> this bug. But they seem ugly and I am not willing to send the patches to
> kernel."
>
> Have you actually verified these patches resolve your issue? It is a
> lot of extra work for the Ubuntu kernel team to maintain out of tree
> patches. As such they require evidence of upstream submission before
> considering to maintain community patches locally.

I've tested one of the patches listed a few comments before the one
you're quoting; as I've answered, #127 and #128 are essentially a
pretty printed version of the one I've tried and an automated
acpi=force; I've tried to recompile 2.6.22 today (before I had only
tried 2.6.20) but looks like the new linux-source-2.6.22 on the
contrary of linux-source-2.6.20 lacks many of the drivers and it would
take for me a lot of time to figure out the whole procedure

> Since the developer
> of the patches commented he's unwilling to send the patches upstream,
> this might not qualify against the team's standard. Also is seems the
> patches are really just to bandaid a buggy BIOS, in which case I'm not
> sure they'd be accepted upstream nor maintained separately for Ubuntu.
> I'll defer to the kernel team for their comment. Thanks.

They *are* a bandaid for a buggy bios, but the whole point in this is
"if it works in Windows, why must have linux users to be penalized?";
the whole bug report is an interesting reading in this sense

> Something else you might want to try. . .

> The Hardy Heron kernel was recently uploaded for testing.

I don't think this would help; and btw I've tried 2.6.23 and it didn't
fix the issue; unfortunately this ugly patch seems the only way to
make it work; I would rather try to push the kernel devs so that this
hack can make it into upstream, so that
1) not only ubuntu but the whole community can benefit of the "bandaid"
2) ubuntu devs won't have to locally maintain the patch :)

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged

I'm in agreement on if it works in windows it should work in Linux philosophy.

I'm getting this on my Dell 1520 at boot up. I dunno how i'd try swapping kernels, so I'm going to try the hardy heron update with maybe 2.6.24 cuz I'm trying to ditch Vista ASAP. I'm almost scared to though, cuz when i did "sudo apt-get upgrade" and it included the new one grub was hosed.

On Dec 21, 2007 3:34 PM, JoshuaKersey <email address hidden> wrote:
> I'm in agreement on if it works in windows it should work in Linux
> philosophy.
>

please, if you have time/will/knowledge have a look at the linked
bug/patches and try to apply them; I was able to patch 2.6.20 series
(from ubuntu repository), while I couldn't figure out where all my
device drivers went with 2.6.22...

Changed in linux-source-2.6.20:
status: New → Invalid
status: New → Fix Released

Unfortunately, fixing this in edgy is somewhat pointless, since the liveCD's will not be re-rolled. I've checked that 2.6.24 does not contain the offending code. I did not check feisty/gutsy, since it is reported that 2.6.18 contains the fix.

Changed in linux:
status: Triaged → Fix Released
Changed in linux-source-2.6.22:
status: Incomplete → Fix Released
Changed in linux-source-2.6.17:
assignee: ubuntu-kernel-acpi → ben-collins
status: Confirmed → Won't Fix

again, I'm suggesting to all of the people affected from this bug to test the patch and/or registering on the kernel's bugzilla and comment about the bug http://bugzilla.kernel.org/show_bug.cgi?id=8896

Bhavani Shankar (bhavi) wrote :

Seems to be happening with hardy beta too

Ref:

https://answers.edge.launchpad.net/ubuntu/+question/30328

Regards.

Removing linux-source-2.6.24 task since beginning with Hardy, kernel bugs should be reported against the "linux" package.

Changed in linux-source-2.6.24:
status: New → Invalid
Poru (poru) wrote :

I have just come across this bug with Hardy and would very much like to see it fixed, so please let me know if there is additional information I can provide to help this process. Please see http://ubuntuforums.org/showthread.php?t=896077

I would give this bug high priority by the way, because it causes both the actual installation and the cd check to crash out at the very beginning, with no information provided about why or what to do to overcome it (such as try with acpi=off). This also gives the impression that the CD might be to blame when that is not the case.

How come this keeps needing to be fixed in subsequent releases of the kernel by the way. Can't the fix be left in the code, or is each fix different?

Having read Leann's last comment, please let me know if I have reported this bug in the wrong place.

Thank you.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Przemek K. (azrael) on 2010-01-08
summary: - Kernel panic - not syncing, when installing Edgy Beta1
+ Kernel panic - not syncing, when installing Ubuntu
summary: - Kernel panic - not syncing, when installing Ubuntu
+ Kernel panic - not syncing, when installing Ubuntu on PCs with VIA
+ motherboards
Przemek K. (azrael) on 2010-04-08
Changed in linux-source-2.6.24 (Ubuntu):
status: New → Invalid
Changed in fedora:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.