[edgy] kernel panic after last update

Bug #61848 reported by NoWhereMan (e.vacchi) on 2006-09-22
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.17 (Ubuntu)
Undecided
Unassigned

Bug Description

after last kernel update, ubuntu refuse to start. i can see no splashimage, so i guess this happens at the very beginning of the init process.

i have a packard bell easynote r1938. acpi=force is required to let it poweroff automatically on shutdown (but not actually used because it made it output a lot of debug code which I was not sure about)

attaching screenshot of what i can see on boot

Quim Calpe (quimcalpe) wrote :

Same here, but with a AMD XP 2200+. The same happened with 2.6.17-8-generic kernel, I just waited for the new kernel update(2.6.17-9-generic), but it crashes the same way.

Kernel linux-image-2.6.17-7-generic works fine thought...

As a side note, my motherboard (Asus K7V8-X) requires acpi=off to boot up correctly, the reporter had also acpi flag set, maybe has any relation?

actually -7 works with both acpi=force or without it, it is disabled as a default, as a for safety reasons by the kernel. I've left it off, as forcing revealed a lot of debug output i was not sure about. keeping it off require me to power off using the hardware button in the end of the shutdown process.

processor is a Celeron m380 1,6GHz

Quim Calpe (quimcalpe) wrote :

well, just wondering if that could be the cause... my system never booted up without the acpi=off flag, but Ubuntu installation put "automagically" the flag in defoptions of grub's menu.lst, so no problem in that regard.

Earthfall (youngikcho) wrote :

I am running my AMD64 desktop system with edge and the recent update of 2.6.17-9-generic gave me the kernel panic. 2.6.17-8-generic was fine.

Quim Calpe (quimcalpe) wrote :

@Earthfall: I think your problem is more related to bug https://launchpad.net/bugs/61877

possbible workaround?

http://ubuntuforums.org/showthread.php?p=1542776#post1542776

damn, I don't have that option on my BIOS (and that's a NEW laptop!)!!
"Insyde Software MobilePro BIOS ver 4.20.10"

koolatron (koolatron) wrote :

Same kernel panic here, on an AMD64 single-core processor, Gigabyte K8U-939 motherboard.

kernel 2.6.17-7 boots, -9 panics leaving me with much the same error as NoWhereMan. I'll scrounge up a screenshot and post it here tonight; failing that, I'll just give my fingers a workout and transcribe it.

koolatron (koolatron) wrote :

Transcribed screen trash on failed boot:

[ 19.103815] CS: 0010 DS: 0018 ES: 0018 CR0: 000000008005003b
[ 19.103858] CR2: 0000000000000008 CR3: 0000000000201000 CR4: 00000000000006e0
[ 19.103906] Process swapper (pid: 1, threadinfo ffff81003f1c8000, task ffff81003f1c7510)
[ 19.103986] Stack: ffff81003d9467c0 ffff810037f76000 ffff810037f76000 0000000000000200
[ 19.104173] ffff81003d8467c0 ffff810037f76000 ffff810037f76000 0000000000000008
[ 19.104405] 0000000000000001 ffffffff8038277a
[ 19.104553] Call Trace: <ffffffff8038277a>{agp_add_bridge+426} <ffffffff80386077>{agp_amd64_probe+1127}
[ 19.104791] <ffffffff8062aef3>{agp_amd64_init+147} <ffffffff80271392>{init+370}
[ 19.104998] <ffffffff80266665>{child_rip+8} <ffffffff8026b3e5>{__down+277}
[ 19.105202] <ffffffff80410683>{_etext+0} <ffffffff80271220>{init+0}
[ 19.105388] <ffffffff80266652>{child_rip+0}
[ 19.105553]
[ 19.105553] Code: 44 8b 79 08 8b 49 04 44 89 fe 89 4c 24 0c bf d0 00 00 00 e8
[ 19.106305] RIP <ffffffff80384724>{agp_generic_create_gatt_table+100} RSP <ffff81003f1c9df8>
[ 19.106450] CR2: 0000000000000008
[ 19.106504] <0>Kernel panic - not syncing: Attempted to kill init!
[ 19.106632]

Doesn't look ACPI related from my end; even went as far as disabling it in GRUB, got much the same thing.

Quim Calpe (quimcalpe) wrote :

@koolatron: The crash you describe is closer to the crash people is reporting in bug https://launchpad.net/bugs/61877 and seems related to AMD64 machines.

@NoWhereMan: The workaround didn't work for me, but one thing did: I changed in BIOS the interrupt mode from APIC to PIC, the crash was the same, but the change allowed me to boot without the acpi=off flag, and without it, the system booted up flawlesly!

So yes, it's seems rather ACPI related...

Quim Calpe (quimcalpe) wrote :

Well I just found something... I have to dualboot Windows XP sometimes, and with this workaround (setting the interrupt mode changed to PIC), Windows XP doesn't boot anymore...

Still not sure if it's good or bad ;-)

Brownie (jebdude89) wrote :

I get the same thing when i start up with the 2.6.17-9-generic kernel, but with the -7. I do not have the -8 kernel to test whether it works or not.
My processor is an AMD Athlon 64 3400+

no luck with -10 update
again, I DON'T have any amd64 nor amd processor

Quim Calpe (quimcalpe) wrote :

Kernel 2.6.17-10 has the same crash as -8 and -9 as guessed here this bug IS NOT a duplicate of 61898. In fact the attached screenshot show a rather different core dump...

Ben should we file a new one or the bug can be unmarked as duplicate?

click "mark as duplicate" (upper left corner) and delete the reference to 61898; that should do.
I won't do it myself as I'm not a member of the team :)

Quim Calpe (quimcalpe) wrote :

Me neither, and I'll wait Ben or any Kernel Team member to do so, as at the end they are the devs and the ones who know exactly what's happening here, and they marked it as dup...

On the other hand, our machines are still unbootable!

Adrian Harvey (ajharvey) wrote :

I get the same thing [as Nowhereman] after upgrading from Breezy. Can still start up by selecting the old (Breezy) kernel from grub. Has never required any special settings previously, and changing some of the BIOS options mentioned (I can't find the PIC/APIC one in my menus) makes no difference.

Is futher information needed to confirm this bug? If so, what can I get you?

Martin (martin-planet-renner) wrote :

I have a Via EPIA board with a C3 processor and Edgy fails to boot with almost the same message. The call trace contains

    pci_write
    pci_bus_write_config_byte
    pci_fixup_device
    init
    init
and finally
    <0> Kernel panic - not syncing: Attempted to kill init!

I could make a screenshot of the message.

I tried to downgrade the kernel from 2.6.17-10-generic: -9 and -8 crash the same way, 2.6.17-7-generic works fine. My previous installation with Dapper worked fine too.

adding pnpbios=off acpi=force to kernel options in grub made me boot with -10 kernel !

ps: the usplash bar is white at the top and brown at the bottom; is this the correct color?

Daniel Kończyk (drmartens) wrote :

I have similar problems as Martin above. After I switched to edgy beta, none of the 2.6.17 kernels worked for me (including -10). Kernel panic each time, with things like pci_write and some 'acpi read' stuff at the end. I'm using amd athlon 2500, abit kv7 motherboard, ati 9500
2.6.15-27-k7 works fine for me (shutdown is not complete though, worked fine with some older 2.6.15 kernels in dapper)

have you tried the kernel options i've posted above ?

Martin (martin-planet-renner) wrote :

@NoWhereMan: Perfect hint! With those two options (pnpbios=off acpi=force) my computer finally boots a -10 kernel.

definitely looks like a pnpbios issue, i guess

Quim Calpe (quimcalpe) wrote :

No luck here with "pnpbios=off acpi=force" flags :-(

without those flags however kernel still panics...

Daniel Kończyk (drmartens) wrote :

@NoWhereMan I finally tried your options, that is "pnpbios=off acpi=force"
It works :) I'm running the latest kernel now, that is -10.30 and it boots wothout problems. I also tried adding only "acpi=force" and it boots as well.
But in my opinion it's still broken. I wouldn't expect any newbie editing his grub menu.lst... I'm adding my kernel panic screenshot, because it looks a bit different than the ones seen here. I hope it will help somehow. Thanks

Adrian Harvey (ajharvey) wrote :

I have also tried it with the "pnpbios=off acpi=force" and that does let my system boot. Clearly a bug though.

I think the next step is for this bug to be marked confirmed. Who does that, and what information do they need to reassure themselves that it's a real bug? It sure seems real from here! Do they need to reproduce it, or what??

Daniel Kończyk (drmartens) wrote :

Yeah, I'm wondering too, what should be done, to make this BUG confirmed and fixed...

Sslaxx (stuart-sslaxx) wrote :

Tried acpi=off and force, with pnpbios=off, nolapic and noapic options... nothing works, 2.6.17-31 does not boot under any circumstances on this machine.

VT8378 (KM400/A) motherboard. Athlon XP 2000+.

Adrian Harvey (ajharvey) wrote :

SSlaxx,
Can you confirm you have the same bug as the rest of us, ie: the kernel panics right after an acpi_hw_low_level_read?

still panic'ing if disabling those two options, even with the latest updates

Daniel Kończyk (drmartens) wrote :

Yep, same here. Actually, in my case "acpi=force" is enough to boot..

Peter Miller (szr4321) wrote :

Same problem here. Kernel panic after acpi_hw_low_level_read, "acpi=force" lets me boot without problems.

Peter Miller (szr4321) wrote :

Forgot to add my system specs: Athlon XP 2000+ on an Elitegroup K7VTA3 (KT333 Northbridge, VT8235 Southbridge)

Quim Calpe (quimcalpe) wrote :

@Adrian Harvey: As I reported above, I'm in the same situation as Sslaxx, and I can confirm from the very beginning of the bug, it's the same, at least the core dump is exactly the same. Those flags doesn't work here...

@Sslaxx: I noticed you probably have a Via chipset, like me, it could be the reason the flags aren't working for us, anyway the flags are a workaround, and the bug should be solved without requiring those extra flags...

For me the only thing that helps is changing in BIOS the interrupt mode from APIC to PIC, then I can boot Ubuntu, but Windows XP becomes unbootable ;-)

@Quim Calpe
my system has a Via chipset, too, but the flags work :/

Quim Calpe (quimcalpe) wrote :

Maybe related to AMD XP processors then (the flags issue)?

oh, maybe I have an Intel; we probably have different BIOSes, too; as I've already said, mine is this "Insyde Software MobilePro BIOS ver 4.20.10" ...

Adrian Harvey (ajharvey) wrote :

@Quim Calpe,
I have a VIA chipset as well...

Quim Calpe (quimcalpe) wrote :

Well it seems most of us (all?) have a VIA chipset, it could have some relation with the kernel panic, couldn't it?

Sslaxx and me can't boot even with the flags, I noticied his chipset is KM400, mine is KT400, could be a particular problem...

IMPORTANT! confirming that now acpi=force is enough to boot (no pnpbios=off)
but--

NEW ISSUE! are you having issues with usb devices? I DO! They're not activated, usb ports look dead! with -7 they work!

please confirm

Peter Miller (szr4321) wrote :

My USB devices are working flawlessly using acpi=force.

did you try to unplug and plug them back after the boot have finished?

I confirm that if you plug them before the boot hey may work (my mouse however is choppy), if you plug them when system is up, they're not seen

Ben Collins (ben-collins) wrote :

The initial problem of amd64-agp is fixed. So please open another bug regarding the USB issues.

Changed in linux-source-2.6.17:
status: Unconfirmed → Fix Released
Quim Calpe (quimcalpe) wrote :

Ben, The problem is not fixed here, should I file a new bug?

I'm sorry, Ben, but this bug is not related to amd64-agp; as I already said, mine is not an amd64

Ben Collins (ben-collins) wrote :

Ok, there's a lot of cruft in this bug. People, please don't put "me too's" into a bug report about a crash just because you have a crash too. Unless your traceback is the same, then you have a different bug.

Changed in linux-source-2.6.17:
status: Fix Released → Confirmed

my dmesg. it may help to fix both this issue (that looks really acpi related). booted with acpi=force (without that, it will just panic)

noapic made usb work!!

so, for me optional parameters are now "noapic acpi=force"

HTH

Sslaxx (stuart-sslaxx) wrote :

acpi=force never worked under the older kernel (2.6.15) for me, and doesn't with the newer one, either. noapic doesn't do much on my hardware, either and nor does pnpbios=off. Still no joy as of 22nd October.

Sslaxx (stuart-sslaxx) wrote :

2.6.17-10-386 appears to work (was using the generic kernel before) without need for any extra boot parameters.

cerealkilla (cerealkilla23) wrote :

I get the same error as the picture shown and cannot even boot the system, except the number on the left is a bit higher. I am also running on a VIA chipset, so these bugs may be related. https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.17/+bug/65710

I am having the exact same problem as original poster, whenever I try to boot the edgy eft live cd. I have AMD Barton 2600+ on MSI KT4 mobo, which uses VIA chipset. I think this definately has to do with VIA. I have tried ACPI =force, ACPI=off, pnpbios=off, and various combinations of these flags, all to no avail. I have updated the BIOS, but it didn't help. AS far as I can see, my BIOS has no ACPI options to play with. Dapper works fine.

Jussi Kukkonen (jku) wrote :

As far as I can see this is a duplicate of bug 63134 (or maybe the other way round as this one is older, but the other bug has a patch attached so I'm going this way).

This bug has quite a few people posting in it, so I had some problems identifying the "correct bug" as reported by NoWhereMan... Just to reiterate:
* Problem is a kernel panic at boot in quirk_via_abnormal_poweroff-function
* The problem appeared in 2.6.17-8
* acpi=force workaround works

I'm marking this one duplicate, please revert if you disagree.

The 18 month support period for Edgy Eft 6.10 has reached its end of life. As a result, we are closing the linux-source-2.6.17 Edgy Eft kernel task. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers