keyboard and mouse freeze after login

Bug #364530 reported by paperdragon on 2009-04-21
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux-rt (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

I've installed Jaunty 9.04 and Linux kernels, both 2.6.28-11-generic and the 2.6.28-3-rt and I'm having no problems with the generic kernel, but for some reason I cannot determine, the mouse and keyboard stop responding after I log in using the real-time kernel. Sometimes it's straight away, and sometimes I'll get a few minutes of functionality with the keyboard and mouse. After it freezes, I can tell the system is still running and has not completely locked up because the system time still goes, and pressing my power button on my pc still brings up the shutdown menu.

As for my computer, I'm running:

Intel Core 2 Quad at 2.3 ghz per core
3gb ram (well 4 but it shows on the system monitor as 3)
Logitech optical mouse and and bog standard qwerty keyboard, both ps/2

Now I'm not sure where I should be looking for errors in logs and stuff, so I'd need a bit of direction in that respect.

Thanks

Gareth

Also I'm running an Nvidia 9800gtx+ with the Nvidia 180.44 drivers
G

One more thing, I'm getting no freezes when I log into a xterm session, this is what I'm doing right now actually. Everything seems functional here, I can load firefox from the terminal etc., it's only when I go into a full gnome session when it freezes up.

Michele Gambirasi (gamby86) wrote :

Same situation with me. I'm trying ubuntu and ubuntustudio 9.04 on a Shuttle XPC SG33G5M (Intel G33 with GMA3100 graphics), core2duo E6550, 2GB of RAM, logitech cordless desktop keyboard and mouse.
Using generic kernel doesn't cause system freezes.

Michele Gambirasi (gamby86) wrote :

I just tried kubuntu 9.04 with generic and rt kernel.
The rt kernel causes system freeze with kde too.

In my case it seems completely freezed: the system time doesn't go.

Changed in linux-rt (Ubuntu):
status: New → Confirmed

In my case, a Core2Quad with 4GiB of RAM and a GeForce 9800GT, with a clean kubuntu 9.04 plus ubuntustudio-audio: booting into -rt (and after hitting #360309 and installing linux-headers-rt) freezes sometime after entering the session, sometimes sooner, others later.

My system seems to be totally frozen, not just mouse and/or keyboard.

Florian Hofmann (fhaust) wrote :

I can confirm this for kubuntu 9.04 running linux-rt 2.6.28-3 on an inspiron 6400 (Core2Duo, ATI Mobility X1400).

I think this is a duplicate of bug #354816.

Davidmhanson (davidmhanson) wrote :

I Used Ubuntu Studio for about a year now, never had any problems. Upgraded to U.S. 9.04.... Getting random freeze ups. I can be on from a minute to 30 minutes... then freeze up. I use an Intel board... LGA775 Socket set.... have GeForce 6200 LE, 2GiB RAM. Pentium 4 3.2 Ghz - HT. My system monitor is repoarting a 50% load with just desktop running. I disabled the HT on the CPU. Normal load was shown on System Monitor but, system still froze up.

eruditelite (eruditelite) wrote :

I'm having the same problem; and have been hoping an update would fix it for some time. The generic kernel runs for quite some time (weeks) and never exhibits this problem. With the real-time kernel, never more than a few days.

== 1 ==
I've tried updating BIOS (motherboard is MSI K9NBPM2-FID, MS-7252, VER: 1.2. Currently running BIOS version 5.8). I tried this because I get messages like the following from /var/log/syslog

Jul 9 07:51:43 gandalf kernel: [ 1.442036] ACPI Warning (nspredef-0858): \_TZ_.THRM._TZD: Return Package type mismatch at index 0 - found Processor, expected Reference [20080926]
Jul 9 07:51:43 gandalf kernel: [ 1.442042] ACPI: Expecting a [Reference] package element, found type C

With the latest BIOS, I still get the above, and the lockup still happens.

== 2 ==
I've now updated my nvida (00:05.0 VGA compatible controller: nVidia Corporation C51 [Quadro NVS 210S/GeForce 6150LE] (rev a2)) driver to NVIDIA-Linux-x86_64-185.18.14-pkg2 using the instructions at http://ubuntuforums.org/archive/index.php/t-1125400.html. Note the patch by tinivole described in the April 28th, 2009, 02:00 PM comment is required to build for the -rt kernel. I'm still running with this and will report back whenever the lockup occurs or if it doesn't after about a week.

== 3 ==
If there's something else I can do that would help resolve this, let me know.

eruditelite (eruditelite) wrote :

I got another lockup within an hour. I then tried reverting to the "nv" driver. That resulted in a lockup as well.

eruditelite (eruditelite) wrote :

After trying a newer version of Linux, and mucking about with ACPI, I've given up and reverted back to Ubuntu Studio 8.04. This solved all my problems, at least so far.

Owen Williams (ywwg) wrote :

I think I have a similar issue, although I can use my computer for long periods of time before I get the input freeze. In my case, the mouse still works, although it won't click, and I can still press ctrl-alt-f1 to get to a console. And I can still type in the console as well. So it seems to be strictly an X issue.

Alessio Igor Bogani (abogani) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that could be fixed in the Beta release of Karmic Koala. It would help us greatly if you could test with it! Thanks again and we appreciate your help.

Alessio Igor Bogani (abogani) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux-rt (Ubuntu):
status: Confirmed → Invalid
eruditelite (eruditelite) wrote :

Alessio,

Karmic works fine. No lockups so far (over a week)!

yajo (yajodj) wrote :

Hi, I'm using linux-rt 2.6.31-9 on karmik and I have the same bug. Which version has it fixed?

Just installed Ubuntu 9.10 amd64 on Tyan Thunder K8SR.
Has same problem

I can boot, log-in, but if I let the system sit with mouse in middle of desktop for a few minutes the mouse and keyboard hang.

*** However ***

If: boot, log-in, immediately click on FireFox, make sure I hit the web, move mouse off FireFox so it quits blinking, then let mouse dwell on desktop for a few minutes, mouse and keyboard are OK. (sounds like xterm "fix")

I though this may have been related to Update Manager trying to make connection but failing. Disabling Update Manager did not fix the problem. Is there anything else the "phones home" about 1-2 minutes after log-in? If so, how can I experiment by selectively turning them off.

Note, my Linux/Ubuntu experience is trying to get this sucker installed on Tyan server box with two AMD Opteron 270 processors. IOW completely lost.

Jim

Bert Claes (bertmlclaes) wrote :

I just installed Ubuntu 10.04 (32 bit) to a clean harddisk and have the same problem.
I didn't have the problem with Ubuntu 9.10.

When I start linux, the login screen starts..
sometimes..
- if I wait a few minutes (without typing or moving the mouse) the computer freezes
- if I type my password, it looks like a key is constantly being pressed, and the computer freezes
- if I log in fast enough, and wait a while, gnome freezes with just the desktop loaded or with a key constantly being pressed.
.. but always one of the three.

* I used a PS/2 keyb&mouse, and an USB keyb&mouse, and had the same problem.
* Without keyboard, I still have the same problem with the mouse.
* I disabled the wireless network drivers.
* chose in the installation for an encrypted, and later an unencrypted homefolder, still had the same problem

But..
When I use, in GRUB, the recovery mode, and use the root shell, I don't have any problems.
I can use the "startx" command to start gnome. Firefox works, Nautilus works.

info:
kernel 2.6.32-21-generic
GNOME 2.30.0
2 x Intel Pentium 4 CPU 2.40GHz
NVIDEA Geforce4 MX440 64MB RAM
524MB RAM

Changed in linux-rt (Ubuntu):
status: Invalid → Confirmed
Bert Claes (bertmlclaes) wrote :

I think it's related to Bug #522091.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers