Comment 6 for bug 60938

Booted http://cdimage.ubuntu.com/daily-live/20060927.2/edgy-desktop-i386.iso on IBM Thinkpad X40 with the following chipset:

02:02.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
        Subsystem: AMBIT Microsystem Corp. Unknown device 0408
        Flags: bus master, medium devsel, latency 168, IRQ 217
        Memory at d0200000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [44] Power Management version 2

This is the information you requested:

root@ubuntu:~# modprobe ath_pci
WARNING: Error inserting ath_rate_sample (/lib/modules/2.6.17-10-generic/madwifi/ath_rate_sample.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting ath_pci (/lib/modules/2.6.17-10-generic/madwifi/ath_pci.ko): Unknown symbol in module, or unknown parameter (see dmesg)
root@ubuntu:~# modprobe ath_hal
FATAL: Module ath_hal not found.
root@ubuntu:~# find /lib/modules/ | grep ath_
/lib/modules/2.6.17-10-generic/madwifi/ath_pci.ko
/lib/modules/2.6.17-10-generic/madwifi/ath_rate_sample.ko
/lib/modules/2.6.17-10-generic/kernel/net/ipv4/multipath_drr.ko
/lib/modules/2.6.17-10-generic/kernel/net/ipv4/multipath_random.ko
/lib/modules/2.6.17-10-generic/kernel/net/ipv4/multipath_rr.ko
/lib/modules/2.6.17-10-generic/kernel/net/ipv4/multipath_wrandom.ko
/lib/modules/2.6.17-10-generic/volatile/ath_hal.ko
root@ubuntu:~# sudo insmod /lib/modules/2.6.17-10-generic/volatile/ath_hal.ko
root@ubuntu:~# sudo modprobe ath_pci
root@ubuntu:~#