ath_hal missing from modules.dep

Bug #60938 reported by Jacob Peddicord on 2006-09-17
34
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.17 (Ubuntu)
High
Scott James Remnant (Canonical)

Bug Description

Under some circumstances, the ath_hal.ko module is properly linked and present, but not found by modprobe due to not being listed in modules.dep.

It's not clear how this could happen, since depmod is run both in the kernel postinst and in the l-r-m postinst.

Anita (a-lewis) wrote :

This seems to be fixed with 2.6.17-8. I just installed it and if fixed it for me.

Anita

Jacob Peddicord (jpeddicord) wrote :

Bug is fixed in latest kernel, 2.6.17-8.

Changed in linux-restricted-modules-2.6.17:
status: Unconfirmed → Fix Released
Niran Babalola (niran) wrote :

This is broken again with 2.6.17-10.

$ uname -a
Linux mog 2.6.17-10-generic #2 SMP Tue Sep 26 16:53:47 UTC 2006 i686 GNU/Linux

From dmesg:

[17179595.288000] wlan: 0.8.4.2 (0.9.2)
[17179595.296000] ath_rate_sample: Unknown symbol ath_hal_computetxtime
[17179595.400000] sd 0:0:1:0: Attached scsi generic sg0 type 0
[17179595.448000] ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 177
[17179595.448000] PCI: Setting latency timer of device 0000:01:00.0 to 64
[17179595.448000] sky2 v1.4 addr 0x90200000 irq 177 Yukon-EC (0xb6) rev 2
[17179595.448000] sky2 eth0: addr 00:17:f2:2e:6b:94
[17179595.504000] ts: Compaq touchscreen protocol output
[17179595.532000] ath_pci: Unknown symbol ath_rate_tx_complete
[17179595.532000] ath_pci: Unknown symbol _ath_hal_attach
[17179595.532000] ath_pci: Unknown symbol ath_rate_attach
[17179595.532000] ath_pci: Unknown symbol ath_rate_newassoc
[17179595.532000] ath_pci: Unknown symbol ath_hal_computetxtime
[17179595.532000] ath_pci: Unknown symbol ath_rate_dynamic_proc_register
[17179595.532000] ath_pci: Unknown symbol ath_hal_mhz2ieee
[17179595.532000] ath_pci: Unknown symbol ath_hal_detach
[17179595.532000] ath_pci: Unknown symbol ath_hal_probe
[17179595.532000] ath_pci: Unknown symbol ath_rate_node_cleanup
[17179595.532000] ath_pci: Unknown symbol ath_rate_detach
[17179595.532000] ath_pci: Unknown symbol ath_rate_node_init
[17179595.532000] ath_pci: Unknown symbol ath_rate_findrate
[17179595.532000] ath_pci: Unknown symbol ath_hal_init_channels
[17179595.532000] ath_pci: Unknown symbol ath_rate_newstate
[17179595.532000] ath_pci: Unknown symbol ath_rate_setupxtxdesc
[17179595.532000] ath_pci: Unknown symbol ath_hal_getwirelessmodes

Jacob Peddicord (jpeddicord) wrote :

Stops functioning in 2.6.17-10 (?)

Changed in linux-restricted-modules-2.6.17:
status: Fix Released → Unconfirmed
Chris Jones (cmsj) on 2006-09-27
Changed in linux-restricted-modules-2.6.17:
importance: Undecided → Critical
status: Unconfirmed → Confirmed
Matt Zimmerman (mdz) wrote :

What happens when you run "sudo modprobe ath_hal" by hand? Check dmesg afterward.

Ben, do you know what's going on here?

Changed in linux-restricted-modules-2.6.17:
importance: Critical → High
status: Confirmed → Needs Info
Chris Jones (cmsj) wrote :

Booted http://cdimage.ubuntu.com/daily-live/20060927.2/edgy-desktop-i386.iso on IBM Thinkpad X40 with the following chipset:

02:02.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
        Subsystem: AMBIT Microsystem Corp. Unknown device 0408
        Flags: bus master, medium devsel, latency 168, IRQ 217
        Memory at d0200000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [44] Power Management version 2

This is the information you requested:

root@ubuntu:~# modprobe ath_pci
WARNING: Error inserting ath_rate_sample (/lib/modules/2.6.17-10-generic/madwifi/ath_rate_sample.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting ath_pci (/lib/modules/2.6.17-10-generic/madwifi/ath_pci.ko): Unknown symbol in module, or unknown parameter (see dmesg)
root@ubuntu:~# modprobe ath_hal
FATAL: Module ath_hal not found.
root@ubuntu:~# find /lib/modules/ | grep ath_
/lib/modules/2.6.17-10-generic/madwifi/ath_pci.ko
/lib/modules/2.6.17-10-generic/madwifi/ath_rate_sample.ko
/lib/modules/2.6.17-10-generic/kernel/net/ipv4/multipath_drr.ko
/lib/modules/2.6.17-10-generic/kernel/net/ipv4/multipath_random.ko
/lib/modules/2.6.17-10-generic/kernel/net/ipv4/multipath_rr.ko
/lib/modules/2.6.17-10-generic/kernel/net/ipv4/multipath_wrandom.ko
/lib/modules/2.6.17-10-generic/volatile/ath_hal.ko
root@ubuntu:~# sudo insmod /lib/modules/2.6.17-10-generic/volatile/ath_hal.ko
root@ubuntu:~# sudo modprobe ath_pci
root@ubuntu:~#

Matt Zimmerman (mdz) wrote :

It looks like depmod hasn't been run for some reason.

ls -l /lib/modules/2.6.17-10-generic/modules.dep \
  /var/lib/dpkg/info/linux-restricted-modules-2.6.17-10-generic.list \
  /var/lib/dpkg/info/linux-image-2.6.17-10-generic.list

and attach /var/lib/dpkg.log

After you've collected that information, 'sudo depmod' should correct the problem permanently.

Matt Zimmerman (mdz) wrote :

I've noticed that on my system, ath_hal is missing from modules.dep for 2.6.17-8-generic (which is the kernel I'm currently running), but is present for -9 and -10.

Changed in linux-restricted-modules-2.6.17:
status: Needs Info → Confirmed
description: updated
Chris Jones (cmsj) wrote :

root@ubuntu:~# ls -l /lib/modules/2.6.17-10-generic/modules.dep /var/lib/dpkg/info/linux-restricted-modules-2.6.17-10-generic.list /var/lib/dpkg/info/linux-image-2.6.17-10-generic.list
-rw-r--r-- 1 root root 336274 2006-09-27 12:24 /lib/modules/2.6.17-10-generic/modules.dep
-rw-r--r-- 1 root root 140754 2006-09-27 12:11 /var/lib/dpkg/info/linux-image-2.6.17-10-generic.list
-rw-r--r-- 1 root root 12347 2006-09-27 12:11 /var/lib/dpkg/info/linux-restricted-modules-2.6.17-10-generic.list
root@ubuntu:~#

Chris Jones (cmsj) wrote :

depmod does indeed permanently fix the problem, although obviously a live cd will need that run on each boot

Jacob Peddicord (jpeddicord) wrote :

depmod fixes the problem here, but not completely:

Open the network monitor applet after you have had your system turned on for more than three minutes. You will notice that it disconnects for 1/2 second, but then reconnects again. This is not a glitch with the applet, as the connection actually halts momentarily. Would it have anything to do with this?

Matt Zimmerman (mdz) wrote :

No, that would not be related to this at all.

Matt Zimmerman (mdz) wrote :

Chris, the output you sent makes it look like you ran depmod before the ls command, which would have lost the information I was looking for. Can you confirm?

Matt Zimmerman (mdz) on 2006-10-12
Changed in linux-restricted-modules-2.6.17:
assignee: nobody → adconrad
Chris Jones (cmsj) wrote :

I'm afraid I can't really confirm one way or the other for sure, but I would say that the timestamps on the files are all earlier than the timestamps on my comments. I would expect that those files have the same timestamps as the files on the beta live CD, but I do not have one to hand to prove that.

On Fri, Oct 13, 2006 at 10:45:42AM -0000, Chris Jones wrote:
> I'm afraid I can't really confirm one way or the other for sure, but I
> would say that the timestamps on the files are all earlier than the
> timestamps on my comments. I would expect that those files have the same
> timestamps as the files on the beta live CD, but I do not have one to
> hand to prove that.

Oh, did you experience this problem on an unmodified, uninstalled live CD?
That would be very useful to know.

--
 - mdz

Chris Jones (cmsj) wrote :

Yes, I believe this was a live CD I noticed it on (see my comment dated 2006-09-28 01:03:30 BST)

Matt Zimmerman (mdz) wrote :

I see; that makes a difference then.

Adam, can you think of anything which could explain this being wrong in the livefs?

Matt Zimmerman (mdz) wrote :

I've confirmed that this problem does not exist in the current edgy i386 desktop CD.

However, I would still like to hear from Adam about possible explanations before deciding whether this is resolved or not.

Chris Jones (cmsj) wrote :

I have just been talking to someone who did an upgrade to Edgy. In the Live CD everything was fine, after install his PS2 keyboard was not detected. I suggested he try the live CD again, mount his install, chroot and run depmod and it appears to have fixed it, but I'm not sure if PS2 keyboards are even handled by a module, so that may have been something else.

Matt Zimmerman (mdz) wrote :

On Mon, Oct 16, 2006 at 03:22:49PM -0000, Chris Jones wrote:
> I have just been talking to someone who did an upgrade to Edgy. In the
> Live CD everything was fine, after install his PS2 keyboard was not
> detected. I suggested he try the live CD again, mount his install,
> chroot and run depmod and it appears to have fixed it, but I'm not sure
> if PS2 keyboards are even handled by a module, so that may have been
> something else.

Unrelated; this has only to do with the restricted modules.

--
 - mdz

Adam Conrad (adconrad) wrote :

I'm still trying to find convincing explanations. Are we beginning to assume that each person who had this problem installed from a (presumably) faulty live/desktop CD at some point, and that kernel was the broken one?

Matt Zimmerman (mdz) wrote :

On Tue, Oct 17, 2006 at 11:53:27AM -0000, Adam Conrad wrote:
> I'm still trying to find convincing explanations. Are we beginning to
> assume that each person who had this problem installed from a
> (presumably) faulty live/desktop CD at some point, and that kernel was
> the broken one?

Given that I saw this on my laptop, with kernels which were installed via
upgrades during edgy, that assumption wouldn't seem to fit the facts.

My best guess is that a difference in the running vs. on-disk kernel caused
some inconsistency.

--
 - mdz

Matt Zimmerman (mdz) on 2006-10-24
Changed in linux-restricted-modules-2.6.17:
assignee: adconrad → keybuk
DiCiCat (dicicat) wrote :

Same thing here.
I just upgraded my dapper to edgy.
My atheros wifi card works with 2.6.17-10-386 without any problem, but with 2.6.17-10-generic i'm unable to find ath_hal module.

DiCiCat (dicicat) wrote :

also solved after a
sudo depmod -a

Confirmed fixed with the new initramfs-tools upload

Changed in linux-restricted-modules-2.6.17:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments