linux-cloud-tools missing from precise

Bug #1345059 reported by Samuel Leslie on 2014-07-19
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-lts-trusty (Ubuntu)
Medium
Unassigned
Precise
High
Andy Whitcroft
linux-meta-lts-trusty (Ubuntu)
Undecided
Unassigned
Precise
High
Andy Whitcroft

Bug Description

The Trusty Tahir Hardware Enablement Stack for Ubuntu 12.04 is available and being aggressively promoted to existing Ubuntu 12.04 deployments running now End-of-Life Hardware Enablement Stacks. However, the linux-cloud-tools packages have not been made available to Precise users. This package was newly introduced in Trusty Tahir and contains "cloud specific" tooling associated with a given kernel version, separate from the general tools provided in the linux-tools packages. Right now, this package only contains Hyper-V specific daemons and utilities.

The result of this is that on updating to the Trusty HWE the userspace hv-kvp-daemon Hyper-V daemon previously provided by the linux-tools packages is no longer present and will fail to start when the hv-kvp-daemon-init package attempts to do so:
hv_kvp_daemon not available for kernel 3.13.0-30

This is in my view a very serious issue as it risks potentially breaking Hyper-V deployments of Ubuntu 12.04 which have either updated to the Trusty HWE or will be installed via the 12.04.05 installation media (the latter has yet to be released). From my brief look at the packaging situation the linux-cloud-tools packages depend on a newer version of sysv-rc than is currently available for 12.04, though, this is the only unmet dependency and I'm unsure if the newer sysv-rc is technically required or was just pinned against the release that Ubuntu 14.04 shipped with.

Samuel Leslie (sdl) on 2014-07-19
affects: hv-kvp-daemon-init (Ubuntu) → linux-meta (Ubuntu)
Brad Figg (brad-figg) on 2014-07-19
affects: linux-meta (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1345059

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: precise
Samuel Leslie (sdl) wrote :

Not sure apport-collect is helpful for this particular bug? It crashes regardless:

*** Collecting problem information

The collected information can be sent to the developers to improve the
application. This might take a few minutes.
.ERROR: hook /usr/share/apport/general-hooks/cloud_archive.py crashed:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/apport/report.py", line 719, in add_hooks_info
    symb['add_info'](self, ui)
  File "/usr/share/apport/general-hooks/cloud_archive.py", line 18, in add_info
    if '~cloud' in packaging.get_version(package) and \
  File "/usr/lib/python2.7/dist-packages/apport/packaging_impl.py", line 95, in get_version
    raise ValueError('package does not exist')
ValueError: package does not exist
.....No packages found matching linux.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
Tim Gardner (timg-tpi) on 2014-07-22
Changed in linux (Ubuntu Precise):
assignee: nobody → Andy Whitcroft (apw)
status: New → In Progress
Changed in linux (Ubuntu):
status: Confirmed → Invalid
Adam Conrad (adconrad) wrote :

Given the hyperv reorg in trusty, it's probably saner to make lts-trusty produce packages that look more like the previous versions and less like trusty, rather than trying to backport all the other userspace changes required to work with the new package layout. Maybe. Will discuss with Andy.

jrgns (jurgens.du.toit) wrote :

We're running 12.04 on Hyper V, and have now run into this problem.

Starting the hv-kvp-daemon-init start service fails silently:

sudo service hv-kvp-daemon-init start
hv-kvp-daemon-init start/running, process 2222

Running the hv-kvp-daemon-init command direclty hightlights the version difference:

$ /usr/sbin/hv_kvp_daemon
/usr/sbin/hv_kvp_daemon_3.13.0-34 not found
You may need to install linux-tools-3.13.0-34

Is there a way around this?

Andy Whitcroft (apw) on 2014-08-28
affects: linux (Ubuntu) → linux-lts-trusty (Ubuntu)
Changed in linux-lts-trusty (Ubuntu Precise):
importance: Undecided → High
Andy Whitcroft (apw) wrote :

It appears we do not currently make the cloud pieces on the assumption that h/w enablement is not useful in a cloud image. That said the recommendation for Hyper-V specifically is now to use these HWE kernels. I will look at enabling these in the lts-trusty kernel in the first instance. It appears we have sufficient smarts in the existing wrappers to handle the new layout and split. I propose we do make the linux-tools-lts-trusty Recommend: the cloud-tools so that existing behaviours are maintained.

Andy Whitcroft (apw) on 2014-08-29
Changed in linux-meta-lts-trusty (Ubuntu):
status: New → Invalid
Changed in linux-meta-lts-trusty (Ubuntu Precise):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Andy Whitcroft (apw)
Andy Whitcroft (apw) wrote :

Patches submitted to kernel-team@ for review.

Andy Whitcroft (apw) on 2014-09-03
Changed in linux-lts-trusty (Ubuntu Precise):
status: In Progress → Fix Committed
Andy Whitcroft (apw) on 2014-09-04
Changed in linux-meta-lts-trusty (Ubuntu Precise):
status: In Progress → Fix Committed
Enrico S. (es-on-launchpad) wrote :

Hey guys,

I would like to help if needed.

I ran into that as I tried to install the Tools and stuff to get a proper Hyper-V Integration running.

So, what can i do?

I'm on Server 2012 R2 and Ubuntu 2014 LTS

Kernel 3.13-24

Launchpad Janitor (janitor) wrote :
Download full text (44.7 KiB)

This bug was fixed in the package linux-lts-trusty - 3.13.0-36.63~precise1

---------------
linux-lts-trusty (3.13.0-36.63~precise1) precise; urgency=low

  * [ Andy Whitcroft ]

    * UBUNTU: [Config] amd64 -- enable cloud-tools
    - LP: #1345059

  [ Joseph Salisbury ]

  * Release Tracking Bug
    - LP: #1365052

  [ Feng Kan ]

  * SAUCE: (no-up) irqchip:gic: change access of gicc_ctrl register to read
    modify write.
    - LP: #1357527
  * SAUCE: (no-up) arm64: optimized copy_to_user and copy_from_user
    assembly code
    - LP: #1358949

  [ Ming Lei ]

  * SAUCE: (no-up) Drop APM X-Gene SoC Ethernet driver
    - LP: #1360140
  * [Config] Drop XGENE entries
    - LP: #1360140
  * [Config] CONFIG_NET_XGENE=m for arm64
    - LP: #1360140

  [ Stefan Bader ]

  * SAUCE: Add compat macro for skb_get_hash
    - LP: #1358162
  * SAUCE: bcache: prevent crash on changing writeback_running
    - LP: #1357295

  [ Suman Tripathi ]

  * SAUCE: (no-up) arm64: Fix the csr-mask for APM X-Gene SoC AHCI SATA PHY
    clock DTS node.
    - LP: #1359489
  * SAUCE: (no-up) ahci_xgene: Skip the PHY and clock initialization if
    already configured by the firmware.
    - LP: #1359501
  * SAUCE: (no-up) ahci_xgene: Fix the link down in first attempt for the
    APM X-Gene SoC AHCI SATA host controller driver.
    - LP: #1359507

  [ Tuan Phan ]

  * SAUCE: (no-up) pci-xgene-msi: fixed deadlock in irq_set_affinity
    - LP: #1359514

  [ Upstream Kernel Changes ]

  * iwlwifi: mvm: Add a missed beacons threshold
    - LP: #1349572
  * mac80211: reset probe_send_count also in HW_CONNECTION_MONITOR case
    - LP: #1349572
  * genirq: Add an accessor for IRQ_PER_CPU flag
    - LP: #1357527
  * arm64: perf: add support for percpu pmu interrupt
    - LP: #1357527
  * cifs: sanity check length of data to send before sending
    - LP: #1283101
  * KVM: nVMX: Pass vmexit parameters to nested_vmx_vmexit
    - LP: #1329434
  * KVM: nVMX: Rework interception of IRQs and NMIs
    - LP: #1329434
  * KVM: vmx: disable APIC virtualization in nested guests
    - LP: #1329434
  * HID: Add transport-driver functions to the USB HID interface.
    - LP: #1353021
  * ahci_xgene: Removing NCQ support from the APM X-Gene SoC AHCI SATA Host
    Controller driver.
    - LP: #1358498
  * fold d_kill() and d_free()
    - LP: #1354234
  * fold try_prune_one_dentry()
    - LP: #1354234
  * new helper: dentry_free()
    - LP: #1354234
  * expand the call of dentry_lru_del() in dentry_kill()
    - LP: #1354234
  * dentry_kill(): don't try to remove from shrink list
    - LP: #1354234
  * don't remove from shrink list in select_collect()
    - LP: #1354234
  * more graceful recovery in umount_collect()
    - LP: #1354234
  * dcache: don't need rcu in shrink_dentry_list()
    - LP: #1354234
  * lift the "already marked killed" case into shrink_dentry_list()
  * split dentry_kill()
    - LP: #1354234
  * expand dentry_kill(dentry, 0) in shrink_dentry_list()
    - LP: #1354234
  * shrink_dentry_list(): take parent's ->d_lock earlier
    - LP: #1354234
  * dealing with the rest of shrink_dentry_list() livelock
    - LP: #1354234
  * dentry_kill() doesn't need the second argument now
    - L...

Changed in linux-lts-trusty (Ubuntu Precise):
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-meta-lts-trusty - 3.13.0.36.31

---------------
linux-meta-lts-trusty (3.13.0.36.31) precise; urgency=low

  * Ubuntu-lts-3.13.0-36
  * added linux-cloud-tools-lts-generic to pull in the appropriate
    cloud tools on amd64 (LP: #1345059).
  * added linux-cloud-tools-lts-generic as Recommends: on
    linux-tools-lts-generic to simplify installation for legacy users
    (LP: #1345059).
  * UBUNTU: Expand the metapackage description
    Make it clear that these are metapackages.
    (LP: #1361639)
 -- Andy Whitcroft <email address hidden> Thu, 28 Aug 2014 17:17:48 +0100

Changed in linux-meta-lts-trusty (Ubuntu Precise):
status: Fix Committed → Fix Released
Enrico S. (es-on-launchpad) wrote :

At a first quick look it seems to be ok. Thank you guys.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers