Comment 0 for bug 1520343

Dennis Marttinen (technowelho) wrote :

I have recently installed Ubuntu 15.10 (64-bit) alongside Windows 10 on an Acer Aspire VN7-792G-76ZH and discovered, that the Qualcomm wireless card doesn't work.
The card has the device id 168c:003e as many other cards, for example the Qualcomm Atheros Killer (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1383184),
but it has a newer revision number (32) and the suggested fixes work only partially and the wireless is unusable.

The computer has just been released this summer and is Intel Skylake -based.

My lspci:
00:00.0 Host bridge [0600]: Intel Corporation Sky Lake Host Bridge/DRAM Registers [8086:1910] (rev 07)
00:01.0 PCI bridge [0604]: Intel Corporation Sky Lake PCIe Controller (x16) [8086:1901] (rev 07)
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:191b] (rev 06)
00:14.0 USB controller [0c03]: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller [8086:a12f] (rev 31)
00:14.2 Signal processing controller [1180]: Intel Corporation Sunrise Point-H Thermal subsystem [8086:a131] (rev 31)
00:15.0 Signal processing controller [1180]: Intel Corporation Sunrise Point-H LPSS I2C Controller #0 [8086:a160] (rev 31)
00:15.1 Signal processing controller [1180]: Intel Corporation Sunrise Point-H LPSS I2C Controller #1 [8086:a161] (rev 31)
00:16.0 Communication controller [0780]: Intel Corporation Sunrise Point-H CSME HECI #1 [8086:a13a] (rev 31)
00:17.0 SATA controller [0106]: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] [8086:a103] (rev 31)
00:1c.0 PCI bridge [0604]: Intel Corporation Sunrise Point-H PCI Express Root Port #3 [8086:a112] (rev f1)
00:1c.3 PCI bridge [0604]: Intel Corporation Sunrise Point-H PCI Express Root Port #4 [8086:a113] (rev f1)
00:1c.4 PCI bridge [0604]: Intel Corporation Sunrise Point-H PCI Express Root Port #5 [8086:a114] (rev f1)
00:1f.0 ISA bridge [0601]: Intel Corporation Sunrise Point-H LPC Controller [8086:a14e] (rev 31)
00:1f.2 Memory controller [0580]: Intel Corporation Sunrise Point-H PMC [8086:a121] (rev 31)
00:1f.3 Multimedia audio controller [0401]: Intel Corporation Sunrise Point-H HD Audio [8086:a170] (rev 31)
00:1f.4 SMBus [0c05]: Intel Corporation Sunrise Point-H SMBus [8086:a123] (rev 31)
01:00.0 3D controller [0302]: NVIDIA Corporation GM107M [GeForce GTX 960M] [10de:139b] (rev ff)
07:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
08:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)

What I have tried:

I've tried the patch from bug 1383184, which has a fix for the card revision 20:

Make the directory /lib/firmware/ath10k/QCA6174/hw3.0/

And put in the patch files:
board.bin
firmware-4.bin
notice_ath10k_firmware-4.txt

ath10k_pci succeeds in loading the firmware, but it seems that the firmware is not working correctly:

dmesg | grep ath

[ 5.452683] ath10k_pci 0000:07:00.0: pci irq msi-x interrupts 8 irq_mode 0 reset_mode 0
[ 5.678420] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/cal-pci-0000:07:00.0.bin failed with error -2
[ 5.678773] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/board-pci-168c:003e:11ad:0807.bin failed with error -2
[ 5.678781] ath10k_pci 0000:07:00.0: failed to load spec board file, falling back to generic: -2
[ 5.679445] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
[ 5.679453] ath10k_pci 0000:07:00.0: could not fetch firmware file 'ath10k/QCA6174/hw3.0/firmware-5.bin': -2
[ 7.802316] ath10k_pci 0000:07:00.0: qca6174 hw3.2 (0x05030000, 0x00340aff, 168c:003e:11ad:0807 fallback) fw WLAN.RM.2.0-00180-QCARMSWPZ-1 api 4 htt 3.26 wmi 4 cal otp max_sta 32
[ 7.802329] ath10k_pci 0000:07:00.0: debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[ 8.200607] ath: EEPROM regdomain: 0x6c
[ 8.200614] ath: EEPROM indicates we should expect a direct regpair map
[ 8.200619] ath: Country alpha2 being used: 00
[ 8.200621] ath: Regpair used: 0x6c
[ 8.216605] ath10k_pci 0000:07:00.0 wlp7s0: renamed from wlan0
[ 13.462029] ath10k_pci 0000:07:00.0: failed to enable dynamic BW: -11
[ 16.461416] ath10k_pci 0000:07:00.0: could not suspend target (-11)
[ 24.760062] ath10k_pci 0000:07:00.0: failed to enable dynamic BW: -11
[ 27.759534] ath10k_pci 0000:07:00.0: could not suspend target (-11)
[ 36.046205] ath10k_pci 0000:07:00.0: failed to set arp ac override parameter: -11
[ 39.045729] ath10k_pci 0000:07:00.0: could not suspend target (-11)
[ 47.344304] ath10k_pci 0000:07:00.0: failed to enable dynamic BW: -11
[ 50.343794] ath10k_pci 0000:07:00.0: could not suspend target (-11)
[ 58.630534] ath10k_pci 0000:07:00.0: failed to enable dynamic BW: -11
[ 61.629936] ath10k_pci 0000:07:00.0: could not suspend target (-11)
[ 69.920624] ath10k_pci 0000:07:00.0: failed to enable dynamic BW: -11
[ 72.920132] ath10k_pci 0000:07:00.0: could not suspend target (-11)
[ 81.206812] ath10k_pci 0000:07:00.0: failed to enable dynamic BW: -11
[ 84.206218] ath10k_pci 0000:07:00.0: could not suspend target (-11)
...

Then it just constantly prints the last two messages on and on.
I can weirdly enough see the card in iwconfig:

wlp7s0 IEEE 802.11abgn ESSID:off/any
          Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
          Retry short limit:7 RTS thr:off Fragment thr:off
          Power Management:off

And I can see the wireless-icon in the toolbar, but scanning for access points or trying to connect to one doesn't work.

This is the furthest I've gotten. I suspect this card needs a new firmware in ath10k?

I'm currently running the development branch of Ubuntu 16.04 as hardware acceleration support for this PC is currently only supported there.
The same problem exists in this version too and I'm able to reproduce the issue.

Hoping to get this fixed, as many other new laptops seem to include the same wireless card.

/Dennis

============================================

Current system information:

Description: Ubuntu Xenial Xerus (development branch)
Release: 16.04