Atheros Qualcomm Killer N1525 Wireless-AC [168c:003e] is not supported

Bug #1383184 reported by Dimitrios Matanis on 2014-10-20
610
This bug affects 114 people
Affects Status Importance Assigned to Milestone
HWE Next
Medium
Hui Wang
Wily
Undecided
Unassigned
linux (Ubuntu)
Medium
Željko
Wily
Undecided
Unassigned
linux-firmware (Ubuntu)
Medium
Hui Wang
Wily
Medium
Seth Forshee
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

=========================================================

CURRENT STATUS:

Wily(15.10) could not work with and don't need Adam's dkms package 1.0 or 1.1

Wily(15.10) has already fixed the driver part, and the firmware part is in progress.

For now, you guys could use 15.10(purge the ath10k-dkms if you tried installing it), and make a copy of https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/plain/ath10k/QCA6174 into /lib/firmware/ath10k/

15.10 will work in a week by a simple `apt upgrade`

Distros before 15.10(lower than 4.2 kernel) please keep using the dkms(which will be relocated soon)

=========================================================

Card detail: Qualcomm Atheros Device [168c:003e] (rev 20)
Subsystem: Bigfoot Networks, Inc. Device [1a56:1525]

This is on a fully updated Ubuntu Server 14.04 installation, with the ubuntu-desktop environment installed. This happened in order to get the md raid drivers for raid0 on my system, as the desktop version doesn't support them.
---
ApportVersion: 2.14.1-0ubuntu3.5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: matanis 2333 F.... pulseaudio
 /dev/snd/controlC0: matanis 2333 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
CurrentDesktop: Unity
DistroRelease: Ubuntu 14.04
HibernationDevice: RESUME=UUID=1b192ee3-f592-43e9-bdcf-08b91c0aa9b6
InstallationDate: Installed on 2014-10-16 (3 days ago)
InstallationMedia: Ubuntu-Server 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.3)
IwConfig:
 p2p1 no wireless extensions.

 lo no wireless extensions.
MachineType: Micro-Star International Co., Ltd. GT72 2QE
NonfreeKernelModules: nvidia
Package: linux (not installed)
ProcFB: 0 EFI VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-37-generic.efi.signed root=UUID=80998dbb-1f89-4eda-be90-25e35e1c0a90 ro
ProcVersionSignature: Ubuntu 3.13.0-37.64-generic 3.13.11.7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-37-generic N/A
 linux-backports-modules-3.13.0-37-generic N/A
 linux-firmware 1.127.7
RfKill:

Tags: trusty
Uname: Linux 3.13.0-37-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 09/15/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: E1781IMS.10D
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: MS-1781
dmi.board.vendor: Micro-Star International Co., Ltd.
dmi.board.version: REV:0.C
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrE1781IMS.10D:bd09/15/2014:svnMicro-StarInternationalCo.,Ltd.:pnGT722QE:pvrREV0.C:rvnMicro-StarInternationalCo.,Ltd.:rnMS-1781:rvrREV0.C:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: GT72 2QE
dmi.product.version: REV:0.C
dmi.sys.vendor: Micro-Star International Co., Ltd.

Qualcomm Atheros Device [168c:003e] (rev 20)

mainline commit d63955b33b3bee45d784ffdfafeb93076c765660

[ 6.221281] ath10k_pci 0000:02:00.0: pci irq msi interrupts 1 irq_mode 0 reset_mode 0
[ 6.417386] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2
[ 6.417404] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA6174/hw2.1/board-pci-168c:003e:17aa:3044.bin failed with error -2
[ 6.417407] ath10k_pci 0000:02:00.0: failed to load spec board file, falling back to generic: -2
[ 6.417416] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA6174/hw2.1/board.bin failed with error -2
[ 6.417418] ath10k_pci 0000:02:00.0: failed to fetch generic board data: -2
[ 6.417420] ath10k_pci 0000:02:00.0: failed to fetch board file: -2
[ 6.417421] ath10k_pci 0000:02:00.0: could not fetch firmware files (-2)
[ 6.417423] ath10k_pci 0000:02:00.0: could not probe fw (-2)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1383184

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected trusty
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

apport information

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.18 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.18-rc1-utopic/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete

Hello.

I installed the latest x64 upstream kernel as well as the headers for it from the link you provided.

I got to the login screen, and after I entered my password it just hanged there and I never got to the desktop.
I tried one more time, and this time I did not enter my password. I used the top bar to connect to the internet in the login screen but wifi was still not recognized.

Hence, I just added the tag kernel-bug-exists-upstream. Let me know if I should have used the second one you mentioned.

P.S.: I just noticed that during the booting time I get a message saying that Bluetooth is not available either. I guess that doesn't have a proper driver either. Not sure if it's the same device or not.

Cheers.

tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Pelle Johnsen (pelle-johnsen) wrote :

Having similar issue with MSI GS60-2QE (same N1525 chipset). At a hotel with limited wifi, but will try to download upsteram kernel later

Would that be any different for you? Meaning we have the same card and same OS?

Pelle Johnsen (pelle-johnsen) wrote :

Ok I managed to try the 3.18-rc1 kernel. The nvidia-343 driver fails to build for this, so that's probably why you couldn't log in. Testing in a virtual console, no wireless interface was up.

I also tried modprobe athk10k_pci (I think this card is some atheros variant). It loaded fine, but still no wlan interface showed up. So as far as I can tell that kernel doesn't support the chipset :S

Thanks for your effort!

Just letting everybody know:

I just updated to Ubuntu 14.10 and the problem persists. Bluetooth is still not working either.

ivo schindler (k-launchpad-b) wrote :

same here: new gs70 with killer n1525 with ubuntu 14.10 and no wifi... is there a work around with compiling/installing something by hand?

Raúl Vidal (raulvior-bcn) wrote :

This card (N1525) is also used in MSI GS60 laptops. But knowing that the killer E2200 didn't make it into the kernel until 2013, I think it can take a long time to get the N1525 working under Linux.

Meanwhile, you could buy an Intel card or another Atheros card which already works under Linux. At least you know that your laptop antennas are prepared for working under 5 Ghz band, if you need.
It's something cheap, $50 at most.

It's a really good piece of hardware and it is, in my opinion, a shame to replace it with something inferior. It works great on Windows and as I'm using it there I'm willing to stay ethernet-only on linux until it gets supported.

I can't imagine its technology being majorly different than its predecessors, so hopefully it will not take years!

Zemistr (zemistr) wrote :

Same here :/
New Acer Aspire V17 Nitro Black Edition with Ubuntu 14.10 and no wifi. But, bluetooth is OK.

Hmmm how can your bluetooth be OK, Zemistr? Are you sure you have the same card? Have you manually installed some bluetooth driver?

Zemistr (zemistr) wrote :

Correction...

Bluetooth pretend like it is OK, but nothing found.
Even my phone does not find my notebook.
I have a new clean install of Ubuntu 14.10.

'lspci' say:

07:00.0 Network controller: Qualcomm Atheros Device 003e (rev 20)

In windows I install this:
Killer Wireless-AC 1525 Bluetooth – Windows 8.1 (Version 3.0.0.400)

Zemistr (zemistr) wrote :

How do I know if I have the same hardware?

You can look at the manufacturer's specs for an exact model of the wifi card. If that's the driver you installed for windows then maybe you DO have the same one, or at least a really similar variant!

For me the bluetooth icon in ubuntu (tray) does not even show up.

Zemistr (zemistr) wrote :
no longer affects: linux

Got the problem with the msi gs60 2qe

Roland Kohn (roland-kohn) wrote :

also affected with Acer Aspire VN7-591G

card is at least named the same within lspci

Roland Kohn (roland-kohn) wrote :

as stated by a sticker on the back of Acer Aspire VN7-591G the builtin wifi/bluetooth module seems to be "QCNFA344", so probably not the same as mentioned here

Michael Helten (mrhelten) wrote :

Same problem with Acer Aspire VN7-591G and Ubuntu 14.10...
lspci returns Qualcomm Atheros Device [168c:003e] (rev 20)
Sticker on the back states "QCNFA344"... so far no wifi and no bluetooth
Any Idea for a workaround?

Same here on Alienware 13

Catofes (7-i-x) wrote :

Same in MSI Gs60-PE

S.Lacy (stevelacy) wrote :

All MSI late 2014 and 2015 models are affected.

Johannes (jps-o) wrote :

I'm on an Acer Aspire VN7-591G and Ubuntu 15.04 (Vivid dev) with kernel 3.18.0-8 and while wifi doesn't work, bluetooth *does*. It pairs and can send files to my smartphone.

That's some good news. At least something got fixed!

I hope somebody will take a look into the WiFi too at some point.

Thanks for then info Johannes.

jc (bluegill5) wrote :

Yet another disappointed Ubuntu fan the bought an Alienware 13 and frustrated I can't run ubuntu because of the Qualcomm Atheros killer wireless card. Hope the driver comes out soon!

Slipie (slipiefreak) on 2015-02-09
information type: Public → Public Security
information type: Public Security → Private Security
information type: Private Security → Public
chevrier (tc-s) on 2015-03-28
tags: added: utopic
laaag (lagged) on 2015-04-29
Changed in linux (Ubuntu):
status: Confirmed → In Progress
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
status: Fix Committed → Confirmed
status: Confirmed → In Progress
status: In Progress → Confirmed
Răzvan (razvandrt) on 2015-05-08
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Changed in linux (Ubuntu):
status: Fix Released → Triaged
tags: added: patch
Adam Lee (adam8157) on 2015-07-24
Changed in linux-firmware (Ubuntu):
importance: Undecided → Medium
summary: - Atheros Qualcomm Killer N1525 Wireless-AC [168c:003e] not supported
+ Atheros Qualcomm Killer N1525 Wireless-AC [168c:003e] is not supported
Changed in linux (Ubuntu):
assignee: nobody → Adam Lee (adam8157)
Changed in linux-firmware (Ubuntu):
assignee: nobody → Adam Lee (adam8157)
Adam Lee (adam8157) on 2015-07-24
Changed in linux-firmware (Ubuntu):
status: New → Triaged
Changed in hwe-next:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Adam Lee (adam8157)
description: updated
Adam Lee (adam8157) on 2015-07-29
description: updated
Adam Lee (adam8157) on 2015-10-23
Changed in linux (Ubuntu):
status: Triaged → Fix Released
no longer affects: hwe-next/vivid
Adam Lee (adam8157) on 2015-10-23
description: updated
Adam Lee (adam8157) on 2015-10-24
description: updated
Adam Lee (adam8157) on 2015-10-24
description: updated
description: updated
description: updated
Adam Lee (adam8157) on 2015-10-26
Changed in linux-firmware (Ubuntu):
status: Triaged → In Progress
270 comments hidden view all 350 comments
Corey (barnwell9) wrote :

The fix in the first post for 15.10 does not seem to work, I can see the networks but not connect. Eventually I'm not even able to see the available networks.

Adam Lee (adam8157) wrote :

@Ben, sorry, we start to fix it in base ubuntu from 15.10. you could keep using the dkms.

description: updated
Josh Taylor (jtaylor231) wrote :

Upgraded to 15.04, removed dkms as noted (worked fine in 15.04), and copied the files as noted in the description (historic: For now, you guys could use 15.10(purge the ath10k-dkms if you tried installing it), and make a copy of https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/plain/ath10k/QCA6174 into /lib/firmware/ath10k/).

I now get the attached in dmesg when connecting to a network. Seems it's crashing?

Josh Taylor (jtaylor231) wrote :

Update: Seems this only happens on 5Ghz, 2.4ghz works fine.

Adam Lee (adam8157) on 2015-10-28
Changed in linux (Ubuntu Wily):
status: New → Fix Released
Seth Forshee (sforshee) on 2015-10-28
Changed in linux-firmware (Ubuntu):
status: In Progress → Fix Released
Changed in linux-firmware (Ubuntu Wily):
assignee: nobody → Seth Forshee (sforshee)
importance: Undecided → Medium
status: New → In Progress
status: In Progress → Fix Committed
chevrier (tc-s) wrote :

I am totally puzzled. I followed religiously the instructions provided, and yes, it "works", and i can "connect" under 15.10. when i look at "connection information", the details are exactly identical to what i get when i connect under 15.04 (same ISP, same driver, same speed, same ipv4 and ipv6 - all identical)
Yet, under 15.10, no web pages open in any browser - just dies. can't go to google, yahoo, or anything, even though everything looks exactly the same as under 15.04. The only differences i noted were the following lines in dmesg.

Under 15.04:
qca6174 hw2.1 (0x05010000, 0x003405ff, 168c:003e:1a56:1525 fallback) fw rome-hw2.1-v211-michalk api 2 htt 3.0 wmi 4 cal otp max_sta 32
debug 1 debugfs 1 tracing 0 dfs 0 testmode 0

Under 15.10:
qca6174 hw2.1 (0x05010000, 0x003405ff, 168c:003e:1a56:1525 fallback) fw WLAN.RM.1.1-00141 api 5 htt 3.1 wmi 4 cal otp max_sta 32
debug 0 debugfs 1 tracing 1 dfs 0 testmode 0

everything else seems identical.

anyone patient enough to kindly let me know what i could have possibly stuffed??
:-(

Many thanks,
thomas

Hello chevrier.

Sorry to hear about your problem.

Even though I'm sure this isn't the answer you are looking for, could you please make sure this is not a router problem?

I mean, do you have access to the internet over the same wifi connection on another device?

Kind of sounds like you've actually got connected to your modem/router but you do not have outside world access.

I am sorry if this doesn't help and the issue persists. I'm sure someone with more knowledge than me will be able to help you further.

Frank Zafka (kafkaesque1978) wrote :

Just my 2 cents. I'm running arch, but still I seem to have the same issue as Thomas (chevrier). In the last day or two it's gone from slow but stable (6mb/s on 5ghz) to downright ridiculous. It is connected to the router, but drops connections left right and centre. Seems to work better on 2.4ghz but then I'm getting a report 1mb/s. On windows i'm getting nearer 300. This isn't a router issue, it's a wifi card issue. Sounds like me and Thomas are experiencing the same thing.

chevrier (tc-s) wrote :

Thanks much Dimitrios, really appreciate you took the time to answer, even though you are spot on - not the answer i am looking for :-) - been following your posts too. thanks god, i wasn't that stupid! ;-p
same laptop, same config, same everything.
As i explained in an earlier post, Adam's dkms package worked perfect for me with ALL ubuntus (i have quadruple boot, win 10, 14.04 LTS, 15.04 and 15.10 beta final). I had kernel 3.19 installed and booted. see my post #300.
Definitely stupidity, but by mistake, i issued sudo apt-get autoremove and lost the magic 3.19 kernel under ubuntu 15.10. Reinstalling "manually" 3.19 (i.e. not via synaptic) has not helped. :-s and it's after that that i have been wifi deprived - weird.
Therefore, I am trying to get 4.2 to work again, initially without success, but finally seems to work. My output is the same as the one people who have it working!, including you Dimitrios!! :-ss
Everything is also identical to what i get here under 15.04, except that i am not accessing anything on the www! :-( i can use any browser to go to yahoo or google and it just dies after a long wait.
I had read Frank's comment obviously, and everyone else's, and i have access to multiple ISPs, but none work, whatever their speed (5Ghz, etc...)
Really baffled by what is happening... could it be related to the duplication of places where to get the firmware files?? i used the location provided by the last guy above to say it worked for him.... maybe i am not using the correct files? that's the only thing that should be different, since i copied the file as instructed whereas for 15.04, which i am using to type this, i am using Adam's dkms.

chevrier (tc-s) wrote :

Still looking into this...
I see that when I use Adam's dkms, dmsg gives
qca6174 hw2.1 (0x05010000, 0x003405ff, 168c:003e:1a56:1525 fallback) fw killer-n1525-fw api 4 htt 3.0 wmi 4 cal otp max_sta 32
whereas just copying the files, i get like everyone else...
qca6174 hw2.1 (0x05010000, 0x003405ff, 168c:003e:1a56:1525 fallback) fw WLAN.RM.1.1-00141 api 5 htt 3.1 wmi 4 cal otp max_sta 32
(or sometimes, the other driver)
could that be the issue? somehow using adam's package my card gets properly identified as killer-n1525, while it's not when i just use those recommended files?
maybe i am just talking rubbish here - apologies if so.
I obviously don't really know.

Max (papel647) wrote :

Hello everyone !

Unfortunately for me, the solution of the deb package did not work... My network card is still not recognized ...
Someone has an idea ? Maybe there is a link with the fact I tried several drivers, like backports, ath10k, and ath9k ?

Someone know what I would need to do in order to the deb package to work like everyone else ? I really need a solution for this, as this computer is used to make simulation on a cluster, and I need to be connected to the server !

btw, I have Linux 14.04 LTS

Manu thanks for your help!!!!
Max

Adam Lee (adam8157) on 2015-10-30
Changed in hwe-next:
status: Triaged → Fix Committed
chevrier (tc-s) wrote :

Max - can you provide some details at which exact steps you took, what kernel you use, what you tried etc?
Adam's solution is definitely working.
As a matter of fact, I just tried a fresh 15.10 install and it's working fine. Just followed steps and is all fine.
I just don't understand why my other 15.10 install just won't work. I did remove the dmsg-ath10k package. really confused.
:-s
let us know max, so we can help properly. see above posts.
thanks

Chris Glass (tribaal) wrote :

Could somebody summarize that the instructions to get this working on wily are? Thanks a lot

Download full text (5.9 KiB)

very simple.
Follow the instructions provided in the email you quoted, copied for your
convenience:

  For now, you guys could use 15.10(purge the ath10k-dkms if you tried
  installing it), and make a copy of

https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/plain/ath10k/QCA6174
into /lib/firmware/ath10k/

in the git link - two folders, copy them in a QCA6174 folder you'll create
first, as with a fresh install, it won't exist.
reboot and your system will have wifi.
revert if you experience any difficulties.
tks

On Mon, Nov 2, 2015 at 11:14 PM, Chris Glass <
<email address hidden>> wrote:

> Could somebody summarize that the instructions to get this working on
> wily are? Thanks a lot
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1383184
>
> Title:
> Atheros Qualcomm Killer N1525 Wireless-AC [168c:003e] is not supported
>
> Status in HWE Next:
> Fix Committed
> Status in HWE Next wily series:
> Fix Committed
> Status in linux package in Ubuntu:
> Fix Released
> Status in linux-firmware package in Ubuntu:
> Fix Released
> Status in linux source package in Wily:
> Fix Released
> Status in linux-firmware source package in Wily:
> Fix Committed
>
> Bug description:
> =========================================================
>
> CURRENT STATUS:
>
> Wily(15.10) could not work with and don't need Adam's dkms package 1.0
> or 1.1
>
> Wily(15.10) has already fixed the driver part, and the firmware part
> is in progress.
>
> For now, you guys could use 15.10(purge the ath10k-dkms if you tried
> installing it), and make a copy of
> https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-
> firmware.git/plain/ath10k/QCA6174 into /lib/firmware/ath10k/
>
> Distros before 15.10(lower than 4.2 kernel) please keep using the
> dkms(which will be relocated soon)
>
> =========================================================
>
> Card detail: Qualcomm Atheros Device [168c:003e] (rev 20)
> Subsystem: Bigfoot Networks, Inc. Device [1a56:1525]
>
> This is on a fully updated Ubuntu Server 14.04 installation, with the
> ubuntu-desktop environment installed. This happened in order to get the md
> raid drivers for raid0 on my system, as the desktop version doesn't support
> them.
> ---
> ApportVersion: 2.14.1-0ubuntu3.5
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC1: matanis 2333 F.... pulseaudio
> /dev/snd/controlC0: matanis 2333 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> CurrentDesktop: Unity
> DistroRelease: Ubuntu 14.04
> HibernationDevice: RESUME=UUID=1b192ee3-f592-43e9-bdcf-08b91c0aa9b6
> InstallationDate: Installed on 2014-10-16 (3 days ago)
> InstallationMedia: Ubuntu-Server 14.04.1 LTS "Trusty Tahr" - Release
> amd64 (20140722.3)
> IwConfig:
> p2p1 no wireless extensions.
>
> lo no wireless extensions.
> MachineType: Micro-Star International Co., Ltd. GT72 2QE
> NonfreeKernelModules: nvidia
> Package: linux (not installed)
> ProcFB: 0 EFI VGA
> ProcKernelCmdLi...

Read more...

Hello Dimitrios, or anyone else affected,

Accepted linux-firmware into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/linux-firmware/1.149.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Adam Lee (adam8157) wrote :

@Chris, linux-image 4.2 + linux-firmware 1.149.2 works

description: updated

As above, the combination of;

ii linux-firmware 1.149.2
ii linux-image-extra-4.2.0-16-generic 4.2.0-16.19

Works fine for me on 14.04.

Thanks.

Seth Forshee (sforshee) wrote :

Adding verifycation-done tag based on positive test results in comments #325 and #326.

tags: added: verification-done
Download full text (5.2 KiB)

Has anyone done proper testing of this on 5GHz wifi networks?

On Thu, Nov 5, 2015 at 1:59 PM, Seth Forshee <email address hidden>
wrote:

> Adding verifycation-done tag based on positive test results in comments
> #325 and #326.
>
> ** Tags added: verification-done
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1383184
>
> Title:
> Atheros Qualcomm Killer N1525 Wireless-AC [168c:003e] is not supported
>
> Status in HWE Next:
> Fix Committed
> Status in HWE Next wily series:
> Fix Committed
> Status in linux package in Ubuntu:
> Fix Released
> Status in linux-firmware package in Ubuntu:
> Fix Released
> Status in linux source package in Wily:
> Fix Released
> Status in linux-firmware source package in Wily:
> Fix Committed
>
> Bug description:
> =========================================================
>
> CURRENT STATUS:
>
> Wily(15.10) could not work with and don't need Adam's dkms package 1.0
> or 1.1
>
> Wily(15.10) has already fixed the driver part, and the firmware part
> is in progress.
>
> For now, you guys could use 15.10(purge the ath10k-dkms if you tried
> installing it), and make a copy of
> https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-
> firmware.git/plain/ath10k/QCA6174 into /lib/firmware/ath10k/
>
> 15.10 will work in a week by a simple `apt upgrade`
>
> Distros before 15.10(lower than 4.2 kernel) please keep using the
> dkms(which will be relocated soon)
>
> =========================================================
>
> Card detail: Qualcomm Atheros Device [168c:003e] (rev 20)
> Subsystem: Bigfoot Networks, Inc. Device [1a56:1525]
>
> This is on a fully updated Ubuntu Server 14.04 installation, with the
> ubuntu-desktop environment installed. This happened in order to get the md
> raid drivers for raid0 on my system, as the desktop version doesn't support
> them.
> ---
> ApportVersion: 2.14.1-0ubuntu3.5
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC1: matanis 2333 F.... pulseaudio
> /dev/snd/controlC0: matanis 2333 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> CurrentDesktop: Unity
> DistroRelease: Ubuntu 14.04
> HibernationDevice: RESUME=UUID=1b192ee3-f592-43e9-bdcf-08b91c0aa9b6
> InstallationDate: Installed on 2014-10-16 (3 days ago)
> InstallationMedia: Ubuntu-Server 14.04.1 LTS "Trusty Tahr" - Release
> amd64 (20140722.3)
> IwConfig:
> p2p1 no wireless extensions.
>
> lo no wireless extensions.
> MachineType: Micro-Star International Co., Ltd. GT72 2QE
> NonfreeKernelModules: nvidia
> Package: linux (not installed)
> ProcFB: 0 EFI VGA
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-37-generic.efi.signed
> root=UUID=80998dbb-1f89-4eda-be90-25e35e1c0a90 ro
> ProcVersionSignature: Ubuntu 3.13.0-37.64-generic 3.13.11.7
> RelatedPackageVersions:
> linux-restricted-modules-3.13.0-37-generic N/A
> linux-backports-modules-3.13.0-37-generic N/A
> linux-firmware 1.127.7
> RfKill:
>
> Tags: trusty
...

Read more...

Roman (romanbn) wrote :

I didn't used the new purposed firmware-package because i installed the firmware manually from the ath10k-firmware repository before. If testing this one is not valid ignore this post:

Im getting a firmware crash on the 5 GHz network at my university (see attachment) with Kernel 4.2.0-16.
After this one i tested the testing-firmware (SW_RM.1.1.1-00157-QCARMSWPZ-1) from the ath10k-firmware repository too. It didnt crash but i wasn't able to connect either.

I am on Ubuntu 15.10, and using the package from proposed repository

* linux-firmware 1.149.2

* Linux name 4.2.0-17-generic #21-Ubuntu SMP Fri Oct 23 19:56:16 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

I am currently on a 5GHz connection and it seems fine. I am not sure what counts as proper testing, though.

Download full text (5.8 KiB)

I tried connecting to 5GHz at work today and it did not work. I am using
adam's copy paste suggestion from earlier posts.

Nomal wifi networks work fine.

On Thu, Nov 5, 2015 at 7:55 PM, Roman <email address hidden> wrote:

> I didn't used the new purposed firmware-package because i installed the
> firmware manually from the ath10k-firmware repository before. If testing
> this one is not valid ignore this post:
>
> Im getting a firmware crash on the 5 GHz network at my university (see
> attachment) with Kernel 4.2.0-16.
> After this one i tested the testing-firmware
> (SW_RM.1.1.1-00157-QCARMSWPZ-1) from the ath10k-firmware repository too. It
> didnt crash but i wasn't able to connect either.
>
>
>
> ** Attachment added: "WLAN.RM.1.1-00141"
>
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1383184/+attachment/4513672/+files/WLAN.RM.1.1-00141
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1383184
>
> Title:
> Atheros Qualcomm Killer N1525 Wireless-AC [168c:003e] is not supported
>
> Status in HWE Next:
> Fix Committed
> Status in HWE Next wily series:
> Fix Committed
> Status in linux package in Ubuntu:
> Fix Released
> Status in linux-firmware package in Ubuntu:
> Fix Released
> Status in linux source package in Wily:
> Fix Released
> Status in linux-firmware source package in Wily:
> Fix Committed
>
> Bug description:
> =========================================================
>
> CURRENT STATUS:
>
> Wily(15.10) could not work with and don't need Adam's dkms package 1.0
> or 1.1
>
> Wily(15.10) has already fixed the driver part, and the firmware part
> is in progress.
>
> For now, you guys could use 15.10(purge the ath10k-dkms if you tried
> installing it), and make a copy of
> https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-
> firmware.git/plain/ath10k/QCA6174 into /lib/firmware/ath10k/
>
> 15.10 will work in a week by a simple `apt upgrade`
>
> Distros before 15.10(lower than 4.2 kernel) please keep using the
> dkms(which will be relocated soon)
>
> =========================================================
>
> Card detail: Qualcomm Atheros Device [168c:003e] (rev 20)
> Subsystem: Bigfoot Networks, Inc. Device [1a56:1525]
>
> This is on a fully updated Ubuntu Server 14.04 installation, with the
> ubuntu-desktop environment installed. This happened in order to get the md
> raid drivers for raid0 on my system, as the desktop version doesn't support
> them.
> ---
> ApportVersion: 2.14.1-0ubuntu3.5
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC1: matanis 2333 F.... pulseaudio
> /dev/snd/controlC0: matanis 2333 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> CurrentDesktop: Unity
> DistroRelease: Ubuntu 14.04
> HibernationDevice: RESUME=UUID=1b192ee3-f592-43e9-bdcf-08b91c0aa9b6
> InstallationDate: Installed on 2014-10-16 (3 days ago)
> InstallationMedia: Ubuntu-Server 14.04.1 LTS "Trusty Tahr" - Release
> amd64 (20140722.3)
> IwConfig:
> p2p1 no wireless extensions.
>
> lo ...

Read more...

Adam Lee (adam8157) on 2015-11-06
Changed in hwe-next:
assignee: Adam Lee (adam8157) → Hui Wang (hui.wang)
Changed in linux (Ubuntu):
assignee: Adam Lee (adam8157) → Hui Wang (hui.wang)
Changed in linux-firmware (Ubuntu):
assignee: Adam Lee (adam8157) → Hui Wang (hui.wang)

I am on UbuntuStudio 15.10, and using the package from proposed repository

i linux-image-4.2.0-17-lowlatency (4.2.0-17.21)
ii linux-firmware (1.149.2)

works fine for me.

Thanks.

tags: added: verification-done

chevrier (tc-s) wrote :
Download full text (5.5 KiB)

worked for me on 4.2.0.16, but upgrading to 4.2.0.17 made the wireless
adaptor disappear... :-s

On Sat, Nov 7, 2015 at 1:03 AM, radiovirusgenerator <email address hidden>
wrote:

> I am on UbuntuStudio 15.10, and using the package from proposed
> repository
>
> i linux-image-4.2.0-17-lowlatency (4.2.0-17.21)
> ii linux-firmware (1.149.2)
>
> works fine for me.
>
> Thanks.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1383184
>
> Title:
> Atheros Qualcomm Killer N1525 Wireless-AC [168c:003e] is not supported
>
> Status in HWE Next:
> Fix Committed
> Status in HWE Next wily series:
> Fix Committed
> Status in linux package in Ubuntu:
> Fix Released
> Status in linux-firmware package in Ubuntu:
> Fix Released
> Status in linux source package in Wily:
> Fix Released
> Status in linux-firmware source package in Wily:
> Fix Committed
>
> Bug description:
> =========================================================
>
> CURRENT STATUS:
>
> Wily(15.10) could not work with and don't need Adam's dkms package 1.0
> or 1.1
>
> Wily(15.10) has already fixed the driver part, and the firmware part
> is in progress.
>
> For now, you guys could use 15.10(purge the ath10k-dkms if you tried
> installing it), and make a copy of
> https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-
> firmware.git/plain/ath10k/QCA6174 into /lib/firmware/ath10k/
>
> 15.10 will work in a week by a simple `apt upgrade`
>
> Distros before 15.10(lower than 4.2 kernel) please keep using the
> dkms(which will be relocated soon)
>
> =========================================================
>
> Card detail: Qualcomm Atheros Device [168c:003e] (rev 20)
> Subsystem: Bigfoot Networks, Inc. Device [1a56:1525]
>
> This is on a fully updated Ubuntu Server 14.04 installation, with the
> ubuntu-desktop environment installed. This happened in order to get the md
> raid drivers for raid0 on my system, as the desktop version doesn't support
> them.
> ---
> ApportVersion: 2.14.1-0ubuntu3.5
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC1: matanis 2333 F.... pulseaudio
> /dev/snd/controlC0: matanis 2333 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> CurrentDesktop: Unity
> DistroRelease: Ubuntu 14.04
> HibernationDevice: RESUME=UUID=1b192ee3-f592-43e9-bdcf-08b91c0aa9b6
> InstallationDate: Installed on 2014-10-16 (3 days ago)
> InstallationMedia: Ubuntu-Server 14.04.1 LTS "Trusty Tahr" - Release
> amd64 (20140722.3)
> IwConfig:
> p2p1 no wireless extensions.
>
> lo no wireless extensions.
> MachineType: Micro-Star International Co., Ltd. GT72 2QE
> NonfreeKernelModules: nvidia
> Package: linux (not installed)
> ProcFB: 0 EFI VGA
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-37-generic.efi.signed
> root=UUID=80998dbb-1f89-4eda-be90-25e35e1c0a90 ro
> ProcVersionSignature: Ubuntu 3.13.0-37.64-generic 3.13.11.7
> RelatedPackageVersions:
> linux-restricted-modules-3.13.0-37-generic N/A
> linux-backports-modules-3.13.0-37...

Read more...

S Krishnaswamy (mkukrishna) wrote :

I am using Lenovo G50-80 with Ubuntu 15.10. After installing the
 https://launchpad.net/ubuntu/+source/linux-firmware/1.149.2/+build/8264018/+files/linux-firmware_1.149.2_all.deb
from the above fix, I am still not getting the wireless.

lpsci -nnk gives for network controller
03:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:0041] (rev 20)
       Subsystem: Lenovo Device [17aa:3545]
There is no mention of Kernel driver in use.

How can I get the kernel driver for this device included?

Please help

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.149.2

---------------
linux-firmware (1.149.2) wily; urgency=medium

  * Update ath10k firmware to support Atheros Qualcomm Killer N1525
    Wireless-AC
     ath10k: QCA6174 hw2.1: add firmware WLAN.RM.1.1-00141 and board.bin
     ath10k: QCA6174 hw3.0: add WLAN.RM.2.0-00180-QCARMSWPZ-1
    -LP: #1383184

 -- Seth Forshee <email address hidden> Wed, 28 Oct 2015 11:26:13 -0500

Changed in linux-firmware (Ubuntu Wily):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for linux-firmware has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in hwe-next:
status: Fix Committed → Fix Released
f0cks (f0cks) wrote :

Hey!
Nice work, Killer Wireless-AC 1525 is working great with solution #209 and installation of dkms before.
However, all my wireless usb adapters do not work anymore... I can see them with lsusb but they are not present in iwconfig or ifconfig. Seems like all other wifi drivers are failing. Any solution to get them back?
sudo modprobe rtl8187 does not work to load the module:
modprobe: ERROR: could not insert 'rtl8187': Invalid argument
Thanks for your help!

osterchrisi (osterchrisi) wrote :

Is there any update on the dmks yet? The current status hasn't changed for some weeks now and I am still having this issue with 14.04.

osterchrisi (osterchrisi) wrote :

Thank you f0cks for pointing that out. This doesn't really work for me... I never had the dkms installed... would that make a difference? Or would I have to also make all steps of post 209 maybe?

osterchrisi (osterchrisi) wrote :

Okay, I figured it out now. After unpacking, configuring, making and installing and then copying the ath10k firmware as in the link that you gave me in #340, I figured through "dmesg | grep ath10k" that the system couldn't find the firmware. It was both in the wrong folder and it had a weird name:

So instead of the file
firmware-5.bin being at
/lib/firmware/ath10k/QCA6174/hw2.1

I had a file named
firmware-5.bin_SW_RM.1.1.1-00157-QCARMSWPZ-1 being at
/lib/firmware/ath10k/ath10k-firmware/QCA6174/hw2.1

I copied the whole content of the "ath10k-firmware" folder one level up and renamed the file to firmware-5.bin and now it works!! Also the LAN module still works ;)

Nucleo (admar505) wrote :

Hello,

the above fix, copying files into the correct location worked until this upgrade came through:

upgrade network-manager:amd64 1.0.4-0ubuntu5.1 1.0.4-0ubuntu5.2

now it seems ath10k is not loading.

if I do a manual sudo modprobe force ath10k_pci

it lists in lsmod, but networkmanager seems to not care. maybe this is a network manager problem, not for this post?

Nucleo (admar505) wrote :

sorry, no, I am wrong. it loads now. disregard #343

Keng-Yu Lin (lexical) on 2015-12-21
Changed in network-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu Wily):
status: New → Confirmed
Keng-Yu Lin (lexical) on 2015-12-21
Changed in network-manager (Ubuntu):
status: Confirmed → Invalid
importance: High → Undecided

Sorry, it says "willy should work" but it doesn't for me .

lspci --n
03:00.0 Ethernet controller [0200]: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller [1969:e091] (rev 13)
04:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 20)

uname -a
Linux guigolum-GT72-2QE 4.2.0-22-generic #27-Ubuntu SMP Thu Dec 17 22:57:08 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

I have a netgear X4 R7500 802.1 g/n/ac router with two access points (one ac and one n)

network-manager can SEE all the wifi AP (both n and ac) BUT can only connect to the n. When I try to connect to ac, it asks me for password, then after some time request the password again. At this moment I can't connect to any AP unless I enter sudo network-manager restart .

Basically I am stuck with 802.11n now.I also bought other WIFI USB dongles with 802.11ac but none were working correctly.

MoonSky219 (moonsky219) wrote :
Download full text (9.8 KiB)

Willy still doesn't work:

Linux version: 4.2.0-22-generic
Linux-firmware version: 1.149.3
Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 20)
05:00.0 0280: 168c:003e (rev 20)

dmesg | grep ath10k
[ 5.534130] ath10k_pci 0000:05:00.0: pci irq msi interrupts 1 irq_mode 0 reset_mode 0
[ 5.791596] ath10k_pci 0000:05:00.0: Direct firmware load for ath10k/cal-pci-0000:05:00.0.bin failed with error -2
[ 5.792386] ath10k_pci 0000:05:00.0: Direct firmware load for ath10k/QCA6174/hw2.1/board-pci-168c:003e:1a56:1525.bin failed with error -2
[ 5.792388] ath10k_pci 0000:05:00.0: failed to load spec board file, falling back to generic: -2
[ 7.230331] ath10k_pci 0000:05:00.0: qca6174 hw2.1 (0x05010000, 0x003405ff, 168c:003e:1a56:1525 fallback) fw WLAN.RM.1.1-00141 api 5 htt 3.1 wmi 4 cal otp max_sta 32
[ 7.230335] ath10k_pci 0000:05:00.0: debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[ 7.314488] ath10k_pci 0000:05:00.0 wlp5s0: renamed from wlan0
[ 20.121135] ath10k_pci 0000:05:00.0: no channel configured; ignoring frame(s)!
[ 104.337703] ath10k_pci 0000:05:00.0: firmware crashed! (uuid 834440fd-8eea-474b-9540-920bf9abceca)
[ 104.337718] ath10k_pci 0000:05:00.0: qca6174 hw2.1 (0x05010000, 0x003405ff, 168c:003e:1a56:1525 fallback) fw WLAN.RM.1.1-00141 api 5 htt 3.1 wmi 4 cal otp max_sta 32
[ 104.337722] ath10k_pci 0000:05:00.0: debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[ 104.339730] ath10k_pci 0000:05:00.0: firmware register dump:
[ 104.339738] ath10k_pci 0000:05:00.0: [00]: 0x05010000 0x000015B3 0x00939797 0x00955B31
[ 104.339742] ath10k_pci 0000:05:00.0: [04]: 0x00939797 0x00060330 0x00000000 0x00000000
[ 104.339745] ath10k_pci 0000:05:00.0: [08]: 0x00413980 0x0000FFFF 0x00000000 0x00000000
[ 104.339748] ath10k_pci 0000:05:00.0: [12]: 0x00000009 0xFFFFFFFF 0x0096C09C 0x0096C0A7
[ 104.339752] ath10k_pci 0000:05:00.0: [16]: 0x0096BDBC 0x009287BD 0x00000000 0x009287BD
[ 104.339756] ath10k_pci 0000:05:00.0: [20]: 0x40939797 0x0041A700 0x00407124 0x00000000
[ 104.339759] ath10k_pci 0000:05:00.0: [24]: 0x8093D6C4 0x0041A760 0x004059D0 0xC0939797
[ 104.339761] ath10k_pci 0000:05:00.0: [28]: 0x8094777F 0x0041A780 0x0046D5D8 0x00000001
[ 104.339763] ath10k_pci 0000:05:00.0: [32]: 0x800AA427 0x0041A7B0 0x0046D5D8 0x00000001
[ 104.339765] ath10k_pci 0000:05:00.0: [36]: 0x800AA58E 0x0041A7D0 0x00424824 0x00000001
[ 104.339767] ath10k_pci 0000:05:00.0: [40]: 0x80994D90 0x0041A7F0 0x00424824 0x0041A838
[ 104.339769] ath10k_pci 0000:05:00.0: [44]: 0x80996DC6 0x0041A820 0x0046F888 0x00412984
[ 104.339770] ath10k_pci 0000:05:00.0: [48]: 0x800B43F5 0x0041A860 0x004222F8 0x00005008
[ 104.339772] ath10k_pci 0000:05:00.0: [52]: 0x809A6ACC 0x0041A8F0 0x0042930C 0x0042CA24
[ 104.339774] ath10k_pci 0000:05:00.0: [56]: 0x809A6120 0x0041A930 0x0041A958 0x00427110
[ 104.357981] ath10k_pci 0000:05:00.0: failed to poke peer 94:b4:0f:ad:ee:70 param for ps workaround on vdev 0: -108
[ 105.856177] ath10k_pci 0000:05:00.0: firmware crashed! (uuid 4adf30b2-804c-403e-b050-ec673da281be)
[ 105.856190] ath10k_pci 0000:05:00.0: qca6174 hw2.1 (0x05010000, 0x003405ff, 168c:003e:1a56:1525 fallback) fw WLAN.RM.1.1-001...

MoonSky219, given this report is closed, if you would like your issue addressed then please file a new report via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

For more on this, please see https://wiki.ubuntu.com/ReportingBugs .

no longer affects: network-manager (Ubuntu Wily)
Stephen Boesch (javadba) wrote :

Why was this closed? The following entries -near the end of this bug - show that Ken-Yu Lin first set it to high priority but then to invalid on same day 12/21. But also the problem continues to affect users - including myself

Keng-Yu Lin (lexical) on 2015-12-21
Changed in network-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → High

Changed in network-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Launchpad Janitor (janitor) wrote on 2015-12-21: #345
Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu Wily):
status: New → Confirmed
Keng-Yu Lin (lexical) on 2015-12-21
Changed in network-manager (Ubuntu):
status: Confirmed → Invalid
importance: High → Undecided

Željko (zeljko2222) on 2016-03-18
Changed in linux (Ubuntu):
assignee: Hui Wang (hui.wang) → Željko (zeljko2222)
Carlos Laviola (claviola) wrote :

Still unsupported as of 16.04 and yakkety for my hardware (Dell Latitude E7270).

The workaround involves replacing "/lib/firmware/ath10k/QCA6174/hw3.0/board.bin" with a version from Killer Networking's website, as per:

http://www.killernetworking.com/product-support/knowledge-base/17-linux

The required file is directly available at:

http://www.killernetworking.com/support/K1535_Debian/board.bin

The machine is a Dell Latitude E7270. Here's the lspci output:

01:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
        Subsystem: Dell QCA6174 802.11ac Wireless Network Adapter [1028:0310]
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx+
        Latency: 0
        Interrupt: pin A routed to IRQ 130
        Region 0: Memory at e1000000 (64-bit, non-prefetchable) [size=2M]
        Capabilities: <access denied>
        Kernel driver in use: ath10k_pci
        Kernel modules: ath10k_pci

Displaying first 40 and last 40 comments. View all 350 comments or add a comment.