'wl' driver is broken in lrm 2.6.24.14-20.46

Bug #252630 reported by Mario Limonciello on 2008-07-28
56
Affects Status Importance Assigned to Milestone
linux-backports-modules-2.6.24 (Ubuntu)
High
Tim Gardner
Hardy
Undecided
Unassigned

Bug Description

Installing the version of LRM in hardy-proposed causes wireless to stop working.

wl: disagrees about version of symbol ieee80211_get_crypto_ops
wl: Unknown symbol ieee80211_get_crypto_ops

Changed in linux-restricted-modules-2.6.24:
assignee: nobody → timg-tpi
Tim Gardner (timg-tpi) wrote :

You probably have linux-backports-modules installed which replaces the wireless protocol stack. The Broadcom driver was built against lum and kernel headers, but not against lbm headers. I'm going to have to think about how to isolate the LBM compat-wireless stack.

Tim Gardner (timg-tpi) wrote :
Changed in linux-restricted-modules-2.6.24:
importance: Undecided → High
milestone: none → ubuntu-8.04.2
status: New → Fix Committed
Tim Gardner (timg-tpi) wrote :

SRU Justification

Impact: LBM compat-wireless symbols conflict with existing drivers, therefore LBM wireless drivers will not load because of ABI skew.

Patch Description: Rename all public symbols in LBM compat-wireless such that they do not conflict with existing kernel packakge symbols.

Patch: http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-hardy-lbm.git;a=commit;h=87ef1112f783710e3940f38405fadc6f432cb84e

Test Case: see bug description

Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux-backports-modules-2.6.24:
status: New → Fix Committed
milestone: none → ubuntu-8.04.2
status: Fix Committed → New
status: New → Fix Committed
milestone: ubuntu-8.04.2 → none
Mario Limonciello (superm1) wrote :

I can confirm the "direct" issue at hand with loading the broadcom module is resolved now (it will modprobe). Unfortunately b43 is still broken in this regard.

Gabriel de Perthuis (g2p) wrote :

I've added a patch to check for missing symbols at #254104.

It reports there is another one missing:
WARNING: /home/g2p/var/co/git/ubuntu-modules/debian/linux-backports-modules-2.6.24-20-generic.check-symbols/lib/modules/2.6.24-20-generic/updates/lbm_mac80211_hwsim.ko needs unknown symbol device_create_drvdata

Since the update on August 1st, my wireless card is being detected again, but it doesn't work yet. Everything goes well, until it tries to connect. Although it does detect wireless networks, it fails to connect to any of them. When booting with 2.6.24-19, I does connect to all networks.

Stuart Bishop (stub) wrote :

D-Link DWA-110 usb stick is working again with 2.6.24-20.38. Having issues with graphics now though - Bug #254418

Stuart Bishop (stub) wrote :

The D-Link DWA-110 usb stick is a Ralink RT73 chipset btw. I also just noticed that I seem to have reduced signal with 2.6.24-20 - the network manager notification thingy is reporting 61% under 2.6.24-20.38 and 91% under 2.6.24-19.

The latest update (2.6.24-21) didn't change my situation. It still won't connect to any detected networks, so I'm still working with 2.6.24.19 to get a connection.

Florian Kisser (flok) wrote :

With 2.6.24-20 for me it was fixed, but with 21 it broke again.

Robert McMeekin (rrm3) wrote :

So, this driver has always worked for me, it still works in Hardy, but it has disappeared from Intrepid. Can someone please put it back in Intrepid so my wireless card will work? It compiles and loads and works cleanly from http://www.broadcom.com/support/802.11/linux_sta.php

I don't understand why it can't be kept in the distribution for the people it does work for.

Pete Graner (pgraner) wrote :

The driver is in Intrepid run the following:

sudo /etc/init.d/linux-restricted-modules-common start
sudo depmod -a
modprobe wl

You will only have to do this once. After that wl will be available and jockey should pick it up.

Robert McMeekin (rrm3) wrote :

I see. Thanks, I was really confused about why it wasn't there.

Again, the latest update (2.6.24-21.27) doesn't change my situation. The card (laptop with a Ralink chip which uses rt2500pci, BTW) is being detected, my wireless network is listed, but I can't connect (both 'leds' in the systray stay grey). It still works fine with 2.6.24-19.

Martin Pitt (pitti) wrote :

Robert, do you happen to get "RTNL: assertion failures" in the output of "dmesg"? BUg 271191 might be related.

Martin Pitt (pitti) wrote :

Robert, oh, hang on, you are using a completely different driver. Can you please open a new bug report about this then, with attaching /var/log/kern.log? This one is about the "wl" driver. Thanks!

Stuart Bishop (stub) wrote :

I have unduplicated Bug 251604. There are other duplicates to this bug for other chipsets, including at least one other ralink, but I have left them alone as they may be redundant or fixed.

Martin Pitt (pitti) wrote :

linux-backports-modules-2.6.24 -21 copied to hardy-updates.

Changed in linux-backports-modules-2.6.24:
status: Fix Committed → Fix Released
status: Fix Committed → Invalid

I'll create a new report, Martin. Just need some time to look at the logs from -19 and -21.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers