Ubuntu

Boot hangs at "Booting system without full network configuration..."

Reported by Janne Snabb on 2011-09-22
314
This bug affects 64 people
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
Medium
Unassigned
lightdm (Ubuntu)
High
Unassigned
upstart (Ubuntu)
Undecided
Unassigned

Bug Description

I installed Ubuntu 11.10 beta1 64bit on a new laptop. I rebooted and it came up nicely.

After that I did "apt-get update" and "apt-get dist-upgrade" to get the most recent fixes and installed some additional software.

Now I do not seem to be able to boot.

Fist I see:
Waiting for network configuration...

Then I see:
Waiting up to 60 more seconds for network configuration...

And then it just hangs forever displaying the following:
Booting system without full network configuration...

Nothing happens after that, no matter how long I wait. However, I can switch to the console with CTRL-ALT-F1 and log in from there. The network is configured with DHCP and it works just fine from the console. I do not understand what the GUI boot display is waiting for.

I installed the system using the alternate install CD to get LVM based partitions with full disk encryption.

I noticed the bug #847782 and removed the "auto eth0" entry from my /etc/network/interfaces. Unfortunately that did not change anything, it still hangs forever.

Janne Snabb (snabb) wrote :

I was trying to do apport-collect but it does not seem to work with links browser (I can not use a graphcal console because the boot hangs and I do not get the login screen).

However, additional details:

- I am using wired interface (eth0) with no defined configuration. It makes no difference if my network cable is plugged in or not.

- There is also a wlan interface but I did not get around to configuring that yet.

I am also attaching dmesg and syslog output.

Janne Snabb (snabb) wrote :
Janne Snabb (snabb) wrote :

I had a second look at my syslog output and noticed the following line:

lightdm main process (1154) killed by TERM signal

I replaced the lightdm with gdm:

sudo apt-get install gdm

...and after that the login screen comes up just fine with gdm.

Thus it seems this is not network related after all. It is confusing that the network related error message remains on the screen forever when it is lightdm which seems to be the problem.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in netcfg (Ubuntu):
status: New → Confirmed
Michael (mdferrier) wrote :

Exact same problem here. Installed gdm and I get to the login screen as described in comment #3.

Michael (mdferrier) wrote :

I had the exact same problem and did the steps in comment #3 with the exact same results.

So, I tried:

sudo dpkg-reconfigure lightdm

That appeared to resolve the problem once I switched the default display manager back to lightdm.

After that I was able to do:

sudo apt-get purge gdm

And I did not have any problems getting to the login screen with lightdm after that.

Janne Snabb (snabb) on 2011-09-23
affects: netcfg (Ubuntu) → lightdm (Ubuntu)
Changed in lightdm (Ubuntu):
status: Confirmed → New
kvark (kvarkno1) wrote :

I had the same problem, but I don't use gdm or lightdm, only standalone compiz.

There is a /etc/init/failsafe.conf file and this causes the waiting for network configuration.
I've just commented the sleep commands out and now the boot time is normal.

That's not an elegant solution, but it's working for me.

Janne Snabb (snabb) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

(Looks like I messed up the status previously, so I am trying to fix this back to how it was set by the Janitor. Sorry about that.)

Changed in netcfg (Ubuntu):
status: New → Confirmed
Janne Snabb (snabb) wrote :

Just an observation: I installed Xubuntu 11.10 beta2 from the alternate install CD on the same hardware (after wiping the previous beta1 install) and did NOT hit this bug.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Clint Byrum (clint-fewbar) wrote :

Hi Janne, can you attach your /etc/network/interfaces file? If you have a hardware interface defined there as dhcp, but not always plugged in, the system will wait an extra 2 minutes to boot. As kvark points out, those are the relevant bugs that have been dealt with since introducing that change.

However, I'm fairly certain this is a red herring, as the last message is the one thing printed before the failsafe boot continues. Essentially, at that point, the system is virtually guaranteed to enter runlevel 2, which should result in lightdm starting as long as dbus has been started, and a graphics device has been initialized.

If somebody affected can boot with '--verbose nomodeset' added to the kernel command line (edit it during the grub menu) and 'quiet' removed, and then try looking on tty1 (ctrl-alt-f1) and 7 (ctrl-alt-f7) for some log output, that may be helpful in debugging this.

On Mon, 26 Sep 2011, Clint Byrum wrote:

> Hi Janne, can you attach your /etc/network/interfaces file? If you have
> a hardware interface defined there as dhcp, but not always plugged in,
> the system will wait an extra 2 minutes to boot.

Please note the following in my original report:

I noticed the bug #847782 and removed the "auto eth0" entry from my
/etc/network/interfaces. Unfortunately that did not change anything,
it still hangs forever.

Also in my comment #1:

- I am using wired interface (eth0) with no defined configuration.
It makes no difference if my network cable is plugged in or not.

I wiped my installation and replaced it with Xubuntu as soon as I
realized that oneiric standard desktop installation does not offer
the "Classic Ubuntu" GUI experience any more. Thus I can not
reproduce / test any more.

--
Janne Snabb / EPIPE Communications
<email address hidden> - http://epipe.com/

Sämy (saemy-zehnder) wrote :

For me it seems like this bug is related to #811441. After removing /var/run/dbus/pid and restarting, the login screen appeared immediately.

In my case, this behavior went away as soon as I tried the fix in comment #9 for bug #811441. For me, this was just a symptom that the system could not communicate with dbus.

Bernhard (b.a.koenig) wrote :

I noticed the following: this bug happens if I have lightdm and some other login manager installed (say gdm or slim). Then lightdm starts at boot even if it's not the default login manager. Then lightdm is shut down and the default login manager kicks in. After that, there seems to be a network configuration problem.

So the problem went away for me after I uninstalled lightdm.

Alexandre Devaud (devauda) wrote :

The problem is also solved for me by clearing the /var/run/dbus folder's content and rebooting. (#6 bug #811441)

Koen Verweij (kfverweij) wrote :

I have the same problem and tried both this:

"I noticed the bug #847782 and removed the "auto eth0" entry from my /etc/network/interfaces."

and this:

"In my case, this behavior went away as soon as I tried the fix in comment #9 for bug #811441. For me, this was just a symptom that the system could not communicate with dbus."

but my problem is not fixed.
I have now used a workaround: I edited /etc/init/failsafe.conf and changed the sleep numbers.

This problem happened aqui after an upgrade to 11.04 to 11.10 and I'm unable to solve it.
GDM do not start anymore and my boot continues with the annoying message and the 60 seconds of wait... And my network do not works correctily.

I think this is the bug https://bugs.launchpad.net/ubuntu/+source/ifupdown/+bug/377432
But in Oneiric.

Somebody more can test and confirm?

My last information about this bug:

- This not only about lightdm, I'm running beta2 and never installed lightdm, and have the bug

- Something not really installed causes the bug: always at restart we can see the message "The system need be restarted". Something isn't correctly configured yet, and will never be...

- Sounds, for me, the problem is caused about a broken link into /etc/network/run to /run/network (see the bug in last comment). The folder /run/network and his content is removed at boot for some unknown application.

- Trying discover what service was removing the folder, I created a script who executes stop and start for each "initctl list" service list and executed it. The system was automatically restart in some service in that list and all was magically solved o.O'
This make me think it's about some procedure who don't runs at system restart correctily, maybe about a dbus problem (I'm was with a dbus problem who magically disapeared too: "unable to connect to system bus: Failed to connect to socket /var/run/dbus/system_bus_socket: Connection refused") or something more out of my knowledge.

- My problem is out, then I think I cannot bring here good informations. But something need debug here.

If there are something more I can put here to help, please let me know.

Tuukka Hastrup (tuukkah) wrote :

I had the same symptoms as the original reporter but the problem was wrong contents of /etc/X11/default-display-manager: #864174

Yves Dorfsman (yves-zioup) wrote :

Same issue, this is what I get on tty7:

 * Checking battery state... [ok]
 * Starting TIMidity++ ALSA midi emulation.. [ok]
 * Stopping system V runlevel compatibility [ok]
Waiting for network configuration...
 * Stopping read required files in advance [ok]
Waiting up to 60 more seconds for network configuration...
Booting system without full network configuration...
 * Stopping Failsafe Boot Delay [ok]

I switched to ctrl - alt - F1, and run "/etc/init.d/lightdm start ; exit" and I'm in business.

GeekSmith (lixo-geeksmith) wrote :

Manual symlink of /var/run->/run and /var/lock-/run/lock fixed my issues.

Sebastien Bacher (seb128) wrote :

GeekSmith, could you open a new bug? your symlick seems different to others

Could people check on bug #864174 as well which said to "edit the contents of /etc/X11/default-display-manager to read "/usr/sbin/lightdm"."

Nicolas Diogo (nicolasdiogo) wrote :

same here

iinstalled gdm

wait until sorted

Sebastien Bacher (seb128) wrote :

the issue there doesn't seem to be lightdm, if you have an issue due to the default-display-manager, use #864174

Changed in lightdm (Ubuntu):
status: Confirmed → Invalid
importance: Undecided → Low
importance: Low → High
Colin Watson (cjwatson) wrote :

I don't see how this can be a netcfg bug; even if it were generating incorrect interfaces files (which seems unlikely), ifupdown would have to deal with old ones *anyway*. Reassigning.

affects: netcfg (Ubuntu) → ifupdown (Ubuntu)
Colin Watson (cjwatson) wrote :

In fact, failsafe.conf is owned by upstart isn't it ...

affects: ifupdown (Ubuntu) → upstart (Ubuntu)
Zaphod (vilppu777) wrote :

This is still an issue I did a fresh install of 11.10 x64 and I have the issue.

ubunturox (ubunturox-kk) wrote :

Here is my experience with this issue:

I have a fresh install of 11.10 running since Alpha 2 - NEVER had ANY sorts of problems

I have another image running 11.04 without any problems. Today I decided that I would upgrade my 11.04 to 11.10 and since my 11.10 did not show any problems, I did it with confidence.

After reboot, I saw the "waiting for network" issue. From there, it booted to a blank screen.
Tried booting with the splash turned off in text mode and noticed dbus was not starting followed by the waiting for network issue. Still it booted in to blank screen.

Next tried to boot in to single user mode, noticed the network no longer lists eth0 in interfaces file.

tried booting with "init 5" from here with no success.

Then read about the lightdm issue and migration to /run, so I did as follows:
0) Start dbus manually
1) start "gdm" from single user mode
2) log in
3) desktop appears, unity appears, task bar appears
4) start ANY program, the icon shows in unity but the app window is not visible. Not a single window is visible ... even shutdown dialog
5) reboot

Repeat the above steps, but now select "ubuntu 2D" in step (2) above. Now its fine, can see app windows, interact with them etc. No network still.

Now I did
1) run dpkg-reconfigure lightdm like "Michael" said above
2) Moved the files from /var/run to /run and /var/lock to /run/lock and made symlinks (thanks Gabriel Thörnblad)
3) Cleaned out the dbus directory under /var/dbus (from Alexandre Devaud #17)
4) install VBOX addons (again ... to try to get network back)
5) reboot

Now it seems like everything is fine.

I suspect
upgrade script is not working properly and failing in migrating the file from /var/run & /var/lock to their new location. This is causing the dbus to fail and hence lightdm gets messed up and doesnt start which results in blank screen and no app windows.

Not sure why my ethernet related settings disappeared though.

Hope this helps others

Felix Vollmer (felixvollmer) wrote :

Hey,
I just experienced this problem yesterday, but with upstream kernel (I know there is no support for upstream kernels). I only installed it for testing and did my testing in failsafe. I just thought it might should now. (daily kernel is here: http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/)

Mark Furneaux (markfurneaux) wrote :

This bug affects me on only 1 of my 4 Oneiric machines running the full release, not the RC. I did a reinstall fresh and everything worked without this problem until I installed ifenslave and setup a bond0 interface between eth0 and eth1. It is setup in /etc/network/interfaces. I have noticed that /var/run/network contains placeholders for all interfaces except bond0, and I remember that that directory had something to do with a related bug.

Changed in linaro-ubuntu:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 11.10
Ricardo Salveti (rsalveti) wrote :

I'm also able to see this happening while using the linaro-nano image (just a minimal rootfs based on ubuntu oneiric).

The failsafe service will always be called, because of the upstart script dependencies:
"start on filesystem and net-device-up IFACE=lo"

This just exists so rc-sysinit.conf can also be called after failsafe:
"start on (filesystem and static-network-up) or failsafe-boot"

On my case I need to debug upstart to see why the static-network-up event wasn't available at the time failsafe-boot finished, still in progress.

Ricardo Salveti (rsalveti) wrote :

The problem happens because /etc/network/if-up.d/upstart now only emits the static-network-up event when all network interfaces described at /etc/network/interfaces are properly configured (bug 838968).

At linaro-nano the bug only happens because we're also adding the usb0 interface, as it's common at some devices we support. After removing it at Panda I'm able to boot it without the annoying wait for more than 2 minutes.

Hi, I also have Boot hangs at "Booting system without full network configuration..." problem. Deleting /var/run/dbus/pid is the only way for me to reboot. I also had to remove the sleeps from /etc/init/failsafe.conf to get more normal booting time, otherwise it just waits even though the dbus pid is removed. Upgraded from Natty yesterday.

Tuukka Hastrup (tuukkah) wrote :

I think this bug report demonstrates a significant problem in the current boot system: the reported user-visible symptom can be caused by a wide variety of underlying issues during the boot process. Further, it's hard to diagnose which underlying issue affects each system .

I propose this bug number should track this difficulty of diagnosis in the boot system. Then, the various underlying causes should be filed as separate bugs as discovered, such as bug #838968, bug #864174 etc.

I had the same problem, solved it as comment #3

sudo apt-get install gdm, don't forget to restart(sudo reboot).

In my case also manual symlinking of /var/run->/run and /var/lock-/run/lock fixed my issues.
In my case the problem was caused by dbus. As long as I did not symlink /var/run and /var/lock dbus could not be started and prevented practically anything else to run.
Although dbus created /var/run/dbus/pid and /var/run/dbus/system_bus_socket but the process listed in pid was never running. After removing the pid, restarting dbus sometimes worked sometimes not but when dbus could be started gdm or even lightdm could be started successfully and gui was working fine.

So probably you can simulate this error having
/var/run, /var/lock, /run, /run/lock all as different directories and if dbus fails with this config then there you go.

anw (anw-d) wrote :

wow, are you serious, this bug should be classified as critical. Looking on google, a LOT of users are getting this error...
I couldn't get my system boot for all evening after upgrading from previous ubuntu version.
Here is how i sorted this out :

sudo mv /var/run/* /run/
sudo mv /var/lock/* /run/lock/
sudo rm -r /var/run
sudo rm -r /var/lock
sudo ln -s /run /var/run
sudo ln -s /run/lock /var/lock
sudo rm /run/dbus/*

Jhair (jhair-tocancipa) wrote :

On my system the symlinks /var/lock -> /run/lock and /var/run -> /run already exist and I have the same issue. Is the only workaround to change the sleep parameters in /etc/init/failsafe.conf? I'm using gdm, xfce4 and ubuntu 11.10.

k anliot (mistertwig) wrote :

bug bit me after upgrading today. (xubuntu & lightdm)
comment 17 in this thread worked for me, after I hit ctrl+alt+f1 and logged in.

https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/856810/comments/17

k anliot (mistertwig) wrote :

This bug is not a 'moderate' severity bug.

Boot to 'black screen' would have most people buy new hardware.

GeekSmith (lixo-geeksmith) wrote :

I had this issue again on another system after an upgrade from 11.04.

I wholly agree with others that the severity on this is critical. It results in a system that will not boot. How is this "moderate"?

GeekSmith (lixo-geeksmith) wrote :

Again, a manual symlink of /var/run->/run and /var/lock-/run/lock fixed the issue on this second system.

ill (illumilore) wrote :

That manual symlink didn't work for my system, so that isn't a fix all solution.

Adam Niedling (krychek) wrote :

Removing an old DSL connection from /etc/network/interfaces fixed the problem for me. I also removed it from the network connections GUI along with some other connections that I haven't used in a long time.

Artuom (artem501) wrote :

It's an awful bug, the total booting time of the system becomes very long. But my network connections with "pon" utility are OK.

Anita (anitabowersock) wrote :

When i got up this morning i had 25 updates to install and after updating restarted computer all went well. ubuntu fixed the bug thanks everyone

ill (illumilore) wrote :

Still happening here...

Koen Verweij (kfverweij) wrote :

I can confirm that this is fixed for me too. However since it is still happening for illumilore I think that my bug was actually bug 881079 instead. Bug 881079 is fixed with the new upstart update. There are also several other similar (or maybe duplicate??) bugs to this one: bug 876449, bug 858122 and bug 881079.

Jens Maus (jens.maus) wrote :

I had the same problem here with one system after having upgraded it from 11.04 to 11.10. However, the instructions given in #40 solved the problem after a reboot. So it really seems that something when upgradeing a 11.04 to 11.10 seems to screw up the new /var/run -> /run move. Here also /etc/network/run was unresolved, thus on bootup the system couldn't bring up the network device (eth0) and also dbus couldn't start. Now after applying the instructions in #40 immediately fixed the problem.

Jim Ciallella (jimc) wrote :

#40 for the win. Thanks.

#40 for the win. Thanks.

Owen Duffy (owwn) wrote :

Frustrated with this same problem for quite some time now with no apparent fix coming, I attacked the problem on my own system today.

None of the fixes mentioned earlier in this thread fixed the problem, not any that I have otherwise seen.

Since my problem might have different root cause for the same outcome, I have written some notes in another bug report at https://bugs.launchpad.net/ubuntu/+bug/885909 which might help some people to a solution.

Owen

Louis Pastorik (lbpastorik) wrote :

I encountered this bug when upgrading from Ubuntu 11.04 to 11.10. I read all the comments from this issue and the accompanying issue mentioned previously, then I resolved this issue by doing the following actions (in this order):

sudo dpkg-reconfigure lightdm
sudo apt-get purge gdm
sudo rm /var/var/dbus/pid
su root
created directories /run and /run/lock (these already existed)
moved contents of /var/run into /run and /var/lock into /run/lock,
delete directories /var/run and /var/lock
create replacement simlinks; e.g. 'ln -s /run /var/run' and 'ln -s /run/lock /var/lock'
reboot

I rebooted twice just to be sure since I went through part of this process once, resolved it, then the problem reappeared after reboot. The problem only stayed resolved after doing ALL of the above steps. Had I been an uneducated user (not a techie) I would have been really angry. Ubuntu community needs to upgrade the OS soon to fix this. This is a huge issue since the machine UI was unusable until this fix was in place!

Martin G Miller (mgmiller) wrote :

Had this problem after upgrading 32 bit 11.04 to 11.10 in Lenovo T400 notebook. Comment #40 solved it for me.

Fathi Boudra (fboudra) on 2011-11-11
Changed in linaro-ubuntu:
milestone: 11.10 → 11.11
Yongzhi Pan (fossilet) wrote :

Using interfaces file to set up ethernet cards causes this problem for me, and comment #40 doesn't work.

Changed in linaro-ubuntu:
status: Confirmed → Fix Released
no!chance (ralf-fehlau) wrote :

I think Ubuntu was NOT tested on a system with 2 NICs. I commented out thes sleep lines and it will boot without issues. My /etc/network/interfaces contains eth0 and eth1 and these static interface definition will remain there, since I use NIS. Former Ubuntu releases had no problem with this configuration. Why has Ubuntu 11.10 a problem with it??

Matteo Landi (landimatte) wrote :

FWIW, I managed to solve the issue by adding ``auto eth0'' to my /etc/network/interfaces configuration file.

mandza (filmovi) wrote :

I have had the same problem, but after removing "/var/run/dbus/pid" and rebooting server everything was normal again.
(#14 comment)

mandza (filmovi) wrote :

My server worked for a hour and now i have same problem.
when i remove /var/run/dbus/pid again it doesnt have any effect.

mandza (filmovi) wrote :

#40 doesnt work for me :(
my server doesnt work. i will take backup and reinstall. but not 11.10.

Ondrej Hajek (ondrej-hajek) wrote :

after upgrade to 11.10 same problem here, comment #40 worked for me

mandza (filmovi) wrote :

My problem was bad ethernet cable?
i changed it and my problem was solved.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers