compiz crashes on i915 graphic module with GLX_EXT_texture_from_pixmap is missing

Bug #851345 reported by Philipp Meier on 2011-09-15
102
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Unity
Invalid
Critical
Sam Spilsbury
compiz (Ubuntu)
Critical
Canonical Desktop Experience Team
Oneiric
Critical
Canonical Desktop Experience Team
Precise
Critical
Unassigned
lightdm (Ubuntu)
High
Robert Ancell
Oneiric
High
Robert Ancell
Precise
High
Unassigned

Bug Description

Ubuntu 11.10:
unity: 4.20.0-0ubuntu2
compiz: 1:0.9.6+bzr20110929-0ubuntu1
xorg: 1:7.6+7ubuntu7
linux-image-generic: 3.0.0.12.19
lightdm: 1.0.0-0ubuntu4

Since today’s updates compiz does not load any more. When i try to log into unity-3d it quickly blinks with the following error message:
compiz --replace &

Backend : gconf
Integration : true
Profile : unity
Adding plugins
Skipping upgrade com.canonical.unity.unity.01.upgrade
Skipping upgrade com.canonical.unity.unity.02.upgrade
Initializing core options...done
Initializing bailer options...done
Initializing detection options...done
Initializing composite options...done
Compiz (opengl) - Fatal: GLX_EXT_texture_from_pixmap is missing
Compiz (opengl) - Fatal: Software rendering detected
Compiz (bailer) - Info: Ensuring a shell for your session

But my hardware was absolutely fine with 3d acceleration before today.

lspci -v:
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07) (prog-if 00 [VGA controller])
 Subsystem: Lenovo Device 20e4
 Flags: bus master, fast devsel, latency 0, IRQ 43
 Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
 Memory at d0000000 (64-bit, prefetchable) [size=256M]
 I/O ports at 1800 [size=8]
 Expansion ROM at <unassigned> [disabled]
 Capabilities: <access denied>
 Kernel driver in use: i915
 Kernel modules: i915

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: compiz 1:0.9.5.94+bzr2803-0ubuntu5
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: None
Date: Thu Sep 15 23:00:56 2011
DistUpgraded: Log time: 2011-09-13 18:19:39.302686
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 vboxhost, 4.1.2, 3.0.0-11-generic, x86_64: installed (WARNING! Diff between built and installed module!) (WARNING! Diff between built and installed module!)
 virtualbox, 4.1.2, 3.0.0-11-generic, x86_64: installed (WARNING! Diff between built and installed module!) (WARNING! Diff between built and installed module!)
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:20e4]
   Subsystem: Lenovo Device [17aa:20e4]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110302)
MachineType: LENOVO 2774A29
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=de:en
 PATH=(custom, no user)
 LANG=de_CH.UTF-8
 LC_MESSAGES=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=7cec099f-15dd-4509-ba10-033af14b1600 ro quiet splash pcie_aspm=force vt.handoff=7
SourcePackage: compiz
UpgradeStatus: Upgraded to oneiric on 2011-09-13 (2 days ago)
dmi.bios.date: 12/10/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6EET54WW (3.14 )
dmi.board.name: 2774A29
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6EET54WW(3.14):bd12/10/2010:svnLENOVO:pn2774A29:pvrThinkPadX301:rvnLENOVO:rn2774A29:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2774A29
dmi.product.version: ThinkPad X301
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.5.94+bzr2803-0ubuntu5
version.ia32-libs: ia32-libs 20090808ubuntu21
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Philipp Meier (meier-philipp) wrote :
Philipp Meier (meier-philipp) wrote :

I just tried to reproduce the bug with an older kernel and was successful.
Same Error happens with Kernel 2.6.38-11-generic which was working perfectly with natty.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Philipp Meier (meier-philipp) wrote :

Looks like it was not a problem with compiz, as it is working now again after todays update of:
upstart 1.3-0ubuntu9
lightdm 0.9.7-0ubuntu1
Therefor marking as invalid.

Changed in compiz (Ubuntu):
status: Confirmed → Invalid
Philipp Meier (meier-philipp) wrote :

I reopen this bug because after last weeks update the bug is back again.
I still can't figure out why it suddenly does happen again.

Changed in compiz (Ubuntu):
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Philipp Meier (meier-philipp) wrote :

added lightdm as it was resolved last time by updating lightdm.

affects: compiz (Ubuntu) → lightdm (Ubuntu)
description: updated
description: updated
Jean-Baptiste Lallement (jibel) wrote :

I get this error and Unity fails to start on 2 systems. One is a fresh installation and the other has been updated.
It doesn't fail on every boot though.

Changed in compiz (Ubuntu):
importance: Undecided → Critical
milestone: none → ubuntu-11.10
status: New → Confirmed
Changed in lightdm (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Changed in compiz (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Changed in lightdm (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → nobody
tags: added: rls-mgr-o-tracking
Didier Roche (didrocks) on 2011-10-03
Changed in unity:
status: New → Triaged
importance: Undecided → Critical
milestone: none → 4.22.0
assignee: nobody → Sam Spilsbury (smspillaz)
Jean-Baptiste Lallement (jibel) wrote :

output of "LIBGL_DEBUG=verbose glxinfo" attached

important bits:
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/i965_dri.so
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/i965_dri.so
libGL error: failed to open drm device: Permission denied
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/swrast_dri.so

output of ck-list-sessions
ession3:
 unix-user = '1000'
 realname = 'ubuntu'
 seat = 'Seat1'
 session-type = ''
 active = FALSE
 x11-display = ''
 x11-display-device = ''
 display-device = '/dev/tty1'
 remote-host-name = ''
 is-local = TRUE
 on-since = '2011-10-03T08:45:46.135467Z'
 login-session-id = ''
 idle-since-hint = '2011-10-03T09:09:06.602876Z'

I added the information to bug 863119 which might be the root cause of this problem.

Changed in lightdm (Ubuntu Oneiric):
importance: Undecided → High
importance: High → Critical
status: New → Confirmed
Sam Spilsbury (smspillaz) wrote :

These are invalid for compiz and unity since there's no graphics acceleration to run them.

Changed in unity:
status: Triaged → Invalid
Changed in compiz (Ubuntu Oneiric):
status: Confirmed → Invalid
Changed in lightdm (Ubuntu Oneiric):
status: Confirmed → Invalid
status: Invalid → Confirmed

after a day testing, I've finally been able to reproduce but still didn't find a pattern to do it reliably. It seems to happen after a system upgrade.

lightdm logs are attached.

I noticed that each time it happens there is the following message in syslog
Oct 4 23:55:32 white kernel: [ 175.787767] init: lightdm main process (909) killed by ABRT signal

I'll attach the list of packages that have been updated to next comment.

Changed in lightdm (Ubuntu Oneiric):
assignee: nobody → Robert Ancell (robert-ancell)

packages updated before the failure.

I'm lowering importance because 1) it is not easy to reproduce and seems to requires very specific conditions to be triggered 2) restarting the system works around the problem.

Changed in lightdm (Ubuntu Oneiric):
importance: Critical → High

~/.xsession-errors when it fails.

there are a lot of dbus reject messages and I also noticed this warning emitted by several apps:
WARNING **: Failed to get the current CK session: GDBus.Error:org.freedesktop.ConsoleKit.Manager.GeneralError: Unable to find session for cookie

Philipp Meier (meier-philipp) wrote :

Well on my machine it happens every boot time. It does not help to reboot or to logout and log back in.
Any additional information I could provide?

Sebastien Bacher (seb128) wrote :

bug #863054 seems similar

Philipp Meier (meier-philipp) wrote :

At least for me it does not sound familiar to bug #864054 as everything from update to synaptic to external drives is working properly. Just the 3d-acceleartion did stop and therefore unity-2d is running. But the hardware is fully capable of 3d acceleration and a different kernel did not help at all.
The bug was once fixed by an update of lightdm as you can see above.

Philipp Meier (meier-philipp) wrote :

.xsessions-errors has the following access rights: -rw------- username usergroup

Robert Ancell (robert-ancell) wrote :

What I suspect is happening here is the lightdm daemon has crashed. When it does that CK automatically deletes the ConsoleKit sessions it owned so even though the session and X server continue to run you wont have permission to access things anymore. You can confirm this by running:
$ sudo killall -SIGABRT lightdm
You will have to kill the X server after this and run sudo start lightdm to recover.

The question is, what has caused the lightdm daemon to crash and why hasn't apport restarted it / gone into failsafe X mode?

Robert Ancell (robert-ancell) wrote :

I mean to say why hasn't *upstart* restarted it...
Note that SIGABRT seems to be implicated as the signal stopping lightdm. This is normally due to an assertion being hit, perhaps something like an out of memory error?

no trace of an out of memory error here, after boot and this error, the system still has 1.6GB of RAM free and no kernel message that would suggest a memory failure.

Philipp Meier (meier-philipp) wrote :

same here does not look like it has not enough "real" memory. I do also have around 1.7 GB of free RAM.
any way to make sure it really is a lightdm problem?

Changed in compiz (Ubuntu Oneiric):
milestone: ubuntu-11.10 → none
Changed in compiz (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → High
Changed in lightdm (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → High
Changed in compiz (Ubuntu Precise):
status: Confirmed → Invalid
importance: High → Critical
Robert Ancell (robert-ancell) wrote :

I saw this for the first time last night. The symptons for me were the user switching not being visible, and the dmesg log about LightDM crashing with SIGABRT. Compiz kept running and was usable however. I'm flying today so I wont be able to investigate it until I get there.

Jonathan Meek (shroudedcloud) wrote :

I think this is what just happened to me. Had a LightDM update earlier and upon restart got the desktop with nautilus' menu across the top. Have a Radeon mobility card.

Nicolas Delvaux (malizor) wrote :

Same bug here, with the free radeon driver.

I captured a stack trace of the SIGABRT. You'll also find the trace from a SIGUSR in there, but that looked like normal behavior.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.0.1-0ubuntu6

---------------
lightdm (1.0.1-0ubuntu6) oneiric; urgency=low

  * debian/patches/08_correct_ck_ref.patch:
    - backported fix from Mikkel Kamstrup Erlandsen for a refcounting issue
      which leads to sessions where unity can't start (lp: #851345)
 -- Sebastien Bacher <email address hidden> Fri, 07 Oct 2011 13:57:44 +0200

Changed in lightdm (Ubuntu Oneiric):
status: Confirmed → Fix Released
Martin Pitt (pitti) on 2011-10-09
Changed in lightdm (Ubuntu Precise):
status: Confirmed → Fix Released
David Bowman (dave-ubuntuguru) wrote :

happened to me after a kernel upgrade

Philipp Meier (meier-philipp) wrote :

it is still not fixed for me after update to:
lightdm 1.0.1-0ubuntu6

Still there is no 3d acceleration and I can only use unity2d. Is there any other step that needs to be done to fix this issue?

Philipp Meier (meier-philipp) wrote :

it works. It seems to have removed xserver-xorg-video-intel driver before installing it through the software centre did fix it.

vennec (vennec) wrote :

It still doesn't work for me.
lightdm is updated to 1.01-0ubuntu6, kernel is 3.0.0.12.
My grapĥic card is an i945 (i915 graphic module)

When I run compiz --replace, I get:
compiz Error: GL_ARB_vertex_buffer_object not supported

Dana Goyette (danagoyette) wrote :

I can confirm that it seems to be ConsoleKit killing the session, because it's taking out both DRI and audio.
This bug should probably renamed -- it's not merely an i915 issue.

Rocko (rockorequin) wrote :

I am seeing this about once a day. It happens after a compiz crash - when it happens, unity tries to restart but the launcher and panel don't appear.

Just now I tried the suggestion in comment #21 (ie from a root tty, kill the X session and do "killall -SIGABRT lightdm; start lightdm"), but it didn't work - after restarting the X session the problem persisted. I had to completely reboot the machine to fix it.

Since this bug is marked fixed, should we open another one?

patrick samples (ptrakk) wrote :

its doing this to me too.. i am using unity-2d right now and it wont autohide.

To post a comment you must log in.