Cannot login after un upgrade from 12.04 to 12.10 (ubuntu-2d)

Bug #1059137 reported by Aizelauna on 2012-09-30
56
This bug affects 13 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
High
Michael Terry
Quantal
High
Michael Terry
update-manager (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

After an upgrade from ubuntu 12.04 to 12.10, I was no more able to login with my usual account.
Lightdm failed to load x session.
After a long search, I understood that the problem was coming from ubuntu-2d xsession.
My user account was configured to use unbuntu-2d when i was in ubuntu 12.04.
But as this xsession has been removed in ubuntu 12.10, lightdm failed to load it.

I managed to fix my problem doing following steps :
 - edit my user file with gedit in this folder :
/var/lib/AccountsService/users
 - replace "XSession=ubuntu-2d" by "XSession=ubuntu"
 - reboot ubuntu for the file modification to be taken in account.

In my opinion, this fix should be applied automatically for all users using ubuntu-2d and upgrading their distribution.
---
ApportVersion: 2.5.3-0ubuntu1
Architecture: amd64
DistroRelease: Ubuntu 12.10
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
Package: update-manager
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.5.0-16.25-generic 3.5.4
Tags: quantal running-unity
Uname: Linux 3.5.0-16-generic x86_64
UpgradeStatus: Upgraded to quantal on 2012-09-30 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare sudo

Sasa Paporovic (melchiaros) wrote :

Yes, that would be better.

Please run from terminal

apport-collect 1059137

this will bring up the logs that help to handle the ticket.

When there are missing libraries (launchpadlib) please install them in addtion to run the above command.

I let the status to new(and not incomplete), but the apport collect is mostly really needed.

greetings

melchiaros

affects: lightdm → update-manager (Ubuntu)
tags: added: dist-upgrade precise quantal
Sasa Paporovic (melchiaros) wrote :

Also a compresed

var/log/dist-upgrade

folder would be helpfull.

apport information

tags: added: apport-collected running-unity
description: updated
Sasa Paporovic (melchiaros) wrote :

Yes, thank you. Unfortunally apport has not gatherd the dist-upgrade folder. Could you manually.

Aizelauna (aize-launa) wrote :

Please find attached to this comment a zip of dist-upgrade folder.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Changed in update-manager (Ubuntu):
status: New → Confirmed
Dave Gilbert (ubuntu-treblig) wrote :

Marked as High, not being able to log in after upgrade seems bad. (Although this might be a greeter bug rather than lightdm itself?).

We had a couple of people on #ubuntu+1 yesterday hitting this.

One way to distinguish this from a post-login crash is that if the users delete their .xsession-errors, and then try logging in again
the .xsession-errors isn't recreated.

I think there needs to be some logic along the line of:
  If the last session no longer exists then select the 1st available session type.

The people who were talking about this on +1 yesterday didn't see the icon to click on to select the other session (I'm not sure
if this was because there was only one installed session, or because the icon is normally an icon representing the currently selected session, and since that doesn't exist it doesn't have anything to show).

Changed in lightdm (Ubuntu):
importance: Undecided → High
scottku (scottku) wrote :

I had problems logging in after upgrading two (out of three) different machines. One some of these machines, I may have installed alternative desktops and tried them in the distant past---but have generally used Unity. On the two machines I had problems with, I was able to solve the problem by selecting the "Ubuntu (default)" option by clicking the Ubuntu icon next to the password prompt. There must be a bug somewhere, however. If an alternate desktop is available, it should log in to that---or if it is not available, the menu item should be removed from the list.

Sasa Paporovic (melchiaros) wrote :

I copy out the single files from the dist-upgrade.tar.gz folder

Sasa Paporovic (melchiaros) wrote :
Sasa Paporovic (melchiaros) wrote :
Sasa Paporovic (melchiaros) wrote :
Sasa Paporovic (melchiaros) wrote :
Sasa Paporovic (melchiaros) wrote :
Sasa Paporovic (melchiaros) wrote :

The term.log is emty and could not attached - launchpad do not accept.

MikeCamel (mike-hingston) wrote :

I've marked #964607 as a duplicate. I believe that the problem lies in /var/lib/AccountsService/users/<username> file.

I had this line:

XSession=xsession

I noticed that a new user had

XSession=ubuntu

I changed mine to read "ubuntu", rebooted, and was fine.

The original poster said "In my opinion, this fix should be applied automatically for all users using ubuntu-2d and upgrading their distribution." I'd change this to "this fix should be applied automatically for all users using ubuntu-2d or xsession and upgrading their distribution."

Is there a list of acceptable values for this key? If so, what are the package dependencies?

Ales Katona (almindor) wrote :

I got the same problem, fix works too. This should defenetly get fixed

Ricky (ricky-nance) wrote :

I think the simplest solution would be to honor the unity2d desktop but force it to be unity3d. Then there would be no per user fixes needed. The way I fixed my install was similar to this idea.

Sebastien Bacher (seb128) wrote :

Didier agreed to look at this ;-)

Changed in lightdm (Ubuntu Quantal):
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) wrote :

So, our patch (working in the past) didn't work anymore, it was changing the ubuntu-2d to ubuntu session. See debian/patches/01_transition_ubuntu2d_ubuntu_desktop.patch

This code is still called and the exchange is done, However, it seems that now that lightdm moved to account services, the value is somewhat overriden.

I tried various g_debug() and replacing the value in different place, without any luck (I put high hopes in src/accounts.c TBH as it was referencing XSession, but the g_debug shows that the code isn't even called). TryExec which used to work on the past isn't read anymore as well :(

I attach the patch with different places I tried to patch it and start to be frightened about autologin and other similar case. All of them were covered by the old patch. Mike, as you know better the code than me, can you have a look at this? Thanks!

Changed in lightdm (Ubuntu Quantal):
assignee: Didier Roche (didrocks) → Michael Terry (mterry)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.4.0-0ubuntu2

---------------
lightdm (1.4.0-0ubuntu2) quantal; urgency=low

  * debian/patches/01_transition_ubuntu2d_ubuntu_desktop.patch:
    - Fix 2d->3d transition to handle new support for accountsservice
      LP: #1059137
 -- Michael Terry <email address hidden> Tue, 09 Oct 2012 10:26:43 -0400

Changed in lightdm (Ubuntu Quantal):
status: Confirmed → Fix Released
Steve Langasek (vorlon) on 2012-10-09
Changed in update-manager (Ubuntu Quantal):
status: Confirmed → Invalid
MikeCamel (mike-hingston) wrote :

The patch doesn't seem to cover the case that I came across, where the value was not "ubuntu", but "xsession".

Ephaedrus (rossm-7) wrote :

I also have this bug but as a noobie I am completely lost as how to fix it. Is there any chance of further information or a run through of how to apply the fix? I tried changing the ubuntu-2d to ubuntu with no resolution. Thanks

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1059137

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers