Ubuntu

Right click menu for indicators has corrupted background

Reported by Otus on 2011-02-02
156
This bug affects 30 people
Affects Status Importance Assigned to Milestone
light-themes (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: indicator-applet

The right click menu you get for indicators has a corrupted background image that looks bad. See attached image.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: indicator-applet 0.4.7-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic x86_64
Architecture: amd64
Date: Wed Feb 2 10:03:18 2011
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110201.1)
ProcEnviron:
 LANGUAGE=en_US.UTF-8:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_AG.utf8
 SHELL=/bin/bash
SourcePackage: indicator-applet

Otus (jan-varho) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that's not restricted to the indicator applet though right?

affects: indicator-applet (Ubuntu) → gnome-panel (Ubuntu)
Changed in gnome-panel (Ubuntu):
importance: Undecided → Low
Otus (jan-varho) wrote :

Yes it is. Right clicking on the main menu or an empty part of the panel works fine as do the left click applet menus.

Sebastien Bacher (seb128) wrote :

it's doing the same when right clicking on the workspace switcher applet for example there

Changed in gnome-panel (Ubuntu):
status: New → Confirmed
Otus (jan-varho) wrote :

Ok, didn't notice. Maybe a theme problem then?

tags: added: iso-testing

I'm also attaching a screenshot based on 2011-04-14's natty amd64 daily image

Observed on the menus of both used and newly added applets as well as on the vertical toolbars. Appears in the Ambiance, Radiance themes.

Alin (alin-popa) wrote :

I've also noticed this UI (?) annoying problem:
- Ubuntu 11.04 released, 32bit
I've also attached a screenshot of this (right click on the Indicator Applet)

Jim Bauwens (jimbauwens) wrote :

Quick fix:

Open /usr/share/themes/Ambiance/gtk-2.0/apps/gnome-panel.rc (or change Ambiance to Radiance if you are using that).

Create a new style based on the Panel style, without the backroung image setting, and name is 'panell":
[code]
style "panell" = "dark"
{
 xthickness = 0
 ythickness = 0

 bg[NORMAL] = "#4b4a46"

 engine "murrine" {
  #contrast = 1.0
  textstyle = 2
  text_shade = 0.35
 }
}[/code]

Then look for
[code]widget "*PanelApplet*" style "panel"[/code]
and change it with
[code]widget "*PanelApplet*" style "panell"[/code]

Save it and run "killall gnome-panel", and it should be fixed.

S.Rey (s.rey) wrote :

Jim Bauwens' fix solves the issue for me.

Worked for me too.
Ta.

Alin

On Wed, May 4, 2011 at 9:02 PM, S.Rey <email address hidden> wrote:

> Jim Bauwens' fix solves the issue for me.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/711746
>
> Title:
> Right click menu for indicators has corrupted background
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-panel/+bug/711746/+subscribe
>

Pedro Villavicencio (pedro) wrote :

more like a theme issue, reassigning.

affects: gnome-panel (Ubuntu) → light-themes (Ubuntu)
Changed in light-themes (Ubuntu):
status: Confirmed → Triaged
komputes (komputes) wrote :

I can confirm this issue when right-clicking panel applets in Natty.

Oleg O Andreev (olegoandreev) wrote :

BTW, Jim Bauwens patch fixed the background issue, but the menus were still a bit crumpled due to xthickness/ythickness = 0. The issue was fixed completely for me by changing the line

widget "*PanelApplet*" style "panel"

to

widget_class "*PanelApplet*" style "panel"

On a side not, I do hope, themeing Gtk+3 will be easier than this mess.

The fix has worked for me too.

cgonzalez (cmgonzalez) wrote :

Also

ythickness = 2

in panel is missing...

The issue has occurred on Ambiance on Linux Mint as well.

…and Jim Bauwens' fix has worked on it also. Thanks again.

Andrea Cimitan (cimi) on 2012-04-30
Changed in light-themes (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers