Comment 6 for bug 1313958

felix (f-sperling) wrote :

This broke the upgrade from utopic to vivid for me.
Still no fix? Not even a workaround?

$ sudo apt-get upgrade -f

supported-versions: WARNING: Unknown Ubuntu release: 15:04
(Reading database ... 466018 files and directories currently installed.)
Preparing to decompress ... / libltdl-dev_2.4.2-1.11_amd64.deb ...
Unpacking libltdl-dev: amd64 (2.4.2-1.11) through (2.4.2-1.10ubuntu1) ...
dpkg: error processing the archive /var/cache/apt/archives/libltdl-dev_2.4.2-1.11_amd64.deb (--unpack):
  Attempt Communal ยป/usr/share/libtool/libltdl/Makefile.in" to override that of other instances of the package libltdl-dev different: is amd64
Errors were encountered while processing:
  /var/cache/apt/archives/libltdl-dev_2.4.2-1.11_amd64.deb
Error: GDBus.Error: org.freedesktop.DBus.Error.Spawn.PermissionsInvalid: The permission of the setuid helper is not correct
E: Sub-process / usr / bin / dpkg returned on error code (1)

$ sudo apt-get upgrade
Reading package lists ... Done Building
Dependency tree.
Status information can be read .... Done
Try 'apt-get -f install' to correct this.
The following packages have unmet dependencies:
 epiphany-browser: Depends on: libjavascriptcoregtk-4.0-18 but is not installed
                    Depends on: libwebkit2gtk-4.0-37 (> = 2.6.0) but is not installed
 GDM: Depends on: gir1.2-GDM 1.0 (= 3.14.1-0ubuntu3) but 3.10.0.1-0ubuntu7.1 installed
       Depends: gnome-session-bin (> = 3.12.1) but 3.9.90-0ubuntu16.1 installed
       Recommends: but xserver-xephyr is not installed
 gnome-applets: Depends on: but libpanel-applet0 (> = 3.2.1) is not installed
                 Depends: gnome-applets-data (> = 3.14) but 3.8.1-1ubuntu1 is installed
                 Depends on: but gir1.2 Panel Applet 5.0 is not installed
 gnome-control-center: Depends on: libgnome-control center1 (> = 1: 3.14.2-2ubuntu3) but 1: 3.12.1-5ubuntu2 installed
 gnome-panel: Depends: gnome-panel-data (= 1: 3.14.0-2ubuntu1) but 1: 3.8.1-2ubuntu4 is installed
               Depends on: libical1a (> = 1.0) but is not installed
               Depends on: libpanel-applet0 (> = 3.4.1) but is not installed
               Recommends: gnome-session-flashback (> = 1: 3.14.0) but 1: 3.8.1-2ubuntu4 is installed
 gnome-settings-daemon: Depends on: libgeocode-glib0 (> = 0.99.1) but is not installed
 gnome-shell: Depends on: gir1.2 Mothers 3.0 (> = 3.14.4) but 3.12.2-1ubuntu2 installed
               Depends on: libgjs0e (> = 1.42.0) but 1.41.91-1ubuntu2 installed
               Depends on: libical1a (> = 1.0) but is not installed
               Depends on: libmutter0e but is not installed
               Depends on: gir1.2-upowerglib-1.0 (> = 0.99) but 0.9.23-2ubuntu2 installed
               Depends: gnome-backgrounds (> = 3.13.90) but is not installed
               Depends on: mother (> = 3.14.4) but is not installed
 indicator-applet-complete: Depends on: libpanel-applet0 (> = 3.2.1) but is not installed
 libltdl-dev: Depends: libltdl7 (= 2.4.2-1.10ubuntu1) but 2.4.2-1.11 installed
               Damaged: libltdl-dev: i386 but 2.4.2-1.11 is installed (= 2.4.2-1.10ubuntu1!)
 libltdl-dev: i386: Damaged: libltdl-dev but 2.4.2-1.10ubuntu1 is installed (= 2.4.2-1.11!)
 network-manager-gnome: Depends: libnm-gtk0 (= 0.9.10.1-0ubuntu4.1) but 0.9.8.8-0ubuntu7 installed
 network-manager-pptp-gnome: Depends: libnm-gtk0 (> = 0.9.10.0) but 0.9.8.8-0ubuntu7 installed
 python3: Depends on: python3-minimal (= 3.4.2-1) but 3.4.3-1 is installed
 Rhythmbox: Depends on: gir1.2 RB 3.0 (= 3.1-1ubuntu3) but 3.0.3-1ubuntu2 is installed
 rhythmbox-plugins: Depends: gir1.2 RB 3.0 (= 3.1-1ubuntu3) but 3.0.3-1ubuntu2 is installed
 Unity: Depends on: libunity-core-6.0-9 (= 7.3.2 + 15.04.20150420-0ubuntu1) but 7.3.1 + 14.10.20141016-0ubuntu1 installed
         Recommends: but unity-scope-devhelp is not installed
         Recommends: unity-scope-chromiumbookmarks but is not installed
         Recommends: but unity-scope-virtualbox is not installed
         Recommends: but unity-scope-Zotero is not installed
         Recommends: but unity-scope-gourmet is not installed
         Recommends: but unity-scope-yelp is not installed
         Recommends: but unity-scope-gmusicbrowser is not installed
         Recommends: unity-scope-openclipart but is not installed
         Recommends: but unity-scope-Guayadeque is not installed
         Recommends: but unity-scope-clementine is not installed
         Recommends: but unity-scope-audacious is not installed
         Recommends: unity-scope-colourlovers but is not installed
         Recommends: but unity-scope-calculator is not installed
         Recommends: but unity-scope-texdoc is not installed
         Recommends: unity-lens-photos but is not installed
         Recommends: but unity-scope-firefox bookmarks is not installed
         Recommends: but unity-scope-GDrive is not installed
         Recommends: unity-scope-musique but is not installed
         Recommends: but unity-scope-manpages is not installed
         Recommends: but unity-scope-tomboy is not installed
         Recommends: Indicator appmenu (> = 15.02.0) but 13.01.0 + 14.04.20140404-0ubuntu1 installed
         Recommends: hud but is not installed
 Unity Control Center: Depends on: libtimezonemap1 (> = 0.4.3build1) but 0.4.3 is installed
E: Unmet dependencies. Try to use -f.