Can't install i386 version of libltdl-dev package, Makefile.in file can't be overwrited

Bug #1313958 reported by Julian Alarcon on 2014-04-28
52
This bug affects 7 people
Affects Status Importance Assigned to Milestone
libtool (Debian)
New
Unknown
libtool (Ubuntu)
High
Unassigned

Bug Description

Today I tried to install 2 i386 packages on my Ubuntu 14.04 64 bits version.

I got this error:
sudo apt install unixodbc-dev:i386 libmyodbc:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
libmyodbc:i386 is already the newest version.
The following extra packages will be installed:
  libltdl-dev:i386 libodbc1 unixodbc
Suggested packages:
  libtool-doc:i386 libmyodbc odbc-postgresql tdsodbc unixodbc-bin
The following NEW packages will be installed:
  libltdl-dev:i386 libodbc1 unixodbc unixodbc-dev:i386
0 upgraded, 4 newly installed, 0 to remove and 10 not upgraded.
Need to get 0 B/563 kB of archives.
After this operation, 3.071 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Selecting previously unselected package libodbc1:amd64.
(Reading database ... 211935 files and directories currently installed.)
Preparing to unpack .../libodbc1_2.2.14p2-5ubuntu5_amd64.deb ...
Unpacking libodbc1:amd64 (2.2.14p2-5ubuntu5) ...
Preparing to unpack .../libltdl-dev_2.4.2-1.7ubuntu1_i386.deb ...
Unpacking libltdl-dev:i386 (2.4.2-1.7ubuntu1) ...
dpkg: error processing archive /var/cache/apt/archives/libltdl-dev_2.4.2-1.7ubuntu1_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/libtool/libltdl/Makefile.in', which is different from other instances of package libltdl-dev:i386
Selecting previously unselected package unixodbc.
Preparing to unpack .../unixodbc_2.2.14p2-5ubuntu5_amd64.deb ...
Unpacking unixodbc (2.2.14p2-5ubuntu5) ...
Selecting previously unselected package unixodbc-dev.
Preparing to unpack .../unixodbc-dev_2.2.14p2-5ubuntu5_i386.deb ...
Unpacking unixodbc-dev (2.2.14p2-5ubuntu5) ...
Processing triggers for man-db (2.6.7.1-1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libltdl-dev_2.4.2-1.7ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
darkhole@CO1WDJ39M6V1U:~$

Seems to be a multiarch related problem.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: libltdl-dev 2.4.2-1.7ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Apr 28 17:17:19 2014
InstallationDate: Installed on 2013-10-21 (189 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
SourcePackage: libtool
UpgradeStatus: Upgraded to trusty on 2014-04-21 (7 days ago)

Julian Alarcon (julian-alarcon) wrote :
Changed in libtool (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libtool (Ubuntu):
status: New → Confirmed
Michael Schaller (misch-9) wrote :

This also breaks dist-upgrades from Precise to Trusty if libltdl-dev:amd64 and libltdl-dev:i386 are installed.

Michael Schaller (misch-9) wrote :

Error during dist-upgrade from Precise to Trusty:
Unpacking libltdl-dev:i386 (2.4.2-1.7ubuntu1) over (2.4.2-1ubuntu1) ...
Preparing to unpack .../libltdl-dev_2.4.2-1.7ubuntu1_amd64.deb ...
Unpacking libltdl-dev:amd64 (2.4.2-1.7ubuntu1) over (2.4.2-1ubuntu1) ...
dpkg: error processing archive /var/cache/apt/archives/libltdl-dev_2.4.2-1.7ubuntu1_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/libtool/libltdl/Makefile.in', which is different from other instances of package libltdl-dev:amd64

dpkg status afterwards: (one of the two package is only in state unpacked)
$ dpkg -l | grep libltdl-dev
ii libltdl-dev:amd64 2.4.2-1ubuntu1 amd64 A system independent dlopen wrapper for GNU libtool
iU libltdl-dev:i386 2.4.2-1.7ubuntu1 i386 A system independent dlopen wrapper for GNU libtool

Trying to unpack the other package fails with the same error:
$ sudo dpkg --unpack /var/cache/apt/archives/libltdl-dev_2.4.2-1.7ubuntu1_amd64.deb
(Reading database ... 198056 files and directories currently installed.)
Preparing to unpack .../libltdl-dev_2.4.2-1.7ubuntu1_amd64.deb ...
Unpacking libltdl-dev:amd64 (2.4.2-1.7ubuntu1) over (2.4.2-1ubuntu1) ...
dpkg: error processing archive /var/cache/apt/archives/libltdl-dev_2.4.2-1.7ubuntu1_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/libtool/libltdl/Makefile.in', which is different from other instances of package libltdl-dev:amd64
Errors were encountered while processing:
 /var/cache/apt/archives/libltdl-dev_2.4.2-1.7ubuntu1_amd64.deb

Difference between the two '/usr/share/libtool/libltdl/Makefile.in' files:
$ dpkg-deb --extract /var/cache/apt/archives/libltdl-dev_2.4.2-1.7ubuntu1_amd64.deb /tmp/libltdl-dev:amd64
$ dpkg-deb --extract /var/cache/apt/archives/libltdl-dev_2.4.2-1.7ubuntu1_i386.deb /tmp/libltdl-dev:i386
$ diff /tmp/libltdl-dev:amd64/usr/share/libtool/libltdl/Makefile.in /tmp/libltdl-dev:i386/usr/share/libtool/libltdl/Makefile.in
90c90
< $(srcdir)/config-h.in lt__dirent.c lt__strl.c argz.c \
---
> $(srcdir)/config-h.in argz.c lt__strl.c lt__dirent.c \

I had a look on the source package of libtool. I ran the bootstrap script in the source twice and was able to reproduce the issue. It appears that there is no stable order in use when the libltdl/Makefile.in will be generated.

Changed in libtool (Debian):
status: New → Fix Released
Changed in libtool (Debian):
status: Fix Released → New
Hans Joachim Desserud (hjd) wrote :

Based on duplicate bug 1471478, this bug is still present in libltdl-dev 2.4.2-1.11 on Ubuntu 15.04.

tags: added: utopic vivid wily
Changed in libtool (Ubuntu):
importance: Undecided → High
felix (f-sperling) wrote :
Download full text (5.2 KiB)

This broke the upgrade from utopic to vivid for me.
Still no fix? Not even a workaround?

$ sudo apt-get upgrade -f

supported-versions: WARNING: Unknown Ubuntu release: 15:04
(Reading database ... 466018 files and directories currently installed.)
Preparing to decompress ... / libltdl-dev_2.4.2-1.11_amd64.deb ...
Unpacking libltdl-dev: amd64 (2.4.2-1.11) through (2.4.2-1.10ubuntu1) ...
dpkg: error processing the archive /var/cache/apt/archives/libltdl-dev_2.4.2-1.11_amd64.deb (--unpack):
  Attempt Communal »/usr/share/libtool/libltdl/Makefile.in" to override that of other instances of the package libltdl-dev different: is amd64
Errors were encountered while processing:
  /var/cache/apt/archives/libltdl-dev_2.4.2-1.11_amd64.deb
Error: GDBus.Error: org.freedesktop.DBus.Error.Spawn.PermissionsInvalid: The permission of the setuid helper is not correct
E: Sub-process / usr / bin / dpkg returned on error code (1)

$ sudo apt-get upgrade
Reading package lists ... Done Building
Dependency tree.
Status information can be read .... Done
Try 'apt-get -f install' to correct this.
The following packages have unmet dependencies:
 epiphany-browser: Depends on: libjavascriptcoregtk-4.0-18 but is not installed
                    Depends on: libwebkit2gtk-4.0-37 (> = 2.6.0) but is not installed
 GDM: Depends on: gir1.2-GDM 1.0 (= 3.14.1-0ubuntu3) but 3.10.0.1-0ubuntu7.1 installed
       Depends: gnome-session-bin (> = 3.12.1) but 3.9.90-0ubuntu16.1 installed
       Recommends: but xserver-xephyr is not installed
 gnome-applets: Depends on: but libpanel-applet0 (> = 3.2.1) is not installed
                 Depends: gnome-applets-data (> = 3.14) but 3.8.1-1ubuntu1 is installed
                 Depends on: but gir1.2 Panel Applet 5.0 is not installed
 gnome-control-center: Depends on: libgnome-control center1 (> = 1: 3.14.2-2ubuntu3) but 1: 3.12.1-5ubuntu2 installed
 gnome-panel: Depends: gnome-panel-data (= 1: 3.14.0-2ubuntu1) but 1: 3.8.1-2ubuntu4 is installed
               Depends on: libical1a (> = 1.0) but is not installed
               Depends on: libpanel-applet0 (> = 3.4.1) but is not installed
               Recommends: gnome-session-flashback (> = 1: 3.14.0) but 1: 3.8.1-2ubuntu4 is installed
 gnome-settings-daemon: Depends on: libgeocode-glib0 (> = 0.99.1) but is not installed
 gnome-shell: Depends on: gir1.2 Mothers 3.0 (> = 3.14.4) but 3.12.2-1ubuntu2 installed
               Depends on: libgjs0e (> = 1.42.0) but 1.41.91-1ubuntu2 installed
               Depends on: libical1a (> = 1.0) but is not installed
               Depends on: libmutter0e but is not installed
               Depends on: gir1.2-upowerglib-1.0 (> = 0.99) but 0.9.23-2ubuntu2 installed
               Depends: gnome-backgrounds (> = 3.13.90) but is not installed
               Depends on: mother (> = 3.14.4) but is not installed
 indicator-applet-complete: Depends on: libpanel-applet0 (> = 3.2.1) but is not installed
 libltdl-dev: Depends: libltdl7 (= 2.4.2-1.10ubuntu1) but 2.4.2-1.11 installed
               Damaged: libltdl-dev: i386 but 2.4.2-1.11 is installed (= 2.4.2-1.10ubuntu1!)
 libltdl-dev: i386: Damaged: libltdl-dev but 2.4.2-1.10ubuntu1 is installed (= 2.4.2-1.11!)
...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.