[Upstream] Nonprinting characters not showing in Writer

Bug #857041 reported by Doug Bates on 2011-09-23
56
This bug affects 11 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
High
libreoffice (Ubuntu)
Undecided
Björn Michaelsen

Bug Description

When authoring, or viewing write-enabled document in Writer (LibreOffice 3.4.3 OOO340m1 (Build:302) ) the non-printing character symbols don't show on screen.

Ctrl-F10 toggles toolbar icon OK, but to no effect on screen.

I'm running Ubuntu AMD64 Oneiric (beta) with Nvidia proprietary driver active.

I have the button for displaying non-printing characters pressed and all boxes in _Tools → Options → LibreOffice Writer → Formatting Aids → Display of_ ticked, including Paragraph end, Custom hyphens, Spaces, Tabs, Breaks. However, Writer randomly turns them off, i. e. the above characters become invisible in the normal view mode and the respective boxes become unticked.

This happens with any file but without any particular cause I could detect. Most often, it happens after printing a document out or switching to print preview and back, but sometimes also during the regular process of text editing.

The issue was found in LO 2.4.3 RC1 and persists in RC2 in Microsoft Windows 7 Professional Russian/JRE 1.6.0_26, however, I did not notice such a problem in 2.4.2 (on the same platform).

For me, paragraph end markers can not be made visible with menu or Ctrl-F10.

However, when I check:
  Tools > LibreOffice Writer > Formatting aid > check Paragraph ends
then Ctrl-F10 does turn them on/off.
Odd.

Reproducible with LibO 3.4.3 release (on WinXP 32b):
1. Writer > Ctrl+P (open print dialog)
2. Writer > File > Export as PDF...

The same bug with LibO-dev 3.5.0
[Build ID: d3d1481-3f8994a-2ba0a9f].

Works fine for me with LibreOffice 3.3.4
[OOO330m19 (Build:401) tag libreoffice-3.3.4.1].

The same with LibreOffice 3.4.3 / OOO340m1 (Build:302) under Ubuntu 10.04:

New Document; Export as PDF -> Paragraph end, Custom hyphens, Spaces, Tabs, Breaks will not be shown anymore until you switch them on with and all boxes
in _Tools → Options → LibreOffice Writer → Formatting Aids.

[Reproducible] with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]" and with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID: d3d1481-3f8994a-2ba0a9f)]".

Modified Subject due to current knowledge, if there is an additional random effect a new report can be submitted.

@Cédric:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.

*** Bug 41267 has been marked as a duplicate of this bug. ***

Reproducible with LibO 3.4.3 release on WinXP 32b.

As manj_k already pointed out, this happens not only when exporting the document as PDF, but also on printing.

Additional observation: Sometimes only some of the nonprinting characters become invisible (and the corresponding options in the Formatting aids settings dialog become unchecked), sometimes more of them. When printing some document "A.doc" (it’s in DOC format) yesterday, only no-breaking spaces (NBSPs) became invisible (they were displayed like ordinary spaces), but when printing "A.doc" again today, most of the options, including the ordinary spaces, became unchecked. Yes, I know, this sounds odd, but it really happened this way.

Yuv (yuv) wrote :

same here with Kubuntu AMD64 Oneiric just updated. No proprietary drivers.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed

*** Bug 41485 has been marked as a duplicate of this bug. ***

*** Bug 41605 has been marked as a duplicate of this bug. ***

summary: - Nonprinting characters not showing in Writer
+ [Upstream] Nonprinting characters not showing in Writer
Balint Reczey (rbalint) wrote :

Workaround:
You can make them visible again using the check-boxes
in _Tools → Options → LibreOffice Writer → Formatting Aids.

Changed in df-libreoffice:
importance: Unknown → High
status: Unknown → Confirmed

Is there any progress on this? I can confirm that it's still happening

Formatting aids - displayed nonprinting characters become unchecked during printing and PDF export. LibO 3.4.4 RC2 Still the same error.
Workaround:
After PDF-export or printing and *before* closing Writer do
Menu:File:Select Page; Close,
otherwise the wrong settings will be saved and can only be reset via Tools/Options...

@Thomas Bigler:
Please do not touch picker fields if you are not absolutely sure that you know for what they are!
<http://wiki.documentfoundation.org/BugReport_Details#Version>

Thank you for the Workaround!

@Thomas Bigler:
No, "OS/Version" is not "Windows (All)", but really "All": this bug is not only visible on Windows but also e.g. on MacOS X.

@Rainer Bielefeld:
Thanks for correcting the picker fields again.

Bug survived in LibO 3.4.4 release...

Change version? Will there be an update for 3.4.3 if the problem is found? I think no.

I hope there will be an answer to this terrible bug. I hate it to do this every 10 mins again and again!

I have found the problem still exists on 3.4.4. Using Windows 7 x64 Professional. The show/hide toolbar button becomes non-functional on first print, and resetting in Options does not fix the problem. The problem for me persists across sessions and restarts of computer. I can fix it by deleting everything under .../user/3 and having the program recreate the folder, but that is much too time consuming a workaround for routine use. I am using OO.o 3.3 pending a fix. Thank you

@ComWebUser: Please don't play with the version number. The bug has been reported for LibO 3.4.3. It is not marked as fixed, so it is clear that is still present in 3.4.4.
Changing the version number make the initial version in which the bug has been found lost.

Best regards. JBF

My apologies, I am a newbie at bug reporting

I confirm the problem "displaying non-printing characters" using LO 3.4.4, Windows 7 prof 64 bit and the following macro:
Sub AktuelleSeiteDrucken
   oDoc = ThisComponent
   aPrinterProperties = oDoc.getPrinter()
   oPrinterName = aPrinterProperties(0)
   If IsNull( oPrinterName ) Then
      MsgBox( "Kein Drucker gefunden" )
   Else
      if MsgBox( "Der aktuelle Drucker ist: " & oPrinterName.Value, 1,"Hinweis") = 2 then
            exit sub
        else
            dim aPrintOps(0) as new com.sun.star.beans.PropertyValue
            oDoc = ThisComponent
            oViewCursor = oDoc.CurrentController.getViewCursor()
            aPrintOps(0).Name = "Pages"
            aPrintOps(0).Value = trim(str(oViewCursor.getPage()))
            oDoc.print(aPrintOps())
        endif
    EndIf
end sub

Question: is this the same problem as Bug 40482?

@Jochen
"Question: is this the same problem as Bug 40482?"

Yes.
I've tested the macro with LibO 3.4.4 release on WinXP.

A workaround (to get back "displaying non-printing characters"):
1. Open 'Page Preview' (Standardbar)
2. Close 'Page Preview'

Testing the macro with LibO 3.3.4 release works fine.

I have this bug on Windows 7 64bit with LO 3.4.3 and LO 3.4.4. Please fix it as soon as possible, because it's very annoying.

I can confim the workaround described by manj_k.

+1 vote for that bug. (Sadly there is no voting feature here.)
Many of our users here in the company are not that IT-skilled that they could handle the workaround or find the settings in the menu. It would be really great if this bug could be fixed.

I have found that displayed nonprinting characters recovered when the file has been closed and reopened. However, the situation is still annoying. I hope that the bug will be fixed in the near future.

*** Bug 43476 has been marked as a duplicate of this bug. ***

*** Bug 43507 has been marked as a duplicate of this bug. ***

I just tested 3.5 beta 1.
LOdev 3.5.0, Build-ID: 7362ca8-b5a8e65-af86909-d471f98-61464c4

The non-printing characters still vanish after pdf export or print. After pdf export the reappear after restart of LO or after pressing the button. However, after print the bug is still there.

Go, go, go LOdevs. It would be awesome if that bug would not see 2012.

this was introduced with the fix for bug 39159:
the view options are not restored for the pages shown in the print preview.

fixed on master:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=89d2733e16ae6233deea6bef3193bd45c89b854c

fixed on libreoffice-3-5:

http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-5&id=871ad55dccbd7121e005a66e3c51f55a236d2b04

will propose for 3.4.5

Good news! That is excellent!
Thanks for fixing that one.

*** Bug 43468 has been marked as a duplicate of this bug. ***

*** Bug 44041 has been marked as a duplicate of this bug. ***

jimav (james-avera) wrote :

Also on linux (lowriter 3.4.4). Could we have an update, e.g. are developers looking at this?

Something was broken since OpenOffice 3.3. So looking at the changes might help.

Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.

IMHO not resolved.

OS: Windows XP
LO: 3.5.0 beta2

Verified: The bugfix works fine with
LOdev 3.5.0beta2+ · Build ID: f47ee3c-7ef74e0-d7a1999
[libreoffice-3-5~2011-12-21_20.57.01_LibO-Dev_3.5.0beta2_Win_x86_install_en-US.msi 22-Dec-2011 · http://dev-builds.libreoffice.org/daily/Win-x86@6-fast/libreoffice-3-5/]
(on WinXP 32b · UI en-US)

... and yes, still a bug with LibO 3.5.0 Beta2
LOdev 3.5.0beta2 · Build ID: 8589e48-760cc4d-f39cf3d-1b2857e-60db978
(on WinXP 32b · UI en-US)

*** Bug 44106 has been marked as a duplicate of this bug. ***

(In reply to comment #32)
> IMHO not resolved.
>
> OS: Windows XP
> LO: 3.5.0 beta2

Fix will be in beta3 because it is already in beta2+ where it works well (LibreOffice 3.5.0beta2+ Version ID : 746cde4-7f15fca-1fc8c06-ca8e46d-b96fade).
Setting back as fixed.

Best regards. JBF

will it be cherry-picked in LibO 3.4.5 as well?

(In reply to comment #36)
> will it be cherry-picked in LibO 3.4.5 as well?

Perhaps ;-) : http://lists.freedesktop.org/archives/libreoffice/2011-December/022826.html

Best regards. JBF

*** Bug 44197 has been marked as a duplicate of this bug. ***

*** Bug 44288 has been marked as a duplicate of this bug. ***

Changed in df-libreoffice:
status: Confirmed → Fix Released

The fix has been just approved and pushed for 3.4.5-rc2.

*** Bug 44493 has been marked as a duplicate of this bug. ***

On 02/01/12 16:44, Pmladek-y wrote:
> The fix has been just approved and pushed for 3.4.5-rc2.
>
Thanks - the earlier work-around had worked for me, but it's nice to
know LO has just got little bit even better :-)

Appreciated.

Doug (aka Coloneldare)

Works fine (on WinXP 32b · UI en-US) with LibO 3.4.5 RC2
[LibreOffice 3.4.5 · OOO340m1 (Build:502)].

*** Bug 44547 has been marked as a duplicate of this bug. ***

*** Bug 44600 has been marked as a duplicate of this bug. ***

Works fine (on WinXP 32b · UI en-US) with LibO 3.5.0 Beta3
[LOdev 3.5.0beta3 · Build ID: e40af8c-10029e3-615e522-88673a2-727f724].

*** Bug 44882 has been marked as a duplicate of this bug. ***

Fixed as per upstream 3.5.0 released with precise.

Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
status: Confirmed → Fix Released

*** Bug 45139 has been marked as a duplicate of this bug. ***

*** Bug 49105 has been marked as a duplicate of this bug. ***

*** Bug 42079 has been marked as a duplicate of this bug. ***

Mike Smith (mikesmith239) wrote :

I had the same problem with writer. I tried all the suggestions above and none worked.

I did some digging around and in '~/.openoffice.org/3/user' found the file 'registrymodifications.xcu'. Looking inside it, it seemed to contains the name of the document I was editing etc.

So I renamed it to 'registrymodifications.xcu.old' and restarted writer. Now I can enable and disable the display of invisible characters.

I hope someone finds this useful!

Andrew Price (aprice2704) wrote :

I'm still seeing this in

LibreOffice 3.5.4.2
Build ID: 165a79a-7059095-e13bb37-fef39a4-9503d18

on a brand-new doc.

:( but will try Mike's suggested fix

Andrew Price (aprice2704) wrote :

Oops. Should have mentioned, this is on Win XP 32bit.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.