[Upstream] Deleting a column in Writer deletes whole table

Bug #462564 reported by Leandro on 2009-10-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LibreOffice
Confirmed
Wishlist
OpenOffice
Invalid
Undecided
Unassigned
libreoffice (Ubuntu)
Medium
Unassigned
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.3-1ubuntu2
  Candidate: 1:3.3.3-1ubuntu2
  Version table:
 *** 1:3.3.3-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/462564/+attachment/894856/+files/test.odt && lowriter -nologo test.odt

is when one highlights the second column of the table -> secondary clicks -> Column -> Delete is only that column is deleted. Please see movie for more details: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/462564/+attachment/894864/+files/out.ogv

4) What happens instead is the whole table is deleted.

Reproducible in:
lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.5.2-2ubuntu1
  Candidate: 1:3.5.2-2ubuntu1
  Version table:
 *** 1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

WORKAROUND: Split the table then delete the column.

WORKAROUND: Use Word via WINE.

Microsoft Office Word 2003 (11.5604.6505)

apt-cache policy wine1.3
wine1.3:
  Installed: 1.3.28-0ubuntu1~ppa1~natty1
  Candidate: 1.3.28-0ubuntu1~ppa1~natty1
  Version table:
 *** 1.3.28-0ubuntu1~ppa1~natty1 0
        500 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status
     1.3.15-0ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages

ProblemType: Bug
Architecture: amd64
Date: Wed Oct 28 09:43:20 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: fglrx
Package: openoffice.org-core 1:3.1.1-5ubuntu1
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: openoffice.org
Uname: Linux 2.6.31-14-generic x86_64

Leandro (leandromartinez98) wrote :
Leandro (leandromartinez98) wrote :
Chris Cheney (ccheney) wrote :

You have to split the two merged cell before deleting the column.

Changed in openoffice.org (Ubuntu):
status: New → Invalid
Leandro (leandromartinez98) wrote :

Ok....

But the behaviour is not simmetrical relative to the deletion of a line, as the example I post now shows. What happens when a line is deleted in a similar way is what one actually expects... not the deletion of the whole table...

Chris Cheney (ccheney) on 2009-10-29
Changed in openoffice.org (Ubuntu):
status: Invalid → Triaged
summary: - deleting a column in OOffice Write deletes whole table
+ [upstream] deleting a column in OOffice Write deletes whole table
Chris Cheney (ccheney) on 2010-05-13
tags: added: karmic
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

summary: - [upstream] deleting a column in OOffice Write deletes whole table
+ [Upstream] Deleting a column in Writer deletes whole table

No upstream URL.

description: updated
Changed in openoffice:
status: New → Invalid

Leandro, thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at http://wiki.documentfoundation.org/BugReport . If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
summary: - [Upstream] Deleting a column in Writer deletes whole table
+ Deleting a column in Writer deletes whole table
tags: added: lo33
Changed in df-libreoffice:
status: New → Incomplete
description: updated

Downstream report may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/462564

1) lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.5.2-2ubuntu1
  Candidate: 1:3.5.2-2ubuntu1
  Version table:
 *** 1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/462564/+attachment/894856/+files/test.odt && lowriter -nologo test.odt

is when one highlights the second column of the table -> secondary clicks -> Column -> Delete is only that column is deleted. Please see movie for more details: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/462564/+attachment/894864/+files/out.ogv

4) What happens instead is the whole table is deleted.

WORKAROUND: Split the table then delete the column.

Changed in df-libreoffice:
importance: Undecided → Unknown
status: Incomplete → Unknown
summary: - Deleting a column in Writer deletes whole table
+ [Upstream] Deleting a column in Writer deletes whole table
tags: added: i386 natty

[Reproducible] with "LibreOffice 3.5.2.2" German UI/Locale [Build-ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f] on German WIN7 Home Premium (64bit)

Splitting first cell heals the problem

This one might be more an enhancement request than a bug

@Cédric:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug

Changed in df-libreoffice:
importance: Unknown → Wishlist
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.