[Upstream] [hardy] Writer "Select All" only highlights table in .doc

Bug #210686 reported by Abubakar Gurnah on 2008-04-02
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Medium
OpenOffice
Confirmed
Unknown
libreoffice (Ubuntu)
Medium
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/210686/+attachment/251817/+files/DocTemplate.doc && lowriter -nologo DocTemplate.doc

 (ctrl + A) or edit -> select all and the entire document is selected.

4) What happens instead is it highlights the table but not the text.

WORKAROUND: Use AbiWord.

apt-cache policy abiword
abiword:
  Installed: 2.8.6-0.3build1
  Candidate: 2.8.6-0.3build1
  Version table:
 *** 2.8.6-0.3build1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        100 /var/lib/dpkg/status

Abubakar Gurnah (abugurnah) wrote :
Marcus Asshauer (mcas) wrote :

Thank you for reporting this bug. Please report some more informations about your versions. Which ubuntu version are you using? Did you use the same OOffice version on windows and ubuntu?

Changed in openoffice.org:
status: New → Incomplete
Abubakar Gurnah (abugurnah) wrote :

Im using Kubuntu

gurnah@gurnah:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 7.10
Release: 7.10
Codename: gutsy

I never tried that in windows. I just tried it in laptop

Im using ooffice 2.3.0

Chris Cheney (ccheney) wrote :

Confirmed on upstream's openoffice.org 2.4.0

Changed in openoffice.org:
importance: Undecided → Low
status: Incomplete → Confirmed
Chris Cheney (ccheney) on 2008-06-13
Changed in openoffice.org:
status: Confirmed → Triaged

Forwarded bug upstream

Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Ralph Janke (txwikinger) wrote :

Updated upstream bug link

Changed in openoffice:
status: Unknown → Confirmed
Chris Cheney (ccheney) on 2010-05-13
tags: added: hardy

Created attachment 47164
Simple document where you can reproduce the problem

LibreOffice 3.3.1 on Windows XP 32 bits:

On Writer, create a document and include a table on the first paragraph and some text below it (or use the file attached). Type Ctrl+A (or on the menu: Edit > Select All) and it will only select the table (first the cell, and then the table) and not all the content of the document (table + text).

If you include a paragraph above the table, Select All works fine.

could reproduce this error on LO 3.4 RC1

I can reproduce this with LibO 3.4 RC2 too (Linux). The same is with OOo 3.3 and OOo-dev300m106.

tags: added: lo33
description: updated
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
summary: - [Upstream] [hardy] "Select All" in OOffice doesn't work on specific file
+ [Upstream] [hardy] Writer "Select All" only highlights table in .doc
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

RC2 is bit by bit identical with release version, so separate items in the version picker are useless. Changes have been discussed with Michael Meeks.

Still [Reproducible] with "LibreOffice 3.4.0 – WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:12)]"

Very old issue, I also see that with OOo3.1.1, OOo 1.1.4. (OOo history starts with 1.0.1)

Cédric:
Please feel free to reassign if it's not your area!

Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

This issue remains unresolved in LibreOffice 3.5.0 (tested and confirmed with
beta2 prerelease).

Guilherme and Renato Mendes, please do not toggle the Version. For more on this please see: http://wiki.documentfoundation.org/BugReport_Details#Version

Version -> 3.3.1

This issue remains unresolved in LibreOffice 3.5.3.2.

Just to complete the OS list (MacOS was missing ;-):

Also REPRODUCIBLE with LibreOffice 3.5.4.1 (Build-ID: 7306755-f4f605c-738527d-1cf4bc1-9930dc8), German langpack installed, on MacOS X 10.6.8 German UI.

reproductible with 3.6.0 B1

*** Bug 62720 has been marked as a duplicate of this bug. ***

Added to bug 60270 - (mab4.1) LibreOffice 4.1 most annoying bugs

you should removed it from 4.1 MAB because it's a wrong category for it
that page is intended for bugs that are present in the 4.1.x branch only and not in previous versions.

since first reproducible version is 3.3.1 it could be candidated to be a 4.0 MAB that's why 3.3 MABs page doesn't exist and the 3.4.x, 3.5.x and 3.6.x branches are over so their respective still valid MABs are going to be moved to the 4.0 MAB page.

Added to Bug 54157 - (mab4.0) LibreOffice 4.0 most annoying bugs

*** Bug 67424 has been marked as a duplicate of this bug. ***

*** Bug 67369 has been marked as a duplicate of this bug. ***

I do not agree that this is marked as MAB.
It always has been this way in Writer: no regression. Also there are good and fine work arounds.

i'm also not happy with this as MAB, since the effort to fix this would be huge as it's an inherent limitation of Writer's document and table model.

only thing that could be done easily is to have select-all select everything _except_ the table at the start of the document (instead of whatever silly thing it currently does).

Users who have at least intermediate computer skills would expect that the Select All action selects all content of a document they are editing/viewing in a GUI application. That is a standard across wide range of applications.

If it is broken in LibreOffice Writer because some of its developers decided to use certain document model (a defective model I'd say) then AT LEAST the LibreOffice Help should contain a note about this issue.

Currently, the LibreOffice Help says the following in Text Documents > Command and Menu Reference > Menus > Edit:

Select All
Selects the entire content of the current file, frame, or text object.

What does the "text object" means?

I'd suggest expanding this description so that it is in accordance with the actual functionality of this command especially regarding the case when a document begins with a table.

Also, I see that Select All doesn't include inserted frames.

I don't see also why this bug is in the MAB, and there is a very simple workaround, see
https://wiki.documentfoundation.org/Faq/Writer/165
If the help file has to be amended, this is a different issue. Sophie

As it happens Miklos is working on this bug right now for a Collabora customer :-) It's certainly not a trivial one; but let me CC him.

As a workaround for this issue I inserted a paragraph before the table and formatted the text in the paragraph as hidden. Then tried to use Select All. It selects all text only if the hidden text is visible, which is enabled in Tools > Options > LibreOffice Writer > Formatting Aids > Display of Hidden text. If that option is not enabled the Select All selects only the table, which is strange (another bug?).

Taking from Cédric.

rpr: no, that's expected, this is a UI limitation, so if the hidden paragraph is not shown, you have the same problem.

Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3b11e66ab89c201591d8be8f1ab1af1aba11a821

fdo#37606 SwWrtShell::SelAll(): initial support for doc starting with table

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4b6445dba6bb5b2aed3edb4878ecb327446286e9

fdo#37606 SwWrtShell: fix select all when doc starts with table and cursor ...

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Changed in df-libreoffice:
status: Confirmed → In Progress

Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0fb4adcff534e3841cf6df0e2363fb0797af7022

fdo#37606 SwEditShell::DeleteSel(): handle document starting with a table

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=49505336a629a75f4fb48bbe0c532b402e857ed4

fdo#37606 SwEditShell: fix copying when doc starts with a table ...

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a516ac452e33d3f0df2572089041e2555808a5ee

fdo#37606 testcase

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Hi Miklos,

I tried the copy-paste with the master containing your fix (Build ID: 60aea4b2cadf367736605b09604a0818b7ae571b) on the bugdoc. Selection by ctrl+A and copy work as expected. But is it a side effect or expected if, when pasting in a new empty file, the data are pasted after an empty page?

Best regards. JBF

Yes, that's expected. The reason is that the table (in the bugdoc) explicitly specifies what page style to use, this way it's considered to be a page break.

I mean, if I create a test document that is similar to the bugdoc (starts with a table, then a few non-table paragraphs after it, but I don't explicitly set a page style name for the table), then this does not occur.

Indeed, if I uncheck the checkbox "Break" in the Text Flow tab for the format table, the table is pasted on the first page.

Thank you very much.

Best regards. JBF

Changed in df-libreoffice:
status: In Progress → Fix Released

Hi Miklos,

Small remaining problem: the fix does not work if the table is empty. I do not know if somebody use empty tables, but ... :-)

Best regards. JBF

Could we please have a separate bugreport for that? It would be great to track it in a dedicated bug.

Thanks! :-)

I'd say it's just a special case of the same issue reported in this bug.
This means that the bug is not fixed actually and should be reopened.

rpr - if Miklos would like it as a separate bug, since he's the expert here, and since all bugs are basically specialisations of the "something doesn't work" bug :-) I'll file this as a separate issue. See bug #69894

tags: added: target-4.2.0

*** Bug 77838 has been marked as a duplicate of this bug. ***

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.