[upstream] Multiple instances of global menu entries

Bug #1825741 reported by Jonas Gamao on 2019-04-21
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
LibreOffice
Invalid
Medium
libreoffice (Ubuntu)
Medium
Unassigned

Bug Description

I see 2 instances of each global menu entries. It's cluttering up my top panel.

This also happens in Plasma.

Build ID: libreoffice-6.2.2.2-snap1

Revision history for this message
In , Константин (rilian-la-te) wrote :

Description:
We have double menus in GTK3 VCL, if it is used with Unity-style globalmenu - vala-panel-appmenu, or with GTK3 Backend on KDE (via https://github.com/KDE/plasma-workspace/tree/master/gmenu-dbusmenu-proxy)

Package version: 6.2.2-2
Distribution: ArchLinux.

Steps to Reproduce:
1. Install and configure vala-panel-appmenu (https://gitlab.com/vala-panel-project/vala-panel-appmenu)
2. Open any LibreOffice app
3. Bug happens))))

Actual Results:
We see double menus, as in screenshots in bug on vala-panel-appmenu GitLab (https://gitlab.com/vala-panel-project/vala-panel-appmenu/issues/286)

Expected Results:
We should see only single menu, no double menus.

Reproducible: Always

User Profile Reset: Yes

Additional Info:
Related to:

1. https://bugs.documentfoundation.org/show_bug.cgi?id=123416 - similar (now seems fixed) bug for KDE on 6.2.0 and Qt VCL

2. https://bugs.documentfoundation.org/show_bug.cgi?id=122619 - this bug calls to remove menu export in GTK3 at all, because it is rarely needed. I am strongly against this decision.

3. https://gitlab.com/vala-panel-project/vala-panel-appmenu/issues/286 - Issue on vala-panel-appmenu end, confirmed by me and by some of my users.

Revision history for this message
In , Константин (rilian-la-te) wrote :

Created attachment 150350
Double menus in GTK3 VCL

Revision history for this message
In , Константин (rilian-la-te) wrote :

About attachment - there is just no place for double menu in panel, vala-panel-appmenu made next menu entries scrollable.

Revision history for this message
In , Константин (rilian-la-te) wrote :

Created attachment 150351
Double menus in GTK3 in English (we see, than all menu entries are doubled)

Revision history for this message
In , Xiscofauli (xiscofauli) wrote :

@Caolán, I thought you might be interested in this issue...

Revision history for this message
Jonas Gamao (yamiyukisenpai) wrote :
description: updated
Revision history for this message
Marcus Tomlinson (marcustomlinson) wrote :

Hi Jonty, could you please provide some more info about your system such as the version of Ubuntu you're running and which desktop environment(s) you see this issue on.

Could you also confirm that this still occurs with the libreoffice 6.2.3.2 snap (updated yesterday).

Thank you!

Changed in libreoffice (Ubuntu):
status: New → Incomplete
Revision history for this message
Jonas Gamao (yamiyukisenpai) wrote :

Yes it still occurs.

I'm currently using Ubuntu 19.04 with Unity desktop.

I'll test it with my Neon & Kubuntu install when I get the chance.

Revision history for this message
Marcus Tomlinson (marcustomlinson) wrote :

Ok thank you for that. I’ve managed to reproduce the issue locally now.

Changed in libreoffice (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium
Changed in libreoffice (Ubuntu):
assignee: nobody → Marcus Tomlinson (marcustomlinson)
Revision history for this message
Marcus Tomlinson (marcustomlinson) wrote :

This seems to be an upstream bug. It was resolved in 6.2.2 for some toolkits but not GTK3.

summary: - Multiple instances of global menu entries
+ [upstream] Multiple instances of global menu entries
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → New
Revision history for this message
In , Tor Slettnes (tor) wrote :

Created attachment 151169
Screenshot showing duplicate menu

I see the same in Debian "sid", starting with LibreOffice 6.1. It only appears when using the global "appmenu" plugin in my Window manager (either XFCE4 or MATE), not with Gnome 3 (since the latter does not have a "global app menu" feature anymore).

Revision history for this message
Stefano Dall'Agata (essedia1960) wrote :
Revision history for this message
Stefano Dall'Agata (essedia1960) wrote :

I have the same problem with Ubuntu 16.04.6 with Unity and LibreOffice Version: 6.2.3.2

Revision history for this message
In , Xiscofauli (xiscofauli) wrote :

(In reply to Tor Slettnes from comment #5)
> Created attachment 151169 [details]
> Screenshot showing duplicate menu
>
> I see the same in Debian "sid", starting with LibreOffice 6.1. It only
> appears when using the global "appmenu" plugin in my Window manager (either
> XFCE4 or MATE), not with Gnome 3 (since the latter does not have a "global
> app menu" feature anymore).

Confirmed by Tor.
Moving to NEW

Changed in df-libreoffice:
status: New → Confirmed
Revision history for this message
In , Norbert-notz (norbert-notz) wrote :

*** Bug 124192 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Norbert-notz (norbert-notz) wrote :
Revision history for this message
In , Norbert-notz (norbert-notz) wrote :

Set keyword regression because according to the following screenshot from Bug 124192 the bug did not exist in build 6.1.2.
https://bug-attachments.documentfoundation.org/attachment.cgi?id=150089

Revision history for this message
In , Fergusong2 (fergusong2) wrote :

Same issue with me. Global menu duplicated across top for Writer, Calc, Impress. Running Ubuntu 18.04.03, Libreoffice 6.3.0.4, build ID:Libreoffice-6.3.0.4-snap1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Locale: en-US (en_US.UTF-8); UI-Language: en-US

Revision history for this message
In , Caolanm (caolanm) wrote :

I imagine the GMenuModel is getting picked up twice, once from the native gtk menubar and once from the explicit dbus export.

Revision history for this message
In , Norbert-notz (norbert-notz) wrote :

Works for me with:

Version: 6.2.6.2
Build-ID: 684e730861356e74889dfe6dbddd3562aae2e6ad
CPU-Threads: 8; BS: Linux 4.4; UI-Render: Standard; VCL: gtk2;
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded

I don't know if there has been a fix applied to build 6.2.6.2 or if it works for me now because I have installed this build along with ALL integration packages.

Status set to: RESOLVED WORKSFORME

Revision history for this message
In , Norbert-notz (norbert-notz) wrote :

REOPENED because issue appears again. I don't know why.

Revision history for this message
In , Константин (rilian-la-te) wrote :

Maybe because Gtk2 VCL does not do menu exporting?

Revision history for this message
In , Cleiton-qmc (cleiton-qmc) wrote :

I solved the problem by removing libreoffice-gtk and installing libreoffice-kde. I'm using LibreOffice 6.3 and KDE Neon 5.16.4.

Revision history for this message
In , Jan Willamowius (jan-willamowius) wrote :

Setting the environment variable SAL_USE_VCLPLUGIN=gen also disables the GTK menu and fixed the issue for me without uninstalling libreoffice-gtk.

Using LibreOffice 6.2.6.2 on Ubuntu 16.04.

The menu is ugly now, but not duplicated.

Revision history for this message
In , Константин (rilian-la-te) wrote :

Yes, changing VCL fixes an issue, because Gen is not GTK VCL)

Revision history for this message
In , Darpan Das (darpan93) wrote :

(In reply to OfficeUser from comment #13)
> REOPENED because issue appears again. I don't know why.

The same problem persists in LibreOffice 6.3 as well

Revision history for this message
In , Archisman Panigrahi (apandada1) wrote :

The bug is still there in Libreoffice Build ID: 1:6.3.1~rc2-0ubuntu0.18.04.1~lo1, Running in KDE Neon 5.16.4.

Revision history for this message
In , John Pye (jdpipe) wrote :

Created attachment 154256
doubled menus in Ubuntu 18.04 (Unity)

just to show that the same problem also exists with Unity in Ubuntu 18.04. The second copy doesn't fit, so a 'v' drop down gives the rest of them.

Revision history for this message
In , John Pye (jdpipe) wrote :

I confirm this bug is present in version 6.2.6.2 as installed from the Ubuntu LibreOffice 6.2.x PPA.
https://launchpad.net/~libreoffice/+archive/ubuntu/libreoffice-6-2

Revision history for this message
Jan Schürmann (visionfactory.net) wrote :

I confirm this bug is still present in LO 6.3.1.2 on Ubuntu 18.04.3 with Unity desktop...

disabling the menu in LO disables both menus in panel

Changed in libreoffice (Ubuntu):
assignee: Marcus Tomlinson (marcustomlinson) → nobody
Revision history for this message
In , Samuel Mehrbrodt (sam92) wrote :
Changed in df-libreoffice:
status: Confirmed → In Progress
Revision history for this message
In , Libreoffice-commits (libreoffice-commits) wrote :

Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1c68ab312c5473ce642f75fc35a1edd6be187489

tdf#124391 Fix doubled menu in global menu

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.

Changed in df-libreoffice:
status: In Progress → Fix Released
Revision history for this message
In , Libreoffice-commits (libreoffice-commits) wrote :

Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/eccf0193885d1e46a207966eb52a408dc60e8109

tdf#124391 Fix doubled menu in global menu

It will be available in 6.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.

Revision history for this message
In , Libreoffice-commits (libreoffice-commits) wrote :

Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/commit/fd95a92d600b751ad6a23f35db446bf063cb722b

tdf#124391 Fix doubled menu in global menu

It will be available in 6.2.9.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.

Revision history for this message
In , Mikekaganski (mikekaganski) wrote :

*** Bug 123484 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Samuel Mehrbrodt (sam92) wrote :

*** Bug 122287 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Libreoffice-commits (libreoffice-commits) wrote :

Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-8":

https://git.libreoffice.org/core/commit/46a575a64851512584abcddb0d30b907865251ce

tdf#124391 Fix doubled menu in global menu

It will be available in 6.2.8.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.

Revision history for this message
In , Xiscofauli (xiscofauli) wrote :

*** Bug 128142 has been marked as a duplicate of this bug. ***

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
status: Fix Released → Fix Committed
Revision history for this message
Ian Peters (ipeters61) wrote :

This issue affects LibreOffice 6.3.2.2, the most recent version available in the Ubuntu MATE 19.10 Beta.

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Triaged
Revision history for this message
Adolfo Jayme (fitojb) wrote :

> This issue affects LibreOffice 6.3.2.2

Exactly, Ian. As stated already, the fix was released in 6.3.3.1.

Revision history for this message
In , Xiscofauli (xiscofauli) wrote :

*** Bug 128491 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Michael Krahl (the-cleaner) wrote :

Problem still appears on my system in following LO-components:
- LO manager screen
- LO Base
- LO Math
All other components are OK
I use LO version 6.3.3.2.0, Linux kernel 5.3.10

Revision history for this message
In , Michael Krahl (the-cleaner) wrote :

Created attachment 155708
Double menus in LO ver. 6.3.3.2

Revision history for this message
In , Xiscofauli (xiscofauli) wrote :

(In reply to the_cleaner from comment #32)
> Created attachment 155708 [details]
> Double menus in LO ver. 6.3.3.2

Could you please paste the info from Help - about LibreOffice ?

Revision history for this message
In , Michael Krahl (the-cleaner) wrote :

Created attachment 155715
Screenshot ot Help screen

Here are screenshots of the Help screen and also the troublesome LO components.

Changed in df-libreoffice:
status: Fix Released → Confirmed
Revision history for this message
In , Samuel Mehrbrodt (sam92) wrote :

I can't reproduce this with current master and Unity environment.
Which DE are you using?
Can you try with a recent daily build?

Revision history for this message
In , Bernard Decock (decockbernard) wrote :

Created attachment 155949
Multiple instances of the menubar

Revision history for this message
In , Bernard Decock (decockbernard) wrote :

In my case I'm using Linux Mint 19.2 Cinnamon. I have only this problem as soon as I enable the extension LanguageTool and try to insert a formula into writer. If I disable LanguageTool, then the problem is gone.

I filed the bug as https://bugs.documentfoundation.org/show_bug.cgi?id=128491 which might be a duplicate of this bug. Today I managed to duplicate the menu as much as I wanted (see attachment)

Revision history for this message
In , Xiscofauli (xiscofauli) wrote :

(In reply to Bernard Decock from comment #37)
> In my case I'm using Linux Mint 19.2 Cinnamon. I have only this problem as
> soon as I enable the extension LanguageTool and try to insert a formula into
> writer. If I disable LanguageTool, then the problem is gone.
>
> I filed the bug as
> https://bugs.documentfoundation.org/show_bug.cgi?id=128491 which might be a
> duplicate of this bug. Today I managed to duplicate the menu as much as I
> wanted (see attachment)

Since the issue is different ( yours is with LanguageTool enabled ), let keep them separated. Closing as RESOLVED FIXED

Changed in df-libreoffice:
status: Confirmed → Fix Released
Revision history for this message
In , Marcus Tomlinson (marcustomlinson) wrote :

Created attachment 155982
Screenshots - 6.4.0.0-alpha - Ubuntu 19.10 - Unity DE

I can confirm what <email address hidden> said about certain components working now, and I can appreciate that the problem is closer to being resolved, though the issue just seems a bit different now:

If you launch Writer directly - perfect, no duplicate menus.
If you launch Start Center - duplicate menus (see: 20-11-19-MT-SC.png)
If you launch Writer from Start Center - duplicate menus (see: 20-11-19-MT-SC-Writer.png)

About box - see: 20-11-19-MT-About.png

This is using 6.4.0.0-alpha on Ubuntu 19.10, Unity DE.

Revision history for this message
In , Marcus Tomlinson (marcustomlinson) wrote :

I don't have LanguageTool installed.

Revision history for this message
In , Xiscofauli (xiscofauli) wrote :

(In reply to Marcus Tomlinson from comment #40)
> I don't have LanguageTool installed.

Nevermind. Please, create a follow-up bug. this one is already long enough

Revision history for this message
In , Marcus Tomlinson (marcustomlinson) wrote :

Description:
In certain situations, more than one global menu is displayed in GTK3 VCL, when used with Unity-style globalmenu - vala-panel-appmenu, or with GTK3 Backend on KDE.

Test environment - 6.4.0.0-alpha on Ubuntu 19.10, Unity DE
About box - see: 20-11-19-MT-About.png

Steps to Reproduce:
1. Launch Writer directly - perfect, no duplicate menus.
2. Launch Start Center - duplicate menus (see: 20-11-19-MT-SC.png)
3. Launch Writer from Start Center - duplicate menus (see: 20-11-19-MT-SC-Writer.png)

Actual Results:
Duplicate menus seen in steps 2 and 3.

Expected Results:
No duplicate menus in any of the 3 steps.

Reproducible: Always

User Profile Reset: No

Additional Info:
This issue is closer to being resolved thanks to the work done on: https://bugs.documentfoundation.org/show_bug.cgi?id=124391

Though now the issue seems a little different (see steps to reproduce).

Revision history for this message
In , Marcus Tomlinson (marcustomlinson) wrote :

Created attachment 156036
6.4.0.0-alpha - Ubuntu 19.10 - Unity - About

Revision history for this message
In , Marcus Tomlinson (marcustomlinson) wrote :

Created attachment 156037
6.4.0.0-alpha - Ubuntu 19.10 - Unity - SC

Revision history for this message
In , Marcus Tomlinson (marcustomlinson) wrote :

Created attachment 156038
6.4.0.0-alpha - Ubuntu 19.10 - Unity - SC/Writer

Changed in df-libreoffice:
importance: Medium → Unknown
status: Fix Released → Unknown
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → New
Revision history for this message
In , Xiscofauli (xiscofauli) wrote :

Thank you for reporting the bug. To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present

Revision history for this message
In , Marcus Tomlinson (marcustomlinson) wrote :

Removed both ~/.config/libreoffice and ~/.config/libreofficedev directories, and the steps to reproduce are still valid.

Revision history for this message
In , timur (ba.timur) wrote :

Looks like a duplicate. Please explain if not.

*** This bug has been marked as a duplicate of bug 126870 ***

Changed in df-libreoffice:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.