MTP is preferred over UMS/MSC

Bug #330383 reported by Song Younghwan on 2009-02-17
138
This bug affects 14 people
Affects Status Importance Assigned to Milestone
gvfs
Invalid
Undecided
Unassigned
libgphoto2 (Ubuntu)
Low
Unassigned
Declined for Jaunty by Sebastien Bacher

Bug Description

Binary package hint: gvfs

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu.

Description: Ubuntu jaunty (development branch)
Release: 9.04

====================

2) The version of the package you are using, via 'apt-cache policy packagename' or by checking in Synaptic.

gvfs:
  Installed: 1.1.6-0ubuntu1
  Candidate: 1.1.6-0ubuntu1
  Version table:
 *** 1.1.6-0ubuntu1 0
        500 http://kr.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

====================

3) What you expected to happen

Use my MP3 player(Samsung Yepp YP-Z5F) as USB storage without explicitly running /usr/lib/gvfs/gvfs-hal-volume-monitor in a terminal.

====================

4) What happened instead

Connected by MTP. But I can connect it as USB storage by running /usr/lib/gvfs/gvfs-hal-volume-monitor in gnome-terminal before connecting it.

Stuart Read (sread) wrote :

I have the same problem with a Sony Walkman NWZ-S618. Since the MTP has decreased functionality over the UMS(no access to pictures, video, drag-and-drop music/podcasts without needing library manager), mass storage should be preferred. Or perhaps some way to choose the first time the device is inserted?

The situation here is deteriorating: My NWZ-S618F is now completely useless: Nautilus tries to open it as "gphoto2://[usb:002,006]/", Rhythmbox won't recognize it as an audio player, and the workaround presented in this bug no longer works.

This is just a work around. I changed /usr/share/gvfs/remote-volume-monitors/ gphoto2.monitor to allow the device to be mounted.

[RemoteVolumeMonitor]
Name=GProxyVolumeMonitorGPhoto2
DBusName=org.gtk.Private.GPhoto2VolumeMonitor
#IsNative=false
IsNative=true

Marat (marat-hotmail) wrote :

Hello,
i have a Sony nwz A826 MP3 Player, using Ubuntu Jaunty Beta, Nautilus can not show the content of the device.
The Nautlius window is just empty.
Can we expect the fix in Jaunty Final?

I hope very much, because i have no access to my player

Greetings

Marat (marat-hotmail) on 2009-03-30
Changed in gvfs:
assignee: nobody → marat-hotmail
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?

 This will help us to find and resolve the problem.

Changed in gvfs (Ubuntu):
assignee: marat-hotmail → desktop-bugs
importance: Undecided → Low
status: Confirmed → Incomplete
muhalifsirin (alperense) wrote :

I think this problem is related to this:
https://bugs.launchpad.net/linux/+bug/350739

Here I am attaching some log files that can be useful:

muhalifsirin (alperense) wrote :
muhalifsirin (alperense) wrote :
muhalifsirin (alperense) wrote :
muhalifsirin (alperense) wrote :

Nicholas A. Schembri State College PA USA 's solution seem to be working fine for me. But you should restart the system after the procedure.

Now I can mount my player and also amarok 1.4 seems to recognize it as a mtp device as well

Thanks for the suggestion

leifw (leifwickland) wrote :

Nicholas' fix worked for me with my Sandisk Sansa m240.

muhalifsirin (alperense) wrote :

after updating the system, problem arises again, and you have to do Nicholas's trick again (I updated a lot of things, I don't know which broke the system again, I guess it was gvfs update which broke it again)

Mauricio Barragan (maubarra) wrote :

I have the same problem with a Sony Walkman NWZ-A829. I'm not sure why but sometimes when I plugged the device it will mount as msc but it seems like it was random. Most of the time it mounted has MTP (the device showed Connecting (MTP) on the screen). Nautilus won't show its contents, just says that its an audio device and offers to open Rhythmbox. If you open Rhytmbox (nautilus, main menu or even when pluggin the device) it won't recognize the player unless you first unmount it using the icon on the desktop.

I tried the player in Kubuntu 9.04 and it mounts as MSC with no problems.

Mauricio Barragan (maubarra) wrote :

I tried Nicholas' workaround and it seem to work. Now my Walkman its recognized as MSC and I can browse and add files with no problems. Now I theres another problem. Any program (mtp-detect, Rhythmbox, Gnomad2) that tries to connect via MTP fails. This wouldn't be a problem but the device only handles playlists with the MTP protocol so, despite I can add music via MSC, there is no way to create or edit playlists. This is only affecting Ubuntu (or Gnome maybe) because I try it on a machine running openSUSE and KDE 4.2 and the device mounts as MSC but when a MTP application tries to connect it switches to MTP and the application works fine

Cyclothymia (j4cky-ch4n) wrote :

I upgraded from Hardy to Jaunty immediately after Intrepid.
I also tried Nicholas' workaround and it did not work at first. It turned out that my file for /usr/share/gvfs/remote-volume-monitors/gphoto2.monitor had an extra line for a NativePriority parameter:

NativePriority=3

After commenting out and rebooting, not only is my mp3 player and external HDD automounting successfully as MSC, but on boot the different partitions on my hard drive are automatically shown under the Places menu as well (which was another issue I had with Jaunty which was not in Hardy).

Note the corresponding error message on opening gphoto2.monitor again:

~$ sudo gedit /usr/share/gvfs/remote-volume-monitors/gphoto2.monitor
(gedit:5115): GVFS-RemoteVolumeMonitor-WARNING **: error extracting NativePriority key from /usr/share/gvfs/remote-volume-monitors/gphoto2.monitor: Key file does not have key 'NativePriority'

Misoldgit (simonrhart) wrote :

Can I ask if anyone is actively working on this?

I'm not a coder by any standards but I'm willing to have a go if someone can guide me. Of course, I'm happy to undertake any testing required as guided to fix this problem.

I have a Sony NWZ-A829 MP4 player which suffers from this. I'm currently using a workaround i.e. killing hlad to allow Nautilus access to the player as this is the only way I can get videos onto the player.

Let me know...

yasasvy (yasasvy89) wrote :

I am not sure if this helps but my SONY WALKMAN NWZ-A818 worked fine with amarok when I installed "mtpfs" package in jaunty, but it is still not working with rhythmbox player.

fathonk (fathonk) wrote :

Hey,
just for those who don't want to change their system too much just for getting one of these Sony players mounted, here is a 2-line script which simply kills the process gvfs-gphoto2-volume-monitor.
You can create a starter or something and then it's only one mouseclick t get the player mounted as mass storage.
Hope it helps, still this is a workaround, i know, but it makes things a bit easier.
-cheers, fathonk

PS: does anyone know what gvfs-gphoto2-volume-monitor does exactly? Do I need it?

Sebastien Bacher (seb128) wrote :

The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in gvfs (Ubuntu):
status: Incomplete → New
leifw (leifwickland) wrote :

An update I installed recently broke this, again. Running the fix worked, again.

effell (effell) wrote :

Had this problem with a Sansa Clip. This is a fix.Following a suggestion in https://bugs.launchpad.net/ubuntu/+bug/345916, either deactivate

/usr/share/hal/fdi/preprobe/10osvendor/20-libgphoto2.fdi

by renaming it to say 20-libgphoto2.fdi.old

OR back it up and then delete out the portion of that file that handles a match with your Sansa device.

jack bakunin (jackbakunin) wrote :

Effell suggested fix works. I remove from /usr/share/hal/fdi/preprobe/10osvendor/20-libgphoto2.fdi
the portion where my player is nominated :

<match key="usb.vendor_id" int="1356">
    <match key="usb.product_id" int="806">
     <merge key="info.category" type="string">portable_audio_player</merge>
     <append key="info.capabilities" type="strlist">portable_audio_player</append>
     <merge key="portable_audio_player.access_method" type="string">user</merge>
     <merge key="portable_audio_player.type" type="string">mtp</merge>
     <append key="portable_audio_player.output_formats" type="strlist">audio/mpeg</append>
     <merge key="camera.libgphoto2.name" type="string">Sony Walkman NWZ-S516</merge>
     <merge key="camera.libgphoto2.support" type="bool">true</merge>
    </match>
   </match>

and now my "Sony Walkman NWZ-S516" when inserted is mounted in /media/WALKMAN
and it's fully browsable.

Marat (marat-hotmail) wrote :

Confirming the Fix of the Bug, Thank you very much.

Changed in gvfs (Ubuntu):
status: New → Fix Committed
Sebastien Bacher (seb128) wrote :

the change is an user workaround not a fix for ubuntu

affects: gvfs (Ubuntu) → libgphoto2 (Ubuntu)
Changed in libgphoto2 (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Fix Committed → New
Sebastien Bacher (seb128) wrote :

the issue is not a gvfs one

Changed in gvfs:
status: New → Invalid
Marat (marat-hotmail) wrote :

ok sorry.
Can we expect any changes in Karmic?

Kees (kees-vanveen) wrote :

I can confirm Effels suggestion fixes freezing my Creative Zen each time I connected. Trouble started when upgrading to Jaunty. With this fix I can use Amarok and gnomad2 again. No reboot required.

Thanks very much.

Mauricio Barragan (maubarra) wrote :

I'm using Ubuntu Karmic Alpha 3. My A829 mounts and works fine. I can browse it and add music. But it only works on MSC/UMS mode. mtp-detect doesn't work and Rhythmbox freezes when they try to conect in MTP mode.

Of course this wouldn't be a problem if there where any way to create Playlists other than MTP Playlists. I only connect my player in that mode to create Playlists using Gnomad2 (which also doesn' work).

Any help?

Mauricio Barragan (maubarra) wrote :

Well, I downloaded, compiled and installed libmpt 1.0.0. Ubuntu Karmic comes with 0.3.7. After installing it and rebooting I could manage to get MTP mode to work but only if I connect the device while Rhythmbox is running (with the MTP Addon active of course). That way it seems that Rhythmbox "catches" the device and puts it in MTP mode. After that I can close Rhythmbox and use Gnomad2 or even mtp-detect normally.

If I connect the device without Rhythmbox running it just mounts and I can browse it normally. Running Rhythmbox (or Gnomad2) after that results in the device unmounting and not being able to access it unless unplugging and pluggin again.

Marktrix (markgerlach) wrote :

Its a seesaw change, with my NWZ-A818. In Gutsy it worked, in Hardy not, in Intrepid okay and now in Jaunty not.
I read that in Karmic it would be mounting my Device correctly. Where ist the Problem, i always be happy when it worked
and than next version same Problem. It´s frustrating!

Mangus (il-mangus) wrote :

nwz-s639f here with 9.10
No one of the suggested fix worked for me.

I've also installed the latest libmtp, updated libmtp.rules etc...nothing....I can only see the player in nautilus but I cannot connect it in mtp mode nor as "generic audio player" in amarok...

Sergio (sergio-otero) wrote :

I have the same problem with my Creative Zen.

If i plug into the usb, the Zen enters in mtp-mode, but there isn't a link in Places or Desktop or anywhere else and i cannot connect it with other software like mtpfs.

My solution:

 * Disconnect the Zen
 * Before opening a session (or close the current session), enter in a terminal with ctrl + alt + f2
 * Install mtpfs (if not present): sudo apt-get install mtpfs
 * Create a directory called mtpzen (if not present): mkdir mtpzen
 * Connect the Zen: it won't enter mtp-mode because nautilus is not present
 * Execute mtpfs with: mtpfs mtpzen
 * Go back to graphic mode with ctrl + alt + f7 and enter user/password
 * Use Places -> mtpzen or Desktop -> mtpzen as a drive
 * Unmount it when finished
 * Disconnect the Zen

Hope that helps

PsYcHoK9 (psychok9) wrote :

Same problem here with an Samsung YP-U3 mp3 player.
The workaround has fixed temporarily the problem.

Marktrix (markgerlach) wrote :

"Its a seesaw change, with my NWZ-A818. In Gutsy it worked, in Hardy not, in Intrepid okay and now in Jaunty not.
I read that in Karmic it would be mounting my Device correctly. Where ist the Problem, i always be happy when it worked
and than next version same Problem. It´s frustrating!"

LOL in Karmic everything was fine, now in Lucid i got only access over Rhytmbox. Maybe i skip every second Ubuntu Version :-)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libgphoto2 (Ubuntu):
status: New → Confirmed
Ken Sharp (kennybobs) on 2015-12-06
tags: added: jaunty regression-release
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions