Unable to open addressbook error when loading Google Contacts

Bug #755043 reported by iMac on 2011-04-08
224
This bug affects 43 people
Affects Status Importance Assigned to Milestone
evolution-data-server
Fix Released
High
libgdata (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned
Oneiric
Low
Unassigned

Bug Description

Binary package hint: evolution-data-server

With large Google address books there seems to be some sort of timeout while loading. It makes a large Google addressbook unusable.

On fresh install during the creation of a new Google address book I usually see "Unable to open addressbook. This addressbook cannot be opened. This either means an incorrect URI was entered or the server is unreachable. Detailed error message:Cannot authenticate user: Invalid query" message.
https://launchpadlibrarian.net/70635993/Evo_ContactsBug_OnAdd.png

When upgrading (Maverick -> Natty), I already have the account created and sometimes see partial loading, and see the the "Unable to open addressbook. This addressbook cannot be opened. This either means an incorrect URI was entered or the server is unreachable. Detailed error message: Timeout was reached" message.
https://launchpadlibrarian.net/68733604/evolution_gui_matching_debug.png

Sometimes I also see this message: "Unable to perform search. The backend for this addressbook was unable to parse query: Invalid query".
https://launchpadlibrarian.net/68646259/google_contacts2.png

Sometimes I see "some" contacts, sometimes "none". Whether new install or upgrading, I can usually clicking back and forth between local address books and the Google address books or reload evolution to get some of them loaded and stumble on each of the three messages above.

I have temporarily connected to a Google account that has only 20 contacts I need all the time. This loads fine every time. Every once in a while I see a the error "Unable to perform search. This query did not complete successfully. Cannot connect to the service's server". I suspect this is the mild impact of the same failure, but not happening during the contact load. It may be a lesser separate issue which needs to be separate once this is resolved.
https://launchpadlibrarian.net/71632476/Unable_To_Search.png

I am able to replicate the issue on Evolution 3.0 as well using the Debian unstable packages on Natty 11.04 http://packages.debian.org/experimental/evolution
I was unable to replicate the issues on Evolution 2.32 running on Maverick 10.10 using this PPA https://launchpad.net/~konstigt/+archive/evolution

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: evolution 2.32.2-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Fri Apr 8 16:56:16 2011
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: evolution
UpgradeStatus: Upgraded to natty on 2011-04-06 (2 days ago)

iMac (imac-netstatz) wrote :
iMac (imac-netstatz) wrote :

In every case, my e-addressbook-factory fails in the same place consistently. I have included the output below from LIBGDATA_DEBUG=3 /usr/lib/evolution/e-addressbook-factory

I've obfuscated sensitive details with XxXxXxX, or a comment bounded by this string.

In the final contact prior to failure, none of the removed data had any special or non-standard characters. i.e. [0-9,aA-zZ]. It just sorta goes "Bye" on the console and in the GUI I see "Timeout Reached". (Next attached screenshot).

It seems to indicate a timeout issue of sorts noting the log is paired exactly with the screenshot stating "Timeout reached"

It is important to note, that at this point if I monkey around with the focus in the GUI, I can then arrive at the screenshot submitted in the original bug report where I see 1093 contacts prior to failure. I suspect that caching somewhere in the process allows me to see this partial output, and the problem is still the "Timeout Reached".

iMac (imac-netstatz) wrote :

Here is the matching screenshot to the debug log attached to the previous comment

summary: - Google Contacts fail to load in Evolution
+ Google Contacts timeout while loading in Evolution
description: updated
iMac (imac-netstatz) on 2011-04-08
description: updated

Ok, the problem here seems to be, after looking at the code, that the google backend only returns the list of contacts when it has retrieved them all, so the DBus call from Evolution to evolution-data-server times out.

iMac (imac-netstatz) wrote :

Thanks for the insight Rodrigo; Are you able to isolate the code change required, or possibly forward port the 10.10 version which did not have this issue? Is it as simple as increasing this timeout?

iMac (imac-netstatz) wrote :

I have also confirmed that using google contacts for one of my other accounts with only 8 contacts works just fine, supporting the observations that duration/size/timeout is a factor.

I also encountered the same issue adding my large Google contact addressbook to another Natty evolution instance on a separate machine.

Changed in evolution-data-server:
importance: Unknown → High
status: Unknown → Incomplete
iMac (imac-netstatz) wrote :

Interestingly, I have no issues with 2.32 packages from the ppa below on a fresh maverick installation with my evolution data from pre-natty upgrade.

https://launchpad.net/~konstigt/+archive/evolution

I discovered this while trying to provide some upstream support for a separate contact migration bug 761037.

In summary, it would seem that this timeout issue is related to specific changes in 11.04 that affect DBus based on Rodrigo's comment above or were introduced by some code differences between the google backend 2.32 in 11.04 and the PPA above.

I found a related upstream bug, and linked to it also.

iMac (imac-netstatz) wrote :
Download full text (5.0 KiB)

After talking with the upstream developers, I tried out Evolution 3.0. It's a one-way transition from a data-perspective, so backup if you plan to downgrade back to 2.32, but the good news is that 3.0 exists in upstream Debian experimental so it was easy to do once the apt sources were in place. I was able to meet binary dependencies in Natty, so I didn't even have to rebuild the packages.

My dpkg output is included. Also attached is a screenshot of this problem in 3.0. In the GUI it appears to timeout at the same place in a consistent manner with a 3.0 specific error message.

apt-get install evolution/experimental evolution-data-server/experimental evolution-common/experimental libevolution/experimental libebook1.2-10/experimental libedataserverui-3.0-0/experimental evolution-data-server-common/experimental evolution-plugins/experimental

root@repo:~# dpkg -l | grep evolution
ii evolution 3.0.0-2 groupware suite with mail client and organizer
ii evolution-common 3.0.0-2 architecture independent files for Evolution
ii evolution-couchdb 0.5.3-0ubuntu2 Evolution support for CouchDB databases
ii evolution-data-server 3.0.0-1 evolution database backend server
ii evolution-data-server-common 3.0.0-1 architecture independent files for Evolution Data Server
ii evolution-data-server-dev 3.0.0-1 Development files for evolution-data-server (metapackage)
ii evolution-indicator 0.2.14-0ubuntu4 GNOME panel indicator applet for Evolution
ii evolution-plugins 3.0.0-2 standard plugins for Evolution
ii evolution-webcal 2.32.0-0ubuntu2 webcal: URL handler for GNOME and Evolution
ii libebackend-1.2-1 3.0.0-1 Utility library for evolution data servers
ii libebackend1.2-0 2.32.2-0ubuntu2 Utility library for evolution data servers
ii libebackend1.2-dev 3.0.0-1 Utility library for evolution data servers (development files)
ii libebook1.2-10 3.0.0-1 Client library for evolution address books
ii libebook1.2-dev 3.0.0-1 Client library for evolution address books (development files)
ii libecal1.2-8 3.0.0-1 Client library for evolution calendars
ii libecal1.2-dev 3.0.0-1 Client library for evolution calendars (development files)
ii libedata-book-1.2-9 3.0.0-1 Backend library for evolution address books
ii libedata-book1.2-8 2.32.2-0ubuntu2 ...

Read more...

iMac (imac-netstatz) wrote :

I restored my home directory and downgraded back to the 2.32 stable packages after verifying upstream 3.0.0 has this problem also on Natty.

apt-get install evolution/natty evolution-common/natty evolution-data-server/natty evolution-data-server-common/natty evolution-plugins/natty libevolution/natty libebook1.2-10/natty libecal1.2-8/natty libedataserver1.2-14/natty

root@repo:~# dpkg -l | grep evolution | awk '{ print $1, $2, $3}'
ii evolution 2.32.2-0ubuntu7
ii evolution-common 2.32.2-0ubuntu7
ii evolution-couchdb 0.5.3-0ubuntu2
ii evolution-data-server 2.32.2-0ubuntu2
ii evolution-data-server-common 2.32.2-0ubuntu2
ii evolution-indicator 0.2.14-0ubuntu4
ii evolution-plugins 2.32.2-0ubuntu7
ii evolution-webcal 2.32.0-0ubuntu2
ii libebackend1.2-0 2.32.2-0ubuntu2
ii libebook1.2-10 2.32.2-0ubuntu2
ii libecal1.2-8 2.32.2-0ubuntu2
ii libedata-book1.2-8 2.32.2-0ubuntu2
ii libedata-cal1.2-10 2.32.2-0ubuntu2
ii libedataserver1.2-14 2.32.2-0ubuntu2
ii libedataserverui1.2-11 2.32.2-0ubuntu2
ii libevolution 2.32.2-0ubuntu7
ii libmultisync-plugin-evolution 0.82-9ubuntu1
ii python-evolution 2.32.0-0ubuntu2
ii tracker-miner-evolution 0.8.17-1ubuntu2

Since I received the "Query" error in 3.0 at initial creation of the addressbook, I re-tested 2.32 during a recreation of the addressbook (remove, shutdown, add-back) and also got an invalid query error as the first message. (Screenshot attached)

iMac (imac-netstatz) on 2011-04-29
summary: - Google Contacts timeout while loading in Evolution
+ Unable to open addressbook error when loading Google Contacts

If I empty my Google Contacts by exporting them and then delete them from Google I can add Google Contacts to Evolution without problems. If I then import all the contacts again into Google I can see all of them for a while, or until I close down Evolution. When I open Evolution again I get the error message and can not longer use Google Contacts.

iMac (imac-netstatz) wrote :

Probably worth noting there are at least three different error messages I see with this issue, and sometimes I see "some" contacts and sometimes "none". Starting from a fresh install I usually see "none" with the query error here:

https://launchpadlibrarian.net/70635993/Evo_ContactsBug_OnAdd.png

After clicking around and re-loading, I can also generate these other two:

https://launchpadlibrarian.net/68733604/evolution_gui_matching_debug.png

https://launchpadlibrarian.net/68646259/google_contacts2.png

Sometimes you see "some" contacts, sometimes "none". This is why I changed the bug title to be more generic to the common message in the title of the Error Dialog rather than the message itself.

This is why I changed the name of the bug

summary: - Google Contacts timeout while loading in Evolution
+ Unable to open addressbook error when loading Google Contacts

This is similar to my bug https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/779992 and may well be related.

iMac (imac-netstatz) on 2011-05-13
description: updated

PS> I also find that my Calendar accounts are affected too. Let me explain:

I have 5 private accounts hosted by Google. One I give to my wife and the others are for a private business. In addition I have a standard Google account for private use.

I have set up 4 private accounts and my personal account on two PCs/Laptops for eMail use. I then have the Contacts synced for my main business (private account) and my personal account on these machines. I then have these two accounts and my wife's Calendar sync'd...

On my wife's PC I have her account for eMail, contacts and calendar, plus my business and personal Calendars sync'd. All this worked fine until upgrade. Now what happens is.

ALL the eMail accounts work fine unless they are looking for a contact. None of the Contacts accounts work, even after deletion and re-setting up. Error messages as above.

Calendar in all cases the accounts did not work at the start, but after gong in to properties and re-establishing the account, entering the PW the contents downloaded. However, If I want the account to show or to make any changes I have to either go through the process again, delete the account and start over, or it just refuses to work.

Hope this helps

Changed in evolution-data-server (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
iMac (imac-netstatz) on 2011-05-25
Changed in evolution-data-server (Ubuntu):
status: Triaged → Confirmed
Pedro Villavicencio (pedro) wrote :

Please do not change the bug status without giving a good explanation, if you don't know what they means please have a look to our documentation available at: https://wiki.ubuntu.com/Bugs/Status ; Thanks in advance.

Changed in evolution-data-server (Ubuntu):
status: Confirmed → Triaged
iMac (imac-netstatz) wrote :

Pedro .. Sorry, since there was no explanation on the first change I just changed it back since it wasn't assigned. I am thinking that an early 0.8.0 issue is a contributing factor since I only experience the issue on 11.04, regardless of Evolution version (2.32/3.0). I am looking at testing th 0.8.1 libgdata currently in experimental to see if it resolves, but I have few cycles right now.

iMac (imac-netstatz) wrote :

I tested 0.8.1-1 from oneiric with no change to the issue. However I caught this comment below from a realted bug that seems like a duplicate, https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/762187/comments/15, and was able to resolve my issue.

The problem is that libgdata pre-0.8.2 does not handle Google contact custom fields that do not have a label. The equivalent output in libgdata debug looks like this

<gContact:userDefinedField key='' value='Director'/>

An example of such a field with an empty label is shown in the attached screenshot. At Google.com/contacts where the screenshot was taken, it can be easily edited to contain a label, or removed - both of which will solve the issue.

You can find the contacts with unlabelled custom fields by searching the libgdata debug output (start the factory with ~$LIBGDATA_FORCE_HTTP=1 LIBGDATA_DEBUG=3 /usr/lib/evolution/e-addressbook-factory) for the following string.

userDefinedField key=''

It is worth noting that I have many custom fields with the label defined. These are all fine to be left unchanged, and may look similar to the following with a label and value defined:

<gContact:userDefinedField key='Custom1' <email address hidden>'/>

Thanks Michael Seifert for figuring this out for us.

I had three of these to remove in my 1800+ contacts, and each time I had to shutdown evolution, fix the data, kill the e-addressbook-factory process and restart with the debug output to find the next occurance. Only after I removed them all, and completely restarted evolution did everything work fine. And it has since. Autocomplete, etc. All great. Really happy about this. I've left the 0.8.1 libgdata in place for now, but per the comments linked above, the 0.8.0 shipping with Natty should be fine.

This should no longer be an issue by default when 0.8.2 ships per the upstream bug and commits. I am re-linking this upstream bug for easy patch extraction.

Changed in evolution-data-server:
importance: High → Unknown
status: Incomplete → Unknown
Changed in evolution-data-server:
importance: Unknown → High
status: Unknown → Fix Released
Webmaster (speschko) wrote :

How do I get this fix into my 11.04 now?

affects: evolution-data-server (Ubuntu) → libgdata (Ubuntu)
Pedro Villavicencio (pedro) wrote :

This seems to be fixed at branch : http://git.gnome.org/browse/libgdata/commit/?h=libgdata-0-8&id=400a4e74f5a506ddff07605a93aa7412262fea38 ; nominating it for Natty so it can be fixed there, the report is affecting a good quantity of users already.

JJ Asghar (d-jj) wrote :

I did a clean install last night, and this effects me also.
"Detailed error message: Cannot authenticate user: Invalid query"
When i attempt to pull up the contact list.

Changed in libgdata (Ubuntu Natty):
status: New → Confirmed
Larry Reid (lcreid) wrote :

iMac's excellent suggestion at #16 worked for me, but I had many more messed up contacts than he did. I found an easier way to clean up my contacts. I:

1) Exported my Google contacts as a "Google CSV" file.
2) Opened the file in LibreOffice calc
3) Sorted by "Custom Field 1 - Value" (column BW when I did my export)
4) For all the contacts that had a value in that column, but no value in "Custom Field 1 - Type", I edited the contact in the Google Contacts web interface, and put a label on the value (it was in a section called "Custom" when i edited the contact).

Then I was able to import all my contacts into Evolution.

Helge Klemm (helgeklemm) wrote :

Hi, the suggested solution from iMac didn't work for me, the problem persists with todays proposed for 11.10.

When I kill e-addressbook-factory and reopen contacts in evolution, then they finally show.

This is fixed in precise, but does warrant SRU in Oneiric and Natty. The patch looks simple enough to be easy to provide as a stable update.

Changed in libgdata (Ubuntu Oneiric):
status: New → Confirmed
importance: Undecided → Medium
Changed in libgdata (Ubuntu):
status: Triaged → Fix Released
Changed in libgdata (Ubuntu Natty):
importance: Undecided → Medium
Changed in libgdata (Ubuntu Oneiric):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Angelo Pantano (ghilteras) wrote :

so is it possible to install it on natty? I'm using mint so I cannot upgrade to precise yet

matyy (matthias-mendler) wrote :

For me, this happens in 12.04, too. Fresh install, Evolution 3.2.3.

When I kill e-addressbook-factory it works.

Patrick Dickey (pdickeybeta) wrote :

I too, can verify that this issue is still present in Precise. When I kill e-addressbook-factory, I'm prompted for my passwords (as I had deleted and recreated my addressbooks). After putting in the passwords, my addressbooks showed up. One thing that I may be doing differently now is that I don't have the contacts synced for offline use. I believe that I had that option checked before.

So, for matyy and anyone else still experiencing this issue, do you have that option checked or unchecked? And does it matter (if you have it checked, does the issue persist if you uncheck the option, or vice versa)?

Thanks, and have a great day:)
Patrick.

Download full text (4.2 KiB)

Yes I do....

On 4 August 2012 03:33, Patrick Dickey <email address hidden> wrote:

> I too, can verify that this issue is still present in Precise. When I
> kill e-addressbook-factory, I'm prompted for my passwords (as I had
> deleted and recreated my addressbooks). After putting in the passwords,
> my addressbooks showed up. One thing that I may be doing differently now
> is that I don't have the contacts synced for offline use. I believe that
> I had that option checked before.
>
> So, for matyy and anyone else still experiencing this issue, do you have
> that option checked or unchecked? And does it matter (if you have it
> checked, does the issue persist if you uncheck the option, or vice
> versa)?
>
> Thanks, and have a great day:)
> Patrick.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (779992).
> https://bugs.launchpad.net/bugs/755043
>
> Title:
> Unable to open addressbook error when loading Google Contacts
>
> Status in Evolution Data Server:
> Fix Released
> Status in “libgdata” package in Ubuntu:
> Fix Released
> Status in “libgdata” source package in Natty:
> Confirmed
> Status in “libgdata” source package in Oneiric:
> Confirmed
>
> Bug description:
> Binary package hint: evolution-data-server
>
> With large Google address books there seems to be some sort of timeout
> while loading. It makes a large Google addressbook unusable.
>
> On fresh install during the creation of a new Google address book I
> usually see "Unable to open addressbook. This addressbook cannot be opened.
> This either means an incorrect URI was entered or the server is
> unreachable. Detailed error message:Cannot authenticate user: Invalid
> query" message.
> https://launchpadlibrarian.net/70635993/Evo_ContactsBug_OnAdd.png
>
> When upgrading (Maverick -> Natty), I already have the account created
> and sometimes see partial loading, and see the the "Unable to open
> addressbook. This addressbook cannot be opened. This either means an
> incorrect URI was entered or the server is unreachable. Detailed error
> message: Timeout was reached" message.
> https://launchpadlibrarian.net/68733604/evolution_gui_matching_debug.png
>
> Sometimes I also see this message: "Unable to perform search. The
> backend for this addressbook was unable to parse query: Invalid query".
> https://launchpadlibrarian.net/68646259/google_contacts2.png
>
> Sometimes I see "some" contacts, sometimes "none". Whether new install
> or upgrading, I can usually clicking back and forth between local
> address books and the Google address books or reload evolution to get
> some of them loaded and stumble on each of the three messages above.
>
> I have temporarily connected to a Google account that has only 20
> contacts I need all the time. This loads fine every time. Every once in a
> while I see a the error "Unable to perform search. This query did not
> complete successfully. Cannot connect to the service's server". I suspect
> this is the mild impact of the same failure, but not happening during the
> contact load. It may be a lesser separate issue which needs to be separate
> once this i...

Read more...

Changed in libgdata (Ubuntu Natty):
status: Confirmed → Won't Fix
Changed in libgdata (Ubuntu Oneiric):
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → nobody
importance: Medium → Low
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in libgdata (Ubuntu Oneiric):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.