Ubuntu

[138a:0005] [138a:0008] Fingerprint Validity reader devices VFS301 and VFS300 not recognized.

Reported by carlosv on 2011-03-28
308
This bug affects 62 people
Affects Status Importance Assigned to Milestone
Fingerprint GUI
Undecided
Unassigned
libfprint
Fix Released
Medium
libfprint (Ubuntu)
Wishlist
Unassigned

Bug Description

Hi,
this bugs is concerning the Validity fingerprint reader VFS301. With the command lsusb is listed as: Bus 001 Device 004: ID 138a:0005 DigitalPersona, Inc. This isn't a DigitalPersona fingerprint reader, its "Validity" but they use digitalpersona software.
It affects in my case the model HP Touchsmart tm2-2105. On the Bug #285089 there is a patch for the 138a:0001 VFS101 but unfortunately it didn't work on the VFS301. I am using Ubuntu 10.10 and libfprint-0.3.0.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.35-28-generic 2.6.35-28.49
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.35-28.49-generic 2.6.35.11
Uname: Linux 2.6.35-28-generic x86_64
NonfreeKernelModules: wl
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: carlos 2175 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xc4500000 irq 47'
   Mixer name : 'IDT 92HD81B1X5'
   Components : 'HDA:111d7605,103c1486,00100402'
   Controls : 14
   Simple ctrls : 9
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xc4420000 irq 48'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Mon Mar 28 16:18:41 2011
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=d88d42e5-23c5-4b28-8c45-05ae3ea585fd
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: Hewlett-Packard HP TouchSmart tm2 Notebook PC
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-28-generic root=UUID=69f6eb2d-6a63-4bfa-ba7d-86c5874ad5da ro vga=769 quiet splash
ProcEnviron:
 LANG=en_NZ.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.38.5
SourcePackage: linux
dmi.bios.date: 10/28/2010
dmi.bios.vendor: Insyde
dmi.bios.version: F.23
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1486
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 83.1F
dmi.chassis.asset.tag: CNU0444K7G
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrF.23:bd10/28/2010:svnHewlett-Packard:pnHPTouchSmarttm2NotebookPC:pvr058A210000242A10000120100:rvnHewlett-Packard:rn1486:rvr83.1F:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP TouchSmart tm2 Notebook PC
dmi.product.version: 058A210000242A10000120100
dmi.sys.vendor: Hewlett-Packard

carlosv (carlosved) wrote :
carlosv (carlosved) wrote :

It affects HP Pavillion dv7-4012eg and Dell Vostro 3500 too.

PauLoX (paulox) wrote :

Confirmed on Dell Vostro 3500, device ID 138a:0008 with Ubuntu 10.10 32bit

I tried Fingerprint 1.0 but it not recognize my device.

I attach log from command:
$ sudo lsusb -vs 001:004
Bus 001 Device 004: ID 138a:0008 Validity Sensors, Inc. VFS300 Fingeprint Reader
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 1.10
  bDeviceClass 255 Vendor Specific Class
  bDeviceSubClass 16
  bDeviceProtocol 255
  bMaxPacketSize0 8
  idVendor 0x138a Validity Sensors, Inc.
  idProduct 0x0008 VFS300 Fingeprint Reader
  bcdDevice c.90
  iManufacturer 0
  iProduct 0
  iSerial 1 0020e0492286
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 39
    bNumInterfaces 1
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower 100mA
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 3
      bInterfaceClass 255 Vendor Specific Class
      bInterfaceSubClass 0
      bInterfaceProtocol 0
      iInterface 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x01 EP 1 OUT
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0040 1x 64 bytes
        bInterval 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x81 EP 1 IN
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0040 1x 64 bytes
        bInterval 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x82 EP 2 IN
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0040 1x 64 bytes
        bInterval 0
Device Status: 0x0000
  (Bus Powered)

carlosv (carlosved) on 2011-04-04
summary: - [138A:0001] fingerprint Validity VFS301 reader not recognized
+ [138A:0005] fingerprint Validity VFS301 reader not recognized
summary: - [138A:0005] fingerprint Validity VFS301 reader not recognized
+ [138a:0005] fingerprint Validity VFS301 reader not recognized

Confirmed on dell vostro 3500, is Validity Sensors, Inc. VFS300 Fingeprint Reader
Is the VFS300 on the dell vostro and the VFS301 originally reported the same?

carlosv (carlosved) wrote :

Hi there,
It is a bit confusing. It is not really clear if a solution or a patch for a Fingerprint reader from Validity would work in another one. The patch for VFS101, up to now it didn't work in another Validity fingerprint reader. So it is hard to say if there would be in future a driver for the VFS301, that it would work on the VFS300. But it seems that the Dell Vostro 3500 has the VFS300. On the other bug 138a:0001 somebody declared that the Vostro 3500 had a VFS301. I think it is were the confusion comes. Try the patch for the VFS101, if it doesn't work join the forum.

Changed in libfprint (Ubuntu):
status: New → Confirmed
Download full text (4.1 KiB)

The patch didn't work for me.

2011/4/6 carlosv <email address hidden>

> Hi there,
> It is a bit confusing. It is not really clear if a solution or a patch for
> a Fingerprint reader from Validity would work in another one. The patch for
> VFS101, up to now it didn't work in another Validity fingerprint reader. So
> it is hard to say if there would be in future a driver for the VFS301, that
> it would work on the VFS300. But it seems that the Dell Vostro 3500 has the
> VFS300. On the other bug 138a:0001 somebody declared that the Vostro 3500
> had a VFS301. I think it is were the confusion comes. Try the patch for the
> VFS101, if it doesn't work join the forum.
>
> ** Changed in: libfprint (Ubuntu)
> Status: New => Confirmed
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/744310
>
> Title:
> [138a:0005] fingerprint Validity VFS301 reader not recognized
>
> Status in “libfprint” package in Ubuntu:
> Confirmed
>
> Bug description:
> Hi,
> this bugs is concerning the Validity fingerprint reader VFS301. With the
> command lsusb is listed as: Bus 001 Device 004: ID 138a:0005 DigitalPersona,
> Inc. This isn't a DigitalPersona fingerprint reader, its "Validity" but they
> use digitalpersona software.
> It affects in my case the model HP Touchsmart tm2-2105. On the Bug #285089
> there is a patch for the 138a:0001 VFS101 but unfortunately it didn't work
> on the VFS301. I am using Ubuntu 10.10 and libfprint-0.3.0.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: linux-image-2.6.35-28-generic 2.6.35-28.49
> Regression: No
> Reproducible: Yes
> ProcVersionSignature: Ubuntu 2.6.35-28.49-generic 2.6.35.11
> Uname: Linux 2.6.35-28-generic x86_64
> NonfreeKernelModules: wl
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
> Architecture: amd64
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: carlos 2175 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
> Card hw:0 'Intel'/'HDA Intel at 0xc4500000 irq 47'
> Mixer name : 'IDT 92HD81B1X5'
> Components : 'HDA:111d7605,103c1486,00100402'
> Controls : 14
> Simple ctrls : 9
> Card1.Amixer.info:
> Card hw:1 'Generic'/'HD-Audio Generic at 0xc4420000 irq 48'
> Mixer name : 'ATI R6xx HDMI'
> Components : 'HDA:1002aa01,00aa0100,00100200'
> Controls : 4
> Simple ctrls : 1
> Card1.Amixer.values:
> Simple mixer control 'IEC958',0
> Capabilities: pswitch pswitch-joined penum
> Playback channels: Mono
> Mono: Playback [on]
> Date: Mon Mar 28 16:18:41 2011
> EcryptfsInUse: Yes
> HibernationDevice: RESUME=UUID=d88d42e5-23c5-4b28-8c45-05ae3ea585fd
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64
> (20101007)
> MachineType: Hewlett-Packard HP TouchSmart tm2 Notebook PC
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-28-generic
> r...

Read more...

PauLoX (paulox) wrote :

Someone have tried to use the patch submitted for Bug #285089 and replace the id 138a:0001 (VFS101) with the id 138a:0008 (VFS300) ?

I think it can work !

carlosv (carlosved) wrote :

I tried to change the id 138a:0001 (VFS101) to 138a:0008 (VFS301). It just get recognised by the fprint_demo, but when you tried to enrol my fingerprints, it just doesn't read it at all. You should try if it works on the VFS300 and let us know.
I got an Email from the support of Validity Inc. regarding this bug (missing driver) told me that change the id in the patch may work. But with VFS301, it didn't

carlosv (carlosved) wrote :

sorry I wanted to say: change the id 138a:0001 (VFS101) to 138a:0005 (VFS301)!!! not 138a:0008. Sorry my mistake

Nick Smith (ndaman) wrote :

I just built with the patch, I only found one line where I modified 0001 to 0005, is there anything else I need to do? It didn't work, but I've heard people say that sudo make install put things in the wrong directories, how do I place them in the proper ones? Thanks!

carlosv (carlosved) wrote :

Hi! The fprint dev are working on the driver it basically seems that the patch for the VFS101 (138a:001) just works on the VFS101 and VFS201. On the debug file when you try the driver on the VFS301 it gives errors that we don't know jet what could it be. The driver (or patch) for the VFS101 doesn't work, it was different protocol, register, or who know what else. Even though, I got two email from Validity Inc. insisting that it may work, but maybe it needs some modifications to make it work on the VFS301 that we don't know yet. Let's hope that fprint developers will create soon a driver or that maybe Validity Inc. decides to release a driver for its products.

carlosv (carlosved) wrote :

Hi!. I just got another email from Validity Inc. Here is what I got:

>> SLED 11 SP1 is available this year for VFS451 & VFS471 on certain HP
notebooks.
>>
>> We're working on our own Linux driver for SLED, Ubuntu & Fedora and
we plan to make it available by April next year.
>>
>> It will support VFS301, 5011, 5111 and 5131 in addition to VFS451,
471 & 491.
>>

So let's see. It really seems that is a truthful Email. On the other
hand, Validity announced last year a driver for VFS101 on December 2010
that was never released.

61 comments hidden view all 102 comments

Hi,
this bugs is concerning the Validity fingerprint reader VFS301. With the command lsusb is listed as: Bus 001 Device 004: ID 138a:0005 DigitalPersona, Inc. This isn't a DigitalPersona fingerprint reader, its "Validity" but they use digitalpersona software.
It affects in my case the model HP Touchsmart tm2.
The driver for the VFS101 [138a:0001] doesn't work on this device.

*** Bug 37578 has been marked as a duplicate of this bug. ***

61 comments hidden view all 102 comments
carlosv (carlosved) wrote :

Bug added to the libfprint traking

https://bugs.freedesktop.org/show_bug.cgi?id=37574

62 comments hidden view all 102 comments

As 37578 has been marked as a duplicate of this one, let's comment here.

The VFS300 [138a:0008] does not work either with the current VFS101 driver. This reader is shipped with the ASUSTEK laptops.

I've started developing a driver at https://github.com/andree182/vfs301 . I am able to get some fingerprint from it - but the code still needs some love and integration to libfprint is yet to be done (after it works correctly from console).

If someone test this and it works, let me know (through email/project site/this bugtracker).

62 comments hidden view all 102 comments
Andrej Krutak (andree182) wrote :

I've started developing a driver at https://github.com/andree182/vfs301 . I am able to get some fingerprint from it - but the code still needs some love and integration to libfprint is yet to be done (after it works correctly from console).

carlosv (carlosved) wrote :

Good news. Thanks Andrej! something that we could start working on and hopefully will become driver for the device.

Download full text (4.1 KiB)

Work very fine with VSF300! (Bus 001 Device 004: ID 138a:0008 Validity
Sensors, Inc. VFS300 Fingeprint Reader)

just change the proto.c line (135)
from:
        dev->devh = libusb_open_device_with_vid_pid(NULL, 0x138a, 0x0005);
to:
        dev->devh = libusb_open_device_with_vid_pid(NULL, 0x138a, 0x0008);

Congratulations!

2011/11/6 Andrej Krutak <email address hidden>

> I've started developing a driver at https://github.com/andree182/vfs301
> . I am able to get some fingerprint from it - but the code still needs
> some love and integration to libfprint is yet to be done (after it works
> correctly from console).
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (787876).
> https://bugs.launchpad.net/bugs/744310
>
> Title:
> [138a:0005] fingerprint Validity VFS301 reader not recognized
>
> Status in Fingerprint GUI:
> New
> Status in “libfprint” package in Ubuntu:
> Confirmed
>
> Bug description:
> Hi,
> this bugs is concerning the Validity fingerprint reader VFS301. With the
> command lsusb is listed as: Bus 001 Device 004: ID 138a:0005
> DigitalPersona, Inc. This isn't a DigitalPersona fingerprint reader, its
> "Validity" but they use digitalpersona software.
> It affects in my case the model HP Touchsmart tm2-2105. On the Bug
> #285089 there is a patch for the 138a:0001 VFS101 but unfortunately it
> didn't work on the VFS301. I am using Ubuntu 10.10 and libfprint-0.3.0.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: linux-image-2.6.35-28-generic 2.6.35-28.49
> Regression: No
> Reproducible: Yes
> ProcVersionSignature: Ubuntu 2.6.35-28.49-generic 2.6.35.11
> Uname: Linux 2.6.35-28-generic x86_64
> NonfreeKernelModules: wl
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
> Architecture: amd64
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: carlos 2175 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
> Card hw:0 'Intel'/'HDA Intel at 0xc4500000 irq 47'
> Mixer name : 'IDT 92HD81B1X5'
> Components : 'HDA:111d7605,103c1486,00100402'
> Controls : 14
> Simple ctrls : 9
> Card1.Amixer.info:
> Card hw:1 'Generic'/'HD-Audio Generic at 0xc4420000 irq 48'
> Mixer name : 'ATI R6xx HDMI'
> Components : 'HDA:1002aa01,00aa0100,00100200'
> Controls : 4
> Simple ctrls : 1
> Card1.Amixer.values:
> Simple mixer control 'IEC958',0
> Capabilities: pswitch pswitch-joined penum
> Playback channels: Mono
> Mono: Playback [on]
> Date: Mon Mar 28 16:18:41 2011
> EcryptfsInUse: Yes
> HibernationDevice: RESUME=UUID=d88d42e5-23c5-4b28-8c45-05ae3ea585fd
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64
> (20101007)
> MachineType: Hewlett-Packard HP TouchSmart tm2 Notebook PC
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-28-generic
> root=UUID=69f6eb2d-6a63-4bfa-ba7d-86c5874ad5da ro vga=769 quiet splash
...

Read more...

ID 138a:0005 Validity Sensors, Inc. VFS301 Fingerprint Reader
"No devices found!" (finguerprint GUI).
My notebook is HP Pavilion dm4-1075br.
Thanks.

carlosv (carlosved) wrote :

@Lopan

Could please tell us the instructions how did installed and tried the driver? I would like to give it a try. Thanks

Lopan (arlindo) wrote :

@carlosv

Just change the proto.c line (135)
from:
        dev->devh = libusb_open_device_with_vid_pid(NULL, 0x138a, 0x0005);
to:
        dev->devh = libusb_open_device_with_vid_pid(NULL, 0x138a, 0x0008);

Compile (command make) and run the proto (./proto). All steps like a root.

carlosv (carlosved) wrote :

@Lopan,

thank you for your answer. I muss say that I cannot compile it. (just for the record I am not a programmer). So when I compile it i get:
collect2: ld returned 1 exit status
make: *** [cli] Error 1
I have installed the packages libusb1-0, make and g++. It supposed to compile it without problem. Do you have any suggestion about this?
Thanks

Download full text (3.9 KiB)

@carlosv,

Please, send the last 100 lines before the compile error.

2011/12/15 carlosv <email address hidden>

> @Lopan,
>
> thank you for your answer. I muss say that I cannot compile it. (just for
> the record I am not a programmer). So when I compile it i get:
> collect2: ld returned 1 exit status
> make: *** [cli] Error 1
> I have installed the packages libusb1-0, make and g++. It supposed to
> compile it without problem. Do you have any suggestion about this?
> Thanks
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (787876).
> https://bugs.launchpad.net/bugs/744310
>
> Title:
> [138a:0005] fingerprint Validity VFS301 reader not recognized
>
> Status in Fingerprint GUI:
> New
> Status in “libfprint” package in Ubuntu:
> Confirmed
>
> Bug description:
> Hi,
> this bugs is concerning the Validity fingerprint reader VFS301. With the
> command lsusb is listed as: Bus 001 Device 004: ID 138a:0005
> DigitalPersona, Inc. This isn't a DigitalPersona fingerprint reader, its
> "Validity" but they use digitalpersona software.
> It affects in my case the model HP Touchsmart tm2-2105. On the Bug
> #285089 there is a patch for the 138a:0001 VFS101 but unfortunately it
> didn't work on the VFS301. I am using Ubuntu 10.10 and libfprint-0.3.0.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: linux-image-2.6.35-28-generic 2.6.35-28.49
> Regression: No
> Reproducible: Yes
> ProcVersionSignature: Ubuntu 2.6.35-28.49-generic 2.6.35.11
> Uname: Linux 2.6.35-28-generic x86_64
> NonfreeKernelModules: wl
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
> Architecture: amd64
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: carlos 2175 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
> Card hw:0 'Intel'/'HDA Intel at 0xc4500000 irq 47'
> Mixer name : 'IDT 92HD81B1X5'
> Components : 'HDA:111d7605,103c1486,00100402'
> Controls : 14
> Simple ctrls : 9
> Card1.Amixer.info:
> Card hw:1 'Generic'/'HD-Audio Generic at 0xc4420000 irq 48'
> Mixer name : 'ATI R6xx HDMI'
> Components : 'HDA:1002aa01,00aa0100,00100200'
> Controls : 4
> Simple ctrls : 1
> Card1.Amixer.values:
> Simple mixer control 'IEC958',0
> Capabilities: pswitch pswitch-joined penum
> Playback channels: Mono
> Mono: Playback [on]
> Date: Mon Mar 28 16:18:41 2011
> EcryptfsInUse: Yes
> HibernationDevice: RESUME=UUID=d88d42e5-23c5-4b28-8c45-05ae3ea585fd
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64
> (20101007)
> MachineType: Hewlett-Packard HP TouchSmart tm2 Notebook PC
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-28-generic
> root=UUID=69f6eb2d-6a63-4bfa-ba7d-86c5874ad5da ro vga=769 quiet splash
> ProcEnviron:
> LANG=en_NZ.utf8
> SHELL=/bin/bash
> RelatedPackageVersions: linux-firmware 1.38.5
> SourcePackage: linux
> dmi.bios.da...

Read more...

@Lopan,

thank you again for your fast answer. So here it is:

carlos@Linux:~/Desktop/VFS301/cli$ sudo make
[sudo] password for carlos:
gcc -ggdb `pkg-config --cflags libusb-1.0` `pkg-config --libs libusb-1.0` -o cli proto.c cli.c
/tmp/cchqESW9.o: In function `usb_init':
/home/carlos/Desktop/VFS301/cli/cli.c:52: undefined reference to `libusb_init'
/home/carlos/Desktop/VFS301/cli/cli.c:60: undefined reference to `libusb_open_device_with_vid_pid'
/home/carlos/Desktop/VFS301/cli/cli.c:73: undefined reference to `libusb_kernel_driver_active'
/home/carlos/Desktop/VFS301/cli/cli.c:75: undefined reference to `libusb_detach_kernel_driver'
/home/carlos/Desktop/VFS301/cli/cli.c:81: undefined reference to `libusb_claim_interface'
/home/carlos/Desktop/VFS301/cli/cli.c:88: undefined reference to `libusb_reset_device'
/home/carlos/Desktop/VFS301/cli/cli.c:94: undefined reference to `libusb_control_transfer'
/tmp/cchqESW9.o: In function `usb_deinit':
/home/carlos/Desktop/VFS301/cli/cli.c:110: undefined reference to `libusb_reset_device'
/home/carlos/Desktop/VFS301/cli/cli.c:117: undefined reference to `libusb_release_interface'
/home/carlos/Desktop/VFS301/cli/cli.c:124: undefined reference to `libusb_close'
/home/carlos/Desktop/VFS301/cli/cli.c:130: undefined reference to `libusb_exit'
/tmp/cchqESW9.o: In function `usb_recv':
/home/carlos/Desktop/VFS301/cli/cli.c:161: undefined reference to `libusb_bulk_transfer'
/tmp/cchqESW9.o: In function `usb_send':
/home/carlos/Desktop/VFS301/cli/cli.c:180: undefined reference to `libusb_bulk_transfer'
collect2: ld returned 1 exit status
make: *** [cli] Error 1

Download full text (5.2 KiB)

carlosv, I still didn't have time to install this but you probably
also need libusb-1.0-0-dev

2011/12/15 carlosv <email address hidden>:
> @Lopan,
>
> thank you again for your fast answer. So here it is:
>
> carlos@Linux:~/Desktop/VFS301/cli$ sudo make
> [sudo] password for carlos:
> gcc -ggdb `pkg-config --cflags libusb-1.0` `pkg-config --libs libusb-1.0` -o cli proto.c cli.c
> /tmp/cchqESW9.o: In function `usb_init':
> /home/carlos/Desktop/VFS301/cli/cli.c:52: undefined reference to `libusb_init'
> /home/carlos/Desktop/VFS301/cli/cli.c:60: undefined reference to `libusb_open_device_with_vid_pid'
> /home/carlos/Desktop/VFS301/cli/cli.c:73: undefined reference to `libusb_kernel_driver_active'
> /home/carlos/Desktop/VFS301/cli/cli.c:75: undefined reference to `libusb_detach_kernel_driver'
> /home/carlos/Desktop/VFS301/cli/cli.c:81: undefined reference to `libusb_claim_interface'
> /home/carlos/Desktop/VFS301/cli/cli.c:88: undefined reference to `libusb_reset_device'
> /home/carlos/Desktop/VFS301/cli/cli.c:94: undefined reference to `libusb_control_transfer'
> /tmp/cchqESW9.o: In function `usb_deinit':
> /home/carlos/Desktop/VFS301/cli/cli.c:110: undefined reference to `libusb_reset_device'
> /home/carlos/Desktop/VFS301/cli/cli.c:117: undefined reference to `libusb_release_interface'
> /home/carlos/Desktop/VFS301/cli/cli.c:124: undefined reference to `libusb_close'
> /home/carlos/Desktop/VFS301/cli/cli.c:130: undefined reference to `libusb_exit'
> /tmp/cchqESW9.o: In function `usb_recv':
> /home/carlos/Desktop/VFS301/cli/cli.c:161: undefined reference to `libusb_bulk_transfer'
> /tmp/cchqESW9.o: In function `usb_send':
> /home/carlos/Desktop/VFS301/cli/cli.c:180: undefined reference to `libusb_bulk_transfer'
> collect2: ld returned 1 exit status
> make: *** [cli] Error 1
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/744310
>
> Title:
>  [138a:0005] fingerprint Validity VFS301 reader not recognized
>
> Status in Fingerprint GUI:
>  New
> Status in “libfprint” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  Hi,
>  this bugs is concerning the Validity fingerprint reader VFS301. With the command lsusb is listed as: Bus 001 Device 004: ID 138a:0005 DigitalPersona, Inc. This isn't a DigitalPersona fingerprint reader, its "Validity" but they use digitalpersona software.
>  It affects in my case the model HP Touchsmart tm2-2105. On the Bug #285089 there is a patch for the 138a:0001 VFS101 but unfortunately it didn't work on the VFS301. I am using Ubuntu 10.10 and libfprint-0.3.0.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 10.10
>  Package: linux-image-2.6.35-28-generic 2.6.35-28.49
>  Regression: No
>  Reproducible: Yes
>  ProcVersionSignature: Ubuntu 2.6.35-28.49-generic 2.6.35.11
>  Uname: Linux 2.6.35-28-generic x86_64
>  NonfreeKernelModules: wl
>  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
>  Architecture: amd64
>  ArecordDevices:
>   **** List of CAPTURE Hardware Devices ****
>   card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
>     Subdevices: 1/1
>     Subdevice #0: subdevice #0
>  AudioDevicesInUse...

Read more...

@Sérgio

Thanks for the tip, but the libusb-1.0-0-dev I have it installed already. Cheers.

PauLoX (paulox) wrote :

I've the same problem of carlosv.

I've ubuntu 11.10 64bit.

The issue is related to 64bit infrastructure ?

carlosv (carlosved) wrote :

I have the same Ubuntu 11.10 64bit. Maybe it needs to be developed for 64bit as well.

carlosv (carlosved) wrote :

Hi there the problem has been just fixed. Andrej is working on it. Thanks.

The driver works! Lets hope soon will be full developed.

PauLoX (paulox) wrote :

Now, I compile correctly and get image of fingeprint.

I hope we'll have soon a libfprint driver for vfs300/1

Thanks!

Andrej Krutak (andree182) wrote :

Good new everyone! :-) The libfprint driver can now be integrated into libfprint and seems to work (see the mentioned web for recent patches etc.) - I was able to compile and use the examples provided with libfprint (and the fingerprints matched when expected).

However it could take while until we clean up the code to a state acceptable by the mainline...

carlosv (carlosved) on 2012-01-05
Changed in fingerprint-gui:
status: New → In Progress
Changed in libfprint (Ubuntu):
status: Confirmed → In Progress
carlosv (carlosved) wrote :

Hi Andrej!

IT WORKS!!!! Amazing!

Great job! Thanks for the effort!

I compiled and installed. fprint_demo GUI.

So if anybody wants to give it a shot here is what I did:

I have Ubuntu 11.10 64bit

I have installed fprint_demo from repositories.

Now download fprint: http://cgit.freedesktop.org/libfprint/libfprint/snapshot/v_0_4_0.tar.gz
and download the driver: https://github.com/andree182/vfs301/tarball/master
uncompressed them!

Now from the driver copy all the files:
libfprint/vfs301.c
and all the files on the other folder
cli/vfs301_photo.* (they are 3 files)

So copy all them on the libfprint uncompressed folder v_0_4_0/libfprint/drivers

Then in a Terminal apply the patch:
$ cd ~/v_0_4_0
$ patch -p1 < ~/Desktop/integrate_vfs301.patch
$ ./autogen.sh
$ make
$ sudo make install

Restart the Computer

then test it try in a Termal
$ sudo fprint_demo (I assume that you installed from repositories)

Hope to see it in upstream soon!

summary: - [138a:0005] fingerprint Validity VFS301 reader not recognized
+ Fingerprint Validity reader devices [138a:0005] VFS301 and [138a:0008]
+ VFS300 not recognized.
Download full text (5.4 KiB)

Yes! Congratulations!

I've implemented authentication with PAM(
http://www.reactivated.net/fprint/wiki/Pam_fprint) and it worked perfectly!

/ etc / pam.d / login
auth required pam_securetty.so
auth required pam_env.so
auth sufficient pam_fprint.so
auth sufficient pam_unix.so nullok try_first_pass likeauth
auth required pam_deny.so

See the test:
Login lopan: lopan
Scan right index finger on Validity VFS301
Último login:Qui Jan 5 10:46:26 BRST 2012em :0
lopan@lopan ~ $

Authentication on KDE works well.

/etc/pam.d/kde
auth required pam_env.so
auth sufficient pam_fprint.so
auth sufficient pam_unix.so try_first_pass likeauth nullok
auth required pam_deny.so

att.,

2012/1/5 carlosv <email address hidden>

> Hi Andrej!
>
> IT WORKS!!!! Amazing!
>
> Great job! Thanks for the effort!
>
> I compiled and installed. fprint_demo GUI.
>
> So if anybody wants to give it a shot here is what I did:
>
> I have Ubuntu 11.10 64bit
>
> I have installed fprint_demo from repositories.
>
> Now download fprint:
> http://cgit.freedesktop.org/libfprint/libfprint/snapshot/v_0_4_0.tar.gz
> and download the driver:
> https://github.com/andree182/vfs301/tarball/master
> uncompressed them!
>
> Now from the driver copy all the files:
> libfprint/vfs301.c
> and all the files on the other folder
> cli/vfs301_photo.* (they are 3 files)
>
> So copy all them on the libfprint uncompressed folder
> v_0_4_0/libfprint/drivers
>
> Then in a Terminal apply the patch:
> $ cd ~/v_0_4_0
> $ patch -p1 < ~/Desktop/integrate_vfs301.patch
> $ ./autogen.sh
> $ make
> $ sudo make install
>
> Restart the Computer
>
> then test it try in a Termal
> $ sudo fprint_demo (I assume that you installed from repositories)
>
> Hope to see it in upstream soon!
>
> ** Summary changed:
>
> - [138a:0005] fingerprint Validity VFS301 reader not recognized
> + Fingerprint Validity reader devices [138a:0005] VFS301 and [138a:0008]
> VFS300 not recognized.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (787876).
> https://bugs.launchpad.net/bugs/744310
>
> Title:
> Fingerprint Validity reader devices [138a:0005] VFS301 and [138a:0008]
> VFS300 not recognized.
>
> Status in Fingerprint GUI:
> In Progress
> Status in “libfprint” package in Ubuntu:
> In Progress
>
> Bug description:
> Hi,
> this bugs is concerning the Validity fingerprint reader VFS301. With the
> command lsusb is listed as: Bus 001 Device 004: ID 138a:0005
> DigitalPersona, Inc. This isn't a DigitalPersona fingerprint reader, its
> "Validity" but they use digitalpersona software.
> It affects in my case the model HP Touchsmart tm2-2105. On the Bug
> #285089 there is a patch for the 138a:0001 VFS101 but unfortunately it
> didn't work on the VFS301. I am using Ubuntu 10.10 and libfprint-0.3.0.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: linux-image-2.6.35-28-generic 2.6.35-28.49
> Regression: No
> Reproducible: Yes
> ProcVersionSignature: Ubuntu 2.6.35-28.49-generic 2.6.35.11
> Uname: Linux 2.6.35-28-generic x86_64
> NonfreeKernelModules: wl
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
> Architectu...

Read more...

Hi Andrej and thanks for your work.

I tried last code from vfs301 and libfprint with fprint-demo and it works well.

This is my configuration:
$ lsusb -s 001:004
Bus 001 Device 004: ID 138a:0008 Validity Sensors, Inc. VFS300 Fingerprint Reader
$ uname -a
Linux oz 3.0.0-14-generic #23-Ubuntu SMP Mon Nov 21 20:28:43 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
$ lsb_release -sd
Ubuntu 11.10

I attach a shell script to patch and compile libfprint with vfs301 and test it with fprint-demo and it works for me.

I hope to see soon this patch in the libfprint git master and fprint stable ppa.

triple (triplevic) wrote :

Hi!!
I try to install it, but it don't works!

I have copied the files libfprint/vfs301.c cli/vfs301_*.* to
the libfprint directory libfprint/drivers

Then like carlosv, in a Terminal apply the patch:
$ cd ~/v_0_4_0
$ patch -p1 < ~/Desktop/integrate_vfs301.patch
$ ./autogen.sh
$ make
$ sudo make install

Restart the Computer

and I use:
fingerprint-gui (v 1.02)
or
fprint-demo (v 0.04)

and it doesn't works.

I use Archlinux x86_64 and Bus 002 Device 003: ID 138a:0005 Validity Sensors, Inc. VFS301 Fingerprint Reader

What am I doing wrong?

My computer is HP dv6 3038ss

triple (triplevic) wrote :

uname -a
Linux myhost 3.1.9-1-ARCH #1 SMP PREEMPT Fri Jan 13 12:43:42 CET 2012 x86_64 Intel(R) Core(TM) i7 CPU Q 720 @ 1.60GHz GenuineIntel GNU/Linux

carlosv (carlosved) wrote :

@triple

Hi there!

I think you need to execute the fprint_demo as root user. So in a terminal $ sudo fprint_demo

If it doesnt work try to use the shell script from PaoloX.

If still doesnt work, just tell us a bit more if you get any error on the terminal.

triple (triplevic) wrote :

It works!

My problem was that I had installed the fingerprint-gui package (from yaourt) that depends on libfprint, since, when I installed fingerprint-gui, linfprint be also installed.

I installed after fprint_demo from source code.

Then I installed the patch
$ patch -p1 < ~/Desktop/integrate_vfs301.patch
$ ./autogen.sh
$ make
$ sudo make install

but this did not replace the other libfprint (the lib from yaourt), then, when I execute sudo fprint_demo, it doesn't works. Why make install doesn't replace the other lib?

THE SOLUTION IS:

First install libfprint without driver for ID 138a:0005. (It's to compile fprint_demo)
sudo pacman -S libfprint

Now download fprint_demo (v 0.04) from http://sourceforge.net/projects/fprint/files/fprint_demo/v0.4/fprint_demo-0.4.tar.bz2/download uncompressed them.

Now compile fprint_demo
cd ~/fprint_demo-0.4
./configure
make
sudo make install

Now uninstall libfprint
sudo pacman -R libfprint

Now download fprint: http://cgit.freedesktop.org/libfprint/libfprint/snapshot/v_0_4_0.tar.gz
and download the driver https://github.com/andree182/vfs301/tarball/master
uncompressed them.
Now copy the files libfprint/vfs301.c cli/vfs301_*.* to
the libfprint directory libfprint/drivers

Then, apply the patch:
$ cd ~/v_0_4_0
$ patch -p1 < ~/Desktop/integrate_vfs301.patch
$ ./autogen.sh
$ make
$ sudo make install

Now copy /usr/local/lib/libfprint.so.0.0.0 to /usr/local/lib with the name libfprint.so.0
sudo mv /usr/local/lib/libfprint.so.0.0.0 /usr/lib/libfprint.so.0

then execute fprint_demo
sudo fprint_demo

and, IT WORKS!

Is there another way to solve my problem easier? I mean changing the makefile or something.

carlosv (carlosved) wrote :

Good to know that it worked out. I guess the only problem to solved easier is to wait until it's upstreamed. Andrej is solving a problem that seems to affect to certain device with a segmentation problem. So I guess when it will be solve. It will be upstreamed.

But good to know it works!

triple (triplevic) wrote :

Is the problem with fingerprint-GUI? My question is because I installed fingerprint-GUI and doesn't works, it shows me "Segmentation fault" but pam_fprint and fprint_demo work.

fingerprint-GUI shows me this:

(process:7580): Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale.
fp:debug [fp_init]
fp:debug [register_driver] registered driver upekts
fp:debug [register_driver] registered driver upeke2
fp:debug [register_driver] registered driver aes4000
fp:debug [register_driver] registered driver aes2501
fp:debug [register_driver] registered driver uru4000
fp:debug [register_driver] registered driver vcom5s
fp:debug [register_driver] registered driver upeksonly
fp:debug [register_driver] registered driver aes1610
fp:debug [register_driver] registered driver vfs101
fp:debug [register_driver] registered driver (null)
fp:debug [find_supporting_driver] driver (null) supports USB device 138a:0005
fp:debug [find_supporting_driver] selected driver (null) supports USB device 138a:0005
Segmentation fault

carlosv (carlosved) wrote :

Ah! that may be the issue I was talking about before. Check: https://github.com/andree182/vfs301/issues/3 .

38 comments hidden view all 102 comments

Andrej, any news on this branch and patches?

*** Bug 43252 has been marked as a duplicate of this bug. ***

Whoopie (whoopie79) on 2012-04-15
Changed in fingerprint-gui:
status: In Progress → Invalid
carlosv (carlosved) on 2012-04-16
Changed in fingerprint-gui:
status: Invalid → Confirmed
carlosv (carlosved) on 2012-04-16
Changed in fingerprint-gui:
status: Confirmed → In Progress
carlosv (carlosved) on 2012-04-16
Changed in fingerprint-gui:
status: In Progress → Invalid
16 comments hidden view all 102 comments
Sayantan Das (sayantan13) wrote :

@carlos:
I have checked, I am able to swipe my fingerprints at lockscreen and also when I logout and login.
It does not break lightdm.
Only problem is I have enter my password to unlock the password keyring after login.

Ochir (oabushinov) wrote :

the second bug is the issue of fprintd. The first is the feature of GNOME. Keyring is not locked during login due to security reasons

carlosv (carlosved) wrote :

Hi guys. I found the reason why it crashes when I try to login using my fingerprints. It is because my home folder is encrypted. I created a user non encrypted and works fine. I encrypted the folder, crashes. Any ideas how to fix that? or do you think it should be consider as new bug?

Ochir (oabushinov) wrote :

carlosv,
have you tried to do it without fingerprint?

carlosv (carlosved) wrote :

yes! password always works encrypted or not encrypted home user folder. Just with fingerprint the login doesnt work. Seems is a new issue (or bug), other people inform about it: http://linux.derkeiler.com/Mailing-Lists/Ubuntu/2012-05/msg00053.html . I will report the bug tomorrow.

Sayantan Das (sayantan13) wrote :

@Ochir: is there any 32bit package available for the package you provided in #51?

Ochir (oabushinov) wrote :

no, I built only for amd64

PauLoX (paulox) wrote :

@carlosv I've the same issue with encrypted home user folder.

carlosv (carlosved) wrote :

Well here is the bug report: Bug #998367 of the encrypted home user.
Coming back to the issue I believe this driver works relatively fine. But Ochir is right, the segmentation fault bug in this driver should be solve before merging to libfprint. Now, I believe that Andrej has abandoned the project, so I guess if anybody has an idea how to solve it, just commented.

carlosv (carlosved) wrote :

I tried the driver with Fingerprint GUI. The "segmentation fault" crashes the program. We really have to solve this issue.

Download full text (3.8 KiB)

I tried this on HP Pailion DV6 with 138a:0005 VFS301. It works great.
Thanks for the driver...

On 17 May 2012 21:14, carlosv <email address hidden> wrote:

> I tried the driver with Fingerprint GUI. The "segmentation fault"
> crashes the program. We really have to solve this issue.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/744310
>
> Title:
> Fingerprint Validity reader devices [138a:0005] VFS301 and [138a:0008]
> VFS300 not recognized.
>
> Status in Fingerprint GUI:
> Invalid
> Status in “libfprint” package in Ubuntu:
> In Progress
>
> Bug description:
> Hi,
> this bugs is concerning the Validity fingerprint reader VFS301. With the
> command lsusb is listed as: Bus 001 Device 004: ID 138a:0005
> DigitalPersona, Inc. This isn't a DigitalPersona fingerprint reader, its
> "Validity" but they use digitalpersona software.
> It affects in my case the model HP Touchsmart tm2-2105. On the Bug
> #285089 there is a patch for the 138a:0001 VFS101 but unfortunately it
> didn't work on the VFS301. I am using Ubuntu 10.10 and libfprint-0.3.0.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: linux-image-2.6.35-28-generic 2.6.35-28.49
> Regression: No
> Reproducible: Yes
> ProcVersionSignature: Ubuntu 2.6.35-28.49-generic 2.6.35.11
> Uname: Linux 2.6.35-28-generic x86_64
> NonfreeKernelModules: wl
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
> Architecture: amd64
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: carlos 2175 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
> Card hw:0 'Intel'/'HDA Intel at 0xc4500000 irq 47'
> Mixer name : 'IDT 92HD81B1X5'
> Components : 'HDA:111d7605,103c1486,00100402'
> Controls : 14
> Simple ctrls : 9
> Card1.Amixer.info:
> Card hw:1 'Generic'/'HD-Audio Generic at 0xc4420000 irq 48'
> Mixer name : 'ATI R6xx HDMI'
> Components : 'HDA:1002aa01,00aa0100,00100200'
> Controls : 4
> Simple ctrls : 1
> Card1.Amixer.values:
> Simple mixer control 'IEC958',0
> Capabilities: pswitch pswitch-joined penum
> Playback channels: Mono
> Mono: Playback [on]
> Date: Mon Mar 28 16:18:41 2011
> EcryptfsInUse: Yes
> HibernationDevice: RESUME=UUID=d88d42e5-23c5-4b28-8c45-05ae3ea585fd
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64
> (20101007)
> MachineType: Hewlett-Packard HP TouchSmart tm2 Notebook PC
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-28-generic
> root=UUID=69f6eb2d-6a63-4bfa-ba7d-86c5874ad5da ro vga=769 quiet splash
> ProcEnviron:
> LANG=en_NZ.utf8
> SHELL=/bin/bash
> RelatedPackageVersions: linux-firmware 1.38.5
> SourcePackage: linux
> dmi.bios.date: 10/28/2010
> dmi.bios.vendor: Insyde
> dmi.bios.version: F.23
> dmi.board.asset.tag: Base Board Asset Tag
> dmi.board.name: 1486
> dmi.board.vendor: Hewlett-Packa...

Read more...

Hi all.

Thanks to your help here, I managed to have my HP Pailion DV7 with 138a:0005 VFS301 working on ubuntu 12.04.
Today I wanted to try on an extra partition ubuntu 12.10.
I used the "make.sh" script found above but had no luck untill now.
Did anayone manage to get the driver and fprint_demo work on ubuntu 12.10?

Thanks in advance.

Changed in libfprint (Ubuntu):
importance: Undecided → Wishlist
summary: - Fingerprint Validity reader devices [138a:0005] VFS301 and [138a:0008]
+ [138a:0005] [138a:0008] Fingerprint Validity reader devices VFS301 and
VFS300 not recognized.
6 comments hidden view all 102 comments

Created attachment 64254
Add support for Validity VFS301/VFS300

This is Andrej's patch taken from github and applied to libfprint. I can confirm that fprint_demo works with this patch on my laptop.

hi,
could you tell me which version of libfprint should I apply this patch ?

(In reply to comment #7)
> hi,
> could you tell me which version of libfprint should I apply this patch ?

This patch should apply to git master.

Hi,
Thanks , fprint_demo is able to recognize the device but still gives error that it could not open the device.

BTW I tested with a VFS300 (Dell Vostro). Guarav, do you have the 300 or the 301?

$ lsusb
Bus 001 Device 004: ID 138a:0008 Validity Sensors, Inc. VFS300 Fingerprint Reader

Hi,
Thanks for your reply. I am using HP Pavillion DM4 with a VFS 301 device. Is there anyway I could make it work on this device?

(In reply to comment #11)
> Hi,
> Thanks for your reply. I am using HP Pavillion DM4 with a VFS 301 device. Is
> there anyway I could make it work on this device?

Hi

on this forum: https://bugs.launchpad.net/ubuntu/+source/libfprint/+bug/744310

The comment #51 there is a deb package that works in Ubuntu and its more or less stable. Check if it works for your Laptop

(In reply to comment #11)
> Hi,
> Thanks for your reply. I am using HP Pavillion DM4 with a VFS 301 device. Is
> there anyway I could make it work on this device?

Note I am not the author of this patch. So it may be working for the 300 but not the 301. I don't know what the author tested it with.

(In reply to comment #12)
> Hi
>
> on this forum: https://bugs.launchpad.net/ubuntu/+source/libfprint/+bug/744310
>
> The comment #51 there is a deb package that works in Ubuntu and its more or
> less stable. Check if it works for your Laptop

Hi, I tried the patch provided on that forum and it worked! Now I am able to get fingerprints. Any ideas on how to use it for authentication? I am using Ubuntu 12.04. I tried using fingerprint-gui but it crashes with segmentation fault. fprint_demo is working.

(In reply to comment #14)
> (In reply to comment #12)
> > Hi
> >
> > on this forum: https://bugs.launchpad.net/ubuntu/+source/libfprint/+bug/744310
> >
> > The comment #51 there is a deb package that works in Ubuntu and its more or
> > less stable. Check if it works for your Laptop
>
> Hi, I tried the patch provided on that forum and it worked! Now I am able to
> get fingerprints. Any ideas on how to use it for authentication? I am using
> Ubuntu 12.04. I tried using fingerprint-gui but it crashes with segmentation
> fault. fprint_demo is working.

Yes. The problem with fingerprint-gui is a segmentation fault not yet solved. In order to use it, you have to unistall fingerprint-gui.
Since Ubuntu 11.10 the system integrates the fingerprint authentification without using other fingerprint-gui. And that way it works with this driver.

So to login and authenticate you must have Ubuntu 11.10 or 12.04, uninstall fingerprint-gui. Then reboot the system. Then to access the "Ubuntu" fingerprint go to: System setting -> User accounts. In the users account window you will see the option "Fingerprint Login" on every account. Click the button and register your fingerprints. You will be able to login and use authenticate when root privileges are needed.

P.D. The fingerprint login unfortunately doesn't work if the home user folder is encrypted. But that is not a problem of the driver, is a Ubuntu (or linux) bug.

(In reply to comment #15)
>
> Yes. The problem with fingerprint-gui is a segmentation fault not yet solved.
> In order to use it, you have to unistall fingerprint-gui.
> Since Ubuntu 11.10 the system integrates the fingerprint authentification
> without using other fingerprint-gui. And that way it works with this driver.
>
> So to login and authenticate you must have Ubuntu 11.10 or 12.04, uninstall
> fingerprint-gui. Then reboot the system. Then to access the "Ubuntu"
> fingerprint go to: System setting -> User accounts. In the users account window
> you will see the option "Fingerprint Login" on every account. Click the button
> and register your fingerprints. You will be able to login and use authenticate
> when root privileges are needed.
>
> P.D. The fingerprint login unfortunately doesn't work if the home user folder
> is encrypted. But that is not a problem of the driver, is a Ubuntu (or linux)
> bug.

Hi,
OK. I tried that method ,but I couldn't find any fingerprint login option in that menu. I am using Gnome3 with Ubuntu 12.04. I tried modifying /etc/pam.d/login but its not working. Could you suggest me some method for doing the same.

Created attachment 64558
Screenshot fingerprint login Ubuntu

Hi
Unfortunately at the moment there is not other method. To use the fingerprint-gui we must wait until somebody solves the segmentation fault. Now, I really find strange that you do not have this option in the users menu. I tried in Unity and Gnome and both are there. I attached a screen-shot of how you supposed to find it. Make sure you installed the fprint .deb customized from the forum. Hope it helps.

(In reply to comment #18)
> Hi
> Unfortunately at the moment there is not other method. To use the
> fingerprint-gui we must wait until somebody solves the segmentation fault. Now,
> I really find strange that you do not have this option in the users menu. I
> tried in Unity and Gnome and both are there. I attached a screen-shot of how
> you supposed to find it. Make sure you installed the fprint .deb customized
> from the forum. Hope it helps.

Thank you very much its working now. I did all the steps again and now it works. Thanks a lot for your help. :)

(In reply to comment #19)
> (In reply to comment #18)
> > Hi
> > Unfortunately at the moment there is not other method. To use the
> > fingerprint-gui we must wait until somebody solves the segmentation fault. Now,
> > I really find strange that you do not have this option in the users menu. I
> > tried in Unity and Gnome and both are there. I attached a screen-shot of how
> > you supposed to find it. Make sure you installed the fprint .deb customized
> > from the forum. Hope it helps.
>
> Thank you very much its working now. I did all the steps again and now it
> works. Thanks a lot for your help. :)

Glad I could help!

Created attachment 64946
vfs301 driver (1st public version)

Hi,

I have somewhat updated and improved the driver, should be a little more compatible with the coding style (in terms of internal functionality) of other libfprint drivers. I'm attaching the current version of the patch - please someone integrate it, so that I don't have to keep it on github sync'd .-)

Some notes:

The driver is for the devices 138a:0005 (primarily) and 138a:0008 (some users reported it as working too).

Unfortunately, we didn't decypher the protocol to much detail - so currently it mostly just repeats sequences the original binary driver does (that seems to work fine). That's why the driver doesn't look so pretty as other drivers. Maybe some users will be able to help with that :-)

The device on my notebook contains a LED next to the scanner, but I also didn't yet figure out how to control it - but anyhow, can libfprint use it to provide some feedback, even if we know how to control the LED?

Changed in libfprint:
importance: Unknown → Medium
status: Unknown → In Progress
Andrej Krutak (andree182) wrote :

Hi guys. Sorry for not replying, had other priorities and forgot about this bugzilla. I mostly reply on the github page however. But anyhow, as stated above, I tried to make the patches merge-able into upstream, so they should be in in near future... If you guys still experience any driver-related issues, please let me know on github .-)

Hi, Andrej and Everyone!

I tried your updated patch with 138a:0018 Validity Sensors, Inc. on HP Pavilion dv6-6030er. I tried to change id 0008 to 0018 in sources. fprint-demo finds my device, but cannot open it. If I can help you to make your driver work for 0018, tell my what I should de. Unfortunately, I don't have Windows, so I cannot send you any reverse-engineered stuff.

(In reply to comment #22)
> Hi, Andrej and Everyone!
>
> I tried your updated patch with 138a:0018 Validity Sensors, Inc. on HP Pavilion
> dv6-6030er. I tried to change id 0008 to 0018 in sources. fprint-demo finds my
> device, but cannot open it. If I can help you to make your driver work for
> 0018, tell my what I should de. Unfortunately, I don't have Windows, so I
> cannot send you any reverse-engineered stuff.

Hi

I believe the Validity Sensors are very different from each other. If it doesn't work after modifying the usb id (as it happened to VFS300), I hardly believe this driver would work on this device. Check this bug https://bugs.launchpad.net/ubuntu/+source/libfprint/+bug/827669 maybe you can get more info regarding this device there.

Cleaned up a little more, and pushed. Thanks very much for the patch!

commit c3689665dbf3cd2126f3729792aa71efe13aab8d
Author: Andrej Krutak <email address hidden>
Date: Sun Jul 22 21:44:34 2012 +0200

    lib: Add VFS300/VFS301 driver

    https://bugs.freedesktop.org/show_bug.cgi?id=37574

Changed in libfprint:
status: In Progress → Fix Released
PauLoX (paulox) wrote :

Can you upgrade ubuntu 12.10 package ? Latest commit on git repository contain VFS300/301 driver.

http://cgit.freedesktop.org/libfprint/libfprint/commit/?id=c3689665dbf3cd2126f3729792aa71efe13aab8d

Thanks

David Fraser (davidf) wrote :

Testing this on my Dell Vostro 3700 with a VFS300, and installing the drivers from https://launchpad.net/~fingerprint/+archive/fprint:

* fprint_demo lists the device as a VFS301
* Attempting to enroll fingers does nothing
* the program occasionally segfaults

What am I doing wrong? Versions below... dpkg -l "*fprint*" gksu-polkit

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-===========================================-==========================-==========================-===========================================================================================
ii fprint-demo 1:0.4+git20080303-0ppa2~on i386 GUI to show and test libfprint's capabilities
ii fprintd 0.4.1-5-g73edad0-3 i386 D-Bus daemon for fingerprint reader access
ii gksu-polkit 0.0.2-2.1ubuntu2 i386 command line utility to run programs as root
ii libfprint0 1:0.5.0-git20121204-1-0ppa i386 fingerprint library of fprint project, shared libraries
ii libpam-fprintd:i386 0.4.1-5-g73edad0-3 i386 PAM module for fingerprint authentication trough fprintd
ii xfprint4 4.6.1-3ubuntu1 i386 Printer GUI for Xfce4

Displaying first 40 and last 40 comments. View all 102 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.