Ubuntu

[138a:0018] Validity Sensors fingerprint reader not recognized

Reported by Rob Robinson on 2011-08-16
588
This bug affects 57 people
Affects Status Importance Assigned to Milestone
libfprint
New
Undecided
Unassigned
libfprint (Fedora)
New
Undecided
Unassigned
libfprint (Ubuntu)
Wishlist
Unassigned

Bug Description

In my case, it's on an HP Pavillion dv7 laptop. Fprint won't recognize the device.
I'm running natty, so Ubuntu 11.04.
Fprint package 1:0.4.0+git20110418-0ppa1~natty1

Running fprint_demo, I receive a Status: No devices found message.

Bus 001 Device 003: ID 138a:0018 Validity Sensors, Inc.
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 1.10
  bDeviceClass 255 Vendor Specific Class
  bDeviceSubClass 17
  bDeviceProtocol 255
  bMaxPacketSize0 8
  idVendor 0x138a Validity Sensors, Inc.
  idProduct 0x0018
  bcdDevice 0.78
  iManufacturer 0
  iProduct 0
  iSerial 1 d1f867a97960
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 46
    bNumInterfaces 1
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower 100mA
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 4
      bInterfaceClass 255 Vendor Specific Class
      bInterfaceSubClass 0
      bInterfaceProtocol 0
      iInterface 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x01 EP 1 OUT
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0040 1x 64 bytes
        bInterval 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x81 EP 1 IN
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0040 1x 64 bytes
        bInterval 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x82 EP 2 IN
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0040 1x 64 bytes
        bInterval 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x83 EP 3 IN
        bmAttributes 3
          Transfer Type Interrupt
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0008 1x 8 bytes
        bInterval 4
Device Status: 0x0000
  (Bus Powered)

Changed in libfprint (Ubuntu):
status: New → Confirmed
Facundo Rebord (farebord-u) wrote :

Please let us know as fast as you solve this bug.

Thanks.

Facundo Rebord (farebord-u) wrote :

Forgot to tell all HP DV6 6154 and others are affected..

I have same problem... In vostro 3500

Rob Robinson (ravenmistmedia) wrote :

Now at Oneiric Ocelot Ubuntu version 11.10

LStranger (andrej-rep) wrote :

HP Pavillion dv6 6153sr is also affected (my sister bought one).

Juho Häme (juho-hame) wrote :

Same laptop, same problem.

Spence (spencer.carter) wrote :

HP Pavilion dv6-6c48us on Ubuntu Oneiric Ocelot 11.10 3.0.0-16-generic #29-Ubuntu SMP x86_64.

Uri (oriol-castejon) wrote :

Also in HP Pavilion dm4-2110ss on Natty 2.6.38-13-generic #56-Ubuntu

Neutrino (neutrino-vm) wrote :

Also in HP Pavilion dv6-6169er on Precise 3.2.0-24-generic

Alfons (alfons-trullas) wrote :

Also for HP Pavilion DV6-6197ss on Precise

<<MK>> (mk-rulezz) wrote :

Also in HP Pavilion dv6-6c05er on Precise 3.2.0-25-generic

fred (flyingninjas) wrote :

Same laptop, same problem. Ubuntu 12.04. The fingerprint scanner works great in windows 8.

Dominik2308 (dominik2308) wrote :

I have the same problem on my HP Pavilion DV6-6087 the Fingerprint Scanner isn't recognized!

Changed in libfprint (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Wishlist
James Spinella (jimmyco2010) wrote :

Same issue, HP Pavilion m6 1045dx, so what do the "Triaged" and "Wishlist" statuses mean for getting a driver working?

Eric Draven (evileric3) wrote :

I hope that someone can help i have a HP Pavilon DV6 6180-us runing ubuntu 12.04 X64 it has a finger print scanner. Here is the info for it "Bus 001 Device 003: ID 138a:0018 Validity Sensors, Inc." if ANYONE comes up with a way to make this work for my system i would be greatful.

I am seeing it as well. Is there a config or mod line I can use to make this work?

Thanks
Robert

Eric Draven (evileric3) wrote :

can someone please explan to me what triaged means here (dose this mean that its been fixed or is amputated and not going to be fixed or what am a bit confused on this ) thanks

Badr Ghatasheh (079-e) on 2012-08-31
description: updated
<<MK>> (mk-rulezz) on 2012-10-07
visibility: public → private
security vulnerability: no → yes
visibility: private → public
<<MK>> (mk-rulezz) on 2012-10-07
security vulnerability: yes → no
security vulnerability: no → yes

Same on HP Pavilion dv6-6c13ss running Ubuntu 12.10 with Bus 001 Device 003: ID 138a:0018 Validity Sensors, Inc.

Edoardo Giomi (edogiomi) wrote :

Laptop: HP Pavilion dv6 Notebook PC (QF452EA#ABZ)
Device: Bus 001 Device 003: ID 138a:0018 Validity Sensors, Inc.
Running: Ubuntu 12.10 x64 with Kernel Linux 3.5.0-19-generic

I have the same problem, please fix it.

Thanks,
edo

Yoann H (yoann-hervieux) wrote :

Hi,
same device, same issue.
Don't hesitate to contact me if I can help by providing some logs or info. No coding yet, I'm still discovering Linux ;-)

Thanks,
Yoann

Tristan Beaudoin (tjbeaudoin) wrote :

I am having the same problem on my HP Envy dv6-7210us running Ubuntu 12.10 with kernel Linux 3.5.0-21-generic, with Bus 002 Device 003: ID 138a:0018 Validity Sensors, Inc. I sure hope all of this can get resolved soon.

Thanks,

Tristan

Gluk41 (makc41) on 2013-01-02
Changed in libfprint (Ubuntu):
status: Triaged → Fix Released
Whoopie (whoopie79) wrote :

@Gluk41: Why have you changed the bug report to "Fix Released"???

Max Mustermann (haotti13) wrote :

where is the fix?

bianghouse (bianghouse) wrote :

where is the fix?

Uri (oriol-castejon) wrote :

i don't see the fix either. the computer still does not recognize the fingerprint reader.

Nick (nicktoupin) wrote :

Also affecting HP Envy dv6-7273CA running Ubuntu 12.10 - Bus 001 Device 003: ID 138a:0018 Validity Sensors, Inc.

kinseywk (kinseywk) wrote :

Also affecting HP Pavillion m7; same device (138a:0018)

Dinu (dinu88) wrote :

Also affecting HP dv6-6c60el; Bus 001 Device 003: ID 138a:0018 Validity Sensors, Inc.

no longer affects: libfprint
aimwin (aim-mail) wrote :

Also affecting HP dv6-6137tx
Bus 001 Device 003: ID 138a:0018 Validity Sensors, Inc.
Ubuntu Release 12.04.1 (precise) 64-bit, Kernel Linux 3.2.0-36-generic
According to
https://launchpad.net/~fingerprint/+archive/fprint
no support for 138a:0018
only the 138a:0008

Any one have a success with 138a:0018 ?

MWisBest (repinski23) wrote :

Also affecting HP Envy m6-1205dx (and the m6-1105dx probably too). This is not fixed, and I have no idea why it is marked as so, and why it now says "no longer affects:libfprint"

Vladimir Yakovlev (mrquesty) wrote :

I have updated to the latest libfprint (libfprint - 1:0.5.0-git20130113-1-0ppa1~quantal1) on Ububtu 12.10, but Fingerprint GUI doesn't see my 138a:0018 Validity Sensors, Inc. on HP ENVY dv7
Any ideas?

Whoopie (whoopie79) wrote :

You need to compile a libfprint version which supports VFS5011 on your own.

The info can be found at http://article.gmane.org/gmane.linux.fprint/2241

And please, stop spamming the bug report. Use the "affects me, too" link at the top of the bug report. Thanks!

Jordy Dickinson (jordy-d) wrote :

So the fix was not released in Ubuntu, it was released in libfprint. But the bug report indicates that it's released in Ubuntu, and not in libfprint. That's why the bug report is being spammed; it says a fix was released when it wasn't, and it's leading to confusion.

Danilo Mendes (djmendes) wrote :

Tried to compile the .0.5 and that VFS5011 (which states to work with 138a:0011 and not the 138a:0018, but, hey, why not to try?) and still not working.

Max Mustermann (haotti13) wrote :

I also tried to compile the version .0.5 but there wasn't any success. Still not working

Max Mustermann (haotti13) wrote :

After a small change, it worked perfectly. Just give it a try: https://github.com/maffmeier/fprint_vfs5011

Compile, be sure you have installed frprintd. Now you can Login with your fingerprint ;)

Danilo Mendes (djmendes) wrote :

Sweet trick!

Just another tip: mine only worked after reinstall libfprint0

So...

sudo apt-get install libfprint0 --reinstall

Max Mustermann (haotti13) wrote :

I tried it, too. But it didn't worked for me :(

<<MK>> (mk-rulezz) wrote :

compiled, installed, reinstalled libfprint0 fprint-demo.
scanner is recognized, but fprint-demo startup says "opening device...", as root run normally.

Max Mustermann (haotti13) wrote :

Add This File: /etc/udev/rules.d/50-fingerprint.rules
With this content :

SUBSYSTEM !="usb_device", ACTION !="add", GOTO="fingerprint_rules_end"

SYSFS{idVendor} =="138a", SYSFS{idProduct} =="0018", SYMLINK+="fingerprint"

MODE="0666", OWNER="nobody", GROUP="fingerprint"

LABEL="fingerprint_rules_end"

Add a group fingerprint and add your user to the new group.

And Taddaaa it will work!

Max Mustermann (haotti13) wrote :

you have to create the File!

Max Mustermann (haotti13) wrote :

This File is a Config File for udev. So Udev knows who is allowed to use the Fingerprintreader...

Maybe you have to do chown -R youruser ~/.fprint/

<<MK>> (mk-rulezz) wrote :

Created a rule that the scanner works. When logging in Accepted fingerprint. Everything's great.

Jonathan Moore (jtm013) wrote :

Hello, I'm a total newbie to ubuntu could someone please explain how to compile this fix and install it for me. Thanks for the help

jcervilla (jcervilla) wrote :

Yes, it worked for me. Thank you very much.

Luigi R. (xluigi84) wrote :

Could you please explain how to make it working. I'm on ubuntu 13.04 and I have installed:

fprint-demo
libfprint0
libpam-fprintd
fprintd
libasprint0c2

but still the message no device found on fprint-demo. Could you tell us step by step what to do please?

Luigi R. (xluigi84) wrote :

I have also tried to create the rule but i received the following message at the next boot:

udevd[401]: unknown key 'SYSFS{idVendor}' in /etc/udev/rules.d/50-fingerprint.rules:2
udevd[401]: invalid rule '/etc/udev/rules.d/50-fingerprint.rules:2'

Luigi R. (xluigi84) wrote :

last attempt was:

1) downloaded fprint_vfs5011-master.zip
2) ./configure -prefix=/opt/fingerprint
3) make
4) sudo make install
5) reinstall fprint-demo and libfprint0
6) created /etc/udev/rules.d/50-fingerprint.rules
7) add group and user
7) restarted

and nothing happens

udevd[424]: unknown key 'SYSFS{idVendor}' in /etc/udev/rules.d/50-fingerprint.rules:3
udevd[424]: invalid rule '/etc/udev/rules.d/50-fingerprint.rules:3'
udevd[528]: error opening ATTR{/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.1/1-1.1:1.0/power/control} for writing: No such file or directory

kernel : 3.9.2-030902-generic OS: Ubuntu 13.04

Any suggestions? Thanks!!

Ivan Anisimov (kisk-pismo) wrote :

works, but very rarely detects the correct fingers. fingerprints can be very long.
Maybe I'm doing something wrong

Trudi (trudi-l) wrote :

Same as Ivan, works but detects the correct fingers every 10 or 15th time you scan the finger. Maybe the comparison of the registered print and the scanned print is too accurate.

While I noticed this too, for me the ratio is closer to one in two.
Maybe try re-scanning the original one it compares against with
libfprint_demo or something.

Ruben Rocha (ruben-silvarocha) wrote :

Ok guys

I have built a deb package for 64 bit systems. After you download the package i attached you just need to sudo dpkg -i and it will install the driver.

If you want the integrated ubuntu fingerprint features for login and sudo, apt-get install fprintd libpam-fprintd. Then go to users and you will see the fingerprint login button option. Enroll your fingerprint and voila!

The only annoiance is that on the longin screen when it askes for your fingerprint the process isnt like windows. You swipe your finger and if the fingerprint is recognised it will display a login button you have to click. If the fingerprint isnt recognised it will time out and ask for you user password.

JanCeuleers (jan-ceuleers) wrote :

Thank you very much. This package however requires glibc 2.17 whereas my 12.04.4 LTS system only has 2.15. Would you be able to make available a package that works on the other currently supported Ubuntu versions?

Ruben Rocha (ruben-silvarocha) wrote :

I forgot to specify this deb package was built on ubuntu 13.10 64bit. It was the first time i built a deb package so i dont know how this works. Maybe a ppa with the package for different ubuntu versions?

I got the source driver from the link mentioned above and then ./configure, make, and then made the package with checkinstall.

Maybe someone more experienced can make a ppa for this package/driver.

Ruben Rocha (ruben-silvarocha) wrote :

After some testing with the fingerprint reader integration of ubuntu, there are some minor problems with the fingerprint use.

- The fingerprint reading is way too accurate. 1 out of 3 the fingerprint reads correctly. Maybe this is good on security standards.
- The passwords keyring does not unlock if you log in with fingerprint. A popup will show to unlock the stored passwords keyring after you login. You need to log in back with your password (without fingerprint) and set a blank password on your keyring.
-Everytime you do anything that needs your root password it will ask you for your fingerprint (even in the terminal). If you do not want to swipe your fingerprint you need to wait some seconds to timeout and then input your password.

I think that the fingerprint integration in ubuntu has not matured to a level of reliability like in windows, but is nice to have your hardware working 100% and everything can be used.

Ruben Rocha (ruben-silvarocha) wrote :

I built a deb package on Ubuntu 12.04.4 and tested. Maybe this will help users running this version.

Ruben Rocha (ruben-silvarocha) wrote :

I forgot to mention that for 12.04 versions you will need to add the fprint ppa to your sources and then you will be able to install fprintd and libpam-fprintd to get the integrated fingerprint features.

To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Duplicates of this bug

Other bug subscribers