Latest libcanberra update causes Firefox and Thunderbird to crash on startup

Bug #862553 reported by Michael Marley on 2011-09-29
166
This bug affects 35 people
Affects Status Importance Assigned to Milestone
libcanberra (Ubuntu)
Critical
Unassigned

Bug Description

After updating to the most recent version of libcanberra on my Kubuntu Oneiric system, neither Firefox nor Thunderbird will launch successfully. Both crash on startup. Both produces the following error message when launched from a terminal:

symbol lookup error: /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: undefined symbol: gdk_error_trap_pop_ignored

Reverting to the previous version of libcanberra causes Firefox and Thunderbird to work normally once again.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libcanberra (Ubuntu):
status: New → Confirmed
Lars Renström (lars-renstrom) wrote :

I can also confirm that the update broke my Oneiric Ubuntu install as well. If I launch a terminal there are no window borders for instance. If I start for instance Thunderbird via terminal and do sudo thunderbird it starts, but still no window decorations. I'll try to revert to get back to working state again...

paul (paulhvandermeer) wrote :

I can also confirm. Affects more programs: Gimp, Synaptic.

Alex M. Lowe (lengau) wrote :

This affects rekonq, too:

$ rekonq http://gmail.com
rekonq(3887)/kdeui (kdelibs): Attempt to use QAction "show_history_panel" with KXMLGUIFactory!
rekonq(3887)/kdeui (kdelibs): Attempt to use QAction "show_bookmarks_panel" with KXMLGUIFactory!
lengau@TARDIS:~$ QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /home/lengau/.config/ibus/bus
QFont::setPixelSize: Pixel size <= 0 (0)
No bp log location saved, using default.
[000:001] Browser XEmbed support present: 1
[000:001] Browser toolkit is not Gtk2 (0).
[000:001] Using Xt toolkit
QFont::setPixelSize: Pixel size <= 0 (0)

(rekonq:3887): Gdk-CRITICAL **: IA__gdk_window_set_back_pixmap: assertion `GDK_IS_WINDOW (window)' failed

(rekonq:3887): Gdk-CRITICAL **: IA__gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed
rekonq: symbol lookup error: /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: undefined symbol: gdk_error_trap_pop_ignored

Michael Meaden (chernobyl) wrote :

I experience the same problems. Unity 2D correctly provides window decorations, but 3D doesn't. Running apps as root (with sudo) does not trigger the bug. This bug affects at least gksu, firefox, thunderbird, chromium, banshee, and apport-bug. Running affected apps in terminal reports
<app>: symbol lookup error: /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: undefined symbol: gdk_error_trap_pop_ignored

Lars Renström (lars-renstrom) wrote :

I tried a reinstall of my computer but leaving /home intact. Logging in as other users on the computer was fine, but my account still experienced this bug. I then made a backup of my home-folder and started over again with an empty one. All is now fine! So, there must be something in my old profile/config/settings that triggers this bug. Strange...

Changed in libcanberra (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Critical

Chromium is also not working.

Workaround (from http://ubuntuforums.org/showpost.php?p=11296757&postcount=16):

- Downloading the .deb from https://launchpad.net/ubuntu/oneiric/amd64/libcanberra-gtk-module/0.28-0ubuntu8
- And installing it with dpkg -i

David Henningsson (diwic) wrote :

I can't reproduce it here, but it has to do with something linking against gtk2 instead of gtk3. In any case, I hope the attached patch will fix the problem, can anybody verify?

The attachment "debdiff.patch" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in libcanberra (Ubuntu):
status: Triaged → Incomplete
Paul White (paulw2u) wrote :

Re-installing libcanberra-gtk-module_0.28-0ubuntu8_i386.deb results in working applications again.

Tested with Thunderbird, Firefox, gVim and Emacs.

Michael Meaden (chernobyl) wrote :

This problem was fixed by re-installing 0.28-0ubuntu8 for me as well. I have noticed the bug that led me to this bug has not resurfaced (ubuntu software center crashes after launch, LP# 834403) after reverting to this version.

zoolook (nbensa) wrote :

I fixed this one removing libcanberra-gtk-module. I'm using Kubuntu 11.10 and so I don't use many GTK apps, but Firefox and Google Chrome are running now.

elguavas (elguavas.) wrote :

same problem as original report, same error message confirmed for firefox and thunderbird since latest software update.

this is a complete showstopper for these two critically important applications. will attempt to downgrade libcanberra-gtk-module and report if this works.

elguavas (elguavas.) wrote :

ok. after messing around trying to find a working browser to download it though ;) downgrading libcanberra-gtk-module to 0.28-0ubuntu8_amd64 fixed the problem.

hopefully a permanent fix can be uploaded asap.

cheers,
stephen.

Philip Muškovac (yofel) wrote :

@David: your patch does fix the issue for me after rebuilding the package.

Changed in libcanberra (Ubuntu):
status: Incomplete → Triaged
fejes (anthony-fejes) wrote :

@Stephen when in doubt, you can always use wget on the command line. eg:

wget https://launchpad.net/ubuntu/oneiric/amd64/libcanberra-gtk-module/0.28-0ubuntu8

elguavas (elguavas.) wrote :

@Anthony yep, thanks. thought i only had a link to the page though not the full url to the package. ;) anyway got it with konqueror in the end since rekonq wouldn't work either.

looks like this is in hand now. excellent.

it's exciting, release is so close now! :)

allenmaher (allenmaher-gmail) wrote :

Nice fix on this one, still others from this morning'supdates in gnome... but now apport works for reporting them. Thanks guys

Yves Dorfsman (dorfsmay) wrote :

The link to the ubuntu8 .deb for the 64 bit version is:

wget http://launchpadlibrarian.net/79299853/libcanberra-gtk-module_0.28-0ubuntu8_amd64.deb

(the link above will get you an html file).
It solved the issue for me too.

Martin Pitt (pitti) wrote :

Michael, can you please ask Lennart to commit David's patch upstream as well? Thanks!

Changed in libcanberra (Ubuntu):
status: Triaged → Fix Committed
milestone: none → ubuntu-11.10
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libcanberra - 0.28-0ubuntu10

---------------
libcanberra (0.28-0ubuntu10) oneiric; urgency=low

  * debian/patches/10_no_nonnative_crash.patch:
    Make sure the patch does not make libcanberra crash when
    linked against gtk2 (LP: #862553)
 -- David Henningsson <email address hidden> Thu, 29 Sep 2011 21:49:49 +0200

Changed in libcanberra (Ubuntu):
status: Fix Committed → Fix Released

While GTK apps have stopped crashing, they are still taking forever to load and I get freezes every now and then.

I also still get the "[3:3:800397596:ERROR:nss_util.cc(397)] Error initializing NSS without a persistent database: libsoftokn3.so: cannot open shared object file: Permission denied"

This is using Kubuntu 11.10 64-bit. Funny enough I only have this issue on one of three installs.

Andreas, I don't see why a problem with libsoftokn3.so has something to do with this bug, which was about libcanberra. You should report a new bug for your problem. Maybe you can work around it by trying what is suggested in comment 31 at http://code.google.com/p/chromium/issues/detail?id=91962#c31. If this works, please note that in your newly reported bug for reference.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.